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INTRODUCTION
The EnSight online documentation consists of two main pieces:

How To Manual The How To documentation consists of relatively short articles that describe how to
perform a specific operation in EnSight, such as change the color of an object or
create an isosurface. Step-by-step instructions and pictures of relevant dialogs are
included. In addition, each How To article typically contains numerous hyperlinks
(colored blue) to other related articles (and relevant sections of the User Manual).

Note that, although the entries in the How To table of contents and index are not
colored blue, you can still click on an entry and jump to the appropriate document.

How To Use the How To Manual
How To Table of Contents
How To Index

User Manual The User Manual is a more traditional document providing a detailed reference for
EnSight. The User Manual contains blue hyperlinks as well. Both the User Manual
table of contents and index entries are hotlinked as well as cross-reference entries
within chapters (which typically start with “See Section ...” or “See How To ...").

User Manual Table of Contents
User Manual Index

Command Language The Command Language Reference Manual documents command language used
Manual within EnSight. This manual contains some cross-references to the How To and User
Manuals, but cross-referencing from them back is extremely minimal.

Getting Started The Getting Started Manual, which contains installation instructions and a number of
Manual examples of using EnSight, is also provided on line. This manual is not cross-
referenced with any of the other manuals.

WHERE TO START?

If you are new to EnSight you should read the EnSight Overview article. Chapter 1 and Chapter 5 in the User
Manual also provide overview information. The Introduction to Part Creation provides fundamental information on
EnSight’s part concept.

ACROBAT READER

The EnSight online documentation uses the Acrobat® Reader software from Adobe Systems, Inc. Acrobat Reader
provides much the same functionality as a World Wide Web browser while providing greater control over document
content quality. See How To Use the How To Manual for more information on Acrobat Reader.
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How TO PRINT THE DOCUMENTATION

Printing Topics From The Acrobat Reader

You can easily print any topic in the How To manual or any pages from the other documentation from within Acrobat.
The documents have been optimized for screen manipulation, but will still produce decent hardcopy printouts. To
print a topic:

1. Navigate to the topic you want to print.

2. Choose Print... from the File menu of Acrobat Reader.

3. Be sure the Printer Command setting is correct for your environment and then click OK. Your document should
print to the selected (or default) printer. If you do not have a printer available on your network or you wish to save
the PostScript file to disk, you can do so: click the File button, enter a filename, and click OK.

Printing EnSight Manuals

You can print (all or portions of) the EnSight manuals from provided .pdf files. These files have been print optimized
and should produce reasonably high quality hardcopy. They have all been formatted for letter size paper. These files
are located in the doc/Manuals directory of the EnSight installation.

$CEI_HOME/ensight76/doc/Manuals/GettingStarted.pdf
$CEI_HOME/ensight76/doc/Manuals/HowTo.pdf
$CEI_HOME/ensight76/doc/Manuals/UserManual.pdf
$CEI_HOME/ensight76/doc/Manuals/CLmanual.pdf

You can open these manuals in Acrobat and print any or all pages, or send them to an outside source for printing.

CONTACTING CEI

If you have questions or problems, please contact CEI:

Computational Engineering International, Inc.
2166 N. Salem Street, Suite 101
Apex, NC 27523 USA

Email: support@ensight.com
Hotline: ~ 800-551-4448 (U.S.)
919-363-0883 (Non-U.S.)

Phone: 919-363-0883
FAX: 919-363-0833

WWW: http://www.ceintl.com or http://www.ensight.com
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INTRODUCTION

The “How To” documentation provides quick access to various topics of interest. The topics provide basic and some
advanced usage information about a specific tool or feature of EnSight. Each topic will provide links to the
appropriate section of the EnSight User Manual as well as links to other applicable How To articles.

Topics typically contain the following sections:

Introduction Introduction to the topic

Basic Operation Quick steps for simple usage

Advanced Usage Detailed information on topic

Other Notes Other items of interest

See Also Links to related topics and documentation

(See below for how to quickly jump to a specific section.)

The header and footer of each article page provides simple navigation controls:

First page of

L f
current topic ast page o

current topic

Return to How To
Topics List -------------

Access this page ------------ e Next page
Previous page

In addition, links to other documents are displayed as highlighted text. Note that all links and navigation controls
(except index and table of contents) are colored blue.

ACROBAT READER

The EnSight online documentation uses the Acrobat® Reader software from Adobe Systems, Inc. Acrobat Reader
provides much the same functionality as a World Wide Web browser while providing greater control over document
content quality. The user interface is very simple and provides intuitive navigation controls. Keep in mind that the
pages were designed to be viewed at 100% magnification. Although you can use other magnification settings, the
quality of the dialog images may be degraded.

The Acrobat Reader toolbar provides quick access to various display options and navigation controls.
Selecttext .-..---...

:  Go back to last ---Go forward to previously
Grab and move page -----. . viewed page ----: . viewed page

Page only or

|4 OEDE
A A

. . B
Display setting: kY ” = & | ”f@@.l“ T
A 4 A

Page with Bookmarks or

Thumbnails: -« - --rnnmemmenns : : 1
" : Standard page Standard page Search for text

Click and zoom in navigation magnifications
(Ctl-click to zoom out) -----------:

The “Go back/forward” buttons are particularly useful — they operate somewhat like the “Back” and “Forward” buttons
on standard Web browsers. If your previously viewed page was in a different document, Acrobat will automatically
reload the appropriate file and jump to the correct page. Note that Acrobat also considers a change of view (e.g.
scrolling) or magnification as an event to remember in the back/forward list.

For additional information on Acrobat Reader, you can load the online help by selecting “Reader Online Guide” from
the Help menu.
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Each How To topic provides a set of bookmarks that match the standard section titles. You can quickly navigate to
one of these sections by using the bookmark list in the left column of the Acrobat user interface:

Be sure Bookmark/Thumbnails File Edit Document View W
display is selected -----------4{z ST LY Hooon== = B
4 4 »

Be sure Bookmarks tab is A “ = S | ”ﬁ @)\‘ T

selected oo » Bookmarks “Thumbnalls
(9 Load Multiple Datasets
[ Introduction

Click on any title to jump to

Click the turndown to hide b [ Basic Operation that section
or reveal subsections ------- ®p [ Advanced Usage

o[ Other Notes

o[ Ses Also

8| e [ -=ﬁ

PRINTING

Printing Topics From The Acrobat Reader

You can easily print any topic in the How To manual or pages from the other documentation from within Acrobat. The
documents will produce decent hardcopy printouts. To print a topic:

1. Navigate to the topic you want to print.

2. Choose Print... from the File menu of Acrobat Reader.

3. Be sure the Printer Command setting is correct for your environment and then click OK. Your document should
print to the selected (or default) printer. If you do not have a printer available on your network or you wish to save
the PostScript file to disk, you can do so: click the File button, enter a filename, and click OK.

Printing EnSight Manuals

You can print (all or portions of) the EnSight manuals from provided .pdf files. These files have been print
optimized and should produce reasonably high quality hardcopy. They have all been formatted for letter size paper.
These files are located in the doc/Manuals directory of the EnSight installation.

$CEI_HOME/ensight76/doc/Manuals/GettingStarted.pdf
$CEI_HOME/ensight76/doc/Manuals/HowTo.pdf
$CEI_HOME/ensight76/doc/Manuals/UserManual.pdf
$CEI_HOME/ensight76/doc/Manuals/CLmanual.pdf

You can open these manuals in Acrobat and print any or all pages, or send them to an outside source for printing.
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ENSIGHT OVERVIEW

EnSight is a powerful software package for the postprocessing, visualization, and animation of complex datasets.
Although EnSight is designed primarily for use with the results of computational analyses, it can also be used for
other types of data.

This document provides a very brief overview of EnSight. Consult Chapter 1 in the User Manual for additional
overview information. This article is divided into the following sections:

Graphical User Interface
Client / Server Architecture
EnSight’s Parts Concept
Online Documentation

Graphical User Interface
The graphical user interface (GUI) of EnSight contains the following major components:
Note: This whole upper level of the GUI Message Area - ------------------------o-oooooo-o-oo-o-o,
is referred to as the “Desktop” Information Area Button - - - - - - - _ o ________, !
Click to see information dialog.
Quick Interaction Area - - - - - - _ _ _ _ _ ____________,

|
Interface controls associated with the current !
feature selected from the Feature Icon Bar. |
|
I
|

MainMenu - - - - - - - - - ________ .
Feature lconBar ------------- oo IS
Sets the current feature. Click an oS N o File Edit Query View Tools Case Help ||Current Tine - SLEp(IO.lOOOOOO) Sinulation¢l.000000e+b1y
i ; i 3 . T [ HIE
icon to open the associated Quick -l [Cff = i E @ | &5 ||
Interaction area. Select Part(s) T Operate On Color By  Constant Color Co\n/‘e:‘:::m Magnitude v :
. R _ 1-(M/CI) by - |
Main Parts List - - - - - - - - - - - - - - - 2-(M{Cl)mount g‘sf’rl:_“m;"ﬁ Mix...| B[oso  G[os0 Bloso |
3-(M/C1}) engine block orcinates) |
4-(M/C1y ts (Cizus) |
All parts from your model as well as M) et X
created parts (e.g. clips, isosurfaces) !
are listed here. Click an item to PrnNERYarahIE e I
select part(s) to operate on. y
Shaded _|Hidden Line Cursor _|Line _|Plane Axis _|Bounds Fast Display Legend... Info...

Mode SelectionArea - - - - - - - - - - -~

»
=

Sets the major mode of EnSight (Part,
Annot, Plot, VPort, ...) and loads the
applicable set of icons into the
vertical Mode Icon Bar. Click the
button to select the Mode.

e vs. displacements for Node 750

~o5 5
displacements

E

ModelconBar - - - _________

The set of icons associated with the .
current Mode. Click the icon to N
access the function. If Tool Tips are \\
on (bottom right of desktop), the

icon’s function name will be shown

when mouse is over the icon. If

necessary, use the vertical scroll bar

to access the remainder of the icons.

agenm|TneT <

@ =
ikxi

Transformation Control Area - - - - -

Buttons that control the current
transformation operation (e.g. rotate

or translate) associated with mouse t-—--4--3 W Reset...| Transf, Edit... +x| +¥| +Z| x| .¥| 2| Store| Recall| Unde Tool Tips
action in the Graphics Window. Other : ; =
buttons open dialogs providing ~ reee oo

detailed transformation control. . --  Graphics Window showing inset plot and viewport

Chapter 5 in the User Manual provides additional overview information on the user interface.
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Client / Server Architecture

To facilitate the handling of large datasets and efficiently use networked resources, EnSight was designed to
distribute the postprocessing workload. Data I/O and all compute intensive functions are performed by a server
process. The server transmits 3D geometry (and other information) to a client running on a graphics workstation.
The client handles all user interface interaction and graphic rendering using the workstation’s built-in graphics
hardware.

hostt ... . host2 . .. ...
( Server ) { Server )
Requests 3D objects ' hostt ||
( Client ) C Client )
"Stand-alone Operation Distributed Operation

The client and server each run as separate processes on one or more computers. When distributed between a
compute server and a graphics workstation, EnSight leverages the strengths of both machines. When both tasks
reside on the same machine, a stand-alone capability is achieved. The client—server architecture allows EnSight to
be used effectively, even on systems widely separated geographically.

Before EnSight can be used, the client and server must be connected. For standalone operation, you simply run the
“ensight7” script and the client and server are started and connected for you. For distributed operation (as well as for
standalone operation when more control is desired), there are two methods of achieving a connection: a manual
connection (described in the Getting Started manual) or an automatic connection (described in How To Connect
Automatically).

EnSight’s cases feature allows you to postprocess multiple datasets simultaneously. Cases is implemented by
having a single client connected to multiple servers running on the same or different machines.

EnSight’s Parts Concept

One of the central concepts of EnSight is that of the part. A part is a named collection of elements (or cells) and
associated nodes. The nodes and/or elements may have zero or more variables (such as pressure or stress). All
components of a part share the same set of attributes (such as color or line width).

Parts are either built during the loading process (based on your computational mesh and associated surfaces) or
created during an EnSight session. Parts created during loading are called model parts.

All other parts are created during an EnSight session and are called created or derived parts. Created parts are built
using one or more other parts as the parent parts. The created parts are said to depend on the parent parts. If one or
more of the parent parts change, all parts depending on those parent parts are automatically recalculated and
redisplayed to reflect the change. As an example, consider the following case. A clipping plane is created through
some 3D computational domain and a contour is created on the clipping plane. The contour’s parent is the clipping
plane, and the clipping plane’s parent is the 3D domain. If the 3D domain is changed (e.g. the time step changes),
the clipping plane will first be recalculated, followed by the contour. In this way, part coherence is maintained.

One of the major modes of EnSight is Part Mode. Operations in Part Mode (performed by clicking one of the icons in
the vertical Mode Icon bar) operate on the parts currently selected in the Main Parts list. See How To Select Parts
for more information.

See the Introduction to Part Creation for more information on parts.

Online Documentation

Documentation for EnSight is available online. See How To Use the Online Documentation for more information as
well as hyperlinks to the main documents. Online documentation is accessed from the Main Help menu in the user
interface. In addition, major dialog windows contain Help buttons that will open a relevant “How To” article.
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INTRODUCTION

EnSight is a distributed application with a client that manages the user interface and graphics, and a server that reads
data and performs compute-intensive calculations. The client and server each run as separate processes on one or
more computers. Before EnSight can do anything useful, the client process must be connected to the server
process. For a standalone operation, you can simply start EnSight with the “ensight7” script and the client and server
processes will be started and connected for you. If you desire more control over the standalone operation or want to
take advantage of a distributed operation, you have the options described below.

There are two basic types of connection: manual and automatic. A manual connection is made by starting the client,
telling it to listen for a server connection, and then starting the server (and telling it what machine the client is running
on). Manual connection is covered in detail in the Getting Started manual. Automatic connection is covered here.

BAsSIC OPERATION

The auto-connect mechanism requires that certain conditions exist in your computing environment:

On Unix Systems:

1. You have a valid . rhosts file in your home directory on all systems on which you wish to run the EnSight server.
The file permission for this file must be such that only the owner (you) has write permission (e.g.
chmod 600 ~/.rhosts). A .rhosts file grants permission for certain commands (e.g. rsh or rlogin)
originating on a remote host to execute on the system containing the . rhosts file. For example, the following line
grants permission for remote commands from host c1lienthost executed by user username to execute on the
system containing the . rhosts file:

clienthost username

There should be one line like this for every client host system that you wish to be able issue remote commands
from. It is sometimes necessary to add an additional line for each client host of the form
clienthost.domain.com username (Where domain.com should be changed to the full Internet domain
name of the client host system).

2. You have a . cshrc file (even if you are running some other command shell such as /bin/sh) in your home
directory on the EnSight server host that contains valid settings for CEI_HOME, and that your path variable
includes the bin directory of CEI_HOME. For example, if your EnSight distribution is installed in /usr/local/
CEI and you are running EnSight on an SGI system (other architectures use a different library path variable), your
.cshre should contain:

setenv CEI _HOME /usr/local/CEI
set path = ( $path $CEI_HOME/bin )

3. Your .cshrc file (or files sourced or executed from there) has no commands that cause output to be written (e.g.
date or pwd). Any output would be interpreted as an EnSight server startup error.

4. You can successfully execute a remote shell command from the client host system to the server host system. The
name of the remote shell command varies from system to system. While logged on to the client host system,
execute one of the following (where serverhost is the name of your server host system):

rsh serverhost date
remsh serverhost date

If successful, the command should print the current date.

If any of these conditions are not met, you will be unable to establish a connection automatically and will have to use
the manual connection mechanism. Note that it is not uncommon for system administrators to disable operation of all
remote commands for security reasons. Consult your local system administrator for help or more information.
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On Windows NT Systems:

1. You have the EnSight server (ens76sv.exe) installed on the same system as your EnSight client (if you plan to
connect to the same system)
wme= OR ==--
2. You can successfully execute a remote shell command from the client host system to the server host system.

Note: While all Windows NT workstations have the ability to issue RSH (Remote Shell) requests, only
systems running Windows NT Server have the RSH deamon and can respond by executing the EnSight
server.

The name of the remote shell command varies from system to system. While logged on to the client host system,
execute one of the following (where serverhost is the name of your server host system):

rsh serverhost date
remsh serverhost date

If successful, the command should print the current date.

If condition 1. or 2. is not met, you will be unable to establish a connection automatically and will have to use the
manual connection mechanism. Note that it is not uncommon for system administrators to disable operation of all
remote commands for security reasons. Consult your local system administrator for help or more information.
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Connect Automatically

In an initial session, you must provide the connection information to EnSight. Once this is done correctly, you can
start future sessions and make the connection automatically. To set up for an automatic connection:

1. Select File > Connect... to open the Connect Server dialog.

2. Set the Type to Auto.

3. Enter the host name of the system on which you wish to run the EnSight
server.

4. Enter the full path name of the EnSight server executable.

If the server executable is in your default command search path on the server
machine, you do not have to provide the full path name — only the name of the
server executable.

5. Enter the full path name of the directory from which you wish to start the
EnSight server.

This is typically the directory containing your results files. If this field is left
blank, the working directory will default to the directory from which the client was
started (if both client and server are running on the same system) or your home
directory on the server system (if the server is running on a remote machine).

6. If your login name on the server host is different from your login name
on the client host, enter your server login name here.

7. Click Connect Server to initiate the connection process.

See the Troubleshooting section below if the connection attempt fails.

8. Click Close to close the dialog.

You can restore the connection defaults (as stored in
~/.ensight7/ensight.connect.default) by clicking Show Server
Defaults.

E E Connect Senver
| Status

**Na Connection**

Machine Name:

rmysemrhost

Executable [path/lname:

- Fensighﬂ Server

Working Directory:

" i’/usn‘peopler‘joe:‘prnjecﬂ
| Alternate Login ID:

Connect Server I

Show Server Defaultsl

Transfer Summary
Cliente———>Server
Sent Received

0

You can open the Connect Server dialog at any time and

check the Transfer Summary. This section shows how many
bytes have been Sent from the client to the server and how

many have been Received in return. - --------oovemoi

Once an automatic connection has been successfully performed, you can start subsequent sessions of EnSight and

connect automatically with the following command:

)

% ensight?7

(This assumes that your command search path on the client host has been set up to include the client execution

directory —e.g. for Unix, set path =

( $SCEI_HOME/bin $path ).
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TROUBLESHOOTING

An automatic connection can fail for any of several reasons. Because of the complexity of networking and customized
computing environments, we recommend that you consult your local system administrator and/or CEI support if the
following remedies fail to resolve the problem.

Problem Probable Causes Solutions

For Unix Systems:

Automatic connection fails or is | Server (remote) host name is Is the server host entered correctly in the Machine Name

refused incorrect for some reason. field? Try running telnet serverhost from the client
machine.

Incorrect or missing . rhosts file Follow the instructions on . rhosts files (as described in

in your home directory on the the Basic Operation section, step 1 above). If you cannot

server host. successfully execute a remote command (such rlogin

or rsh) from the client host to the server host, you will not
be able to connect automatically.

The user account (i.e. login name) | Enter your login name on the server host in the Alternate
on the client host does not exist on | Login ID field.
the server host.

The server executable is not found | Is the entry in the Executable [path/[name field correct? If
on the server system the server executable is NOT in your default command
search path on the server, you must include the full path
name to the executable. For example, /usr/local/
bin/ensight76/server/ensight7.server.

Your .cshrc does not contain a Add the appropriate line as described in the Basic
valid setting for CEI_HOME. Operation section, step 2 above.

Your . cshrc file (or files executed | Remove the offending commands from your . cshrc file.
by it) causes output to be written. As a test, do the following:

This is interpreted as a server
startup error.

o°

cd
mv .cshrc .cshrc-SAVE

o0

Create a new .cshrc file that contains only the lines to set
CEI_HOME and path as described in the Basic
Operation section, step 2 above. If that test works, you
will need to examine your . cshrc to find and remove the
offending lines.

For Windows NT Systems:

Automatic connection fails or is | Server not installed or not You should be able to locate the server executable
refused (trying to connect to executable. (ens6sv.exe) using NT Explorer. Double click on it and
same host system) see if a console window opens with “This is EnSight

Server 7.6” etc. If this doesn’t happen, refer to
“Troubleshooting the Installation” in the Getting Started
Manual.

Path to the server is incorrect If using the EnSight Connect dialog, check that the
correct path is specified in the “default path” field.

If running from the ensight7 command, first ensure that
your PATH environment variable contains the paths for
the EnSight7 “client” and “server” directories. You can
check and correct the value of PATH in the Start
>Settings >ControlPanel >System_Environment dialog.

Incorrect hostname entered in the | Make sure that the hostname is correct, including the

“Machine Name” field of the case of all letters. The ONLY way to see the hostname (in

Connect dialog. the correct case) from NT is via the Start >Settings
>ControlPanel >Network >Protocols >TCP/IP >DNS
dialog.

Automatic connection fails or is | Same causes as for a Unix system | See “For Unix Systems” portion of this table above.
refused (trying to connect to a
remote server)
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OTHER NOTES

The automatic connection information is stored in the file ~/.ensight7/ensight .connect.default. The
information contained in this file is loaded to the text fields in the Connect Server dialog when it is opened. If
required, the file can be edited with any text editor.

By default, the connection between the client and server uses a standard TCP/IP socket mechanism. However, if an
automatic connection is being made and EnSight determines that the server will be running on the same machine as
the client, it will use a different connection mechanism (known as named pipes). This mechanism results in much
faster communications between the client and server (from 2 to 5 times speedup). Automatic connection should
therefore always be used when running both client and server on the same machine.

SEE ALSO

See the Getting Started manual for basic information on EnSight installation and manual connections.
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INTRODUCTION

There are a number of options that can be included on the command line when starting EnSight. The following tables
indicate the commands that can be issued for the EnSight script (ensight7), the EnSight client (ensight7.client), the
EnSight server (ensight7.server), or the EnSight server-of-servers (ensight7.sos). To see the most current listing for
any of these, issue one or more of the following:

ensight7 -help
ensight7.client -help
ensight7.server -help
ensight7.sos -help

BASIC USAGE

ensight7 [options]
or

ensight7.client [options]
Section 1. EnSight Startup/Client-Server Options

-ar <f> Restore from specified archive file “f’

-c <host> Do an auto connection to machine named “host”. EnSight server will run on “host”

-case <f> Read EnSight casefile name "f” and display part loader

-cm Do a manual connection of server

-collab_port <#> Specify the port for collaboration socket communication.

-ctx <f> Applies context file “f” as soon as connection is made

-custom Force the license manager to look for a custom token

-delay_refresh Graphics window is not updated during command file playback, until finished

-extcfd Extended CFD variables automatically placed in variable list

-gold Force the license manager to look for a gold token

-localhostname <host> |Host name to force server(s) to use to connect to client

-p <f> Plays playfile “f" as soon as connection is made

-ports # Allows user specification of socket communication port. (passed on to server or sos)

-rsh <cmd> Remote shell program to use for automatic connection. (passed on to server or sos)

-security [#] Forces a handshake between the client and server using the # provided or a random
number

-S0s Set up to connect to the Server-of-Servers (ensight7.sos) instead of normal server.

-soshostname <host> Host name to force server(s) to use to conect to Server-of-Servers

-standard Force the license manager to look for a standard token

-timeout <#> Number of seconds to wait for server connection; default = 60, infinite = -1

Section 2. EnSight Client GUI Options

-ff Use the default EnSight fixed font

-hc <c> Current Selection Highlight Color Name “c”

-iconlblf <#> Mode panel icon label font size

-ni Will use text in place of icons

-sc <c> Section Label color name “c”

-smallscreen Sets window attributes based on the screen size of 1024x768

Section 3. EnSight Server Specific Options

-gdbg Print some debugging info for EnSight format geometries (passed from client to server)
-iwd Ignore the working directory in the ensight.connect.default file

-time Prints out timing information (passed from client to server)

-readerdbg Prints user-defined-reader library loading information in shell window upon startup of

server (passed from client to server)
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-writerdbg Prints user-defined-writer library loading information in shell window upon startup of
server (passed from client to server)

-maxoff Turns off maxsize checking (passed from client to server)

-scaleg <#> Provide scale factor to scale geometry by (passed from client to server)

-scalev <#> Provide scale factor to scale all vectors by (passed from client to server)

-swd <dir> Set the server working directory

Section 4. Miscellaneous Options

-h, -help, -Z Prints the usage list

-helvetica Use Helvetica font instead of the default Times-Roman for annotation text in the
graphics window

-inputdbg Prints user-defined input device information

-nb No automatic backup recording

-no_file_locking Turns off file locking (lock()). Some systems don’t support this properly

-no_prefs Do not load saved user preferences (uses all original defaults)

-range10 Use palette ranges which are 10% in from the extremes

-silent Causes all stdout and stderr messages to be thrown away

-stderr <f> Cause all stderr messages to be written to the file.

-stdout <f> Causes all stdout messages to be written to the file.

Section 5. Rendering Options

-batch <width>< height>

Batch mode with optional width and height. Only available if running X version of
EnSight, which you get by using -X option

-bbox Render only bounding boxes in the GUI window (useful for detached displays with
-prsd2 option). (See How To Setup For Parallel Rendering)

-dconfig Specify a display configuration file

-display_list Use OpenGL display lists

-glconfig Prints current OpenGL configuration parameter defaults to screen

-glsw Forces use of software implementation of OpenGL on Windows machines

-box_resolution <#> Resolution of bounding boxes for part culling (max 9). Implies -no_display_list

-gl Sets line drawing mode to draw polygons

-ogl Sets line drawing mode to draw lines

-no_display_list

Force EnSight to use immediate mode graphics

-norm_per_vert

Use one normal per vertex for flat-shading

-norm_per_poly

Use one normal per polygon for flat-shading

-multi_sampling

Turns MultiSampling on

-no_multi_sampling

Do not use MultiSampling

-no_start_screen

Ignore the start screen image (Good for HP using TGS OpenGL)

-num_samples <#>

Specify number of samples for software multi-sampling

-occlusion_test

Use the HP occlusion extension if available

-no_occlusion_test

Do not use the HP occlusion extension

-stencil_buff

Use the OpenGL stencil buffer (even if not enabled by default)

-no_stencil_buff

Assumes there is not a working stencil buffer (some NT video cards)

-double_buffer

Use double-buffering for the graphics window (default)

-single_buffer Do not use double-buffering

-sort_first Sets the default parallel rendering sorting method to be the sort first method
-sort_last Sets the default parallel rendering sorting method to be the sort last method

-X Starts the X version of EnSight (uses Mesa OpenGL instead of native OpenGL). This

option is mandatory if the -batch option is desired.

Section 5. X Window Specific Options

-bg <c> Background Color colorname “c”
-fg <c> Foreground Color colorname “c”
-fn <fn> Font Name “fn”

-font <fn> Same as -fn
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Client Examples:
ensight7 -cm -p myplayfile

This will allow the user to do a manual connection, after which the “myplayfile” will be run.
ensight7 -c -gold -ports 1310 -case myfile.case

This will do an automatic connection (according to information in the user’s ensight.connect.default file) on port 1310,

using a gold seat. After the connection is made, the “myfile.case” casefile will be run.
ensight7 -rsh ssh -hc yellow (or ensight7.client -c -rsh ssh -hc yellow)

This will use ssh as the remote shell for an automatic connection, and will set the highlight color to yellow (instead of

the default color of green).

ensight7.server [options] |

-c <host> “host” indicates where the client is running

-ctries <#> The number of times (1 second per try) to try to connect client and server.

-ether Ethernet device name such as In0

-gdbg Print some debugging infor for EnSight format geometries

-h, -help Prints the usage list

-maxoff Turns off maxsize checking

-pipe Forces the server to use a named pipe connection (must be on same machine)

-ports <#> Allows user specification of socket communication port.

-readerdbg Prints user-defined-reader lib loading information in shell window upon startup of server
-writerdbg Prints user-defined-reader lib loading information in shell window upon startup of server
-sock Forces the server to use a socket connection

-time Prints out timing information

-scaleg <#> Provide scale factor to scale geometry by

-scalev <#> Provide scale factor to scale all vectors by

-security <#> Provide number for client to server security check

-soshostname <host> Allows different name for servers to connect back to Server-of-Servers with

Server Examples (when started manually):

ensight7.server -c clientmachine -readerdbg

Specifies “clientmachine” as the machine on which the client is running, and that information on user-defined-reader
library loading should be printed out.

ensight7.server -ports 1310 -scaleg 10.0 -scalev 10.0

Specifies that communication is to occur on port 1310, and that the geometry and all vectors are to be scaled by a

factor of 10.

ensight7.sos [options] H

-c <host> “host” indicates where the client is running

-ctries <#> The number of times (1 second per try) to try to connect client and server.

-ether Ethernet device name such as In0

-gdbg Print some debugging infor for EnSight format geometries (passes on to servers)

-h, -help Prints the usage list

-maxoff Turns off maxsize checking (passes on to servers)

-pipe Forces the server to use a named pipe connection (must be on same machine) (passes
on to servers)

-ports <#> Allows user specification of socket communication port. (passes on to servers)

-readerdbg Prints user-defined-reader library loading information in shell window upon startup of
server (passes on to servers)
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-writerdbg Prints user-defined-reader library loading information in shell window upon startup of
server (passes on to servers)

-rsh <cmd> Remote shell program to use for automatic connection of servers. (passes on to servers)

-sock Forces the server to use a socket connection

-scaleg <#> Provide scale factor to scale geometry by (passes on to servers)

-scalev <#> Provide scale factor to scale all vectors by (passes on to server)

-security <#> Provide number for client to server security check (passes on to servers)

-soshostname <host> Allows different name for servers to connect back to Server-of-Servers with (passes on
to servers)

-time Prints out timing information (passes on to servers)

SOS (Server-of-Servers) Examples (when started manually):

ensight7.sos -c clientmachinename -soshostname sosmachinename

Specifies “clientmachinename” as the machine on which the client is running, and that the individual servers should
connect back to “sosmachinename”.

ensight7.sos -readerdbg -gdbg

Specifies that the sos and any servers print out user-defined-reader library loading information, and that the servers
print out EnSight data format geometry loading information.
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INTRODUCTION

Collaboration between an EnSight session (Client and Server) and another EnSight client can be accomplished via
the EnSight collaboration hub. This feature provides a way for a user to allow another colleague to connect to his/her
running EnSight session and interactively work in a master/slave manner. The master drives the session until the
slave requests and is allowed to become the master (or Pilot). The colleague will only need to start an EnSight client
because, when connected via the hub, they share the EnSight server of the originating user. The master will go about
the normal postprocessing operations, but will be issuing commands to the slave client to perform transformations,
part editing, etc., to keep the slave current.

The EnSight collaboration hub (ensight7.collabhub) is now available on the release CD. This hub can be run on any
supported computer on the network to route data between the two clients and the server. The initial connection
between the originating user’s client and server will be redirected through the hub when the connection is made. The
colleague joins by contacting the hub which then asks the originating user if it is okay for this person to join the
collaboration session. All communication between the server and client processes will transfer through the hub.

BAsSIC OPERATION

To start a new session: Fils | Edit Query Wi

1. Select File->Collaboration... ...................... Command...
: Connect Server...

oo Collaboration...
Data (Reader}...
Data (Part Loader}...

Print/Save Image...

Save
Restore
Quit...
-+ Collaboration [=1E3]
Session Control | Options
2. Select Session Control->New.., ~---------r-mmmmmmmmmmmmn e
------ New...
Join Existing...
Break Off...
Hoapuwest To Boe Pilol
3.Enter Your Name. .- - .ol
. Close Help
L Il
= Collaboration Session Start Up [x]
4. Enter the Hub Hostname. -------------------- - - Your Name | 1.1y Doe

Hub Hostnams rm achine.mycompanyl.com
5. Enter the Hub Port Number. .- - ... . .......... S yoompans} |
o | Huk Port Number | ;97

6. Select Start Session to start the session and I < Start Session

allow colleagues to make requests to join. --------

7. When a colleague requests to join your session Cancel Help

you will be prompted with the name and machine
information to allow them to join. Select the
appropriate button as indicated in the dialog that

pops up.
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To join session: il | Bt Quey W

1. Select File->Collaboration... ...................... Command...
Connect Server...

e Collaboration...
Data (Reader}...
Data (Part Loader}...

Print/Save Image...

Save
Restore
Quit...
=+ Collaboration
Session Control | Options
2. Select Session Control->Join Existing... ... ... ... ... ... .., + Join Existing...
Break Off...

Buogueat To e Piivd

Close Help

= Join Collaboration Session [x]

3.EnterYourName. .__.......___.... . ... .. ... [ YewrNamgl . e

5. Enter the Hub Hostname given to you by the Hub Hostnam
person who started the collaboration session. -------fj-------------1

2 | mymachine.mycompany.com |

6. Enter the Hob Port Number given to you by the
person who started the collaboration session. ---: v Join Session

7. Select Join Session to request permission to join ’
! K Cancel Help
thesession. ... . ................ - : .

OTHER NOTES

You close or “Break Off” your session in a similar manner under File -> Collaboration -> Session Control -> Break Off

‘ 2000 ® HowTo Index User Manual Page 2 of 2




How To ... Read Data

h 20000

INTRODUCTION

EnSight supports a number of file formats common in computational analysis. In addition, CEl has defined a generic
data format (in both ASCII and binary versions) that can be used for both structured and unstructured data. In many
cases analysis codes output this data directly (i.e. FLUENT, STAR-CD, KIVA, etc.)

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the first step. The second step is treated in the How To
article for the applicable data format.

BAsSIC OPERATION

Various data formats require a different set of files for proper data loading. The Ensight6 and EnSight Gold formats
require a single file (the casefile) to be provided in EnSight's Data Reader dialog. This casefile provides time and
other information as well as names and descriptions of geometry and variable files needed to represent the dataset
(see EnSight Gold Case File Format). Another example is the EnSight5 format, which requires two files: a geometry
file that specifies coordinates and elements and a results file that provides additional information about the dataset
(such as time information) as well as pointers to the files actually containing the variable data (see EnSight5 Result
File Format). See also the Other Notes section below for a table describing the supported formats and required files.
To select data files for reading into EnSight:

! Select File > Data (Reader)..
2. Select the desired data directory using the Filter

Directories list. - - - - - oo . tscratch/data‘ensight/ensightiensighté/cubes]
You can also enter a directory name directly in the Directorics Files

Filter field to jump to that directory. The Filter can also {1\

provide file name filtering, e.g. using * . geo to display ntch/dntaensichtrensich thensich tGicalel
in the Files list only those files that end with . geo. - ) ) o | i
3. Selectthe desired format.. . ........ . .. .. ... iiiiiiiidbiiiiiratee °“:°-*°’1“P
. cube Velo
4. If desired, specify a starting time (default is the cube_given gea

lasttime step). .- - - -l - :
5. Select the desired case file in the Files list. - --:

6. If the file is binary, set the correct byte order. . . . ..

For some formats, EnSight can determine this
automatically, and your selection is ignored. But if it
can’t determine, it will use this selection.

7. Click the (Set) Case button to select that case Case (Ax.ld,Replace,Delet\e)
file. ------co e or . :
The selected case file is inserted into the text field o i File Information ™
beside the (Set) Case button. o armat Case
If you have variable data (and your format requires it),  : Specify Starting Time Step
perform steps 7 and 8: o Binary Files Arel Big-Endian(HP IBM,SGLSUN)
8. Select the desired results file in the Files list. EnSight Case File(* case Required)
9. Click the (Set) Result button to select that e PiSet) Case
results file. —
If you have measured data, perform steps 9 and 10: b Rewult
10. Select the desired measured data file in the vt Beasured
Files list. cHety Bowndary
11. Click the (Set) Measured button to select that Path
measured data file.
12. Click Okay. - - - - - - - ...l .

The Data Part Loader dialog for the applicable format

. . . Selection
will open. Proceed to the applicable How To article for . -
that format (links are provided below). ||| feeratehidatalensightiensightiensightb/cube/cube.case
Okay Apply Filter Cancel Help
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OTHER NOTES

The following table details the files required for each file type.

data reader has been developed.
Examples: CFX-4, CGNS, Exodus II,
Nastran, STL, Silo, Flow-3D, Vectis,
MSC/Dytran, LS-DYNA3D, TECPLOT,
Cobalt60, Cobalt CASE, Radioss_4.x,
SCRYU, HDF5

Format Type Description Geometry File Result File Required?
Case A “wrapper” format for other formats Yes: file.case No
(typically EnSight 6 and EnSight Gold
format).
EnSight 5 CEl format defined for version 5.x of Yes: file.geo Yes: Regular file.res
EnSight.
EnSight 6 CEl format defined for version 6.x of Yes: file.case No
EnSight. Typically a superset of
EnSight 5 format with support for
structured data. (To troubleshoot, see
How To Use ens_checker)
EnSight Gold CEl format defined for version 7.x of Yes: file.case No
EnSight. Loads into EnSight much
quicker and is much more memory
efficient. (To troubleshoot, see How To
Use ens_checker)
ABAQUS Data written from ABAQUS (commercial | Yes: file.fil. Will also read No
FEM solver). file.dat if present in the same
directory with the same root file
name.
ANSYS Data written from ANSYS (commercial Yes: file.rst (contains both No
FEM solver). geometry and results)
ESTET Data written from ESTET (commercial Yes: file No
CFD solver).
FAST NASA FAST format for unstructured Yes: file.geo Yes: Special file.res. NOTE! Do
(tetrahedral) data. not use your solution file (e.g.
file.q) here. You must create a
special results file to handle FAST
variable files. See FAST
UNSTRUCTURED Result file
format.
PLOT3D NASA format for multiblock, structured | Yes: file.x If your solution (Q) file contains
data. the five standard variables, you
can use it as the results file (i.e. in
the (Set) Result slot in the Data
(Reader) dialog).
If you have a non-standard Q file
(or a function file) you must create
a special results file to handle
PLOT3D variable files. See
PLOT3D Results File Format.
FIDAP NEUTRAL | Data written from FIDAP (commercial Yes: file.fdneut No
CFD solver) in the NEUTRAL format.
FLUENT Data written from Fluent (commercial Yes: file.unv No
UNIVERSAL CFD solver) in the UNIVERSAL format
MOVIE.BYU Data in MOVIE.BYU format. Yes: file.geo Yes: Regular file.res
MPGS CEl format for EnSight prior to version Yes: file.geo Yes: Regular file.res
5.0
N3S Data written from N3S (commercial CFD | Yes: file.geo Yes: N3S format file.res
solver).
User Defined Any format for which a shared library Yes If required. It can vary with each

reader.
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SEE ALSO

How To Read EnSight Gold Data
How To Read EnSight 5 Data
How To Read EnSight 6 Data
How To Read ABAQUS Data
How To Read ANSYS Data

How To Read ESTET Data

How To Read FAST Data

How To Read FLUENT Data
How To Read FIDAP NEUTRAL Data
How To Read MOVIE.BYU Data
How To Read MPGS Data

How To Read N3S Data

How To Read PLOT3D Data
How To Read User Defined

How To Use ens_checker

User Manual:

Reading and Loading Data Basics
EnSight Case Reader

EnSight5 Reader

ABAQUS Reader

ANSYS RESULTS Reader
ESTET Reader

FAST UNSTRUCTURED Reader
FIDAP NEUTRAL Reader
FLUENT UNIVERSAL Reader
Movie.BYU Reader

MPGS 4.1 Reader

N3S Reader

PLOT3D Reader

User Defined Readers
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INTRODUCTION

This program attempts to check the integrity of the EnSight6 or EnSight Gold file formats. Most files that pass this
check will be able to be read by EnSight (see Other Notes below). If EnSight6 or EnSight Gold data fails to read into
Ensight, one should run it through this checker to see if any problems are found.

Ens_checker makes no attempt to check the validity of floating point values, such as coordinates, results, etc. Itis
just checking the existence and format of such.

BASIC OPERATION

Program invocation:
If you invoke the program without any arguments, it will prompt you for the casefile to read. For example:

> ens_checker

hhkkhhhkhhkhkhkhhkhhhhhkhkhkhkhkkhhhhhkhkkkkhhhhkhkkkkhkhhhkhkkkkhkhhhhhkhkkhkkkx

* EnSight Data Format Checker

e — *
* Currently, *
* 1. Must be run from directory in which casefile is located. *
* 2. Handles EnSighté and EnSight Gold formats only. *
* 3. Does not process SOS casefiles. *
dhkhkhkkhkhkhkhhkhkdhhkhkhkhkhkhkdhhhhkhkhdkhkhkhhhkhdkhkhkdhhkhhbhhkhdhkhkhkhhkhhhkhkhkhkhkhkdkhkhkdkhkhkdhkhxhkx

<Enter casefile name (must be in directory containing it!) > mydata.case

You can alternatively invoke the program with the casefile on the command line.

> ens_checker mydata.case

Sample runs:

As ens_checker works it will be providing feedback. This feedback is important in interpreting what is wrong in the
files. Here is a sample run, which was successful:

> ens_checker 3by3.case

hhkkhkhkhkhhkhkhkhhhhhhhhhkhkhkhkkhhhhhkkkkkkhhhhhhkkkkhhhhhhkkkhkhkhhhhhkkhkkkx

* EnSight Data Format Checker

* Currently,

* 1. Must be run from directory in which casefile is located.
* 2. Handles EnSight6 and EnSight Gold formats only.
*
*

*

3. Does not process SOS casefiles.
khkhkhkhkhkhkhkhkhkhkhkhkhkhkhkhkhkhhkhkhkhkhkhhhhhkhkhkhkdhhhkhkhkhdkdkdkhkhkhkhkhkhhkhkhkhkhhhhkhkhkkkkhkhx

*

*

*

*

*

*
<Enter casefile name (must be in directory containing it!) > 3by3.case
Casefile to Process:

3by3.case (Opened successfully)

Required FORMAT section (at line 1)
Required GEOMETRY section (at line 4)
Optional VARIABLE section (at line 7)
Optional TIME section (at line 11)

EnSight 6 Format (set at line 2)
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Time set: 1 (at line 12)
No description provided
Number of steps: 1 (at line 13)
Time values: (starting on line 14)
time values[1l] = 0

Model filename is: 3by3.geo (at line 5)

Static geometry

Opened 3by3.geo successfully

File type is: ASCII

Description 1: EnSight test geometry file
Description 2: ==========================
node ids: assign

element ids: assign

Global section:
Number of nodes: 64
Coordinates for (64) nodes found

Part 1:
Description is: 3 x 3 xy
Unstructured Part
Number of quad4 elements is: 9
Connectivities for (9) quad4 elements found

Part 2:
Description is: 3 x 3 yz
Unstructured Part
Number of quad4 elements is: 9
Connectivities for (9) quad4 elements found

Part 3:
Description is: 3 x 3 xz
Unstructured Part
Number of quad4 elements is: 9
Connectivities for (9) quad4 elements found

Part 4:
Description is: 3 x 3 45
Unstructured Part
Number of quad4 elements is: 9
Connectivities for (9) quad4 elements found

D <
> GEOMETRY section OKAY <
S mm e ——— - <

scalar per node: scalar (at line 8)
Filename is: 3by3.scl
Non transient variable
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Opened 3by3.scl successfully
Description: 3by3 scalar variable

Global section:
(64) Nodal scalar values for unstructured nodes found

vector per node: vector (at line 9)
Filename is: 3by3.vct

Non transient variable

Opened 3by3.vct successfully
Description: 3by3 vector variable

Global section:
(192) Nodal vector values for unstructured nodes found

D e <

> VARIABLE section OKAY <

ST T s T s s s s = <
S----------- Hooray! ---------- <
> <
> Data verification SUCCESSFUL <
> <
> with No Warnings <
> <
D et <

And here is a sample run, with a problem, namely a ‘block’ line is missing:

> ens_checker 3by3s.case

hhkhkhhkhhkhkhkhhhhhhhhkhkhkhkhkkhhhhhhkhkkkkhhhhhhhkkkhhhhhhkkkkhkhhhhhkhkkhkkkk

* EnSight Data Format Checker

___________________________ *
* Currently, *
* 1. Must be run from directory in which casefile is located. *
* 2. Handles EnSighté and EnSight Gold formats only. *
* *
* *

3. Does not process SOS casefiles.
hhkkhkkhkhkhkhkhkhkhkhkhkhkhhkhkdhhhkdkhkhdhkhhhdhhkhdhkhkhkhhkhkhkhkhkhkhkhkhhkhkhkdhkhkdhkhkhkdhkhkhkdhkhdhhx

Casefile to Process:

3by3s.case (Opened successfully)

Required FORMAT section (at line 1)
Required GEOMETRY section (at line 4)
Optional VARIABLE section (at line 7)
Optional TIME section (at line 11)

EnSight 6 Format (set at line 2)
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Time set: 1 (at line 12)
No description provided
Number of steps: 1 (at line 13)
Time values: (starting on line 14)
time values[1l] = 0
Dt <
> TIME section OKAY <
D e i <
GEOMETRY Section:
Model filename is: 3by3s.geo (at line 5)

Static geometry

Opened 3by3s.geo successfully

File type is: ASCII

Description 1: EnSight test geometry file
Description 2: ==========================
node ids: assign

element ids: assign

Global section:
Number of nodes: 0

Part 1:
Description is: 3 x 3 xy block
Structured Part
Not iblanked
ijk=441
Number of nodes: 16
Number of cells: 9

Block X coordinates for (16)
Block Y coordinates for (16)
Block Z coordinates for (16)

nodes found
nodes found
nodes found

Part 2:
Description is: 3 x 3 yz block

===> Problem:

Looking for one of the following valid line types:
element type (unstructured types, any of the following:

point triaé6 tetralo pentals
bar2 quad4 pyramids hexa8
bar3 quads pyramidl3 hexa20
tria3 tetra4 pentaé
block (structured block)
part (the next part)
but found the following:
4 4 1
>TSS ST T T s s s s s s s s <
> GEOMETRY section FAILED <
ST T T T T T s T s s s s m == — <

S—*_*_*x_k_*_% bummer! *-*-*_*_*_*_

> <
> Verification of the data FAILED <
> <

SoKk_kok_k_k_k_k_k_Kk_k_k_Kk_k_k_k_k_

After fixing the ‘block’ line and running the program again, another problem is encountered - namely, an extra space

User Manual

B 2000 @® HowTo Index

Page 4 of 6




How To ... Use ens_checker

h 20000

at the end of the second line of x coordinates for the block that is part 2.

> ens_checker 3by3s.case

LR EEE RS R R R R RS SRR R SRR R R R R EEEEEEREREREEE R R EEREEREEEEREEEEEEEEEEESERE]
* EnSight Data Format Checker

* Currently,

* 1. Must be run from directory in which casefile is located.
* 2. Handles EnSight6 and EnSight Gold formats only.
*
*

3. Does not process SOS casefiles.

*
*
*
*
*
R R R R RS S SRS R R R R RS R SRR SRR RS EEEEEEEEEEEEEEEEEEEEE]

Casefile to Process:

3by3s.case (Opened successfully)

Required FORMAT section (at line 1)
Required GEOMETRY section (at line 4)
Optional VARIABLE section (at line 7)
Optional TIME section (at line 11)
FORMAT Section:
EnSight 6 Format (set at line 2)
TIME section:
Info for timeset number: 1
Time set: 1 (at line 12)
No description provided
Number of steps: 1 (at line 13)
Time values: (starting on line 14)
time values[1l] = 0
Smm e mmm—m - - <
> TIME section OKAY <
S------———----————-- <
GEOMETRY Section:
Model filename is: 3by3s.geo (at line 5)
Static geometry
Opened 3by3s.geo successfully
File type is: ASCII
Description 1: EnSight test geometry file
Description 2: —=========================
node ids: assign
element ids: assign

Global section:
Number of nodes: 0

Part 1:
Description is: 3 x 3 xy block
Structured Part
Not iblanked
ijk=441
Number of nodes: 16
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Number of cells: 9
Block X coordinates for (16) nodes found
Block Y coordinates for (16) nodes found
Block Z coordinates for (16) nodes found

Part 2:
Description is: 3 x 3 yz block
Structured Part
Not iblanked
ijk=441
Number of nodes: 16
Number of cells: 9

===> Problem:

Previous lines end with 1 extra chars on the line,
but line 2 has 2 extra chars. The lines must be consistent
or EnSight will have trouble reading it.

—k_k_k_k_%_% bummer! *-F-k_k_%_%_

Verification of the data FAILED

vV V. V V V
AN NN ANA

—kok ok ok _k_k_k_k_Kk_Kk_Kk_k_k_k_k_%k_

After eliminating the extra space, the file then checked out fine.

ADVANCED USAGE

Redirecting Output to a File:

ens_checker is writing to stderr, so if you want to redirect output to a file, you need to use “>&”. For example, the
following will place the output of the run into a file called output.file:

> ens_checker 3by3.case >& output.file

OTHER NOTES

The word “most” is used above because one of the things that could pass the checker, but fail in EnSight is element
connectivity of EnSight6 files with node ids. The ens_checker checks that node ids used in the element
connectivities lie within the min and max range of the node ids, but does not verify that there is actually a node with
each individual id.

The validity of model extents, presence of nan’s, etc. are currently checked to some degree in ens_checker, but
again, this is a format checker - not a model integrity checker.

SEE ALSO

User Manual:

EnSight Gold Casefile Format
EnSight6 Casefile Format
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INTRODUCTION

Normal operation of EnSight involves one client process (the graphics and GUI) interfacing with one server process
(data I/O and computation) to postprocess your data. You can, however, connect a single client to multiple servers at
the same time. Each server maintains a unique dataset and can potentially run on different machines.

\

Normal Operation Two Cases

The main use of EnSight’s cases capability is to visualize multiple datasets simultaneously. Each dataset is loaded
into a separate case and can be viewed in the same window or in separate viewports. You can perform before and
after comparisons of the same problem or compare experimental with simulated results. The same operation (such
as a clip or a particle trace) can be performed in both cases simultaneously. Created parts always belong to the
same case as the parent from which the part was created. As a consequence, you cannot perform operations that
combine parts (such as a merge) from multiple cases.

When EnSight reads a new case, it searches the current list of variables for matches with the variables from the new
case. Ifitfinds a match (based on an exact match of the variable name), it will not enter the new variable in the list.
Rather, the matched name will be used for both. This behavior is based on the assumption that the identical variable
names represent the same physical entity and should therefore be treated the same. If the new variable name does
not match any existing name, the new variable is added to the list as usual.

Up to 16 cases can be active at one time. To add a case to a running session, you return to the data reader. Adding a
case starts a new server process and connects it to the client. You can then specify the data files and format to load
into the new server. You can also replace an existing case (useful for loading a new dataset into EnSight without re-
starting the client) and delete cases you no longer need.
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BASIC OPERATION

Case operations are accessed through the Case menu.

Add a Case

To add a case to a running EnSight session:

1. Select Case > Add, Replace, Delete... to open the data reader File Selection dialog.

| Filter

traritmp/datalensight!amir*

| Directories Files
rarftmp/datafensight/amil. README.ami
tvarttmp/datafensight/ami/.. ami.gea

5 ami.res |
ami.ecl
ami.ct

2. If the Case section is not open,
click the turndown. ----------------- bl Case {Add, Replace,Delete)

3_c“ckAdd"________________________;--»Add...[ Replace... |  Delete |

4. If desired, enter a name for the
case (other than the default).

Case NanE pase 2

The name will be displayed in the Optional Settings
Case menu so this case can be Create new viewport for this case
selected as the current case. <

Apply Context From Case 1
5. Set optional settings. -------- L
"l )} Beflect Model About Axis

Create new viewport for this case will |} X v Z

place the new case in a new viewport. - .
Z || A origin X4 50006100 ¥ 1 0.0000e-+00 Z | 0.0000e-+00

Apply Context From Case 1 will cause |

the new case to inherit positioning etc. |I" Qkay Canecsl

from case 1.

[ I

Reflect Model About Axis allows the
model to be reflected as it is read in.
Pick the axis and specify the origin
location.

6.ClickOKkay. ..............................

The EnSight client will now start the connection process for the new server. If your original
connection was automatic, the new server will be started automatically. If your original connection
was manual, you will have to manually start another server. You can follow the progress of the
connection in the Message area. See the EnSight Getting Started Manual or How To Start and
Connect Automatically for more information.
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Replace a Case

You can replace an existing case. This is most useful when you wish to load a new dataset without having to stop
and re-start the client. To replace a case:

1. Select the case you wish to replace in the Case menu (Case > casename).
2. Select Case > Add, Replace, Delete... to open the data reader File Selection dialog.
3. If the Case section is not open, click the turndown.

4. Click Replace...

You will be asked to confirm the replacement. If confirmed, the server associated with the selected case is
terminated and the EnSight client will now start the connection process for the new server. If your original connection
was automatic, the new server will be started automatically. If your original connection was manual, you will have to
manually start another server. You can follow the progress of the connection in the Message area. See How To
Start and Connect Automatically for more information.

Delete a Case

To delete a case:

1. Select the case you wish to delete in the Case menu (Case > casename).
2. Select Case > Add, Replace, Delete... to open the data reader File Selection dialog.
3. If the Case section is not open, click the turndown.

4, Click Delete...
You will be asked to confirm the deletion. If confirmed, the server associated with the selected case is terminated.

Displaying Parts by Case

By default all parts from all cases are displayed in the Main Parts list. The parts associated with a given case are
shown by the “C#” code at the beginning of the part entry, where # is the number of the case. You can restrict the
parts listed in the Main Parts list such that only those parts belonging to the currently selected case are shown. This
is useful when you need to quickly select all the parts belonging to a case for some common operation. To do this:

1. Select the case whose parts you wish to display in the Main Parts list in the Case menu (Case > casename).

2. Select Case > Restrict List Info. Per Case.
Note that the parts list in the Feature Detail Editors has also been restricted to the current case.

Case Viewport Display

One of the chief advantages of the case feature is the ability to perform side-by-side comparisons of different
datasets. The best way to do this is to display each case in a separate viewport. To do this:

1. Create as many additional viewports as you need to
display your cases. See How To Define and Change ]
Viewports for more information. Visible In Viewport(s)

2. Select the case whose parts you wish to display only in
certain viewports in the Case menu (Case > casename).

3. Select Case > Viewport Visibility...

4. Click in the desired viewport to enable or disable -

display of the selected case. Red means the selected
case is not displayed in the viewport, green means that
it is displayed.
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ADVANCED USAGE

EnSight’s cases capability has also been used to achieve coarse-grained parallelism for very large datasets by
partitioning a mesh into blocks and reading each block into a different case. Each case can run on different machines
or on different CPUs of a multiprocessor host. Since the EnSight client places the geometry from the different cases
in the same coordinate system, the blocks are effectively “stitched” back together for viewing. Operations such as
clipping and isosurface calculation are then automatically performed in parallel. However, since there is no
communication between the servers (in the current release) you cannot trace particles originating in one block and
expect them to cross a block boundary into a different block.

OTHER NOTES

When you perform an archive operation, a binary dump file is produced for each active server (case). The archive
information file contains details about the cases and can be used to restart the EnSight client as well as all servers
active when the archive was performed. See How To Save and Restore an Archive for more information.

SEE ALSO

User Manual: Case Menu Functions
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INTRODUCTION

From it’s inception, EnSight has been used extensively to postprocess time-varying or transient data. In many cases,
dynamic phenomena can only be understood through interactive exploration as a transient case is animated.

EnSight handles all types of transient data. All variables as well as mesh coordinates and connectivity can vary over
time. The rate at which variables (or the mesh) change can differ (supported through the EnSight 6 data format only).

EnSight can postprocess transient data in many ways. The Solution Time Quick Interaction area lets you easily set
the current time step, step through time, or restrict the range of time to a region of interest. You can perform query
operations to extract information over time. You can use the flipbook capability to create an on-screen animation of
your data changing over time and continue to interact with it during animation playback. EnSight's keyframe
animation capability can be used to create high-quality video animations of transient data.

This article covers reading transient data into EnSight.

BAsSIC OPERATION

Reading transient data into EnSight is essentially the same as reading static data (see How To Read Data for more
information). By default, the /ast time step will become the current time step. This behavior is based on the
assumption that the last step will contain the largest dynamic range of the variable data so that variable palettes will
be initialized properly. However, you can override this by clicking the Specify Starting Time Step toggle and entering
the desired time step in the data reader File Selection dialog (File > Data (Reader)...).

For most data formats, the “results” file supplies the necessary time information, including number of steps, actual
solution time at each step, and how to access the dynamic variable and geometry files. However, some formats
supported by EnSight include this information in the same file that contains other geometry or variable data. The
following table lists how transient data is specified for each format type.

Format Type What File Contains Time Info? Notes
Case file.case Standard EnSight case file
EnSight 5 file.res Standard EnSight results file
EnSight 6 file.case Standard EnSight case file
EnSight Gold file.case Standard EnSight case file
ABAQUS file.fil
ANSYS file.rst, file.rth, etc.
ESTET Does not handle transient data
FAST file.res. Can handle transient geometry Special FAST format results file. See FAST
as well as solution and function files. UNSTRUCTURED Results File Format
PLOT3D file.res. Can handle transient geometry Special PLOT3D format results file. See PLOT3D

as well as solution and function files.

Results File Format.

FIDAP NEUTRAL file.fdneut All time steps must be contained in the same neutral
file (i.e. there is only one file, not one for every time
step).

FLUENT UNIV file.unv Special FLUENT format results file. See FLUENT
UNIVERSAL Results File Format

MOVIE.BYU file.res Standard EnSight results file

MPGS file.res Standard EnSight results file

N3S file.res N3S results file

User Defined as required

SEE ALSO

How To Change Time Steps, How To Animate Transient Data, How To Query/Plot

User Manual: Solution Time, Flipbook Animation, Query/Plot

User Manual Page 1 of 1
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INTRODUCTION

EnSight7 (with gold license key) has the capability of dealing with partitioned data in an efficient distributed manner
by utilizing what we call a server-of-servers (SOS for short). An SOS server resides between a normal client and a
number of normal servers. Thus, it appears as a normal server to the client, and as a normal client to the various
normal servers.

Server
of
Servers

Server 2

This arrangement allows for distributed parallel processing of the various portions of a model, and has been shown to
scale quite well.

Note: EnSight SOS provided with release 7.6 does not yet support transient particle tracing (pathlines), but
does support steady state tracing (streamlines).

Currently, EnSight SOS capability is only available for EnSight5, EnSight6, EnSight Gold, Plot3d, and any EnSight
User-Defined Reader data. (It is not directly available for Fidap Neutral, Fluent Universal, N3S, Estet, MPGS4,
Movie, Ansys, Abaqus, or FAST Unstructured data.)

Please recognize that your data must be partitioned in some manner (hopefully in a way that will be reasonably load
balanced) in order for this approach to be useful. (The exception to this is the use of the auto_distribute capability for
structured data. This option can be used if the data is structured and is available to all servers defined. It will
automatically distribute each portions of each structured block over the defined servers - without the user having to
partition the data.)

(Included in the EnSight distribution is an unsupported utility that will take most EnSight Gold binary unstructured
datasets and partition it for you. The source for this utility (called “chopper”) can be found in the $CEI_HOME/
ensight76/unsupported/partitioner directory.)

Note: If you do your own partitioning of data into EnSight6 or EnSight Gold format, please be aware that each part
must be in each partition - but, any given part can be “empty” in any given partition. (All that is required for an empty
part is the “part” line, the part number, and the “description” line.)

You should place each partitioned portion of the model on the machine that will compute that portion. Each
partitioned portion is actually a self contained set of EnSight data files, which could typically be read by a normal
client - server session of EnSight. For example, if it were EnSight gold format, there will be a casefile and associated
gold geometry and variable results file(s). On the machine where the EnSight SOS will be run, you will need to place
the sos casefile. The sos casefile is a simple ascii file which informs the SOS about pertinent information needed to
run a server on each of the machines that will compute the various portions.

The format for this file is as follows: (Note that [ ] indicates optional information, and a blank line or a line with # in the
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first column are comments.)

FORMAT (Required)
type: master_server datatype (Required)
where: datatype is required and is one of the formats of EnSight’s internal readers (which

use the Part builder), namely:

gold ensight6 ensight5 plot3d
or it can be the string used to name any of the user-defined readers.
Note: For user-defined readers, the string must be exactly that which is defined in the
USERD_get_name_of_reader routine of the reader (which is what is presented in the Format
pulldown of the Data Reader dialog).
If datatype is blank, it will default to EnSight6 data type.

[auto_distribute: on/off] (Optional for structured, Ignored for unstructured)
For structured data only, EnSight will automatically distribute data to the servers specified below
if this option is present and set to “on”. This will require that each of the servers have access to
the same data (or identical copies of it).

[plot3d_iblanked: truelfalse] (Required only if datatype is plot3d)

[plot3d_multi_zone: truelfalse] (Required only if datatype is plot3d)

[plot3d_dimension: 1d/2d/3d] (Required only if datatype is plot3d)

[plot3d_source: asciilcbin/fortranbin](Required only if datatype is plot3d)

[plot3d_grid_double: truelfalse] (Required only if datatype is plot3d)

[plot3d_results_double: truelfalse] (Required only if datatype is plot3d)
where: iblanking, multi_zone, dimension, source type, grid file double precision, and results file
double precision information should be provided. If it is not provided, it will default to the
following (which is likely not to be correct):

plot3d_iblanked: false
plot3d_muti_zone: false
plot3d_dimension: 3d

plot3d_source: cbin
plot3d_grid_double: false

plot3d_results_double: false

NETWORK_INTERFACES (Note: This whole section is optional. It is needed only when more than one network
interface to the sos host is available and it is desired to use them. Thus, distributing the servers
to sos communication over more than one network interface)

number of network interfaces: num(Required - if section used)
where: num is the number of network interfaces to be used for the sos host.
network interface: sos_network_interface_name_1(Required - if section used)

network interface: sos_network_interface_name_2(Required - if section used)

network interface: sos_network_interface_name_num(Required - if section used)

SERVERS (Required)
number of servers: num (Required)
where: num is the number of servers that will be started and run concurrently.

#Server 1 (Comment only)
machine id: mid (Required)
where: mid is the machine id of the server.

executable: /.../ensight7.server (Required, must use full path)
[directory: wd] (Optional)
where: wd is the working directory from which ensight7.server will be run

[login id: id] (Optional)
where: id is the login id. Only needed if it is different on this machine.

[data_path: /.../dd] (Optional)
where: dd is the directory where the data resides. Full path must be provided if you use this line.

casefile: yourfile.case (Required, but depending on format, may vary as to whether it is a casefile, geometry file,
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neutral file, universal file, etc. Relates to the first data field of the Data Reader Dialog.)

[resfile: yourfile.res] (Depends on format as to whether required or not. Relates to the second data field of the Data
Reader Dialog.)

[measfile: yourfile.mea] (Depends on format as to whether required or not. Relates to the third data field of the Data
Reader Dialog.)

[bndfile: yourfile.bnd] (Depends on format as to whether required or not. Relates to the fourth data field of the Data
Reader Dialog.)

--- Repeat pertinent lines for as many servers as declared to be in this file ---

BAsSIC OPERATION

To use Server of Servers, you must:

1. Partition your data, and distribute it (or make it available) to the various machines on which you will run servers.
(Or if you have structured data, you can use the auto_distribute option in the sos casefile.)

2. Create the sos casefile, which defines the server machines, the location of server executables on those machines,
and the name and location of the partitioned data for the servers.

3. Use EnSight7.sos in place of EnSight7.server, and provide it with the sos casefile.

Example SOS Casefile

This example deals with a EnSight Gold dataset that has been partitioned into 3 portions, each running on a different
machine. The machines are named joe, sally, and bill. The executables for all machines are located in similar
locations, but the data is not. Note that the optional data_path line is used on two of the servers, but not the third.

FORMAT
type: master_server gold

SERVERS
number of servers: 3

#Server 1

machine id: joe

executable: /usr/local/bin/ensight76/bin/ensight7.server
data_path: /usr/people/john/data

casefile: portion_1.case

#Server 2

machine id: sally

executable: /usr/local/bin/ensight76/bin/ensight7.server
data_path: /scratch/sally/john/data

casefile: portion_2.case

#Server 3

machine id: bill

executable: /usr/local/bin/ensight76/bin/ensight7.server
casefile: /scratch/temp/john/portion_3.case

If we name this example sos casefile - “all.sos”, and we run it on yet another machine - one named george, you would
want the data distributed as follows:

On george: all.sos

On joe (in /usr/people/john/data): portion_1.case, and all files referenced by it.
On sally (in /scratch/sally/john/data): portion_2.case, and all files referenced by it.
On bill (in /scratch/temp/john): portion_3.case, and all file referenced by it.

By starting EnSight with the -sos command line option (which will autoconnect using ensight7.sos instead of
ensight7.server), or by manually running ensight7.sos in place of ensight7.server, and providing all.sos as the
casefile to read in the Data Reader dialog - EnSight will actually start three servers and compute the respective
portions on them in parallel.
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Optional NETWORK_INTERFACES section notes

If the machine named george had more than one network interface (say it had its main one named george, but also
had one named george2), we could add the section shown below to our casefile example:

NETWORK_INTERFACES
number of network interfaces: 2
network interface: george
network interface: george2

This would cause machine joe to connect back to george, machine sally to connect back to george2, and machine bill
to connect back to george. This is because the sos will cycle through its available network interfaces as it connects
the servers. Remember that this is an optional section, and most userd will probably not use it. Also, the contents of
this section will be ignored if the - soshostname command line option is used.

Example SOS Casefile for PLOT3D, Using auto_distribute

This example shows a plot3d dataset (post.x and post.q) that has not been partitioned, but is on an nfs mounted disk
available to each server machine. EnSight will distribute the data to the 3 servers defined. 10 will not necessarily be
great since each server will be reading from the same file, but execution will be enhanced by the partitioning. We will
use the same machines used in the previous example.

FORMAT

type: master_server plot3d
auto_distribute: on
plot3d_iblanked: true
plot3d_multi_zone: false
plot3d_dimension: 3d
plot3d_source: cbin
plot3d_grid_double: false
plot3d_results_double: false

SERVERS
number of servers: 3

#Server 1

machine id: joe

executable: /usr/local/bin/ensight76/bin/ensight7.server
data_path: /scratch/data

casefile: post_x

resfile: post.q

#Server 2

machine id: sally

executable: /usr/local/bin/ensight76/bin/ensight7.server
data_path: /scratch/data

casefile: post.x

resfile: post.q

#Server 3

machine id: bill

executable: /usr/local/bin/ensight76/bin/ensight7.server
data_path: /scratch/data

casefile: post.x

resfile: post.q

SEE ALSO

How To Read Data

How To Read EnSight Gold Data
How To Read EnSight 6 Data
How To Read User Defined

User Manual: Server-of-Server Casefile Format
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INTRODUCTION

Version 7 of EnSight, while continuing to read EnSight 5 and EnSight 6 formats, defines a new data format that is
essentially the same as that of EnSight 6, except that its parts are self contained - allowing for much improved
efficiency in both read times and memory use. The EnSight Gold format loaded into EnSight through the Case
mechanism. A case file provides all the information needed for an entire dataset, including filenames and
descriptions of any geometry or variable files needed, constant descriptions and values, time set information etc.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for EnSight 6 data. See How To Read
Data for more information on selecting the appropriate files.

EnSight Gold datasets consist of the following files. Note that the entry in the File Name column is only a suggestion,
it typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?

Case file.case | Provides additional information about the dataset (such as time yes
information) as well as pointers to the files actually containing the
geometry, measured, boundary, and variable data.

Geometry file.geo Contains coordinates and element connectivity. yes

Scalar Variable file.scl Each scalar variable file contains one value per node or element defined optional
in the geometry file.

Vector Variable file.vec Each vector variable file contains three values per node or element optional
defined in the geometry file.

Tensor Variable file.ten Each tensor variable file contains six (symmetric) or nine (asymmetric) optional
values per node or element defined in the geometry file.

Measured, * Measured results, geometry, and variable files. Boundary definition files all optional

Boundary, etc. for structured data.

BAsSIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (Case) dialog will open. You use this dialog
to build the desired parts. Since the EnSight Gold format supports both structured and unstructured data, you can
select the type of parts you wish to build and the dialog’s interface will change accordingly.

To build unstructured parts from the EnSight Gold format data:

Data Part L oader (Case)

4+ Unstructured Data o Structured Data

1. If the Data Part Loader dialog is not open,
select File > Data (Part Loader)...

The available parts are listed in the Parts List. You
can build them all by clicking Load All at the bottom.
Alternately, you can build them one by one and
choose a different visual representation and part
name for each. To build selected parts:

| Parts List
left sguare
| right square

2. Select the desired part(s) in the Parts list. ... .

E
3. Choose the desired initial Visual ... §Element Visual Rep. 3D border, 2D full I

Representation for the select part(s). ---------------: Feature An
gle | I

4. If desired, enter a name for the part (to use in New Part I
the Main Parts list). The default name is the ~ |§Description L%
same as the entry in the Parts List. -------------------© & NOTE: Variables will nat be loaded for newly

created parts until this dialog is closed.
5. Click Load Selected. ------------------oooo e

Helpl E
6. Click Close whendone. .............................
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To

1

Valid values in the From and To fields are numbers
advancing from 1(the min for each part), or

The Min and Max fields are for reference

. Be sure Structured Data is selected to

. Select the desired part(s) in the Parts

. Choose the desired initial Visual

. If the selected part has Iblanking, you

] From Tea Step Delta Min Max
1
- You can specify From, To, and Step IJK: ' >I 1 I 1 I 1 I 0 | |
values for the selected part(s). The @ { | 1 | 1 | 1 | 0 ®
From and To values are inclusive. ------ |

- ST LTSI - - >
numbers decreasing from 0(the max for each part): | :
123, > e 3210 : Create And Load Structured Part |
| |
min max 4 [{ lanked Part Creation
(always 1) (varies per part) i

If you specify values that will be outside of the . :
range of an individual part, the proper min or ma):(' :
values for the given part will be used.

build structured parts from the EnSight Gold format data:

. If the Data Part Loader dialog is not open,

select File > Data (Part Loader)...

E E Data Part { sader (Case)

display only the structured parts in the + Unstructured Data 4 Structured Data
Parts List. -------------noei -

arts List { Parts List
zone 1 (ALL), Mins/Maxe=(I:1/74,1:1/25 K:1/2)
1 zone 2 (ALL), Mins/Maxs=(I:1/74,J:1/35,K:1/30)

Ene 3 (ALL), Mins/Maxs={I:1/66,J:1/28,K:1/15)
zone 1 (ALL)Y, Mins/Maxs=(I:1/56,J:1/15,K:1/15)

=

List.

Representation for the select part(s).

Feature Angle I R

can build based on the value (Inside . ;
selects cells where Iblank=1, Outside. .- § Domajn  Inside i I

selects Iblank=0, All selects all cells :

Using Node Ranges:
ignoring Iblanking). .- ----- -0 |

<+ T« [« [ o [ |

1 *OSNOTE****: Variables will not bhe loacded for
1 newly created parts until this dialog is closed.

Closel

only. 7. If you desire to extract multiple

8. If desired, enter a name for the part (to usein ; : surfaces (at a constant delta) from the
the Main Parts list). The defaultname isthe : @ same zone, set one of the directions to
same as the entry in the Parts List.............: : the desired non-zero delta value. ------- -

9. Open this turndown section to create : This is a “blade row” kind of operation.
unstructured parts based on boundary . Please note that this results in an
Iblanking from any parts created above. ..-......: unstructured part instead of a structured one.

10. Click Create and Load Part. .- ..ot e e
11. Click Close when done.

OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

If your data fails to read, you should run it through the ens_checker program provided with the EnSight distribution to
check for format errors.

SEE ALSO

How To Read Data
How To Use ens_checker

User Manual: EnSight Case Reader
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INTRODUCTION

The current release of EnSight still supports the data file format known as “EnSight 5” which was originally released
with version 5.0. The EnSight 5 format supports unstructured (finite-element) geometry with scalar or vector nodal
variable data. Both geometry and variables can change over time. The format provides for both binary and ASCII
versions.

EnSight 5 datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?
Geometry file.geo Contains coordinates and element connectivity. yes
Result file.res Provides additional information about the dataset (such as time information) as well optional

as pointers to the files actually containing the variable data.
Scalar Variable file.scl Each scalar variable file contains one value per node defined in the geometry file. optional
Vector Variable file.vec Each vector variable file contains three values per node defined in the geometry file. optional
Measured * Measured results, geometry, and variable files optional

Note that the EnSight 5 format also supports measured or discrete data. See How To Display Discrete or
Experimental Data for more information.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for EnSight 5 data. See How To Read
Data for more information on selecting the appropriate files.

BAsSIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (EnSight 5) dialog will open. You use this
dialog to build the desired parts. To build parts for EnSight 5 format data:

1. If the Data Part Loader dialog is not open, select
File > Data (Part Loader)...

The available parts are listed in the Parts List. You can mmm
build them all by clicking Load All at the bottom. Data Part Loader EnSight 5)

Alternately, you can build them one by one and choose 4 Unstructured Data o Struchared Dals
a different visual representation and part name for ;
each. To build selected parts:

2. Select the desired part(s) in the Parts list.

‘
3. Choose the desired initial Visual Representation

for the select part(s). ----------ooooii ]

|~

: Element Vizual Rep‘.>3D horder, 2D full

4. If desired, enter a name for the part (to use in the Feature Angle I R
Main Parts list). The default name is the sameas § .
: i ew Part I
the entry in the Parts List. ---------------oonno oo | Description |

NOTE: Variables will not be loaded for newly

. created parts until this dialog is cloaged.
5. Click Load Selected. -------------vmmmoomceeennnnns R -

-
,glnsel Load Selected | Load All | He1p_|-§

6. Click Close whendone. ... - ... ...
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OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

SEE ALSO
How To Read Data

User Manual: EnSight5 Reader
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INTRODUCTION

Version 6 of EnSight defines a new data format that is largely a superset of the EnSight 5 format. The new format was
designed to accommodate block structured data as well as dynamic data varying at different rates. The EnSight 6
format is actually loaded into EnSight through the Case mechanism. A case file supersedes the older “results” file
providing all the information contained in a results file and more. Indeed, the case file can actually be used as a
wrapper for formats other than EnSight 6 (since it contains information on the format of the underlying data files).

NOTE: this How To article also applies to any User Defined Data Reader!

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for EnSight 6 data. See How To Read
Data for more information on selecting the appropriate files.

EnSight 6 datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?

Case file.case Provides additional information about the dataset (such as time yes
information) as well as pointers to the files actually containing the
variable data.

Geometry file.geo Contains coordinates and element connectivity. yes

Scalar Variable file.scl Each scalar variable file contains one value per node or element optional
defined in the geometry file.

Vector Variable file.vec Each vector variable file contains three values per node or element optional
defined in the geometry file.

Tensor Variable file.ten Each tensor variable file contains six (symmetric) or nine optional
(asymmetric) values per node or element defined in the geometry
file.

Measured and * Measured results, geometry, and variable files. Boundary definition | all optional

Boundary files files for structured data.
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BASIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (Case) dialog will open. You use this dialog
to build the desired parts. Since the EnSight 6 format supports both structured and unstructured data, you can select
the type of parts you wish to build and the dialog’s interface will change accordingly. Since the interface for building
unstructured parts is exactly the same as building parts for EnSight 5 format, only structured part building is covered
here. (See How To Read EnSight 5 Data for details on building unstructured parts.)

To build structured parts from the EnSight 6 format data:
1. If the Data Part Loader dialog is not open,

select File > Data (Part Loader)... _
Data Part | oader (Case)

+w Unstuctured Data (A Structured Data

2. Be sure Structured Data is selected to :
display only the structured parts in the

Parts List. ~~----ooommrommmmmmeee e Parts List

. . zone 1 {ALLY, Mina/Max==(1:1/74,J:1/25 K:1/2}
3. Select the desired part(s) in the Parts 1 zone 2 {(ALL), Mins/Maxs=(I:1/74,J:1/35,K:1/30}

List. - » 1 2one 3 (ALL), Mins/Maxs=(1:1/66,J:1/28,K:1/15)

zone 4 (ALL)Y, Mina/Maxs=(1:1/56,J:1/15 K:1/15)
=

4. Choose the desired initial Visual
Representation for the select part(s).

Feature Angle I T

5. If the selected part has Iblanking, you |
can build based on the value (Inside ;" D‘ """ - >I ide 1
selects cells where Iblank=1, Outside : | omatn | nsice I
selects Iblank=0, All selects all cells : § Using Nade Ranges:
ignoring Iblanking). --------oooooooool From T Step Delta Min Max

- ‘P o T e |

6. You can specify From, To, and Step UK |
values for the part. The Fromand To .. { 1 | 1 | 1 | 0 1

Diaybtioeu SO | e e | ]
advancing from 1(the min for each part), or .- . _Structured Part Description |

numbers decreasing from 0(the max for each part):

. Create And Load Stractured Part | |

1,2,3,... > < 23,210 ; A
I | 1 '
: ! | [@ Iblanked Part Creation .
min max
(always 1) (varies per part) *+4NOTE***; Variables will not be loaded for

If you specify values that will be outside of the - newly created parts until this dialeg is closed.
range of an individual part, the proper min or ma>§

values for the given part will be used. o M
The Min and Max values are for reference : L
only. LT

8. If desired, enter a name for the part (to use in :

the Main Parts list). The default name is the
same as the entry in the Parts List. ..........:"!

7. If you desire to extract multiple surfaces (at a
constant delta) from the same zone, set one of

the directions to the desired non-zero delta :
value. ool

9. Open this turndown section to create . ¢ Thisis a “blade row” kind of operation. Please note
unstructured parts based on boundary . 1 that this results in an unstructured part instead of a
Iblanking from any parts created above. ------- : structured one.

10. Click Create and Load Part. .- oooooooo

11. Click Close when done.
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OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

If your data fails to read, you should run it through the ens_checker program provided with the EnSight distribution to
check for format errors.

SEE ALSO

How To Read Data
How To Use ens_checker

User Manual: EnSight Case Reader
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INTRODUCTION

EnSight supports files as written from ABAQUS (a commercial FEM solver) with certain restrictions. Versions 5.2
through 5.8 are supported. Restrictions:

1. For versions prior to 5.6, if a .dat file with the same root name as the fil file is present in the same directory and
contains element set information, EnSight will build parts based on those sets. Otherwise, all elements are com-
bined into a single part. To place element sets in the .dat file, use the ABAQUS command *PRE -

PRINT, MODEL=YES. (For version 5.6, element set data is contained in the fil file and is always used.)

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read (see How To Read Data for more information). Second, parts
are constructed. For ABAQUS data, parts are built automatically: a single part if no .dat file exists or parts based on
the element sets in a .dat file if one is found.

ABAQUS datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is (except that a .dat file must have the same root name
as the fil file).

File File Name Notes Required?
Geometry file.fil Contains coordinates, element connectivity, and variables (Ascii or Binary accepted) required
Element sets file.dat Provides element set information so EnSight can create parts (for versions < 5.6) optional

SEE ALSO

How To Read Data

User Manual: ABAQUS Reader
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INTRODUCTION

EnSight supports files in the results (.rst, .rmg, .rfl, .rth, etc.) format as written from ANSYS (a commercial FEM
solver). Versions 5.0-5.6 are supported. Note that not all element types are supported (although most are). Certain
variables may read more slowly than others. While variables such as displacements and nodal solution variables
read quickly, stress and strain require additional calculations in order to be useful to EnSight.

EnSight also supports results from the FLOTRAN CFD solver from ANSYS. FLOTRAN results are written to .rfl files.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for ANSYS data. See How To Read Data
for more information on selecting the appropriate files.

ANSYS datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?
Geometry file.rst or Contains coordinates, element connectivity, and variables required
file.rth or
file.rmg or
file.rfl

BASIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (ANSYS) dialog will open. You use this
dialog to build the desired parts. To build parts for ANSYS format data:

1. If the Data Part Loader dialog is not open, select
File > Data (Part Loader)...

All parts defined in the .rst file will be loaded to the
EnSight server. However, you have a choice for the
initial visual representation of some parts as displayed
on the client. The choice is made with the Load pull-
down:

All Parts: all parts are loaded to the client in the default visual
representation (typically 3D Border, 2D Full).

Part 1 Only: Only the first part is loaded to the client in the
default visual representation. The other parts will have the
NonVisual representation.

1 i
=| Data Part Loader (ANSYS)
All But Part 1: All parts other than part 1 are loaded to the

client in the default visual representation. Part 1 will be

NonVisual.
Load All Parts - |
v = I |

No Parts: No parts are loaded to the client (i.e. the

representation of all parts is set to NonVisual). .~ Part1Only
Note that you can easily change the visual . | All But Part |
representation of a part at any time. See How To 5 No Parts

Change Visual Representation for more information.

2. Select the desired Load option.  -----------oo oo

3.Click0kay.--------------------------------------------7>0kay| Cancell Help

‘ 2000 ® HowTo Index User Manual Page 1 of 2




How To ... Read ANSYS Data
n 20000

OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

By default, EnSight includes all possible variables, so most users will not need to deal with the .var file described
below. However, since many of the stress variables may actually be zero, and because the list of variables is quite
long, there is a way to filter which variables will be accepted into EnSight. Simply provide a .var file as described
below.

# ,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
# EnSight .var file - for use with ANSYS results files
# ____________________________________________________
# Place in the same directory as the .rst file.
#
# example: If your result file were: my file.rst
# make a file like this and name it: my_file.var
B
Below
0 variable is turned off,

variable is turned on

The first column is significant:
#, space, or a newline will ignore the whole line. (Comment)

The variable keys like “_eqv” or “displacement” must start in 1st column.

The stress and strain variable flags on a line (0’s and 1’s), must come
in the order shown, but are free format.

For Contact: The line indicated as: Will be recognized as:
X _stat
_y _pene
_z _pres
_Xy _stot
_yz _slid

Any extended DOF scalars that are not recognized will be created.

(Note that components or vector sum for vector variables like
“displacement” are controlled within EnSight)

B I T I S I I o o kI I T

# ,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

# stress and strain variables: (Created if flagged on here AND any element
# ============================ nodal results in the ANSYS results file)

# stress total elast plast creep thermal

# strain strain strain strain strain contact

1 # UX, UY, UZ
rotation 1 # ROTX, ROTY, ROTZ

1

1

acceleration # AX, AY, AZ

velocity # VX, VY, VZ
#

PRES
TEMP
VOLT
MAG
ENKE
ENDS
EMF
CURR

SEE ALSO
How To Read Data

User Manual: ANSYS RESULTS Reader
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INTRODUCTION

EnSight supports files written from ESTET (a commercial CFD solver). The ESTET format supports block structured
meshes and is only available in binary format.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for ESTET data. See How To Read Data
for more information on selecting the appropriate files.

ESTET datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?

Geometry file Contains coordinates and variables required

BAsIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (ESTET) dialog will open. You use this
dialog to build the desired vector variables and parts. Before you build parts, you have the option of building vector
variables from the set of available scalar variables. To build vector variables:

After you click Okay in the File Selection dialog, the ESTET
Vector Builder dialog will open. To build vector variables,

you select the desired X,Y,Z components (one at a time) — p cilable Variables |
from the Available Variables list and then click the
corresponding “Set-?-Comp” button. : 4| [veloeity_v

velocity W
temperature
density

dt dt)_functic
temperature
Potentiel_reel
Potentiel Imag
pressure

2. Click SEt-X-COMP. -+« -nrmmmmmmemee e |- Set X-Comp| | velocity U
3. Perform steps 1 and 2 for the Y and Z components. M |

Set Z—Cnmpl

1. Select the name of the X component of the desired
vector variable. --------oooooiooia

WVector Descript

4. Enter a name for the new vector variable. ------------ . B Puild Vector

5. Click BUild VECEOr, ------ - -oeooeiiiiii] e N Vestor Variables === |

6. Build another vector variable or click Okay.  ----------.--
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After you click Okay, the Data Part Loader (ESTET) opens. To build parts for the ESTET format data:

1. If the Data Part Loader dialog is not open,

select File > Data (Part Loader)... :
|| Data Part Loader (ESTET)

Create ESTET Parts By

2.You c'an select the dt?mam fro_m which Domain Inside i v!&:lenlugut 3D border, 2D full I
to build the part: Inside, Outside, or | 1Zual hep.

All, rmrmmmr e - Feature Angle I EEI RS

3. If desired, specify From, To, and Step
IJK values for the part. The From and
To values are inclusive. -------------.. -f--

Min Max

Valid values in the From and To fields are

numbers advancing from 1(the min for each ]
part), or numbers decreasing from 0(the max for
each part): ]

1,2,3,.. —> <o 3,-2,1,0 ;
.‘ I Do Create And Load Structured Part
min max . - N
(always 1) (varies per part) :

a
Iblanked Part Creation

If you specify values that will be outside of the .
range of an individual part, the proper min or max: sk N OTE****: YVariahles will not be loaded for
values for the given part will be used. . | newly created parts until this dialog is closed.

The Min and Max values are for reference :
only. c

5. If desired, enter a name for the part
(to use in the Main Parts list). ------.:

4. If you desire to extract multiple surfaces (at a
constant delta) from the same zone, set one of the

6. Click Create and Load Part. .............. +-+  directions to the desired non-zero delta value. .......:

This is a “blade row” kind of operation. Please note that
this results in an unstructured part instead of a structured
one.

7. Open this turndown section to create
unstructured parts based on boundary
Iblanking (such as symmetry) from any :
parts created above. ------.ooo.o.ooollll

8. Click Close when done. -------------------t

OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above. You cannot, however, return to the ESTET Vector Builder
dialog.

SEE ALSO
How To Read Data

User Manual: ESTET Reader
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INTRODUCTION

EnSight supports files written in the FAST Unstructured data format. The FAST format was designed by NASA as an
adjunct to the PLOT3D format to store unstructured triangle and tetrahedral data. The triangles have associated tag
numbers that permit them to be grouped into EnSight parts. Variables are stored either in a standard PLOT3D
solution (Q) file or in a FAST function file.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is specific
to the applicable data format. This article covers the second step for FAST data. See How To Read Data for more
information on selecting the appropriate files. Note that the solution (or function) file should NOT be specified in
the (Set) Result slot. Instead a modified version of the standard EnSight results file must be used. See FAST
UNSTRUCTURED Results File Format for more information.

FAST datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?
Geometry file.geo Contains coordinates and element connectivity. required
Result file.res Provides additional information about the dataset (such as time information) as well optional

as pointers to the files actually containing the variable data. Note: This is a special
version of the EnSight results file! See FAST UNSTRUCTURED Results File Format
for more information.

Solution file file.q Standard PLOT3D format solution file optional
Function file file.f Standard PLOT3D/FAST function file. optional

BAsSIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (FAST) dialog will open. You use this
dialog to build the desired parts. To build parts for the FAST format data:

All parts defined in the geometry file will be loaded to
the EnSight server. However, you have a choice for the
initial visual representation of some parts as displayed
on the client. The choice is made with the Load pull-
down:

All Parts: all parts are loaded to the client in the default visual
representation (typically 3D Border, 2D Full).

Part 1 Only: Only the first part is loaded to the client in the
default visual representation. The other parts will have the
NonVisual representation.

All But Part 1: All parts other than part 1 are loaded to the

ﬂf:\t/igut;e default visual representation. Part 1 will be '='i Data Part L oader (FAST)

No Parts: No parts are loaded to the client (i.e. the

representation of all parts is set to NonVisual). Load All Parts I - |

With FAST geometry, a good choice is All But Part 1 A Part 1 Only

(which is the tet mesh).
All But Part 1

Note that you can easily change the visual : Neo Parts
representation of a part at any time. See How To : -
Change Visual Representation for more information.

2. Select the desired Load option.  ------..............0 !

AR = 0kay| Cancell Help
3.ClickOkay. .- oo

7]

‘ 2000 ® HowTo Index User Manual Page 1 of 2




How To ... Read FAST
n 20000 Unstructured Data

The parts are named as follows. Any tetrahedral elements will be grouped into one part named “Tet Domain”. If any
triangles are present, they will be grouped into parts based on tag number and named “Tri_tag N” where N is the tag

number.
SEE ALSO
How To Read Data

User Manual: FAST UNSTRUCTURED Reader
FAST UNSTRUCTURED Results File Format
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INTRODUCTION

EnSight supports files written in the PLOT3D block-structured mesh format. Variables are stored either in solution
(Q) files or in “function” files. EnSight's PLOT3D reader supports ASCII, C binary, and Fortran binary as well as
Iblanking and multizone meshes.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for PLOT3D data. See How To Read Data
for more information on selecting the appropriate files.

If the solution (Q) file is in standard form (i.e. it contains five variables: density, X momentum, Y momentum, Z
momentum, and energy) then it can be specified in the (Set) Result slot of the Data (Reader) dialog. Otherwise, if a
non-standard Q file (or a function file) is used, then a modified version of the standard EnSight results file must be
specified in the (Set) Result slot. See PLOT3D Results File Format for more information.

PLOT3D datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?
Geometry file.x Contains coordinates and mesh resolution(s). required
Result file.res Provides additional information about the dataset (such as time information) as well optional

as pointers to the files actually containing the variable data. Note! This is a special
version of the EnSight results file! See PLOT3D Results File Format for more

information.
Solution file.q Standard PLOT3D solution file. Note! You can also give this file as the (Set) Result optional
file (in the Data (Reader) dialog) if it is a standard Q file.
Function file.f Standard PLOT3D/FAST function file optional
Boundary file.bnd Contains boundary surface definitions within or across structured parts. optional

Note:

To successfully read PLOT3D data, the following information must be known about the data:

1. format - ASCII, C binary, or Fortran binary
2. whether single or multizone

3. dimension - 3D, 2D, or 1D

4. whether iblanked or not

5. precision - single or double

EnSight attempts to determine these five settings automatically from the grid file. The settings that were determined
(for the first four) are shown in the Part Builder dialog, where you can override them manually if needed.

The precision setting is not reflected in the dialog, but is echoed in the Server shell window. The g (or function) file
precision will by default be set the same as that of the grid file. In the rare case where the automatic detection is
wrong for the grid file or the precision is different for the q (or function) file than for the grid file, commands can be
entered into the Command dialog to manually set the precision.

test: plot3d grid single to read grid file as single precision

test: plot3d grid double toread grid file as double precision

test: plot3d gr single to read q (or function) file as single precision

test: plot3d _gr double to read q (or function) file as double precision
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Read PLOT3D Data

BAsIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)...

as

discussed in How To Read Data) and clicked Okay, the Data Part Loader (PLOT3D) dialog will open. You use this
dialog to build the desired parts. To build parts for the PLOT3D format data:

1. The first time you read PLOT3D data for a
case, the Data Reader (PLOT3D) dialog
will open. Otherwise, if the Data Part
Loader dialog is not open, select File >
Data (Part Loader)..., and skip to step 7.

2. Click if geometry file has Iblanking. ............

3. Select the file type (ASCII, C Binary,
Fortran Binary). ........... ... ... ... ... ..

4. Click if geometry file has multiple zones..---.-..

5. Click to set the dimension (1D, 2D, 3D)...........
6.Clicktoreadthefile. ... ..o o oiaaeamm™"

(The Data Part Loader dialog will open)

7. If you have Iblanking, you can
select the desired Domain. ......................

8. If you have multi-zone data, select the

desired zone(s) from the Use Zones list. ....---

9. Select a desired initial visual
representation. ...l

10. If only one zone is selected, you can e
specify From, To, and Step IJK values for
the part. The From and To values are
inclusive. -------o-ooeeeeeeeeeiiiiiiiiieeeeees .

Valid values in the From and To fields are numbers
advancing from 1(the min for each part), or numbers

decreasing from O(the max for each part):
1,2,3,... —> <---...-3,-2,-1,0
| |
I I
min max
(always 1) (varies per part)

If you specify values that will be outside of the range
of an individual part, the proper min or max values for : :----
the given part will be used. N

The Min and Max values are for reference
only.

12. If desired, enter a name for the P
part (to use in the Main Parts list). ....... : .

13. Click Create and Load Part.
14. Open this turndown section to create
unstructured parts based on boundary

Iblanking from any parts created above.

15. Click Close whendone. ........................!

-4 Data Reader (PLOT3D) IS
Speecified PLOT3D File

Geometry: whighbin

Boundary:

BResult: whir.bin

Measured:

-t Ihlanked File

Read Ai C Binary

( Multi-Zone File

n Dimensioy, 3D
| » Read Specified File

Claze Help

-4 Data Part Loader (PLOT3D)

[

Unstructured Data Structured Data

Parts List

Zone 2
Zone 3
Zone 4

: Feature Angle
Domain Inside

Using Node Ranges:

From To Step Delta Min
’1\ 1 74 1 0 1
J 1 25 1 0 1
A 3
K 1 2 1 0 b
| Structured Part Description | »
""" » Create And Load Sttuctured Part

E Iblanked Part Creation

#EEHNOQTE**: Variables will not ke loaded for
newly created parts until this dialag is clased.

Claze

Bones — ]

G

Max
74
25

Help

11. If you desire to extract multiple surfaces (at a
constant delta) from the same zone, set one of the

directions to the desired non-zero delta value.

This is a “blade row” kind of operation. Please note that

this results in an unstructured part instead of a
structured one.
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ADVANCED USAGE

EnSight can also handle transient PLOT3D data — the solution file as well as the grid file can change over time. The
relevant file information is provided in the special results file required for PLOT3D data. See PLOT3D Results File
Format for more information.

OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

SEE ALSO
How To Read Data

User Manual: PLOT3D Reader, PLOT3D Results File Format
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INTRODUCTION

EnSight supports files in the NEUTRAL (.fdneut) format as written from FIDAP (a commercial CFD solver). Versions
6—7 are supported.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for FIDAP data. See How To Read Data
for more information on selecting the appropriate files.

FIDAP datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?

Geometry file.fdneut | Contains coordinates, element connectivity, and variables yes

BAsSIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (FIDAP) dialog will open. You use this
dialog to build the desired parts. To build parts for FIDAP format data:

1. If the Data Part Loader dialog is not open, select
File > Data (Part Loader)...

All parts defined in the .fdneut file will be loaded to the
EnSight server. However, you have a choice for the
initial visual representation of some parts as displayed
on the client. The choice is made with the Load pull-
down:

All Parts: all parts are loaded to the client in the default visual
representation (typically 3D Border, 2D Full).

Part 1 Only: Only the first part is loaded to the client in the
default visual representation. The other parts will have the
NonVisual representation.

| Data Part 1 oader (FIDAP)
All But Part 1: All parts other than part 1 are loaded to the

client in the default visual representation. Part 1 will be

NonVisual.
Load{ All Parts I = |

No Parts: No parts are loaded to the client (i.e. the

representation of all parts is set to NonVisual). - Partl Only
Note that you can easily change the visual All But Part 1
representation of a part at any time. See How To : No Parts

Change Visual Representation for more information.

2. Select the desired Load option.  -----------oooon e

3. Click OKay. «~---------oooeoooooooo o e Okay | Cancel | Help ||

J

OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.
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SEE ALSO
How To Read Data
User Manual: FIDAP NEUTRAL Reader
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INTRODUCTION

EnSight supports files in the UNIVERSAL (.univ) format as written from Fluent (a commercial CFD solver). Note that
other solvers from Fluent, Inc. (notably Fluent UNS and RAMPANT) will directly output EnSight 5 format files (from
the CORTEX interface).

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for Fluent data. See How To Read Data
for more information on selecting the appropriate files.

Fluent datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?

Geometry file.univ Contains coordinates, element connectivity, and variables required

BASIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (FLUENT) dialog will open. You use this
dialog to build the desired parts. To build parts for Fluent UNIVERSAL format data:

1. If the Data Part Loader dialog is not open, select
File > Data (Part Loader)...

All parts defined in the .univ file will be loaded to the
EnSight server. However, you have a choice for the
initial visual representation of some parts as displayed
on the client. The choice is made with the Load pull-
down:

All Parts: all parts are loaded to the client in the default visual
representation (typically 3D Border, 2D Full).

Part 1 Only: Only the first part is loaded to the client in the
default visual representation. The other parts will have the
NonVisual representation.

= Data Part L oader (FLUENT)

All But Part 1: All parts other than part 1 are loaded to the
client in the default visual representation. Part 1 will be

NonVisual. Load  All Parts I P | |

No Parts: No parts are loaded to the client (i.e. the 7 Part 1 Onl
representation of all parts is set to NonVisual). a Unly
All But Part 1

Note that you can easily change the visual :
representation of a part at any time. See How To : No Parts
Change Visual Representation for more information. :

2. Select the desired Load option.  ----------- ool

3. CliCK OKAY. < + Okay| Cancel | Help

7]

ADVANCED USAGE

The UNIVERSAL file provides all required information for a steady-state case. For transient data, a UNIVERSAL file
is required for each time step, as well as a standard EnSight results file providing time and variable information.
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OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

SEE ALSO
How To Read Data

User Manual: FLUENT UNIVERSAL Reader

‘ ? .... How To Index User Manual Page 2 of 2




How To ... Read MOVIE.BYU Data
n 20000

INTRODUCTION

EnSight supports files in MOVIE.BYU format. This format supports general n-sided polygons which may not map to
EnSight's element set. In most cases, this is not an issue since most applications generating MOVIE.BYU files are
based on a standard element set.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for MOVIE.BYU data. See How To Read
Data for more information on selecting the appropriate files.

MOVIE.BYU datasets consist of the following files. Note that the entry in the File Name column is only a suggestion
— it typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?
Geometry file.geo Contains coordinates and element connectivity. required
Result file.res Provides additional information about the dataset (such as time information) as well optional

as pointers to the files actually containing the variable data.
Scalar Variable file.scl Each scalar variable file contains one value per node defined in the geometry file. optional
Vector Variable file.vec Each vector variable file contains three values per node defined in the geometry file. optional

BASIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (Movie.BYU) dialog will open. You use this
dialog to build the desired parts. To build parts for MOVIE.BYU format data:

1. If the Data Part Loader dialog is not open, select
File > Data (Part Loader)...

All parts defined in the geometry file will be loaded to
the EnSight server. However, you have a choice for the
initial visual representation of some parts as displayed
on the client. The choice is made with the Load pull-
down:

All Parts: all parts are loaded to the client in the default visual
representation (typically 3D Border, 2D Full).

Part 1 Only: Only the first part is loaded to the client in the
default visual representation. The other parts will have the
NonVisual representation.

= Data Part Loader (Movie.BYU

All But Part 1: All parts other than part 1 are loaded to the
client in the default visual representation. Part 1 will be

NonVisual.
Load’ All Parts I - | |

No Parts: No parts are loaded to the client (i.e. the

representation of all parts is set to NonVisual). .-~ Part1Only
Note that you can easily change the visual All But Part 1
representation of a part at any time. See How To : Neo Parts

Change Visual Representation for more information.

2. Select the desired Load option.  ------------o ool

3.Click OKay. -------rcmmrmrari > Ok.ayl Cancell Help

7]
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OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

SEE ALSO
How To Read Data

User Manual: Movie.BYU Reader
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INTRODUCTION

EnSight supports files in MPGS format. This format supports general n-sided polygons and n-faced polyhedra which
may not map to EnSight’s element set.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for MPGS data. See How To Read Data
for more information on selecting the appropriate files.

MPGS datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?
Geometry file.geo Contains coordinates and element connectivity. required
Result file.res Provides additional information about the dataset (such as time information) as well optional

as pointers to the files actually containing the variable data.
Scalar Variable file.scl Each scalar variable file contains one value per node defined in the geometry file. optional
Vector Variable file.vec Each vector variable file contains three values per node defined in the geometry file. optional

BAsSIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (MPGS) dialog will open. You use this
dialog to build the desired parts. To build parts for MPGS format data:

1. If the Data Part Loader dialog is not open, select
File > Data (Part Loader)...

All parts defined in the geometry file will be loaded to
the EnSight server. However, you have a choice for the
initial visual representation of some parts as displayed
on the client. The choice is made with the Load pull-
down:

All Parts: all parts are loaded to the client in the default visual
representation (typically 3D Border, 2D Full).

Part 1 Only: Only the first part is loaded to the client in the
default visual representation. The other parts will have the
NonVisual representation.

= Data Part Loader (Movie.BYU
All But Part 1: All parts other than part 1 are loaded to the

client in the default visual representation. Part 1 will be

NonVisual.
Load All Parts I = |
v =

No Parts: No parts are loaded to the client (i.e. the
representation of all parts is set to NonVisual). Part 1 Only

Note that you can easily change the visual : All But Part 1
representation of a part at any time. See How To : Na Parts
Change Visual Representation for more information. ' —

2. Select the desired Load option.  -----------ooooaool o

3.Click OKay. ---------vmmmamae e > 0kay| Cancell Help

7]
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OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

SEE ALSO
How To Read Data

User Manual: MPGS 4.1 Reader
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INTRODUCTION

EnSight supports files as written from N3S (a commercial CFD solver). Versions 3.0, 3.1, and 3.2 are supported.

Reading data into EnSight is a two-step process. First, the appropriate files are selected. This step is largely the
same regardless of the format of the data being read. Second, parts are constructed using an interface that is
specific to the applicable data format. This article covers the second step for N3S data. See How To Read Data for
more information on selecting the appropriate files.

N3S datasets consist of the following files. Note that the entry in the File Name column is only a suggestion — it
typically does not matter to EnSight what the actual file name is.

File File Name Notes Required?
Geometry file.geo Contains coordinates and element connectivity required
Result file.res Contains time and variable data required

BAsSIC OPERATION

After you have specified the appropriate data files with the File Selector (opened with File > Data (Reader)... as
discussed in How To Read Data) and clicked Okay, the Data Part Loader (N3S) dialog will open. You use this dialog
to build the desired parts. To build parts for the N3S format data:

1. If the Data Part Loader dialog is not open, select
File > Data (Part Loader)...

There are three methods for building parts from N3S
geometry: All Elements, by Color Number, or by
Boundary Information. Do one of the following:

2. Click All Elements -« -«-----ocoovemaoiae, Create N8S Parts By
- dp-# All Elements

-OR- ;
P+ Calar Number

2. Click Color Number and select the desired

T
—OR-
2. Click Boundary Information and select the -4 |~ Boundary Information

desired Condition and Code.  -----------ooooinnnt Condition Code

L £ Faow Mouke
TRRED ATY i Homogena

PFREBEION 3 MNon-howoeg

3. If desired, enter a name for the part (to use in the
Main Parts list).

NOTE: Variables will not be loaded for newly
created parts until this dialog is clased.

4. Click Create and Load Part. ------------vovmoooooenns e Create And Load Part I
5. Click Close when done. -----------cccxremmmenanes # Close | Help |
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OTHER NOTES

You can reopen the Data Part Loader dialog at any time to build additional parts. Simply select File > Data Part
Loader)... and build the desired parts as described above.

SEE ALSO
How To Read Data

User Manual: N3S Reader
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INTRODUCTION

EnSight provides a mechanism for users to write their own readers and have the code automatically link and execute
at run-time (using a shared library). Since this is a capability which is somewhat subject to change, usage information
is best provided in README files in the EnSight Distribution. See the README files in $CEI_HOME/ensight76/
src/readers/ for details. A couple of sample readers, as well as the code for several actual readers are also
provided below this directory.

Additionally, a udr_checker.c file is provided in $CEI_HOME/ensight76/src/readers/checker which can be
used to debug your User-defined reader before using it with EnSight. See the README in this directory.

OTHER NOTES

When starting EnSight (ensight7 or ensight7.server), you use the command line option “-readerdbg” to echo user
defined reader loading status. This will allow you to see what readers are actually being loaded.

Set the environment variable ENSIGHT7_READER to point to the path where additional user defined readers exist.

SEE ALSO

How To Read Data
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INTRODUCTION

When building parts from the Data Part Loader dialog for structured parts (Ensight6 structured parts, EnSight gold
structured parts, PLOT3D parts), there is some flexibility in what is actually extracted. If the model contains iblanking,
then you have control over which iblanking domain to use, namely Inside, Outside (blanked out), or All (which ignores
the iblanking). If no iblanking in the model, the domain is All by default. You can extract all or portions of zones at
original or coarser resolutions, do the extractions on single or multiple zones, extract planes at every delta value
within a zone, etc.

BAsSIC OPERATION

When extracting the domain parts, whether iblanked or not, some (but definitely not all combinations) of the options
include:

Extracting a complete zone at original resolution,

1. Select the structured zone desired. .....................
. Unstructured Data Structured Data

Optionally you can change the domain and provide a part © | parts List

description. -

2. Hit the Create And Load Structured Part button. - ---. :

. . . . n Element Visual Rep. 3D border, 2D full
The part will be created and shown in the graphics window. *,

In the example below, it is shown in border representation
mode *, || Demain  Inside

Feature Angle jEIRE

Using Nade Ranges:

From To Step Delta Min Max
1 1 8 1 0 1 38
J““ 1 6 1 0 1 L
K1 1 38 1 0 ! ®

St'ru‘-c‘tur\ed Part Description
‘ Create And Load Structured Part

Thlanked Part Creation

A NOTE****: Variables will not he loaded for
newly created parts until this dialog is closed.

Close Help
L
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Extracting a complete zone at coarser resolution,

1. Select the structured zone desired. -------------------. .
Unstructured Data Structured Data

Optiopa!ly you can change the domain and provide a part N Parts List

description. one t |

2. Modify the Step values. - ---------- oo

Element Visual Rep. 3D border, 2D full
Feature Angle | 4

These should be positive integer values. A step of two meansé
to deal with every other plane, a step of four means every — *--ff--------omemaiiaannnn

fourth plane, etc. Domain | Inside
Using Nade Ranges: v
3. Hit the Create And Load Structured Part button. ----- .. . From Te Step Delta Min Max
T 1 28 2 0 1 38
The part will be created and shown in the graphics window. In ™ 1 7% 1 o 1 76

the example below, it is shown in border representation mode.
Note that it is considerably coarser than the previous because

step values of 2, 4, and 5 were used in the ijk directions ™
respectively. [N Create And Load Structured Part

B[ 1 38 5 0
St'ritg:tur\ed Part Description

Thlanked Part Creation

A NOTE****: Variables will not bhe loaded for
newly created parts until this dialag is closed.

Close Help
L
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Extracting portions of a zone,

1. Select the structured zone desired. ------------------- .

. . . Unstructured Dat: Structured Dat:
Optionally you can change the domain and provide a part netetped Hats chired Dala

description. Q| Parts List
Zone t |
2. Modify the From and To values. ----------------oonnnne

These can be anything between the ranges shown in the Element Visual Rep. | 3D border, 2D full

Min and Max columns. By default they will be the entire ! Feature Angle | 125

range, but you can modify them. : Domain | Tnsids

3. Hit the Create And Load Structured Part button...... It’fr:;deli'f:s Sep  Delta  Min  Max
I

The part will be created and shown in the graphics . ! % ! 0 ; i:

window. In the example below, it is shown in border N 1 15 ! 0 . us

representation mode. Note that you now get a portion K 1 8 1 o

instead of the whole. Note also that we got original Structured Part Description

resolution because we set step values back to one. The | < Create And Load Stuctured Pact

step values can be other than one, and your portion will be
at the coarser resolution.

Iblanked Part Creation

e NOTE***: Variables will not be loaded for
newly created parts until this dialog is closed.

Close Help
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Extracting multiple planes within the same zone (these become unstructured),

1. Select the structured zone desired. -----------cooo.... i
. Unstructured Data Structured Data

Optionally you can change the domain and provide a part | Paxts List

description. oner ]

2. Modify the From and To values so that one

dimensionisaplane. ---------oooooaiail Element Visual Rep. 3D border, 2D full

One of I, J, or K must have the same values for both From Featurs Angle | 54

and To - indicating a plane in the other two dimensions. ‘.. | Domain Inside
Using Node Ranges:
3. Enter a value in the Delta field for the dimension that Y "*From To Step Delta Min Max
isaplane. - oo LT ] s 1 0 1 38
e N T 1 5 ! 6
Only one of the Delta fields may be non-zero, and it must K ! p : ‘ . 1 38

be one where the From and To values are the same. P | Shricbared Past Daseription [

4. Hit the Create And Load Structured Part button. ---------. }» Create And Load Structured Part
The part will be created and shown in the graphics Tblanked Part Creation

H it i #kNOTE**+*: Variables will not e loaded for
window. In t.he example below, it is shown in border newly ereated parts nntil this diale is losed.
representation mode. Note that you now get an IK surface

atJ=1,6,11, 16, 21, 26, ... Close Help
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Extracting the same portions over multiple parts,

1. Select the structured zones desired. ...... .
Optionally you can change the domain
2. Modify the From and To values. ....................

These can be anything between the ranges shown in the Miri}
and Max columns (which will now be the min and max of all

parts selected). By default they will be the entire range, but

you can modify them. Additionally, “-1” is a valid entry, :
indicating the last plane. Minus numbers are ways to specify
the plane from the max back toward the min, thus -2 equals :
the next to last plane. (Note: Zero is treated the same as -1) :

3. Hit the Create And Load Structured Part button. '

In this example, 4 parts will be created, and they will each be
the full extent IK plane at J = 1 for each of the four zones.
Note that the IK ranges can actually vary per part because the
max is specified, but each zone may be less than the max.

!

In our example, we then changed From and To to be “0”, thus"**
extracting the last plane in each zone. Note the image below.
The image at the right includes complete zones that were
extracted, but shown in feature angle representation so
you get the feel of the complete zone.

L] ¥

| Zone 2

From To Step Delta Min Max
I 1 7 1 0 1 7
J o 0 1 0 1 35
v - 4
: 1 30
APE LT 30 1 0

—* Data Part Loader (FLOT3D)
Unstructured Data Structured Data

Parts List

Element Visual Rep, 3D barder, 2D full
Feature Angle | a4
Domain All

Uszing Node Ranges:

From Tao Step Delta Min Max
Il 1 74 1 0 1 4
P . o 1 35
K 1 30 1 0 2

Structured Part Description

Create And Load Structured Part

|- =» Data Part Loader {PLOT3D) IE_

Unstructured Data Structured Data

Parts List

fones 0000000000000 |

7

Element Visual Rep. 3D border, 2D full

Feature Angle jEIRE
Domain All

Using Nade Ranges:

Structured Part Description

| Create And Load Structured Part

Thlanked Part Creation

B 2000 @® HowTo Index
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Do Structured Extraction

Extracting unstructured iblanked parts.

1. Select the structured zones desired.

"""""""""
Optionally you can change the Domain, From, To, and Unstructured Data Strustured Data
Step values. ‘ Parts List
ponet.
.
2. Hit the Create And Load Structured Part button. ---------
In this example, 4 parts will be created, and they will each
be the full extents at original resolution. Iblanking for the Element Visual Rep. 2D border, 2D full
domain will be ignored. Feature Angle | a0
3. Open the Iblanked Part Creation turndown. ------------- Domain | Al
Using Node Ranges:
4. Select from the domain parts that you have . From Te Step Delta Min Max
previously created. --------cooooioioia ! s ! 0 ! L
I 1 35 1 0 1 35
5. Select the iblanking valuetouse. ---------..oooool K I 2 1 o 30
Optionally you can specify your own name for the part Do | Struetured Paxt Description
that will be created. IR [ > Create And Load Structured Part
6. Hit the Create and Load Iblanked Unstructured Part | ; = ]Il tenied Part Creation
button. ... ol Structured Part{z) Ta Be Iblank _Values
Parent Of Iblanked Part For Entire Mesh
This will create an unstructured part consisting of the : :: L ::2:;5:?3 b potween ii;
elements which have the selected iblank value from thg 1 _z?f.?_a_(éxjxj)_: MinsM |, _',‘Between -2)
selected parts. :
Iblank Part Description
......... » Create And Load Iblanked Unstructured Part
N OTE 4 Variakles will not be loaded for
newly created parts until this dialog is closed.
Close Help
SEE ALSO
How To Read Data
How To Read EnSight Gold Data
How To Read EnSight 6 Data
How To Read PLOT3D Data
User Manual: Using Node Ranges:
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INTRODUCTION

EnSight command files are useful for restoring the system to a state reached in a previous session. However,
restoring a long session dealing with large files can be a tedious process. Fortunately, EnSight provides an archiving
mechanism that saves only the current state of the system, rather than the entire history of a session.

This capability is useful not only for large data files with several active variables, but also for saving a standard
starting point for sessions. In the initial session, geometry can be loaded, variables activated, a good viewpoint
selected, and an archive written. Subsequent sessions take advantage of this investment by merely loading the
archive (which can be done as you start EnSight from the command line).

The client and server each write separate binary files containing the complete current state of the respective
processes. Since these files are binary, they can be quickly written and restored. Note that an archive only contains
information resident in either client or server memory at the time of the archive. No information is available for
variables that were inactive or time steps other than the current. For this reason, you should never remove the
original dataset and attempt to use the archive as a substitute (unless you know what you're doing).

BASIC OPERATION

An EnSight archive consists of three files:

1. The Archive Information File. This file provides pointers to the client and server archive files as well as additional
information required to load the archive. An example is given in the Advanced Usage section below.

2. The Client Archive file. This is the client’s binary dump file.

3. The Server Archive file. This is the server’s binary dump file.

Although each file has a default location, you can override the default during the archiving process.

Saving an Archive
1. Close all open EnSight windows except the main window.
2. Select File > Save > Full Backup... to open the Save Full Backup Archive dialog.

Archive Information File ensight0402_1527.archive

Client Directory

Server Directory fusrpecplefjoedatal

Select File Name or Directory Names:

Archive Information File...I Client Direct'm'y...l Server Directory...l

Okay Cancell

2. If desired, enter a new name for the Archive Information file. You can set the directory for
the Archive Information File by clicking the Archive Information File... button to open a
standard File Selection dialog.

3. If desired, select a directory for the client’s binary dump file by either entering the directory
in the Client Directory field or clicking the Client Directory... button to open a standard File
Selection dialog.

4. If desired, select a directory for the server’s binary dump file by either entering the
directory in the Server Directory field or clicking the Server Directory... button to open a
standard File Selection dialog.

5. Click Okay.
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Save and Restore
an Archive

You also have the option of saving an archive as you exit EnSight.

1. Select File > Quit... to open the Quit Confirmation

dialog.

2. Click the Save Full backup Archive To toggle and,
if desired, enter a new name for the Archive

information file.

3. Click Yes to save the archive and exit.

When saving an archive via the Quit Confirmation dialog,
you do not have the option of specifying the directories

for the archive files.

Restoring an Archive

 Save Command Backup File Tu:

Fenad Propieonelgiia Al

Save Full Backup Archive File Tao:

snvipghioddd 19 avchive

Do you really want to exit?

Cancell HelpI

You can restore an archive either as part of EnSight startup or during an active session. To load an archive on

startup:

1. Use the “-ar archive_info_file” option when you start EnSight. For example,

)

% ensight7 -ar load.ar

where load.ar is an Archive Information file saved in a previous session.

To restore an archive during an active session:

1. Select File > Restore > Full Backup... to open the File Selection dialog.

2, Select the desired Archive Information file and click Okay.

3. If the original connection (when the archive was saved) was manual, you will need to manually restart the

server.

ADVANCED USAGE

There are times when you may want to modify the contents of the Archive Information file. If you wish to use the
archive on a different machine or change the location of the binary dump files, you can simply edit the file with a text
editor. The following example shows the contents:

Date saved

Path to client’s binary file
comment

Case internal number
Case name

Connect type (auto or manual)
Server host machine
Server executable

Server data directory
Alternate server login ID
Path to server’s binary file

Wed Apr 2 15:31:51 1997

client ./ensight0402_153151.clientbkup
# server for Case ‘Case 1’. **Warning Don’t Modify The Internal Number**.
case_internal number 0

case_name Case 1

case_connect_type auto

case_connect_machine indigo2

case_connect_executable /usr/local/bin/ensight/server/ensight.server
case_connect_directory /usr/people/joe/data

case_connect_login_id

server ./ensight cl 0402 153151.serverbkup

Note that there will be a section for all the case_ variables for each current case in the EnSight session. See How
To Load Multiple Datasets for more information on cases.

26006
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OTHER NOTES

Important note! Archives are typically not upwardly compatible with new major — and some minor — releases of
EnSight. For this reason, the complete current command file is also saved as part of the client’s binary dump. If you
attempt to restore an archive and EnSight determines that the archive is not compatible with the current release, the
command file will be restored to a default location.

SEE ALSO

User Manual: Saving and Restoring a Full backup
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INTRODUCTION

Most powerful software systems have a built-in language that provides additional levels of power and functionality to
complement and enhance a graphical user interface. EnSight is no exception. Any action that you can perform with
the mouse or keyboard has a counterpart in the EnSight command language. A sequence of commands can be
saved during a session to automate repetitive or tedious tasks. Command files can be automatically executed on
EnSight startup to initialize the system to a desired state. Execution of command files can also be bound to keyboard
keys for user-defined macros.

BAsSIC OPERATION

During an EnSight session, all actions are recorded and saved to a file known as the default command file. This file
name typically starts with “ensigDAA” and is saved in /usr/tmp (unless you have redefined your TMPDIR
environment variable). The default command file can be saved (and renamed) when exiting EnSight.

Recording Commands
To record a series of commands:
1. Select File > Command... to open the

Gommand dilog. e e——

2. Toggle the Record buttonon.  -----------ccvvenneeos

3. A File Selection dialog opens. Select the :
desired file to save commands to and click 5 Command Entry=
Okay. :

4. When you wish to stop recording, toggle the :
Record button off. -+ |7 Record | /tmplemddfile

Record Part Selection By Number
Play
Fuderrupt| Bhep| Skip) Oendawue
Delay Between Commands 0
Delay Refresh

Reload Macros

Close Help
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Playing a Command File

To replay a command file:

XA command ||E|

1. Select File > Command... to open the Command
dialog.

2. Toggle the Play buttonon.  ---------cevmrieiineniaaos
. Command Entry=

3. A File Selection dialog opens. Select the desired
command file and click Okay.

You can control command execution by interrupting the Record

playback. Once playback is stopped, you can single step  : ||| Record Part Selection By Number
through commands or even skip commands. :
. . {1117 Play | Hmplemdfile
1. To stop command execution, click the Interrupt

button. ------oooo 1> Interrupt Sfep SAkip C::nl'inue

2. To single-step through the commands, click the Delay Between Commands 0

Step button. -------ooe Delay Refresh

3. To skip a command, click the Skip button.

Reloac] Macros

4. To continue execution, click the Continue button. .- - Clase . ... ... ... ... ... . Help

Note that the next command to be executed is shown in
the Command Entry field. You can also enter commands
to be immediately executed in this field.

Playing a Command File on Startup
You can execute a command file as part of EnSight startup:
1. Use the “-p command_file” option when you start EnSight. For example,

% ensight7 -p redo.cmd

where redo.cmd is a command file saved in a previous session.

ADVANCED USAGE

Command files are simple ASCII text and can be edited with any text editor. To easily determine the command for a
given action, open the Command dialog and watch the list at the top as you perform various operations. Keep in
mind that the successful execution of some commands depends on the proper state existing at the time of execution.
For example, creating a part when the parent part (as referenced by the part number) does not exist will cause an
error.

Command files can be nested: if you have a file that performs a certain task, you can “call” that command file from
another file with the “play: filename” command. An “exit:” command will cause EnSight to quit. An
“interrupt :” command will cause the command file to pause execution and open the command dialog.

OTHER NOTES

Command files provide an excellent method of documenting problems or potential bugs encountered during your use
of EnSight. The command file can be transmitted to CEI electronically to help determine the nature of the problem.
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SEE ALSO

How To Define and Use Macros

User Manual: Command Files
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Print/Save an Image

INTRODUCTION

The image displayed in the Graphics Window can

be saved to disk or printed in a variety of formats: Apple PICT, PCL

(Printer Control Language), TIFF, JPEG, PostScript (supporting image, “move-draw”, and EPS), RGB (Silicon
Graphics default image format), TARGA, and EnVideo.

If you wish to save a sequence of images (e.g. for a smooth animation or a transient data display), use EnSight’s

keyframe animation facility.

BASIC OPERATION

. Select File > Print/Save Image....

. Select Format... to choose
the desired output format
and format options.

. Enter a file name prefix to
save the image to disk.

— AND/OR -

Fomat..: I Current Format: Silicon Graphics RGB

[7 To File{Prefix)

_| Ta Printer Using Command I

_| Convert To Default Print Colors

_| Show Plotters Only

b Window Size Normal b | |35~ I 56 ¥ I §¥4

. Toggle the “To Printer ...”

' Okayl Cancel I

Helpl

button on and enter a print
command (see Notes o Image/Movie Formats (Select One) Color Black & White
below)_ ___ APPLE PICT Saturation Factor | | g - --
. JPEG
TIFF

5. If desired, automatically Page Control Language(PCL)
convert colors for printing ,

(see notes below). .- ... ‘TARGA

CEI RGE with depth
EnVidea

MPEG

AVI

6. If desired, select a window size option.. : Okay| Gancel Help
Normal is the current size of the Graphics " .
Window and Full is full screen size. If the
setting is User Defined, you can enter the desired size in the X and Y text fields.

7. Click Okay.

Notes:

1. The file is saved or printed from the EnSight client machine — not the server.

2. The printer command should not include the file name. For example, if you normally print with
“lpr -Plaserl file.ps”thenenter “lpr -Plaserl”in the To Printer Using Command
field.

3. If you toggle on Convert to default print colors, all viewport background colors are changed to
white and any object (part, viewport border, annotation, efc.) currently colored pure white (RGB
=1,1,1) will be changed to black.
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Options for Apple PICT Format
Image/Movie Formats (Select One) Caolor Black & Whitef® --------"

Select either color or black and white output.
T Fol MMM | | Stuxation Factor 15,

TIFF \

Page Control Language(PCL)
PostScript

Set the saturation factor for color images. Full
o8 . saturation is 1.0 and no saturation (i.e. white) is 0.0.
Silicon Graphics RGE

Okay Caneel Help

Options for JPEG Format

Image/Mavie Pormats (Select One) © Color v Black & Whitgg ... Select either color or black and white output.

l;_%EPEE_PI_CT_ _______ | Saturation Factor 1.00

JTPEG : H

eFF - - oo* Quality [ 75 D 2EE EEETEERRE Set the. sat.uratlon factor for colgr images. .FuII.

Page Control Language(PCL} » saturation is 1.0 and no saturation (i.e. white) is 0.0

PostSeript R

Silicon GraphiesRGE | = ...l Set the desired output quality. The value represents a
trade-off between fidelity and compression: 100
means maximum fidelity and 0 means maximum

Okay Cancel Help compression.

Options for TIFF Format

=+ ImagefMovie Format And Options [x]

Image/Movie Formats (Select Ong) Saturation Factor [ g

APPLE PICT e Set the saturation factor for color images. Full

J | saturation is 1.0 and no saturation (i.e. white) is 0.0

PostSeript
Silicon Graphicz RGB

Okay Cancel Help

Options for PCL Format

—* Image/Movie Format And Options (=]

Image/Movie Formats (Select One) <> Color < Black & White<a - -|f - - - - - Select either color or black and white output.

APPLE PICT Saturation Factor . .
JPEC 100 e Set the saturation factor for color images. Full
Portrait < Landscape <€ ---|---+  saturation is 1.0 and no saturation (i.e. white) is 0.0.
Gamma | 1 000000 -
s . . ‘.. Select Portrait or Landscape output orientation.
Silicon Graphics RGB Printer Model | LaserJet II P P

4 ----- Set gamma correction factor. Gamma can correct for

nonlinearities in monitor brightness.
Okay Caneel Help

i R Select the destination PCL printer model.

‘ 2000 ® HowTo Index User Manual

Page 2 of 5




How To ...

h 20000

Print/Save an Image

Options for PostScript Format

Image/Movie Formats (Select One) Caolor Black & White -

CEI RGE with depth

Toggle on to remove invisible geometry.“:

Toggle on to subdivide geometry for smooth color and
shading output.

- Select either color or black and white output.

Set the saturation factor for color images. Full
saturation is 1.0 and no saturation (i.e. white) is 0.0.

-- Select Portrait or Landscape output orientation.

APPLE PICT Saturation Facter | g ~eo--
JPEG

TIFF Portrait Landscape < - - - - {- - - :
f—l I:all_glx_age.(gcl..)_! Full Page Scale Factor 1.00 <E-f--- .
I-Sil_i-t:;n_(}1_'&11;11i_ncs_l'\‘,al?-_ - Type  Move/Draw -€------
TARGA

L Set the page scale factor.

Select either “Move/Draw” or “Image” PostScript
output (see below).

Toggle on for Encapsulated Postscript output.

Toggle on to enable a preview image for EPS files
(for import into PC Windows applications ONLY —
see Other Notes below).

The PostScript format handles primitives either as precise drawing instructions (e.g. move to here, draw a line to
here, fill this region) or as sampled images (pixel data). There are advantages and disadvantages to both.

Move/draw output is resolution-independent and will reproduce fine lines and text. Since even low resolution printers
have 3-4 times the resolution of a typical graphics workstation (in dots/inch), move/draw PostScript typically produces
higher quality output. However, for very large models, the output files can become quite large (even with visibility

culling on) and subsequent printing can be slow.

In contrast, image or pixel PostScript saves the pixels of the image in the Graphics Window. Such an image is, by
definition, fixed resolution. When printed, the pixels will be scaled to fit the page. Since the printer resolution is
higher than the screen resolution, each pixel must be printed larger than it appeared on the screen resulting in visible
pixels and jagged edges. To improve the quality of image PostScript output, EnSight will print only 3D geometry as
pixels — the remaining objects (annotation text, color legends, and plots) will be output as move-draw instructions and

will overlay the image.

Options for SGI RGB Format

—" Image/Movie Format And Options

Black & Whi

Saturation Factor | § oo

Image/Movie Formats (Select One) Color

APPLE PICT

JPEG

TIFF

Page Contral Language(PCL}
PastSeript
ilicon Graphics RGE

Okay

Canecel Help

Options for TARGA Format

Image/Movie Formats (Select One) Color Black & Whitgg

Page Contral Language(PCL}
PostSeript

Silicon Graphics RGB_ _ _ _
ARG X

'CEI RGB with depti
EnVidea

Saturation Factor | § oo

Okay Canecel Help

Select either color or black and white output.

Set the saturation factor for color images. Full
saturation is 1.0 and no saturation (i.e. white) is 0.0.

Select either color or black and white output.

Set the saturation factor for color images. Full
saturation is 1.0 and no saturation (i.e. white) is 0.0
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Options for CEl RGB with depth Format

Image/Movie Formats (Select One) <> Color < Black & White te - - - - - - - - Select either color or black and white output.

Silicon Graphicz RGB Saturation Factor [ 4o . .

TARGA _ _ _ _ __ ___ | : » Set the saturation factor for color images. Full

JCEI RGE with depth ______§ cefeeeeeeee saturation is 1.0 and no saturation (i.e. white) is 0.0.

EnVideo

MPEG . » .

AVI Note: This format cannot be viewed or printed. It
is used for compositing two or more images
according to depth values.

Okay Canecel Help
1 I

Options for EnVideo Format

—" Image/Movie Format And Options [%]

Tovage/Niovie Formuate (Select Oney Type RLE 1| =€~ Select Run Length Encoding or JPEG type.

Silicon Graphicz RGB Saturation Factor | 4o
TARGA ‘

CEI RGE with depth _ _ _ _ (LY EEXEEEEETY Set the saturation factor for color images. Full
SPEG - ) saturation is 1.0 and no saturation (i.e. white) is 0.0

et Download Player From:
#tgrww . ensight.com/lenvideo html

Okay Canecel Help

Options for MPEG Format

. .
Iimage/Movie Formats (Select One) Saturation Factor [ oq~ —s - ------ - Set the saturation factor for color images. Full
Silicon Graphics RGB saturation is 1.0 and no saturation (i.e. white) is 0.0
TARGA
CEI RGE with depth
EnVideo _ _ _ _ _ _ _ _ _
pMPEG |
EX
Okay Cancel Help

Options for AVI Format

Image/Movie Formats (Select Oney Saturation Factor [ o) <« --------. Set the saturation factor for color images. Full

Silicon Graphics RGB saturation is 1.0 and no saturation (i.e. white) is 0.0
TARGA

CEI RGE with depth
EnVideo

IR

Okay Cancel Help

Note: AVI files are a Microsoft standard format for movies, audio, icons, and other data types.

The AVI files created by EnSight contain uncompressed image data. These files can be quite large for even small
animations. You should compress these files on your Windows PC using the utility avi_compress.exe found in the
“unsupported” directory of the EnSight distribution. This is a Windows command line based program.
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To use the utility, copy it and the AVI movie file to a folder on your PC. Then open a ‘Command Prompt’ window
(DOS shell) and change to the folder containing the files. Next, run the command using the following syntax:

avi_compress in.avi out.avi

where ‘in.avi’ is the name of the uncompressed movie file and ‘out.avi’ is the name to use for the compressed movie
file.

The utility will open a simple dialog box presenting a choice of compression methods available on your PC. For
portability reasons, you should probably choose ‘Cinepak’. You may choose others but they may not generate
portable movies that others can view on their PC.

Question: Why doesn’t EnSight generate compressed AV files directly?

Answer: Because the various compression schemes require technology that must be licensed from other vendors.
This technology is typically not available for all of the platforms that EnSight supports. Additionally, there are
numerous compression choices available, not all of which are available on every Windows PC. This utility uses the
compression libraries available on the PC; thus the user can use whatever compression choices the PC has.

ADVANCED USAGE

Most workstations provide tools to display and manipulate images. Silicon Graphics provides a rich image
manipulation environment. See, for example, the manual pages for imgworks and dmconvert.

There are also some excellent public domain (i.e. free) tools for manipulating images. A suite of tools for manipulating
and converting images is available from the San Diego Supercomputing Center. You can download pre-complied
binaries for most UNIX workstations from the SDSC FTP server: ftp.sdsc.edu in pub/sdsc/graphics/
imtools. ImageMagick is a public domain, X-windows based program for displaying both images and animations
(loaded as sequences of images) on a wide variety of platforms. Visit the Web site
http://www.wizards.dupont.com/cristy/ImageMagick.html for more information.

OTHER NOTES

Almost all desktop publishing, page-layout, or word-processing packages permit importation of Encapsulated
PostScript files or PICT files. Macintosh packages recognize files by explicit file typing based on a four letter code
(unlike UNIX, which has no intrinsic file-typing). This code is not stored in the file itself, but in an “information file”
used by the Finder (the Mac OS) to handle files. EPS files are recognized by the code “EPSF” and PICT images by
the code “PICT”. There are various methods of setting this code. File transfer utilities such as “fetch” can set the code
during the transfer process. The “FileTyper” utility can be used to directly edit the Finder Information File. Unless this
file type is set properly, it is likely that applications will refuse to recognize your EPS or PICT files. Send email to
fetch@dartmouth.edu for information on fetch.

EPS files typically contain a “preview image” that lets the importing application display a facsimile of the actual
graphic for ease in interactive positioning, scaling, or clipping. There are different methods of specifying this image
(e.g. PICT resources for Macintosh or TIFF files for Windows). Unfortunately, the different methods of specifying the
preview image preclude EnSight from providing this capability for import into Macintosh applications. When you
import an EPS file, most Macintosh applications will display it as a gray box. You can, however, still resize and
position the image and it should print fine. EnSight can, however, attach a preview image that can be used by
Windows applications. Enable the “Windows (PC) Preview Capable” toggle in the Image Format Options dialog. The
suffix “.EPS” should be used for the resulting files.

Do not attempt to send a PostScript file containing a preview image to a printer!

SEE ALSO

User Manual: Saving and Printing Graphic Images
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INTRODUCTION

EnSight can has three internal writers that allow saving geometric data and variable values in Brick of Values, Case
(EnSight Gold) or VRML. EnSight also allows the user to create their own writer as a dynamic shared library that is
loaded at runtime and listed in the addition to the internal writer formats.

BAsIiC OPERATION
Saving Parts in EnSight Gold or VRML Formats

1. Select File > Save > Geometric Entities...

== Zave Geometric Entities
Brick of Values the variahles you wish to save from the Variables list, and then fill
O Ly e | in the following information. These files will be saved by the EnSight
"'CI]' _______ server as *.geo, *.case, *.variable.
VRML th/]fil £i
Flatfile ‘ [path/]filename prefix A
HDF 5.0 Save As Binary File(s) < -5« -----ocmacoaooiooaoo
STL : .
Begin Time Step 0 i Ll Save As A Single File
"End Time Step 159 [ l’a-i;ggimém Fite [acae ag
Bhwedln Mo ‘
Step .l::'.y 1 el
e pb Okay| Cancel . Help
I = ; ' ' I

: 2. Be sure the desired output format is selected.
| ...3. Follow the instructions given.
4. Enter a file root name.
5. If the dataset is transient, specify the beginning, ending, and step values.

For EnSight Gold only:

6. Toggle to save as binary files or not.

7. If the dataset is transient you can choose to save the multiple timesteps in one flIe
(one file per variable). If you choose this option, you can also specify the max:mum
file Size., - e

: --8. Click Okay.

Both internal and user-defined writers have access only to the geometry of selected parts and each of their active
variables. Only parts located on the server can be saved. This includes all original model parts, and the following
created parts: 2D-clips, Elevated Surfaces, Developed Surfaces, and Isosurfaces. The VRML internal writer saves
all the visible parts on the server (thus, particle traces, vector arrows, contours, etc. will not be saved) in their current
visible state except for Parts which have limit fringes set to transparent. The VRML file will be saved on the client.

Output in the EnSight formats is intended to provide a method to save both model and created parts (with active
variables) for subsequent reuse with EnSight. VRML output is intended for export to other systems.

Most World Wide Web browsers come with either built-in or plug-in support for VRML file viewing. Since VRML is a
subset of the Inventor format, you can also import it into programs accepting Inventor files. You may, however, have
to modify the first line of the file (with any text editor) to read:

#Inventor V2.0 ascii
This may work when importing VRML into Showcase from Silicon Graphics (a presentation layout tool). Once
imported, the 3D model can still be manipulated — even during a presentation.

There are some important differences in how EnSight saves parts according to format chosen.

Case(EnSight Gold) VRML
Which parts are saved? All parts currently selected in the Main Parts List (except those indicated below)| All visible parts
Saved from where? EnSight server EnSight client
Which parts cannot be saved? Any client-based part: contours, vector arrows, particle traces, profiles.
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Saving Parts in Brick of Values Format

1. Select File > Save > Geometric Entities...

-~ Save Geometric Entities [O][x]
Output Formats (Select One} Please select the parts you wish to zave from the Parts list,
_________________ Ny | e i s Then select a variable below and fill in the rest of the following
|| e information. These files will be saved by the EnSight client.
Case {Gaold} B ;
e Variahle{s) P P
YEML L Resolution X | ja5 Y| 128 Z| jag
Flatfile o [PRESSION . .
HDF 5.0 VITESSE Ny | | Format | Brick of Bytes A
STL . -1 A .
. Zé{sff R v LR T ssn&ﬁﬁzl}cé winiued
Vector ; h
I tud :
Component agmituce -,
[ath/Mfilename prefix A
fave Ax Blaary Filesy '
Begin Time Step 0 I s ’w A Bingle E e
End Time Step 159 "%i&mmzzm e néé-E o an
l Hiwa] m e . ;
Step By 1 .
Okay| Cancel Lo . . Help
| Il

2. Be sure Brick of Values is selected as the Format type.

.. 3. Follow the instructions given.

. Select the desired variable. -.---................o.l ]

. If the variable is a vector, select the component desired. --------- :

. Select the sampling resolution. ... et

. Select the sampling format, Brick of Bytes or Brick of Floats.......... . :
. Enter afile root NAMe. -~ - o
. Click Okay.

© 00 N O g A~ W

Brick of Bytes and Brick of Floats is intended to give you an interface mechanism to volume rendering codes.

When you click the Okay button the selected parts are discritized to the resolution indicated using the box tool as the
bounds and orientation (x/y/z resolution refers to the x/y/z directions for the box tool).

For Brick of Bytes (BoB) format a value of 0 is reserved for undefined (i.e., the discritized point found no variable
information). The value of 1 is tied to all variable values less than or equal to the minimum palette value tied to the
variable chosen while 255 is tied to all values greater to or equal to the maximum palette value.

For Brick of Floats (BoF) format undefined values are assigned the undefined value indicated in dialog.

Both BoB and BoF files are written out without any metadata - only the values for the discritized points is written. The
order of the data is according to the following pseudo code:
num_values = 0
for(z=0; z<z_resolution; ++z) {
for (y=0; y<y resolution; ++y) {
for (x=0; x<x_resolution; ++x) {
value_array[num values] = value_at_ this location
}

}

write (file_name,value_array)
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Saving Parts in User Defined Writer Formats
(Flatfile, HDF 5.0, STL)

1. Select File > Save > Geometric Entities...

X Save Geometric Entities |@|Z|
Output Formats (Select One)} Please select the parts yon wish to zave from the Parts list,
Prick of Values select a variable, and then fill in the follewing infermation.
(These files will be saved by the EnSight server.
Case {Gold} -
VRML -7 Parameter{s)
Flatfile o A
HDF 5.0 L [path/Mfilename prefix . A
"""" Lol
. TL . Save Aa Biuery Filels) R
Begin Time Step 0 ?Z\;zst’ci.«“w EY .‘lféing_f;}fc File
: End Time Step 159 W HMoaubmbes Pile [5ra0 a0
. Co. Biwedih My
: Step By 1 S . .
Okay| Cancel N Help

L 2. Select the desired user defined writer format.
e 3. Follow the instructions given.

4. If the writer accepts parameters, enter any desired ones in the
Parameter(s) field. -----------rororoiirieie e

5. Enter a file root NAMe. .......wooom e
6. Save as binary or Ascii file, based on this toggle. ------ ...

7. If the dataset is transient, specify the Time Step info. ............................ ..
(Note that some writers produce static data, and thus may only use the
Begin Time Step info)

8. Click Okay.

The userd-defined writers can call the routines of an EnSight API to retrieve, for example, nodal coordinates, node
ids, element ids of parts selected in the Parts window, to be passed by value to be used, manipulated and/or written
out in any format desired. The User-defined writer dialog includes a Parameter field that allows the passing of text
into the writer from the GUI. This text could contain extra options which the writer understands.

Several example writers (including source code header files, Makefile and the corresponding shared library) are
included to demonstrate this capability.

The Case (Gold) Lite reader is included to demonstrate how to exercise most of the API and output a subset of the
Case (Gold) format. Complex numbers and custom Gold format are not supported with this writer. The Case (Gold)
writer ignores the Parameter field. While the writer is not compiled, the source code of this writer, the required header
files, and the Makefile are included.

The Flatfile user-defined writer is designed to demonstrate the output of selected part nodal data (coordinates & IDs)
as well as active variable values (scalar and/or vector only) in a comma delimited format easily imported into other
applications. If any of the keywords ‘ANSYS’ or ‘force’ or ‘body’ is entered into the Parameter field, then Flatfile will
output an ANSYS body force file.

The HDF 5.0 writer is designed to write out selected parts and their corresponding active variables using the HDF 5.0
API which is compatible with the EnSight HDF user-defined reader. The HDF writer ignores the Parameter field.

The STL user-defined writer is designed to write out the border geometry in the form of triangular 2D elements of the
selected part(s) at the beginning timestep. The end time and the step time are ignored. The STL format does not
support multiple parts in a single binary file, but does support multiple parts in a single ASCII file. Therefore, if multi-
ple parts are selected and ascii is checked, the STL writer outputs an ascii file with the border of each of the parts. If
multiple parts are selected and binary is checked, the STL writer outputs a binary file containing a single border of the
multiple parts. The STL writer only saves the beginning timestep and ignores the End Timestep and Step By fields.
The STL writer ignores the Parameter field.
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There are some important differences in how EnSight saves parts according to format chosen.

User Defined Writers (UDW)
Which parts are available to the UDW? All parts currently selected in the Main Parts List (except those indicated below)
Where are the available parts located? EnSight server

Which parts are unavailable to the UDW? |Any client-based part: contours, vector arrows, particle traces, profiles

More user-defined writers may be distributed with EnSight in the future.

SEE ALSO

User Manual: Saving Geometric Entities

Readme files is $CEI_HOME/ensight76/src/writerssREADME
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How To ... Save or Restore a
n 20000 Context File

INTRODUCTION

EnSight context files can be used to duplicate the current EnSight state with the same or a different, but similar,
dataset. The context file works best if the dataset it is being applied to contains the same variable names and parts,
but can also be used when this is not the case.

BASIC OPERATION

An EnSight context consists of a set of files: the context file itself as well as associated palette, view, and keyframe
animation files. The names of the associated files will be that of the context file with a standard extension.

Saving a Context
1. Select File > Save > Context... to open the Save Current Context dialog.

=+ Save Current Context

Current casze is: Case 2

EEEEEEE > Save Current Case Only Save All Cases

Context File Select File...

A i

Okay| Cancel Hels»

2. Toggle Save Current Case Only or Save All Cases. .- S

3. Enter a name for the Context File. -~ -« «oooooeo
You can set the directory for the Context File by clicking the _
Select File... button to open a standard File Selection dialog. .- .. .................... ... ...

4. Click Okay.

Restoring a Context

Three options:

1) Start EnSight and restore a context as described below. This will recreate the parts of the original dataset
and restore them to their saved condition.

2) Start EnSight, read a new dataset, cancel the part loader without creating parts, and restore a context as
described below. This will create the parts of the new dataset (mapping as directed) and restore the
context of the original dataset.

3) Start EnSight, read a new dataset, create the desired parts, and restore a context as described below. This
will do the mapping (as directed) of parts and restore the context of the original dataset.

1. Select File > Restore >
Context...

=M FRestore Context From File

Select case(s) to restare ta

2. Select the case to
v

restore the context to. -----
Note: If the context file
contains information for
multiple cases, ignores the

selection Context File Select File
_________________________ -

3. Enter or select the

desired context file ---: Oliay Cancel Help

4.ClickOkay. ----ccooeeaeaoi o T I
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OTHER NOTES

The same part names (and variable names) do not have to exist in the new case. If this situation arises, a pop-up
dialog will appear where you will be asked to match the part names (or variable names) from the context file with the
parts (or variables) from the new case. This dialog is not available in batch mode. Therefore, you can’t use a context
file that needs matching in batch mode.

When restoring context files with multiple cases, the needed cases will be started, if needed, according to the
connection scheme of the current run of EnSight.

Flipbook animations are not restored using the context file because it is unknown at the time the context file is
created what state existed when the flipbook was saved.

If data is not read before restoring the context file, the data that was used when the context file was saved will be
loaded.

Context files use EnSight’s command language and other state files (such as palette, view, and keyframe animation)
to recreate the parts, variables, and view state.

SEE ALSO

User Manual: File Menu Functions
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INTRODUCTION

Scenario files are used by CEI's EnLiten product which is capable of viewing all geometry (such as parts, annotation,
plots, etc.) that EnSight can display, including flipbook, keyframe, and particle trace animations.

A “scenario” defines all visible entities you wish to view with EnLiten and includes any saved views and notes that you
want to make available to the EnLiten user.

BASIC OPERATION

1. Create the display you want to share with - -

the EnLiten user. -,‘fj__ff.'f File |2 ]

Scenario Project

2. Select File > Save > Scenario... to open

the Save Scenario dialog. Please specify a ’directory’ to save the scenario project

3. Select File to save a scenario file only, or | | te. The directary will be created and a set of scenario

. .. . : scenario files{.els, jpg, elv, etc) will be saved tao it.
Project to save the scenario, jpg image | gy "girectory can be read into EnLiten. The CEI HTML
file, and EnSight context file. .............: publisher program can be run in the directory or in the

" top level directory of multiple projects ta antomatically
4. E_nter a name for the Scenario f"_e/ create HTML files for easy navigation and organization
directory. You can set the root directory with a Web Browser. See Web Publisher in Help.

for the Scenario by clicking the Select...
button to open a standard File Selection | » Select...
dialog. -~ oo S

Pleaze enter a general description to decument

5. If saving Scenario Project, enter a the contents of this scenario project.

general description for this scenario.
This description is used when a html
page is generated for the scenario. .-...-... 1-»

6. If you currently have flipbook, keyframe,
and/or particle trace animations, indicate

if you want these saved to the scenario |5 [ Save Keyframe Animation
file. ... > |7 Save Flipbook Animation
EN
7. Save the scenario. ... __ Save Particle Trace Animation
T Save Scenario Project Directory

ADVANCED USAGE

. A starting view point was saved with the scenario file.
After the scenario has been saved you may You can add additional views with the button below.
save additional views by setting the desired Add Current View...

view in EnSight, then selecting the “Add
Current View...”. You will be asked to name

the view in a resulting pop-up dialog. You can save notes for the scenario by entering
. the information below and then selecting the

After the scenario has been saved you may Save Note button.

write notes regarding the scenario by entering Subject

a Subject line and typing in the notes input
area. When satisfied, select the “Save Note”
button.

Save Note Clear

Clasze Help
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OTHER NOTES

EnLiten is a geometry viewer only. As such it is not capable of creating or modifying any new/existing information
such as variables or parts, or of changing timesteps.

Since EnLiten is only a geometry viewer, only keyframe transformation information is stored when saving a scenario
file, i.e., no transient data keyframing is possible (consider loading a flipbook instead).

SEE ALSO

User Manual: File Menu Functions
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h 20000 Translate, Scale

INTRODUCTION

EnSight provides global transformations (rotation, translation, and zooming) to permit user manipulation of objects in
the Graphics Window. The transformations can either be performed interactively with the mouse, or precisely by
entering explicit values. The mouse buttons can be user-programmed to perform different transformations.

BAsSIC OPERATION

The Transformation Control Area controls the operation of the left mouse button (by default) in the Graphics Window.
The icon of the current action will be highlighted (e.g. Rotate is current below):

Open the Reset Tools and
Viewport(s) dialog

Open the Transformation Store / Recall
Rotate Zoom . Editor dialog stored view
\J \J \J \J Yy VY
| & )| B3| Reset...| Transt. Edit... +X| +v| +Z|-x| -¥| Z| Store| Recall| Unda| ITeol Tips
1 ] A
Translate Rubber-band zoom A Undo last transformation

View from directions

Select Part [or View] mode in the Mode Selection area.

To rotate:
1. Click the rotate icon.
2. Move the mouse pointer into the Graphics Window.
3. Click and hold the left mouse button and:
* move the mouse left and right to rotate about the screen Y (vertical) axis, or
* move the mouse up and down to rotate about the screen X (horizontal) axis, or
* hold down the Control key and move the mouse left and right to rotate about the screen Z axis.
4. Press the F1, F2 or F3 keys for 45 degree rotation about the X, Y, or Z axis, respectively. Hold the Control
key down for -45 degree rotation. (Note: cursor must be in the EnSight window for F keys to work)
5. Press +X to view the scene from the positive X axis (looking toward the origin). The +Y, +Z, -X, -Y, -Z
buttons are similar. Press the “Last” button to get the scene back to the view that existed before any of
the +/-XYZ keys were pressed.

To translate:
1. Click the translate icon (or use the middle mouse button in steps 2 and 3 (defaulit)).
2. Move the mouse pointer into the Graphics Window.
3. Click and hold the left mouse button and:
* move the mouse left and right to translate in the screen X (horizontal) direction, or
* move the mouse up and down to translate about the screen Y (vertical) direction, or
* hold down the Control key and move the mouse left and right to translate in the screen Z
direction.

To zoom:

1. Click the zoom icon (or use the middle mouse button in steps 2 through 5 (default)).
2. Move the mouse pointer into the Graphics Window.

3. Click and hold the left mouse button.

4. Drag down to zoom in or drag up to zoom out.

5. Hold down the Control key and move the mouse to pan.

To rubber-band zoom:

1. Click the rubber-band zoom icon.

2. Move the mouse pointer into the Graphics Window and position it at one corner of the desired viewing
region.

3. Click and hold the left mouse button.

4. Drag to include the desired viewing region. An outline of the region will appear as you drag.
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Note that zooming actually changes the location of EnSight’s virtual “camera” or “look-from” point. Zooming in moves
the camera closer to the object; zooming out moves it farther away. The look-from/look-at points can also be
edited explicitly.

If you have multiple viewports visible, each one can be manipulated independently. To transform in a different
viewport, place the mouse pointer within the bounds of that viewport before you click the left mouse button.

You can reset transformation parameters (as well as tool and frame transforms) by clicking the Reset.... See How
To Reset Tools and Viewports for more information.

ADVANCED USAGE

All EnSight transformations can be controlled precisely by specifying explicit transforms in the Transformations Editor
dialog. To open the dialog, click the Transf Edit... icon on the desktop. The slider performs the requested
transformation (based on the selected transformation action) in the selected viewport(s).

= Transformation Editor (Global Transform) =EA
File Editor Function Help

Select the desired

transformation action. ........ Specify axis to which

- the transform applies

Slider to specify

- 0 +
transform. .................... | =) PR = -
L L Which Viewport(s) Scale Settings -:t-4F - Increment controls the
Set (by clicking within Increment [ 1 o000 || <@ - step size for the slider
the desired region) the L. end arrows
. Limit .
viewport that the 80.000000

transform appliesto. ---------- > Enter explicit values in

: the Increment field
Link Interactive : (and press return) to

. . »  Transforms . p b N
To interactively perform : transform by a precise
transformations on multiple : : amount.

viewports, select viewports | | cioee ;

then toggleon. ------------..! ; : ;

:--- Limit controls the sensitivity and
limit of the slider action.

You can also perform scaling in any or all dimensions (to, for example, magnify subtle differences in a surface).
Although you cannot perform the scaling operation with the mouse, you can scale using the Transformations dialog.
Click the Scale icon in the Transformation Control area and specify the scaling as described above.

You can copy the transformations from one viewport to another. First select the viewport you wish to copy, select
Editor Function->Copy Transformation State, then select the viewport(s) you wish to modify and select Editor
Function->Paste Transformation State.

OTHER NOTES

By default, EnSight uses only the left mouse button for performing transformations. You can, however, program the
transformation action attached to each mouse button. See Customize Mouse Button Actions for more information.

The transformation operations described here also apply to frame transformations. If additional frames have been
created and if the mode has been set to Frame, then any transform will apply to the currently selected frame. See
Create and Manipulate Frames for more information.

Pressing the F5, F6, or F7 keys while the mouse is in the Graphics Window will transform the scene to show a
standard right, top, or front view, respectively. Pressing the F8 key will return the scene to that which existed prior to
F5, F6, or F7 being pressed. Further, holding the Control key down while pressing F5, F6, or F7 will store the current
view to the selected Fx button.

Pressing F9 while the mouse is in the Graphics Window will zoom the display to full screen. Press F9 again to return
to the normal display.
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SEE ALSO

Other viewing operations: How To Set LookFrom/LookAt, How To Set Z Clipping, How To Create and
Manipulate Frames, How To Reset Tools and Viewports.

User Manual: Global Transform, Frame Transform
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INTRODUCTION

EnSight provides two basic drawing styles for graphics objects: line or shaded. Line mode draws only the line
segments of an object — regardless of the whether the lines are polygon edges or not. Shaded mode displays all
objects consisting of polygons (e.g. element or cell faces) as solid filled regions with light source shading enabled.

These drawing styles can be enhanced by enabling hidden-line mode. If the current mode is line, hidden-line will
eliminate all those lines that would be invisible if the object were a solid surface. If the current mode is shaded,
hidden-line mode will draw lines overlaying face edges. In shaded mode, hidden-line overlays are particularly useful
for visualizing computational grids.

The setting of line or shaded mode is a global toggle. You can also set the mode on a per part basis so that some
parts are displayed as lines and others as shaded surfaces. Each viewport also provides individual controls so that
the drawing mode can differ from viewport to viewport.

Line mode Shaded mode Hidden-line mode Hidden-line overlay mode

BASIC OPERATION

The global toggles for shaded and hidden-line mode are available in View mode or from the desktop. You can also
enable these modes by selected View > Shaded or View > Hidden Line. To use the desktop toggles:

_IShaded [ Hidden Line
1. Click the Shaded toggle to switch from line to A A

shaded mode (or vice-versa). .................... ...

2. Click the Hidden Line toggle to enable or The currently selected mode is
disable hidden-line mode. ----------------eeoonooooooooo....0indicated by toggle. Here, the mode
is line with hidden-line enabled.

If the current mode is Shaded when you toggle on
Hidden Line, the Hidden Line Overlay dialog is
displayed. This dialog allows you to specify a color for ***N"’*;i:is‘:‘i_‘;‘;ﬁ:;‘;::‘g‘*:j;‘ff*:?f“;f:;“:zi;’:eg:‘f-
the overlay edges. If Specify Line Overlay Color is not )
enabled, overlay color will be set to the native color of
each part. Ifitis enabled, the color can be specified

-~ Hidden Line Overlay [Ol[=]

| Specify Line Overlay Culorl

either by entering red, green, blue color values, or by E G B Mix...
clicking the Mix... button and picking a color with the
standard Color Selector dialog. Okay Cancel

Note that hidden-line and hidden-line overlay are disabled during interactive transformations. The drawing
calculations required for these modes can be quite substantial for large models — so much so that interactive
manipulation would be unacceptably slow.

Note also that hidden line overlay mode is disabled if transparency is on.
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The per-part toggles for shaded and hidden-line mode are available in Part mode.
1. Select Part in the Mode Selection area.

2. Click the Shaded toggle to switch from line to
shaded (or vice-versa).

3. Click the Hidden Line toggle to enable or
disable hidden-line mode.

Note that enabling shaded mode for a part has no effect unless the global shading toggle is also enabled (on the
desktop orin View mode). The same is true for hidden-line: unless the global hidden-line toggle is enabled, the part
will be drawn without hidden lines.

ADVANCED USAGE

Drawing modes can also be set on a per-viewport basis. As with per-part settings, these toggles require that the
corresponding global toggle is also set to have any effect.

1. Select VPort in the Mode Selection area.

2. Select (click in) the desired viewport in the Graphics
Window.

3. Click View Settings... to open the Viewport Special

Attributes dialog. ----------ooeooee e v D 3D |
| View Dimension |

4. Click the Shaded button to disable shading in the .
current viewport. U Perspective

Shaded
5. Click the Hidden Line button to disable hidden-line in

the current viewport. --------coocaiiiiiiaiiie > Hidden Line

Closel

OTHER NOTES

When a part is drawn in shaded mode (with or without hidden-line overlay) the surface is displayed with light source
shading enabled. EnSight uses two pre-defined light sources: one at the look-from point (the camera) and one on the
opposite side of the model (for back-lighting). In the current release, the location of the light sources cannot be
changed. Subsequent releases will allow editing of lights (including position, color, etc.).

In computer graphics, the appearance of a shaded surface is governed by a lighting model controlled by various
parameters. In EnSight, these parameters are part of the part’s attributes and can be changed on a per-part basis.
See How To Set Attributes for more information.

SEE ALSO

User Manual: Global Shaded, Global Hidden Line
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INTRODUCTION

EnSight provides various modes that control global viewing behavior. Three of these modes are discussed here:
perspective/orthographic projection, bounding box display modes, and static lighting.

EnSight can display viewports in either perspective or orthographic projection. A perspective projection is how we
normally view the world: objects that are farther away appear smaller. An orthographic projection removes this effect:
objects appear the same size regardless of distance. The projection setting can be specified on a per-viewport basis.

By default EnSight draws every point, line, and polygon for every visible part each time the Graphics Window
updates. For very large models (or slow graphics hardware), this behavior leads to unresponsive manipulations
since the update lags behind the corresponding mouse motion. Fortunately, EnSight provides other display modes
that improve responsiveness. Fast Display mode displays a bounding box around, a point cloud for, or if using
immediate mode - a percentage only of all visible parts to be displayed during interactive manipulations. The point
cloud and sparse model options are only available in EnSight Gold. When the mouse button is released, parts are
drawn normally. The Fast Display mode can also be set such that the bounding display is used until the mode is
changed - even when the mouse is released. (Edit->Preferences... Performance - Static Fast Display)

Surface shading operations are expensive for very large models. Since the shading is dependent on the orientation
of the model with respect to the light sources, the surface colors must be recalculated each time the model moves.
Static lighting mode precalculates surface colors for a given orientation and then uses these colors during
subsequent transformations, resulting in improved interactive response.

BAsSIC OPERATION

Perspective/Orthographic Projection

The projection mode can be toggled either from a menu (View > Perspective) or in the VPort icon bar. To set the
projection from the icon bar:

1. Select VPort in the Mode Selection area.

2. Select (click in) the desired viewport in the Graphics
Window.

3. Click View Settings... to open the Viewport Special :
Attributes dialog. ---------o-iiiiiiiiiii

View Di ion 3D 1 ||
4. Click the Perspective button to toggle the projection rew Himension -l
type in the current viewport. ... ... .. ... .. ... ... 7 Perspective

| Shaded

Note that a viewport will only display a perspective projection
if the global toggle (as set with View > Perspective) is on as
well.

| Hidden Line

Close I
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Fast Display Mode

The Fast Display Mode can be set either from a menu (View > Fast Display > ) or by the Fast Display toggle on the
desktop. To change between the Dynamic or Static operation of this mode, go to Edit->Preferences... Performance.
To change the part representation for Fast Display Mode:

1. Click the Fast Display Representation
pull-down icon. -~

2. Select Dynamic Box.----------- ...

or Off
>+ Box
3. Select Points (EnSight Gold only)........... » & Points
i AR Note, if using immediate mode (and
EnSight Gold) a Sparse Model option
Select Off to return to standard display will also be available here.
mode.

Static Lighting

The Static Lighting setting is only available from the View menu. Select View > Static Lighting to enable or disable
static lighting. Although interaction speed is improved in static lighting mode, note that the light source appears to
rotate with the object. This is often an acceptable trade-off.

ADVANCED USAGE

If using immediate mode (and EnSight Gold), and you desire to use the Sparse Model option for Fast Display, you
can control the percentage of the model that is displayed. See “Performance Preferences” . This mode is intended
for large models. It generally will not be pleasing (nor should it be needed) for small models.

SEE ALSO

User Manual: See “Part Mode” and Static Lighting
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INTRODUCTION

As you apply zoom transformations in EnSight, you may have noticed that the model begins to progressively
disappear as you move close to the model. This happens when the visible model parts intersect the front Z clipping
planes. The Z-clip planes (which are always perpendicular to your line of sight) are specified as distances from the
look-from point (the camera position). The Z clipping plane positions can be set by the user and can be used to
remove unneeded geometry from the display. Each viewport has it's own set of Z clipping planes. By default, the Z-
clip planes adjust (float) with the model - thus stay out of the way if possible.

BAsSIC OPERATION

The initial position of the Z clipping planes is set based on the Z (depth) extent of the visible geometry — plus quite a
bit extra to leave room for transformations. The plane positions can only be set via the Transformation Editor dialog.

1. In the Transformation Control area, Click Transf. Edit... -> Editor Function -> Z_clip to open
the Transformation Editor.
If the Float Z-Clip Planes With Transform option is on,

The graphics display shows the relative positions you can specify the minimum Z value that the Front clip
of the front and back clipping planes (left and right plane can float to. -« -« -xxx emrmememaaaaaaan,

vertical red lines) to the Z extent of all currently
visible objects (white box).

2. Toggle the Float Z-Clip Planes option on to E [ Transformation Editor (Z-Clip)

have the Z-clip planes automatically adjust.
OR File Editor Function

Toggle the option off to manually adjust the

. X Float Z-Clip Planes With Transform.
Z-clip plane locations. - -------oooiiil -

Minimum Z Value | | g000e-01 <
If the Float Z-Clip option is off, you can edit the Topomt Back

plane positions either by dragging the red lines or
by entering explicit values in the Front and Back _
text fields. Recall that the values represent the

distance from the look-from point to the plane. _,',

Flane Distance

i i Front Bauk
3. Place the mouse pointer over the desired i s

plane marker and click the left mouse 1.5630e+01 §.9010e+01
button. -----oeeeeeeeeeeeeeeeeeie e ’

Redraw Z-Clip Area Above ‘

4. Drag the marker left or right to the desired
location. The Graphics Window will update
as the marker is moved.

-OR- "
. . If the markers become difficult to manipulate due,
3. Enter exph_c|t values in the Front and/or to changes, click the Redraw Z-Clip Area Above
Back text fields and press return. button to rescale the Markers. «------eeeeeveeeeeo..

Each viewport maintains it's own independent Z clipping planes. The operation described above will change the
planes for the current viewport (as set by clicking in the desired viewport in the Graphics Window).

Note that clicking Reinitialize, in the Reset Tools and Viewport(s) dialog found under the Reset... button of the
Transformations area, will reset the Z clipping planes of the current viewport based on the Z extent of all objects
currently visible in that viewport.

OTHER NOTES

EnSight uses your workstation’s graphics hardware to implement Z clipping. The same hardware is used for Z-
buffering — determining which objects are visible based on Z (depth) values. The Z buffer typically provides 24 bits of
resolution. EnSight attempts to make the best use of this limited resolution by setting the front and back clipping
planes reasonably close together. If the planes are too far apart, relative Z resolution is reduced and the hardware
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may not be able to accurately determine surface visibility. If you see artifacts like this, move the clipping planes
closer together.

EnSight also provides an additional clipping plane: the auxiliary clipping plane. Unlike the Z clipping planes which are
always perpendicular to your line of sight, the auxiliary clipping plane can be placed at any location in any orientation.

The Plane Tool specifies the location of the auxiliary clipping plane. By default, all geometry on the negative Z side of
the Plane Tool is removed. However, you can specify auxiliary clipping on a per part basis — some parts are clipped

while others are not. See How To Set Auxiliary Clipping for more information.

SEE ALSO

How To Define and Change Viewports, How To Set Auxiliary Clipping

User Manual: Z-Clip
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INTRODUCTION

In addition to providing control over model manipulations, EnSight also provides control over the virtual camera used
to view the scene in the Graphics Window. The two control parameters are the look-from point (the position of the
camera) and the look-at point (a point on the camera’s line-of-sight vector). The Global Axis is positioned at the look-
at point and is always in the center of the Graphics Window.

Initially, the look-at point is set to the geometric center of all visible objects and the look-from point is set to a point on
the positive Z axis such that all visible objects fit in the Graphics Window (as shown in the top image below). The
white axis triad is the Global Axis and can be displayed by selecting View > Axis Visibility > Axis - Global. The bottom
image shows the view after the look-from point has been repositioned between the X and Z axes. The diagrams to
the right of each image show a top-down schematic of each viewing case.

BAsSIC OPERATION

The look-from, look-at points are controlled via the Transformation Editor dialog.

1. Click Transf. Edit... in the Transformation Control Area.

2. Select Editor Function > Look At/Look From.
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[l Transtormation Edior ook Atlook From) ]

File Editor Function Help

Viewer Area for Look At Look From
i i Text fields for
interactive 5.0000e-01 | = || 5.0000e-01 . .
manipulation entering numeric

5.0000e-01 ¥ || 5.0000e—01 4 - values

1.0000e+00 | Z || 1.8459e+01
Viewer Area plane X-Y Plane Distance 1.5159e+01 <€---b-blioeennn. Text field for

i moving look-from
toggles -----cooioiaoae- - Y-Z Plane Viewer Area L
Control Lock one by setting an
X-Z Plane

Redraw Viewer Area Abowve explicit distance

Close

The Transformation Editor dialog provides two methods for setting the look-at and look-from points. Numeric values
can be entered directly into the X,Y,Z Look At, Look From text fields (remember to press return). You can also enter
a value in the Distance field to explicitly move the look-from point a certain distance away from the look-at point.

Alternately, the Viewer Area can be used to interactively manipulate the points. The presentation of the Viewer Area
depends on the which plane toggle is set: X-Y (view from the positive Z axis), Y-Z (view from the positive X axis), or
X-Z (view from the positive Y axis —the default). In each case, the gray box represents the extent of all visible parts.
The intersection of the two red lines is the look-from point. The opposite end of the long red line is the look-at point
(which is initially near the center of the gray box). The example below shows the X-Z Plane presentation, the others
behave analogously.

To change the look-from point:
1. Place the mouse pointer over the
intersection of the two red lines. ------- i

To change the look-at point:
1. Place the mouse pointer over the free
end-point of the long red line. -----.

2. Click and drag to the desired 2, Click and drag to the desired location.
location. Note that the Graphics Note that the Graphics Window
Window updates as the look-from X_¥ P1 updates as the look-from point is

. . - aAne
point is moved. moved.

Y-Z Plane

X-Z Plane

During your manipulation, the display in the View Area may become difficult to use. Click the “Redraw Viewer Area
Above” button to rescale the display.

The Viewer Area Control Lock pull-down menu effects interactive operation in the Viewer Area as follows:
None No constraints are placed on movement of either the look-from point or the look-at point.

Distance Movement of the look-from (look-at) point is restricted to a circle whose radius is the current Distance
value and whose center is the look-at (look-from) point.

Together The movement of both points is locked such that movements applied to one are applied to the other.

You can easily reset the look-from and look-at points such that all currently visible parts are displayed. Click Reset...
in the Transformation Control area to open the Reset Tools and Viewports dialog. Click the Reinitialize button to reset
the currently selected viewports.
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OTHER NOTES

You can also set the look-at point by picking an object with the

1. Click Reinitialize in the Reset Tools and Viewport(s)
dialog to clear all global transformations.

2. Click Part in the Mode Selection area to enter Part
Mode, «-----ereerieiiiini e

3. Select Pick Look/At Point from the Pick Pull-down
ICON, - rsrrrrrmre e

4. Move the mouse into the Graphics Window. Place the
mouse pointer over the point you wish to set to the
look-at point and press the ‘p’ key.

mouse in the Graphics Window:

A

3 Pick Part

: Pick Plane(3 Ptz.} Tool Location
>t Pick Plane{2 Pt=.) Tool Location

A Pick Plane Tool Origin

n Pick Plane Tool Normal

: Pick Line Tool Location

t Pick Cursor Tool Location

P Pick Center Of Transform

k- Pick Look/At Point

Other camera parameters, such as the camera up direction and the field-of-view angle, cannot be set in this release.

SEE ALSO

How To Define and Change Viewports.

User Manual: Look At/Look From
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INTRODUCTION

Unlike standard Z clipping where the front and back planes are always perpendicular to your line of sight, auxiliary
clipping lets you clip parts against a plane with arbitrary position and orientation. In addition, the auxiliary clip
attribute can be set on a per-part basis. This permits selective clipping to reveal objects of interest.

EnSight’s Plane Tool is used to provide the location for auxiliary clips. As the Plane Tool is manipulated (either
interactively with the mouse or via the Transformations dialog), the display in the Graphics Window updates to reflect
the new location of the plane.

BAsSIC OPERATION

Auxiliary clipping can be enabled in one of two ways:
1. Select View > Auxiliary Clipping.

—OR-

1. Select View Mode in the Mode Selection Area. (If
View Mode is currently not available, turn it on
by Edit->Preferences... General User Interface -
View Mode Allowed.)

2. Click the Auxiliary Clipping toggle. ------------oremiianan

The Plane Tool will become visible and all objects on the negative Z side of the plane will be clipped (assuming the
plane currently intersects some visible part). You can now manipulate the Plane Tool to achieve the desired display
effect (see How To Use the Plane Tool for details). Note that Auxiliary Clipping always uses the infinite extent of the
plane specified by the Plane Tool — there is no way to restrict it to the rectangular bounds of the tool.

Each part has an attribute that controls whether it is clipped by the Auxiliary Clipping plane or not. To toggle this
setting:

1. Select the desired part (see How To Select Parts).
2. Select Part Mode in the Mode Selection area.

3. Click the Auxiliary Clipping toggle.

(This attribute can also be toggled in the Feature Detail Editor
dialog for the part. See How to Set Attributes for more
information.)

SEE ALSO

How To Use the Plane Tool, How To Set Z Clipping.

User Manual: Global Auxiliary Clipping
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INTRODUCTION

EnSight provides up to sixteen user-defined viewports in the Graphics Window. Each viewport is a rectangular region
of the screen (with or without a border) displaying some or all of the currently visible parts. Each viewport can be
transformed (e.g. rotated or zoomed), sized, and positioned independently. Viewports have several display
attributes including background and border color. Viewports provide a very flexible environment for data display.

This article is divided into the following sections:

Create a New Viewport

Select Viewports

Move and Resize Viewports

Set Viewport Background Color

Set Viewport Attributes

Display Selected Parts in Viewports
Set Case Visibility Per Viewport
Perform Transformations in Viewports
Reset Viewport Transformations
Delete Viewports

BASIC OPERATION

Create a New Viewport
On startup, EnSight creates a single viewport that fills the Graphics Window. To create a new viewport:

1. Click VPort in the Mode Selection area to
enter Viewport mode.

2. Click the Viewports Layout pull-down icon .
. v

to select any of the standard viewport
layouts. ..ol

OR |
2. Click the New Viewporticon.--------------------- »

Select Viewports

When you create a new viewport, it automatically becomes the currently selected viewport (as shown by the border
drawn in the default highlight color). Any action to change viewport attributes always operates on the currently
selected viewport(s). To select viewports:

1. Click VPort in the Mode Selection area to enter Viewport mode.

2. Move the mouse pointer into the Graphics Window and click the left mouse button anywhere within
the desired viewport. You can add to an existing selection by holding down the Control key as you
click in additional viewports.

Note that the selected viewport is also changed in other modes (such as View) any time you perform some action
in a viewport (such as rotation). There is however, no visual feedback of this change until you enter VPort mode
again.
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Move and Resize Viewports

Viewports can be easily moved and resized. You can either reposition a viewport with the mouse in the Graphics
Window, or precisely by entering exact values. To move or resize a viewport:

1. Click VPort in the Mode Selection area to enter Viewport mode.
2. Select the desired viewport.

3. To move a viewport, move the mouse pointer into the Graphics Window and into the selected viewport.
Click and hold the left mouse button and drag the viewport to the desired location.

4. To resize a viewport, move the mouse pointer into the Graphics Window and place it over one corner of
the selected viewport. Click and hold the left mouse button and drag the corner to the desired
location.

To precisely reposition a viewport:

3. Click the Viewport Location Attributes icon
to open the Viewport Location Attributes
dialog.

4. Enter new values in the Origin X,Y, Width, or
Height fields (and press return).

Values are given as a fraction{0.0-1.0) of X and ¥.

Origin X | 0.000 ¥ | 0.000
The origin (at 0,0) is the lower left corner of the Width I 1.000 Height I L.000

Graphics Window. Note that the values are

normalized to the width and height of the default Cl"sel HB]P---I E

EnSight permits overlapping viewports. You can
control the ordering (from front to back):

Click The Viewport Forward icon to bring the
selected viewports to the top. --------------onionn-

Click The Viewport Back icon to send the
selected viewports to the bottom. ------------....-

Note: Viewport 0 is always displayed first, thus it
cannot be pushed or popped with these icons.
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Set Viewport Background Color
Viewport background colors can be constant, blended, or inherited from the default viewport. To set viewport
background color:

1. Click VPort in the Mode Selection area to enter Viewport
mode.

2. Select the desired viewport(s).

3. Click the Color icon to open the Viewport Background
Color Attributes dialog. -------- - - o @

The Type pull-down controls the type of background coloring
used. There are three types: Constant, blended, and inherit.

Constant
A constant color will be used for the entire background. To set a Type Constant i |
r-- AR 2

constant color:

Viewport Color

4. Select Constant from the Type pull-down.
D o

r...
— Constant —

5. Either enter values in the RGB color fields (and press
return OR click the Mix Color... button to open the Color :
Selector di@alog. -« ---veoae e L. R+0_00 G Iu_oo B Io_uo

— Blencded

£ ¥ Lowvels I 3
! [
= Eehit Laved I 1

Blyae <§|§s,s}€s 3-}=|€s,s3€=

::: Position I{;Ji}gg

Clnsel Refresh Viewp?rtl HelpI

6. Click Refresh VIEWPOt, ------rrr-x-rsssseomnminiiiiieieeeeee T
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Blended

Up to 5 horizontal level colors can be specified with
interpolation between levels. To set a blended
background:

1. Select Blended from the Type pull-down. --------

2. Enter the desired number of levels in the # of
Levels field (and press return). Up to five

levels are supported. -----cocciieieiiiiiiiiieas

3. To edit a color, first select it by clicking on the
number label in the Viewport Color window.

As shown, level 2 is currently selected. ---------

Alternately, you can enter a value in the Edit

Level field or click the up/down arrows. ----------

4. Change the selected color by either entering
new values in the RGB fields (and pressing
return) or clicking the Mix Color... button to

open the Color Selector dialog. ~------------------

5. You can also change the relative vertical
position of a level by either clicking on the
level number with the left mouse button and
dragging up or down OR by entering a new
value in the Position field (and pressing

return). .- .o .

6. Click Refresh Viewport. -----------oovoiioioot

Inherit

The selected viewports inherit the background type
and color from the default viewport. To set an
inherited background:

1. Select Inherit from the Type pull-down.

2. Click Refresh Viewport.

T iMype T Blended i |

Viewport Color

— Constant

# |{a,s;§a G|{s,e;§a E-"|{a,s;§a

— Blencded

Close| Refresh Viewport| HelpI

B 2000@® HowTo index
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Set Viewport Attributes

Viewports can be displayed with a variety of attributes:

1. Click VPort in the Mode Selection area to enter
Viewport mode.

2. Select the desired viewport(s).
3. Set the desired attribute as described below:

Click the Viewport Visibility Toggle to toggle display
of the selected viewports on or off (when not in

Click the Viewport Border Attributes icon to open the
Viewport Border Attributes dialog.

Click the Visible toggle to display a border. ------------

Enter values in the RGB fields (and press return) or
click the Mix... button to open a Color Selector

Click the Viewport Special Attributes icon to open
the Viewport Special Attributes dialog

Each viewport has it's own toggles for perspective,
hidden surface, and hidden line drawing styles. These
controls will toggle the respective attribute for the
selected viewports. See How To Set Drawing Style
and/or How To Set Global Viewing for more
information.

In addition, a viewport can be 3D or 2D in nature. If the
viewport is designated as 2D, only planar parts may be
displayed in the viewport and transformations will
become 2D limited.

Mix... ||

View Dimension 3D i

[T Perspective
[7 Shaded

[~ Hidden Line

Clnsel
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Display Selected Parts in Viewports

Part visibility can be a set on a per-viewport basis such that some parts are visible in some viewports but not in
others. To set part visibility per viewport:

1. Select the desired part(s) in the Main Parts list.

2. Click the Part Visibility in Viewport Toggle icon.

The Part Visible in Which Viewport? dialog displays a

schematic of the current viewports. The part is currently _H

visible in the green viewports but invisible in the red . .
viewports. Visible In Viewport{s}

3. Click in a green viewport to disable display of the
selected part(s) in that viewport OR click in a red
viewport to enable display of the selected part(s)
in that viewport.

Note that a similar interface for setting this attribute Close
appears in the General Attributes section of the Feature
Detail Editor dialog.

Set Case Visibility Per Viewport
If you have multiple cases in your session of EnSight, you can set viewport visibility for all parts associated with a
case. This makes it easy to display one case per viewport. To set case visibility per viewport:

1. Select the desired case from the Case menu (Case > casename).

2. Select Case > Viewport Visibility to open the Case Visible in Which Viewport? dialog.

3. Click in a green viewport to disable display of the selected case in that viewport OR click in
a red viewport to enable display of the case in that viewport.

Perform Transformations in Viewports

You can transform objects in a user-created viewport as easily as in the default viewport (See How To Rotate, Zoom,
Translate, Scale for details). For precise viewport transformations, you can use the Transformations Editor on a per
viewport basis:

1. Click Transf. Edit... in the Transformations -+ Transformation Editor (Global Transforn) (][]
Control area. File Editor Function Help

Transform Action:

2. To perform precise transformations in a

viewport, click the desired viewport in the About Axis: X
Which Viewport(s) window and perform the - 0.0 +

transformation. . *
. Which Viewport(s) Scale Settings
Increment | § 400000

Limit Tto.oo0000

To select more than one viewport,

simultaneously hold down the control key ~ © | »r

and click on additional viewports. .
[ ]

Note that this action will change the currently

selected viewport(s). Link Interactive

Transforms

Claze
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Reset Viewport Transformations
The transformations for one or more viewports can be reset at any time in the Reset Tools and Viewports dialog.

Reset...| Transf. Edit...| Z-Clip...
\

- Reset Tools and Viewport{s) =E3)
: Which Viewport(s)

1. Click the Reset... button on the bottom of the desktop. .- : V.
2. Select the viewport(s) on which the reset willact. ........ .

Rezet Tool{s)
By Glabal By Selected
KYZ Space Viewport
Reset Cursaor Reset Line Reset Plane

Reszet Quaddric| Reset Box

3. Click on the appropriate button to perform the reset Reset Viewport(s}
action desired. ---------ooooiiioioii Reset By Selected | Reset Rotate!
You can reset the selected action only, all rotates translates "& Transferm Only | Translate/Scale
and scales at once, or do a complete reinitialization of the
viewport. Reinitialize
Claze Help

Setting/Changing Viewport Part Bounds

Part bounds can be displayed within a viewport. This is useful for understanding the size of the model domain.

Cursor _|Line _|Plane Axis \Bounds Fast Display = Legend... Info...

1. To turn on part bounds within the .
viewport, toggle the Bounds button on.----
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2. To modify, in Vport mode, any of the settings

for the bounds display, click the Select GL“;II K-Axds le’:: Zrixis

7 Visible Dimension 3D
Line Width 2 Pixels
‘ R G B ;
P 1.00 1.00 1.00 Mix...
3. Select General or one of the axes to workon. ................ . -
ransparency [ | g
Auta Size Length  As Specified

4. Modify any attributes desired. .................._. [ > GradationfGrid
N Line Width 1 Pixel Line Style Solid
Blioo © 100 Blioo Mix.
Sub-Gradation/Sub-Grid
Line Width 1 Pixel Line Style | Salid

Bloso Closo Bloso Mix.

Close ELal:
N -+ Viewport 2D£30 Grid Attributes{¥-#[E3]
‘.‘ Generall Y-Axis| Z-Axis

Axis Min [ 2000 | ¥ax (15000

Value Labels

Axis Location All

Extent Location Min

4[| Format og Format...

Rlyoo G100 Bl100  Mix...
Gradation/Sub-Grad

Grad Type Tick #of | g
Sub( Type Tick #af 5

Extent Location Min

Close Help...

Delete Viewports
A created viewport can be deleted at any time:
1. Click VPort in the Mode Selection area to
enter Viewport mode.

2. Select the desired viewport(s).
(Hold down the control key to select multiple viewports)

3. Click the Delete icon. - ----- oot

Other Notes

You can interactively transform multiple viewports simultaneously by selecting the viewports you want to link together
and turning on the Link Interactive Transforms toggle. An “L” will be displayed in all linked viewports.

You can copy the transformations from one viewport to another. First select the viewport you wish to copy, then
select Editor Function->Copy Transformation State. Next select the viewport(s) you wish to modify and select
Editor Function->Paste Transformation State.

SEE ALSO

How To Rotate, Zoom, Translate, Scale

User Manual: VPort Mode
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INTRODUCTION

EnSight does not support the running of the client on one machine and setting the system display environment back
to a different machine. It is intended that you actually run the client from the console of the client machine.

The server(s) can of course be run on remote machine(s).

And, of course the various VR combinations of display are valid.

SEE ALSO

How To Use Server of Servers
How To Setup for Parallel Rendering
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INTRODUCTION

EnSight’s viewports provide a great deal of flexibility in how objects are displayed in the Graphics Window. Given the
complicated transformations that can be performed, it is imperative that users be able to save and restore
accumulated viewport transforms.

BAsIC OPERATION

View saving and restoring is accessed from the Transformations dialog.

Saving Viewing Parameters

Click Transf. Edit... in the Transformations -+ Transfonmation Editor {Global Transfornm) [o][x]
Control area to open the Transformations File | Editor Function Help
dialog. SRR By Save View... |on: ==l — o]

Restore View...
1. Select the viewports you want to save. ! T X oY vZ ©an
Click within a viewport to select it. Hold . . 0.0 +
down the control key as you click to : 2 .

e . . Which Viewport(s) Scale Settings
select additional viewports. ----------------- PR

Increment | § gnp000

. . : Limit
2. Select Save View... from the File menu. ------: s 2.000000

Select a directory and enter a file name

in the file browser and click OK.

Link Interactive
Transforms

Clasze
L Il

EnSight provides a maximum of 16 viewports: the main viewport (which you cannot change) and 15 additional
viewports. When EnSight saves one or more viewports, it also includes the viewport number (which is equal to the
creation order) as a tag. When you request that one or more viewports be restored, EnSight looks in the saved file
and searches for tag numbers corresponding to the currently selected viewports. [f it finds a match, it restores that
viewport. If there is no match for a selected viewport, it is left unchanged.

Restoring Viewing Parameters

Click Transf. Edit... in the Transformations Control area to open the Transformations dialog.

1. Select the viewports you want to restore. As shown above, click within a viewport to select it. Hold down
the control key as you click to select additional viewports.

2. Select Restore View... from the File menu. Select a file name in the file browser and click OK.

What is Saved

Only global and local (frame) transformations are stored in a view parameters file. No information is stored for
viewport attributes, look-from/look-at points, or Z clipping.

Other Notes

By default, the F5, F6, or F7 buttons restore a standard right, top, or front view (respectively) of the selected viewport.
However, by holding down the Control key while pressing one of these keys, the current view will be saved to that
key. Subsequent pressing of that key will restore the saved view. Only Global transforms are saved / restored by
these operations, not Frame transforms.

SEE ALSO

How to Define and Change Viewports, How to Create and Manipulate Frames.

User Manual: Save/Restore View
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INTRODUCTION

By default, all parts are assigned to the same frame of reference. You can, however, create additional coordinate
frames and assign parts to them. These frames (and the parts assigned to them) can be manipulated (rotated,
translated, scaled) independently of other frames. Some examples of frame usage:

1. You wish to create a copy of a part and display a different variable on the copy. When you create the copy, a new
frame is automatically created and the copy is assigned to it. The new frame can be translated away from the
original to visualize both variables simultaneously.

2. You wish to create an animation of parts moving independently (e.g. for an exploding view or to “open” a closed
object with a “hinged door”). Each dynamic part is assigned to a new frame. During keyframe animation, the
frames are manipulated independently to achieve the desired motion.

3. You have a dataset with rotational periodicity but the symmetry axis is not aligned with a major axis. A new
frame is created and positioned such that one of it's axes is aligned with the symmetry axis.

4. You have a dataset that makes correct positioning of EnSight tools difficult, e.g. a duct not aligned with a major
axis. Create a new frame and align one of the axes with the duct. Since tool positions are always specified with
respect to the current frame, you can now use the Transformation Editor to accurately position tools along the axis
of the duct.

In addition to position and orientation, frames have a number of display attributes such as visibility, line width, and
color. You can also specify the length of each axis separately and display a series of evenly spaced labels to use as
a 3D measuring tool.

Frames are a powerful but complex feature of EnSight. Understanding the basics of frames is essential for proper
use. This article is divided into the following sections:

Introduction

Create a New Frame

Select Frames

Assign Parts to Frames

Move and Rotate Frames

Reset Frame Transform

Set Frame Attributes

Determine What Frame a Part is Assigned To
Delete Frames
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BAsIC OPERATION

Introduction

On startup, EnSight creates a default frame — frame 0 — located at 0,0,0 of the right-handed “world” or model
coordinate system and aligned with the X, Y, Z axes. All parts (model and newly created) are assigned to frame 0
initially. Frame 0 is special in that it cannot be repositioned or deleted.

Note: Frame mode is reserved for the expert user. By default, it is not enabled. To enable it, go to Edit-
>Preferences..., select General User Interface and toggle on Frame Mode Allowed.

Frames are selected either by clicking the frame axis triad (while in Frame mode) in the Graphics Window or by
selecting the frame in the “Which Frame” list of the Transformation Editor dialog. Any frame operation (such as
setting attributes) acts on the currently selected frames.

The EnSight positioning tools (Cursor, Line, Plane, and Quadric tools) are always positioned with respect to the
currently selected frame. If more than one frame is selected, frame 0 is the reference frame for tools. If you have
tools visible, you will notice them changing position as the selected frame is changed.

EnSight implements computational periodicity (such as rotational symmetry) as an attribute of frames. If a frame has
symmetry enabled, all parts assigned to the frame will be duplicated as specified by the particular type of symmetry.

All frame axis triads are visible when in Frame mode. The axis triad consists of three lines representing the X, Y, and
Z orientation vectors plus labels. Selected frames are colored with the default highlight color (typically green). If the
frame is visible (meaning it will be displayed in all modes) the frame axes are drawn with solid lines. Otherwise,
dashed lines are used.

EnSight does not support hierarchical frames: you cannot assign a frame to another frame to implement nested
transformations. All frames are embedded in the same world coordinate system (i.e. frame 0).

Create a New Frame

In general, you have to explicitly create new frames. However, EnSight will automatically create a new frame each
time you create a copy of a part and assign the copy to the frame.

To create a frame:

1. Click Frame in the Mode Selection area to enter Frame mode.

(Note: If Frame does not appear as an available mode, first go to Edit-
>Preferences..., select General User Interface and toggle on Frame
Mode Allowed.)

The initial position of a new frame can either be set to 0,0,0 or

automatically centered on a set of parts.

2. If desired, select one or more parts in the Main Parts list — the new
frame will be centered on the selected parts.

3. Click the New Frame icon to create the frame.

The new frame also becomes the currently selected frame.
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Select Frames

There are two ways to select frames. You can click on the frame axis triad in the Graphics Window or select frames
in the “Which Frame” list in the Transformation Editor dialog. Selected frames are colored with the default highlight
color (typically green).

To select frames in the Graphics Window:

1. Click Frame in the Mode Selection area to enter Frame mode.

(Note: If Frame does not appear as an available mode, first go to Edit->Preferences..., select General User
Interface and toggle on Frame Mode Allowed.)

2. Position the mouse pointer over the frame axis triad (the lines — not the XYZ labels) and click the left
mouse button.
You can extend a selection of frames by holding down the Control key as you click on frames.

To select frames using the Transformation Editor dialog:

1. Click the Transf. Edit ... icon in the -~ Transformation Editor (Frame Transform) [O][=]
Transformation Control area to open the File Editor Function Help

Transformation Editor dialog. TRy
ransiorm CT1lOn:
; ]

2. Select Frame > Transform from the Editor About Axia: <
Function menu. Note that this puts EnSight o .
into Frame mode. ---------oooiiiii - -
) ) . Which Frame Scale Settings
3. S_elect the desired frames in the Which Frame Coomd. frame 0 Increment [ 000000
fist. .o | Coord. frame 1 .
it | | i LT
You can use standard Motif list selection techniques, - LIRS 2

such as shift-click to extend a selection or control-
click to de-select an item.

The Which Frame list is also displayed if the Editor
Function menu is set to one of the Tool modes (e.g. Close
Tools > Cursor). I L

Assign Parts to Frames

To assign a part to a frame:

1. Click Frame in the Mode Selection area to enter Frame mode.

(Note: If Frame does not appear as an available mode, first go to Edit-
>Preferences..., select General User Interface and toggle on Frame
Mode Allowed.)

2. Select the desired part(s) in the Main Parts list.

3. Select the desired frame (as described above).

4. Click the Part Assignment icon to assign the part(s) to the frame. - - » =3

A message is printed to the Status History area confirming the assignment.
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Move and Rotate Frames

You transform a frame (and all parts assigned to it) when you perform any transformation while in Frame Transform
mode. Frame Transform mode is set automatically when you enter Frame Mode. You can also set it explicitly from
the Editor Function menu in the Transformation Editor dialog.

To transform in Frame Transform mode:

1. Click Frame in the Mode Selection area to enter Frame
mode.

(Note: If Frame does not appear as an available mode, first go to
Edit->Preferences..., select General User Interface and toggle :--- ¥+ Transform
on Frame Mode Allowed.) ' 5 T

Definition

2. Select Transform from the Transform/Definition pull- .
down.

3. Select the desired frame(s) (as described above).

4. Perform the desired transformation either interactively
(using the Transformations Control icons and the mouse
in the Graphics Window) or via the Transformation Editor
dialog. See How To Rotate, Zoom, Translate, and Scale
for more information.

Frame transforms are implemented as a transformation applied with respect to the frame’s position and orientation.
At times you will need to modify the position and orientation of the frame independent of the parts assigned to it. This
is done while in Frame Definition mode. You enter Frame Definition mode either explicitly from the mode menu in the
Transformation Editor dialog (Editor Function > Frame > Definition), or via the Transform/Definition pull-down icon
while in Frame Mode.

Important! You cannot change the frame definition if you have performed any frame transformations (if you attempt
to do so, a dialog will remind you). Any frame definition must be applied prior to a frame transformation. If you have
already made frame transforms you can clear them by returning to frame transform mode and using the Reset Tools
and Viewports dialog (click Reset... to open).

To transform the Frame Definition:

1. Click Frame in the Mode Selection area to enter Frame
mode.

2. Select Definition from the Transform/Definition pull-
down.

. Transform
3. Select the desired frame(s) (as described above). Teeees =+ Definition

4. Perform the desired transformation. This can be done either interactively (with the mouse in the
Graphics Window) or via the Transformation Editor dialog. To translate the frame interactively, move the
mouse pointer into the Graphics Window and click and drag the left mouse button. To rotate the frame
interactively, click and hold the left mouse button on one of the frame axes and drag the mouse. Clicking
on the X axis will rotate the frame about its Y axis. Clicking on the Y axis will rotate the frame about its X
axis. Clicking the Z axis will rotate about both X and Y. Use the Transformation Editor dialog to rotate
about the Z axis only.
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How To ... Create and Manipulate
B 26000 Frames

You can also edit the frame’s definition explicitly using the Transformation Editor dialog:
1. Click Frame in the Mode Selection area to enter Frame mode.
(Note: If Frame does not appear as an available mode, first go to Edit- .
>Preferences..., select General User Interface and toggle on Frame :
Mode Allowed.)

2. Click the Frame Location Attributesicon... .. ... ... ... .. ... ...

This opens the Transformation Editor dialog in Frame Definition mode.

File Editor Function Help

- . ; =
cf 1 ]
Which Frame Scale Settings

Coord, frame 0 | |2 In::r\ementl 1000000
3. Select the desired frame(s). J

Coord. frame 1 i
. Limit I 90000000

soord. frame 2

Y Axis Al .II
o | =

4. If desired, enter new value(s) in the XYZ —— Origin
fields to change the frame’s origin
(remember to press return). ..o

X | 5.0000e-01 ¥ | 5.0000e-01 Z | 1.0000e+00
F =

Orientation Vectors

5. If desired, enter new value(s) for the

. . X| 1.00002+00 | 0.0000e-+00 | 0.0000e-+00
orientation vectors (remember to press
return). -« -coocoooiiii =Y | 0.0000-+00 | 1.0000e-+00 | 0.00002+00
Z | 0.0000¢+00 | 0.0000¢-+00 | 1.0000¢-+00
Note that the orientation vectors are re 7
normalized when you press return. = =

Clase I

Reset Frame Transform

The frame transform can be reset back to the default position and orientation by using the Reset Tools and Viewports
dialog. To clear the frame transform:

1. Click Frame in the Mode Selection area to enter Frame mode.

2. Select Transform from the Transform/Definition pull-down.  ----------------:

3. Select the desired frame(s) (as described above). PN Iransforml

v+ Definition

4. Click the Reset... button in the Transformation Control area to open the
Reset Tools and Viewports dialog.

5. In the Reset Tools and Viewports dialog, click the desired button:

Reset By Selected Transform Only: clear only the transformation component
currently selected (e.g. rotate or translate) in the Transformation Control area

Reset Rotate/Translate/Scale: clear all transformation components

See How To Reset Tools and Viewports for more information.
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Frames

Set Frame Attributes

Frames can be displayed with a variety of attributes:

1. Click Frame in the Mode Selection area to enter Frame mode. (If needed, first enable Frame Mode

under Edit->Preferences..., General User Interface.)
2. Select the desired frame(s) (as described above).

3. Set the desired attribute as described below:

Click the Frame Visibility Toggle to toggle display of the axis triad of selected

frames on or off (when not in Frame Mode).  -~---------reememmemnmne e >

Click (opens the Color Selector) to set the color for the axis triad of selected

111 1=V >

Click the Frame Line Width pull-down to set the line width for the axis triad of
selected frames.  -------c-cooioiiiiiii i >

To adjust the length of the frame axes, enter
new values in the X, Y, and Z Length fields and ¢
press return.

Y
| %] 1.00006+00 Y| 1,0000e+00
To display a series of evenly spaced labels :

Z | 1.0000g-+00

along an axis (showing distance from the axis
origin), toggle on the applicable Label button,

| X Lahels #nfl 3

enter the desired number of labels in the # of 1 Y Labkels # of |3_
field, and press return. ----------o-oioiaioonn

Clnsel
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Determine What Frame a Part is Assigned To

You can determine what frame a part is assigned to (and change it) by opening the Feature Detail Editor for the part:

1. Open the Feature Detail Editor for the part
type (Edit > Part Feature Detail Editors >) or i
double click on the appropriate Feature File Edit View Help
Icon.

2. Select the desired part in the parts list at the
top of the Feature Detail Editor.

4] - (M/CLl) Computational mesh [l

!
-] -
Desc I Computational mesh o
. . Creation Attributes
3. Open the General Attributes section.  --------..
— .E General Attributes
, . . Visihle In Fast
The part’s current frame number is shown in the I Visible Viewport(s) Display Rep. B"" -'
Ref. Frame field. You can reassign a partto a [T Aux. Clip
different frame by entering a new value and O Acti Symometry
pressing return. «---«... oo e Ref.

Frame

Caolar By None

Delete Frames

Selected frames can be deleted. Note that a frame cannot be deleted if any parts are currently assigned to it. All
parts assigned to the frame must be assigned to other frames prior to deletion.

1. Click Frame in the Mode Selection area to
enter Frame mode.

2. Select the desired frame(s) (as described
above).

3. Click the Deleteicon. -------ooomvmnnno

SEE ALSO

How To Set Symmetry, How To Rotate, Zoom, Translate, and Scale, How To Reset Tools and Viewports

User Manual: Frame Mode
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How To ... Reset Tools

B 20006 and Viewports

INTRODUCTION

EnSight provides support for complex transformations of various entities (e.g. the scene, tools, frames). It is often
necessary to clear all or part of the transformation associated with an entity; the Reset Tools and Viewports dialog
provides this capability.

BAsIC OPERATION
To clear global transformations or tool positions:
1. Click View or Part in the Mode Selection area (to

be sure that EnSight is in Global Transform rather
than Frame transform).

2. Click the Reset... button in the
Transformation Control area to open the Reset A
Tools and Viewports dialog. -~ - oo

3. Perform the desired operation as described
below.

4. Click Close.

Transformations will only be reset for
the current viewport(s). Click in a

viewport to select it. Control-click to
extend the selection or de-select a Which Viewport{s)
selected item. --------ooooooo-

= Resetl Tools and Viewport(s)

Reset Tool{s)
By Global By Selected —---------------g - Toggle selects whether tool is
) ) XYZ Space Viewport reset based on the global XYZ
Click the applicable button to reset the space or reset based only on
corresponding tool. - ceiiian > Reset Cursor | Reset Line Reset Plane the selected viewport.

Reset Quadric| Reset Box
Click to clear only the transformation

component currently selected in the Reset Viewport(s)
Transformation Control area (e.g.
Rotate or Translate). -« -------------- o Beset By Selected | Reset Ratate

Transform Only | Translate/Scale
K

T { | Click to clear all

Reinitialize transformations in the
4 selected viewport(s). Note
Close Help that zoom is not a scene

: transformation and is not

L L cleared. Zoom is

. implemented by moving the
look-from point (the camera
position). To clear zoom, click
Reinitialize.

Click to clear all transformations as well

as reset the camera look-from/look-at

points so that all currently visible parts :
are centered in the selected viewport(s). .- --.....-.....0
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How To ... Reset Tools

B 20006 and Viewports

ADVANCED USAGE

The Reset Tools and Viewports dialog is also used to clear Frame transformations. See How To Create and
Manipulate Frames for more information on frames and frame transforms.

To clear frame transformations:

1. Click Frame in the Mode Selection area to enter
Frame mode. (If needed, first enable Frame mode
under Edit->Preferences... General User Interface.)

2. Select Transform from the Transform/Definition.......... »* Transform
pulldown. Definition

3. Select the desired frame(s).

)

Bont| Reset...| Transf. Edit...

4. Click the Reset... button in the Transformation :
Control area to open the Reset Tools and ~------------------mmmmmmmmnnnnnnnat
Viewports dialog.

5. Perform the desired operation as described
below.

6. Click Close.

=+ Reset Tools and Viewport(s)

Which Viewport(s)
Frame transformations will only be

reset for the current viewport(s). Click
in a viewport to select it. Control-click
to extend the selection or de-select a
selected item.  ceeeeoiifReiiiiaonn

Reset Tool(=)
By Global By Selected
XYZ Space Viewport
Reszet Cursor Reset Line Reset Plane

Click to clear only the frame
transformation component currently
selected in the Transformation Control
area (e.g. Rotate or Translate) for the Reset Viewpart(s)

selected frame(s) in the selected . Reset By Selected | Reset Rotate/

Reset Quadric| Reset Box

viewport(s). e Transform Only Translilhefﬂcale
Reinitialize R ERRREEEE] EEEEEEEEES - Click to clear all frame
transformations for the
selected frame(s) in the
Close Help selected viewport(s).
| |
SEE ALSO

How To Rotate, Zoom, Translate, Scale, How To Define and Change Viewports, How To Create and Manipulate
Frames
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How To ... Use the
B 20000 Color Selector

INTRODUCTION

Several operations in EnSight require that you select a color. The Color Selector dialog is used throughout the user
interface to provide a powerful and easy-to-use color selection mechanism.

BAsSIC OPERATION

The selector operates using one of two basic color models: RGB or HSV. The RGB color model specifies color by the
percentage of red, green, and blue and closely mimics the way computers deal with color. The HVS color model
specifies colors as percentages of hue (the actual color with red equal to both 0.0 and 1.0, green equal to 0.33, and
blue equal to 0.66), saturation (the “amount” of color, where 0.0 is white and 1.0 is full), and the value (the brightness,
where 0.0 is black and 1.0 is full). The HSV model is often more intuitive for mixing custom colors. Although HSV is
the default, you can switch to RGB by clicking the RGB toggle button.

The dialog provides four basic methods of selecting colors:

1. By picking one of the 2. By grabbing the marker in the
predefined colors from the color cube and moving it with
grid of colorcells. - - - - - - -~ - ovoie the mouse.-------

| U RGB © HSV © & Change Color Cell |

Color square always displays
the current color selection. - - - - - -

4. By grabbing and moving the
sliders associated with each
color component. - - - -

3. By entering values for HSV
(or RGB, depending on
mode) directly in the fields :
and pressing return. .- --. ... - :

When you have selected a color, click the Apply button to have the selected color applied to the object being edited
(e.g. part, color map level, text, etc.).

Specify Custom Colors

If you have colors that you use frequently that are not represented in the color grid, you can save them by replacing
selected cells. Your custom colors are automatically saved for future sessions. To set custom colors:

1. Select the desired color using any of the methods described above.

2. Toggle on Change Color Cell.

3. Click in the color cell you wish to replace.

4. Continue to select colors and replace cells.

5. Toggle off Change Color Cell when done.

The color information is saved in ~/.ensight7/ensight.colpal.default.

SEE ALSO

User Manual: Color Selector
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How To ... Enable Stereo Viewing
26000

INTRODUCTION

EnSight supports active stereo display on workstations with quad-buffered OpenGL stereo capability, in addition to
passive (polarized) stereo support for detached displays (see How To Setup Parallel Rendering). Active stereo
works by rapidly displaying alternating left and right eye views on the screen. An emitter (which sits on top of your
display monitor) sends an infrared signal to special glasses worn by the viewer(s). The glasses contain liquid crystal
shutters that alternately open and close the left and right eye lenses in response to the signal from the emitter in sync
with the monitor display. The update frequency is such that the viewer effectively fuses the left and right views into a
single stereo image.

Stereo is useful for viewing any type of visually complex geometry. It is especially helpful for visualizing amorphous
objects such as animating particle traces, trace ribbons, or discrete particles. It has also been noted that
management and customers are typically quite impressed by stereo display.

See the “See Also” section below for information on purchasing NuVision stereo glasses through CEI.

BAsSIC OPERATION

In EnSight, stereo display is enabled by pressing the F12 key on your keyboard. Pressing the F12 key again will
return to normal display. The stereo separation angle can be controlled by pressing the F10 and F11 keys. F10
decreases the angle and F11 increases the angle. When EnSight is configured to use a detached display (see How
To Setup Parallel Rendering), these commands affect only the detached display. The GUI window remains
monoscopic.

Configuring your display

On most platforms the display is not initialized by default in a mode which enables stereo viewing. In general quad-
buffered stereo requires a refresh rate of 96Hz or higher. On some monitors it may be necessary to decrease the
display resolution in order to accommodate this higher refresh rate. Check your monitor documentation before
attempting to change the refresh rate.

For Unix platforms there is a utility distributed with EnSight which can be used to determine if your display has stereo
capability. Run ‘glx_info’ and look for X visuals with a ‘y’ the column ‘stro’. If none exist, then the current display
parameters do not allow for stereo viewing.

Below are example instructions for various platform configurations which have been tested and confirmed to work
with EnSight. When in doubt, refer to your system documentation for OpenGL as well as the X server (Unix) or video
adapter device driver (Windows).

Compaq Tru64 Unix
1. Edit the file /usr/var/X11/Xserver.conf
Find the section that looks similar to:

args <

| PowerStorm 300/350 Server args start
-pn -su -bs -nice -2

! PowerStorm 300/350 Server args end
-pn

>

Modify to something like:

args <
! PowerStorm 300/350 Server args start

-pn -su -bs -nice -2 -screen 1280x992 -vsync 100
| PowerStorm 300/350 Server args end

-pn
>

Restart the Xserver with /usr/sbin/xsetup

2. Connect an appropriate emitter. The NuVision emitter with a 3-pin to 5-pin converted has been tested.
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CrystalEyes users should be able to use an ‘ESGI’ emitter with a 5-pin cable.

HP-UX 10.2 - 11.0
1. Configure the display settings using:
/opt/graphics/common/bin/setmon
Select a setting which includes “Stereo in a Window”
2. Connect a 3-pin emitter to the graphic card. The NuVision emitter works fine. For CrystalEyes a converter cable
may be needed.
IBM AIX 4.3

1. First, make sure that the graphics card is properly configured for OpenGL and stereo display. See the file /usr/
1lpp/X11/README for directions on configuring the X server. You may need to edit the file /usr/lpp/xX11/
defaults/xserverrc to add a “-stereo” argument similar to:

# _________________________________________________________________________
# Load GLX extension to the X server for OpenGL

B o s ___
if [ -f /usr/lpp/OpenGL/bin/loadGL -a \

-f /usr/lpp/X11l/bin/loadAbx -a \
-f /usr/lpp/X11/bin/loadDBE ] ; then
EXTENSIONS="$EXTENSIONS -x abx -x dbe -x GLX -stereo”
fi
2. Next you need to set the refresh rate to a stereo-capable setting. Stereo settings are usually 96+Hz vertical
refresh. Use the ‘smit’ tool to see which settings you can use. When running smit, select:

Devices->Graphic Displays->Select the Display Resolution...

You will be prompted to select your graphics adapter. After selecting your graphics adapter you will see the current
setting, and you can now query for the available settings. Hopefully you will find something at 96+Hz. If not, you
may have a monitor which cannot support such high refresh. Connect a new monitor and reboot the machine, run
smit again. Note that many monitors can only handle high refresh at lower resolution (i.e. 1024x768 at 96Hz or
120Hz).

3. The last step is to hook up a stereo emitter to sync with the glasses. We have successfully used the NuVision
emitter with built-in 3-pin connector. The CrystalEyes EPRO emitter with external power and 3-pin to BNC cable
should work as well.

SGl Irix 6.5

1. Configure the video resolution/refresh rate for stereo. On an Infinite Reality pipe this may be done with something
like:
/usr/gfx/ircombine -destination eeprom -source file \
/usr/gfx/ucode/KONA/dg4/cmb/1024x768 120s.cmb -target :0.0
On other platforms the ‘/usr/gfx/setmon’ command can be used to select the correct mode. An example may
be:
/usr/gfx/setmon 1024x768 96s

See the man page for platform specific information and the locations of the configuration files. You may get a
message telling you that the format is not available, however in some cases all that is needed is a reboot in order
to switch the resolution.

2. Hook up your stereo emitter. The CrystalEyes ESGI emitter works with the SGI, and there is a 3-pin to 9-pin cable
to use the NuVision emitter on the SGI.
Sun Solaris 8

1. Configure the video resolution/refresh rate for stereo. On an Expert3D Card this is done with a command similar
to:

fbconfig -dev /dev/fbs/ifb0 -res stereo
The fbconfig utility is a wrapper tool that calls afbconfig/ffbconfig depending on the type of graphics adapter.

2. Hook up a stereo emitter. The Expert3D uses a 7-pin cable.
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Linux

A few OpenGL drivers are known to support stereo OpenGL under Linux, including the HP fx-5/fx-10 and the ATI
FireGL2/FireGL4. Documentation is included with the drivers, which may be downloaded from the card vendors
web sites.

MS Windows

Configuration of stereo under Microsoft Windows is dependent upon the graphics card driver which is installed.
Right-click on the background and choose “Properties” to open to Display Properties dialog. Look for a tab which
such as “OpenGL Properties” or “Advanced” and search for a stereo option. In many cases there is a toggle button
for enabling stereo display. You will usually need to restart the machine in order for changes to take effect. If stereo
still does not work, try changing the display resolution, as stereo may not be available at higher resolutions.

SEE ALSO

Most SGI hardware is “stereo ready” meaning that you need no additional hardware (other than glasses and the
emitter). However, check with your local SGI technical representative to be sure. The 02, in particular is not stereo
ready and additional hardware must be purchased.

In the U.S., NuVision hardware (glasses and emitters) can be purchased through CEI. Contact Sales and Marketing
for pricing and availability:

CEl, Inc.
919-363-0883
919-363-0833 FAX
ensight@ceintl.com

Outside the U.S., contact your local EnSight distributor.
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How To ... Pick Center of

» 20000 Transformation

INTRODUCTION

EnSight allows you to pick where you would like the center of transformation to be for the model.

BAsIiC OPERATION
1. In Part Mode, select the Pick Object icon. ------------------oo--.

A

p Pick Part

a

1- Pick Plane(3 Pt=.) Tool Location
t

2. Toggle on Pick Center of Transformation.----------.... Pick Plane(2 Pts.) Tool Location

3. Position the mouse cursor on your model at the Pick Plane Tool Origin

desired location for the center of transformation. : Pick Plane Tool Normal

Pick Line Tool Location
4. Press the “p-key”. =

: Pick Cursor Toal Location
Your model will now rotate about the position on the model:-}--- -~ pick Center Of Transform

that you just picked. Pick Look/At Point

You can also set or change the exact location of the center of transform by using the Transformation Editor.

1. Click the “Transf. Edit” button on the
. desktop below the graphics screen.

=M Tranzformation Editar {Center Of Transform}

: File Editor Function Help
. 2. Under “Editor Function”, select “Center of
Transform”. Center Of Transformation
. X Y z
: 3. Set of modify the x,y,z coordinate location 0.0000e+00 0.0000e+00 0.0000e+00
. of the center of transform in the dialog which =
L COMES UP. -----mmmmmmmeeee ool

Close

I 1
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How To . . Set Model Axis/
n 20000 Extent Bounds

INTRODUCTION

EnSight provides model axes and extent bounds to help in orienting your model. These features are toggled on/off via
the quick access area on the desktop. ...

IBIEIES]

Select Part(s) To Operate On
1-(M/C1) Computational mesh

Shaded _|Hidden Line Cursor _|Line _|Plane Axis [TBounds Fast Display  Legend..|  Info...

~mom | mo=" [~ozzp [ muew

(5] B Resct...| Transf. Edit... +x| +¥| +Z| x| .¥| -Z| Store| Recall| iinde Toel Tips

BAsSIC OPERATION

Model Directional Triad

The model axes help maintain awareness of the principal directions of the reference frame of the model. This is
especially helpful during model transformations.
Shaded _|Hidden Line Cursor _|Line _|Plane Axis [ Pounds Fast Display Legend... Infa...

Click the Axis toggle to display the model directional :
triad. o

‘ 2000 ® HowTo Index User Manual Page 1 of 2




How To ...

h 20000

Set Model Axis/
Extent Bounds

Model Extent Bounds

The model extent bounds also help maintain dimensional information pertaining to the extents of the model.

Shaded _|Hidden Line

Click the Bounds toggle to display the model extents

To control the various attributes associated with the model

extents:

1. Select the Viewport Mode icon.

2. Select the Model Extent Bounds icon, which opens the
Viewport 2D/3D Grid attributes dialog. - ------- - - oo

3. Modify the various general and/or axes attributes as

Cursor

Line

Plane

Axis ABounds Fast Display

Legend...

Infa...

desired. .- - oLl . : :
L =" Viewport 2D/3D Grid Attributes{General)
Generall X-Axis| Y-Axis| Z-Axis
E A All Axes
v Vigible Dimension 3D
R e ey x| ||| Line Width |2 Pixels
Generall Y-Axis| Z-Axis Rj00 G[100 B[roo | Mix..
Awie Biin RN Haw 4 ey Transpamncy 1.00
Value Labels Auto Size  Length As Specified
Axis Location All Gradation/Grid
Extent Location Min Line Width 1 Pixel Line Style Solid
Format f}*og Format... R 1.0 G 1.00 B 1.00 Mix...
Bljoo G100 Blioo Mix. Sub-Gradation/Sub-Grid
Gradation/Sub-Grad Line Width 1 Pixel Line Style Salid
Grad Type Tick #of g Bloso Gloz Bloso |Mix.
SubG Tick # of
ubG Type | Tic 2 Clasze Help...
Extent Location Min L L
Clasze Help...
1| L
SEE ALSO
User Manual: Part Bounds Attributes
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How To ... Use the Cursor

20000 (Point) Tool

INTRODUCTION

EnSight provides a 3D point specification tool called the “Cursor” tool. When visible, the Cursor appears as a 3D
cross colored red (X axis), green (Y axis), and blue (Z axis). The Cursor tool is used to supply EnSight with point
information, for example to specify the location for a query or the starting point for a particle trace.

BAsSIC OPERATION

In many cases, the Cursor tool will automatically turn on when performing some function that requires it. You can
also turn the tool on and off manually by toggling the Cursor entry in the Tools menu or by clicking the Cursor toggle

on the Desktop. .

File Edit Query View Tools | Case

CER-~ HE

Line

Select Part(s) To Operate { , pr,. o

Box
Quadric

Toel Positions. ..

Shaded _|Hidden Line Cursor _|Line _|Plane

The Cursor tool can be placed in three ways: interactively through direct manipulation with the mouse, by positioning
the mouse pointer over a part and pressing the ‘p’ key, or precisely positioned by typing coordinates into a dialog.

To position the Cursor with the mouse:

1. Place the mouse pointer over the center of the tool.  ---------------. .
2. Cli . .
ick (and hold) the left mo.use butto.n ><
3. Drag the Cursor to the desired location.
4. Release the mouse button.

(Undo/Redo button at the bottom of screen can be used to undo/redo the
tool transformation)

Cursor translation is restricted to the plane perpendicular to your line of sight. If you need to move the cursor in
another plane, rotate the model such that the desired translation plane is perpendicular to your new line of sight.
(Note that the Cursor will not exactly track the location of the mouse pointer.)

To position the Cursor on a part with the ‘p’ key:

ol |

Pick Part
Pick Plane(3 Pts.} Tool Location
Pick Plane(2 Pts.) Tool Location

2. Click the Pick Pull-down and select “Pick Cursor Pick Plane Tool Origin
Location” from the pop-up menu. ................. Pick Plane Tool Normal

Pick Line Tool Location

1. Click the Part mode button. -------------nvmveeiinnnnns

+Hp g

Leeeen- - --- % Pick Cursor Tool Location
Pick Center Of Transform

3. Place the mouse pointer over the desired location on Pick Look/At Point
a part in the graphics window and press the ‘p’ key. =
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How To ... Use the Cursor

B 260000 (Point) Tool

To set the Cursor by specifying coordinates:

1. Open the Transformation Editor dialog by

clicking Transf. Edit... on the desktop. -+ Transformation Editor {Cursor Tool)
File Edit‘orAFuncﬁon Help
2. Select Editor Function > Tools > Cursor: - ------ -~ [P 0 e me ey on:  pam ”
== BB mE
About Axis: X ¥ A All
0.0 +

Which Frame Scale Settings

Coord. frame 0 Increment | | 400000

Limit

Coord. frame 2 2.000000

44 Cartesian Coordinates ##+
##+4 af Cursor Tool in Frame 1 ####

3. Enter the desired coordinates into the X, Y, X ¥ z
and Z type-ins and hitreturn. ---------oooooo P 1.65T0e+01 1.0198e+01 3.9887e-+01

Claze

You can also move the Cursor by setting the desired axis of translation in the Axis pop-up and manipulating the slider
bar. In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Cursor since the X,Y,Z numeric
values always update to reflect the current location. If you are positioning the Cursor interactively with the mouse, the
values will update when the mouse button is released.

ADVANCED USAGE

After a model has been loaded, the initial location of the Cursor is set to the “look-at” point — the geometric center of
all visible geometry. The coordinates of the Cursor are specified with respect to the default frame: frame 0. However,
if you have created additional frames, you can position the Cursor relative to the origin of a different frame. This is
accomplished by selecting the desired frame in the “Which Frame” list in the Transformation Editor dialog.

You can easily reset the position of the Cursor tool to the default. See How To Reset Tools and Viewports for more
information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO

Other tools: Line, Plane, Box, Cylinder, Sphere, Cone, Surface of Revolution. See the How To article on Frames
for additional information on how frames effect tools.

User Manual: Tools Menu Functions
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How To ... Use the Line Tool

h 20000

INTRODUCTION

EnSight provides a 3D linear specification tool called the “Line” tool. When visible, the Line tool appears as a
(typically white) line with a cross at the center point. The Line tool is used to supply EnSight with a linear
specification, for example to specify the location for a line clip or a “rake” for a particle trace.

BAsSIC OPERATION

In many cases, the Line tool will automatically turn on when performing some function that requires it. You can also
turn the tool on and off manually by toggling the Line entry in the Tools menu or by clicking the Line toggle on the
Desktop. : ;

File Edit Query View Tools | Case . Help

o - [Ee ] [
& . Line ----
Select Part(s) Ta Operate ( Plane
Box
Quadric

Tool Positions...

Shaded _|Hidden Line Cursor _|Line _|Plane

The Line tool can be placed in three ways: interactively through direct manipulation of tool “hotpoints” with the mouse,
by positioning the mouse pointer over a part and typing the ‘p’ key, or precisely positioned by typing coordinates into
a dialog.

To move the Line with the mouse:
1. Place the mouse pointer over the center of thetool.  .--..-................._. .
2. Click (and hold) the left mouse button. )
3. Drag the Line to the desired location.
4. Release the mouse button.

To stretch the Line with the mouse: .
1. Place the mouse pointer over one of the Line endpoints.
2. Click (and hold) the left mouse button.

3. Drag the endpoint to the desired location.

4. Release the mouse button.

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool
transformation)

Line moving and stretching is restricted to the plane perpendicular to your line of sight. If you need to move the Line
in another plane, rotate the model such that the desired translation plane is perpendicular to your new line of sight.
(Note that the Line will not exactly track the location of the mouse pointer.)
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To position the Line on a part with the ‘p’ key:

1. Click the Part mode button.

2. Click the Pick Pull-down and select “Pick Line Tool

Location” from the pop-up menu.

3. In the Graphics Window, place the mouse pointer on
a part over the desired location for the first Line
endpoint and press the ‘p’ key. Move the mouse

pointer to the desired location for the
endpoint and again press the ‘p’ key.

To set the Line by specifying coordinates:

second Line

1. Open the Transformation Editor dialog by clicking

Transf. Edit... on the desktop.

2. Select Editor Function > Tools > Line.

3. Enter the desired coordinates for the

endpoints into the X, Y, and Z fields and

press return.

Which Frame

X Y z
1
~ o -1.1926e+01 1.0198¢+01 2.9887e+01
2
8.7850e+00 1.0198e+01 2.988Te+01

Length | 5 0710e+01

Pick Part

Pick Plane(3 Pts.} Tool Location
Pick Plane(2 Pts.) Tool Location
Pick Plane Tool Origin

Pick Plane Tool Normal

Pick Line Tool Location
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Pick Cursor Tool Location
Pick Center Of Transform
Pick Look/At Point

=

[o][x]

Help

=~ Transfonmation Editor {Line Tool)
File Editor Flin-ct'ion

All

About Axis: i

0.0

Scale Settings

¥

Coord. frame 0
Coord. frame 1

Joord., frame 2

Increment | ; noooon

Limit 2.000000

et Cartesian Coordinates #t+
#rtk af Line Tool in Frame 2 #46

Cloze

You can also move the Line by setting the desired axis of translation in the Axis pop-up and manipulating the slider
bar. In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Line since the X,Y,Z numeric values
always update to reflect the current location. If you are positioning the Line interactively with the mouse, the values
will update when the mouse button is released.
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ADVANCED USAGE

After a model has been loaded, the initial location of the Line center is set to the “look-at” point — the geometric center
of all visible geometry and parallel to the X axis. The coordinates of the Line are specified with respect to the default
frame: frame 0. However, if you have created additional frames, you can position the Line relative to the origin of a
different frame. This is accomplished by selecting the desired frame in the “Which Frame” list in the Transformation
Editor dialog.

You can easily reset the position and orientation of the Line tool to the default. See How To Reset Tools and
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in
positioning tools since you can see the tool simultaneously from multiple vantage points.

To find the distance between two nodes that have IDs, you can use the calculator function Dist2Nodes. However, to
find the distance between two nodes on different parts, or between two nodes if one or both don’t have IDs, use the
line tool. First drag down to Pick Line Tool Location on the pick part icon to the left of the GUI screen, then move the
cursor over the first location, hit ‘p’ key, move to the second location and hit the ‘p’ key, then open up the
transformation editor and in the transformation editor menu, Edit>Tools>Line you'll find the length of the line tool
which is the distance between those two points.

SEE ALSO

Other tools: Cursor, Plane, Box, Cylinder, Sphere, Cone, Surface of Revolution. See the How To article on
Frames for additional information on how frames effect tools.

User Manual: Tools Menu Functions
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INTRODUCTION

EnSight provides a plane specification tool called the “Plane” tool. When visible, the Plane tool appears as a
(typically white) rectangular region with an axis located at the center point. The Plane can also have a semi-
transparent “filled” center that enhances visibility of the region. The Plane tool is used to supply EnSight with a
planar specification, for example to specify the location for a planar clip or a “net” for a particle trace.

BAsIC OPERATION

In many cases, the Plane tool will automatically turn on when performing some function that requires it. You can also
turn the tool on and off manually by toggling one of the Plane entries in the Tools menu (e.g. Tools > Plane) or by
clicking the Plane toggle on the Desktop.

File Edit Query View Tools | Case Help

CEERL B EE

Line .
Select Partis} To Operate { ; plape < - -~ - === ==-==ccmmmmemns

Quadric

Shaded _|Hidden Line Cursor _|Line _IPlane

The Plane tool can be placed in three ways: interactively through direct manipulation of tool “hotpoints” with the
mouse, by positioning the mouse pointer over a part and typing the ‘p’ key, or precisely positioned by typing
coordinates into a dialog.

To move the Plane with the mouse:

1. Place the mouse pointer over the center of the tool.  ------------------emvmeeiions .
2. Click (and hold) the left mouse button. ;
3. Drag the Plane to the desired location.
4. Release the mouse button.

To stretch (or scale) the Plane with the mouse:

1. Place the mouse pointer over the corner between the X and Y axis
labels. - o i

2. Click (and hold) the left mouse button.

3. Drag the corner to the desired location.

4. Release the mouse button.

To rotate the Plane tool with the mouse:

1. Place the mouse pointer over one of the axis labels (X, Y, or Z).

2. Click and drag to the desired orientation. Grabbing the X (Y) label
will rotate around the plane’s Y (X) axis. Grabbing the Z label
enables free rotation about the Plane’s center point.

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool
transformation)

Plane moving is restricted to the plane perpendicular to your line of sight. If you need to move the Plane in another
plane, rotate the model such that the desired translation plane is perpendicular to your new line of sight. (Note that
the Plane will not exactly track the location of the mouse pointer.)
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To position the Plane on a part (by specifying three points) with the ‘p’ key:

1. Click the Part mode button. .............................__.

Pick Part

-1 > Pick Plane(3 Ptz.) Tool Location
Pick Plane(2 Ptz.} Tool Location
Pick Plane Tool Origin

Pick Plane Tool Normal

Pick Line Tool Location

2. Click the Pick Pull-down and select “Pick Plane (3
Pts.) Tool Location” from the pop-up menu.-------------

A .

~0=n

Pick Cursor Toal Location
Pick Center Of Transform

3. In the Graphics Window, place the mouse pointer on
Pick Look/At Point

a part and press the ‘p’ key. Repeat two more times.
Note that you are not specifying corner points — just
three unique points.

=

You can also position the Plane Tool by tracing out a line on the screen. The Plane orientation will be changed such
that it is both parallel to the specified line and perpendicular to the screen.

To position the Plane (by specifying a line):

1. Click the Part mode button. .................................

2. Click the Pick Pull-down and select “Pick Plane (2 A
Pts.) Tool Location” from the pop-up menu. ---------. | 3y
C| P Pick Part
a
Ve Pick Plane(3 Ptz.} Tool Location
& Pick Plane(2 Pts.) Tool Location
A Pick Plane Tool Origin
n Pick Plane Tool Normal
A . . i : Pick Line Tool Location
3. Move the mouse pointer into the Graphics Window t Pick E Tool Locati
and press the ‘p’ key. Place the pointer over the ek Lursar Loal Lacatlon
desired starting point. Click and hold the left mouse | p Pick Center Of Transform
button as you trace out the desired line. 1 Pick Look/At Point

4. Release the mouse button.
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You can also position the Plane Tool by picking an origin, then a point out on the normal. This takes two picking

operations to accomplish.

To position the Plane (by picking origin, then point on normal):

1. Click the Part mode button. ---------------ooonoo-.

2. Click the Pick Pull-down and select “Pick Plane Tool
Origin” from the pop-upmenu. --------- oL ‘ &
’ =
3. Move the mouse pointer into the Graphics Window : P Pick Part
and place the pointer over the desired origin of the 5 : Pick Plane(3 Pts.) Tool Location
plane tool - then press the ‘p’ key. t =
‘ Pick Plane(2 Pts.} Tool Location
4. Click the Pick Pull-down and select “Pick Plane Tool - "3 [# < Pick Plane Tool Origin
Normal” from the pop-up menu. -----------oooooii n- B Pick Plane Tool Normal
. . : Pick Line Tool Location
5. Place the pointer over a point along the normal t . .
vector (from the origin of the plane tool) - then press Pick Cursor Tool Lacation
the ‘p’ key. p Pick Center Of Transform
1 Pick Look/At Point
To set the Plane by specifying coordinates:
1. Open the Transformation Editor dialog from XA Transfor Editor (Plane Tool) mlx

the desktop by clicking Transf. Edit...

2. Select Editor Function > Tools >Plane. ..........

3. Enter the desired coordinates for the origin,
the components of the normal vector, and
the x and y size, and press return. ...............

About Axis:

Which Frame

File Editor Function Help

TransfornAEAcﬁon: ] '_I_' m %&
Z

Increment | 1 ogoooo

##k+ Cartesian Coordinates #+++
##4% of Plane Tool in Frame ( #++#

X ¥ Z
Origin | 5.0000e-01 5.0000e-01 1.0000e+00
Normal | 0.0000e+00 0.0000e+00 1.0000e+00

All

Scale Settings

Limit 90000000

—-OR- K-Size | 25000et00 V5122 | 5 5000e+00
T || e Plane Equation --------
3. Enter the plane equation parameters (Ax + X + ¥ + z
By + Cz=D) and press return. ------------------ 0. 0. 1.
= | 1000000
-OR- .
-------- Plane Corner Points ---e----
. . X Y z
3. Enter the desired coordinates for three
corner points into the X, Y, and Z fields and g LT-000e01 -7.50006-01 1.0000+00
pressreturn. -----o-oiiioiiiiiiiiii | 1.75002+00 -7.5000e-01 1.0000e-+00
1.7500e+00 1.7500e+00 1.0000e-+00
Cloze
il I
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You can also rotate the Plane by setting the desired axis of rotation in the Axis pop-up and manipulating the slider bar.
In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Plane since the X,Y,Z numeric
values always update to reflect the current location. If you are positioning the Plane interactively with the mouse, the
values will update when the mouse button is released.

The Undo/Redo button at the bottom of screen can be used to undo/redo the tool transformation.

ADVANCED USAGE

After a model has been loaded, the initial location of the Plane center is set to the “look-at” point — the geometric
center of all visible geometry and parallel to the X-Y plane. The coordinates of the Plane are specified with respect to
the default frame: frame 0. However, if you have created additional frames, you can position the Plane relative to the
origin of a different frame. This is accomplished by selecting the desired frame in the “Which Frame” list in the
Transformation Editor dialog.

You can easily reset the position and orientation of the Plane tool to the default. See How To Reset Tools and
Viewports for more information.

By default the plane tool will be displayed in line mode. You can display the tool as a transparent plane by changing
the setting for Edit > Preferences... View - Plane Tool Filled.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO

Other tools: Cursor, Line, Box, Cylinder, Sphere, Cone, Surface of Revolution. See the How To article on
Frames for additional information on how frames effect tools.

The Plane Tool is also used to specify the location of the clip plane for Auxiliary Clipping.

User Manual: Tools Menu Functions
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INTRODUCTION

EnSight provides a hexahedron shaped specification tool called the “Box” tool. When visible, the Box tool appears as
a (typically white) wireframe box icon with a triad at one corner. The Box tool is used to supply EnSight with a 3D
volume specification, for example to specify the location for a box clip or cut.

BAsSIC OPERATION

In many cases, the Box tool will automatically turn on when performing some function that requires it. You can also
turn the tool on and off manually by toggling Tools > Box. The Box tool can be placed in two ways: interactively
through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing coordinates into a

. To move the Box Tool with the mouse:
. 1. Place the mouse pointer over the origin corner
ofthetool. ~--------r-vorroiiiiii 3

2. Click (and hold) the left mouse button. g
. 3. Drag the Box to the desired location. 4<
5 4. Release the mouse button. B —
. To stretch the Box Tool with the mouse: ,:"-:

: 1. Place the mouse pointer over any of the corner -
:  points (except the origin). ......................... ‘

© 2. Click (and hold) the left mouse button.

3. Drag the endpoint to produce the desired
. stretched size.

4. Release the mouse button.

To rotate the Box Tool with the mouse:
. 1. Place the mouse pointer over the center of the
X, Yy, or z edge(not at the endpoints). ----------;

2. Click and drag to rotate.

. Note: Selection of the X axis edge will rotate the
box about the Y axis edge. Selection of the Y
axis edge will rotate about the X axis edge.
Selection about the Z axis edge will rotate
about the origin.

: (Undo/Redo button at the bottom of screen can be used to
+ undo/redo the tool transformation)

Box tool moving and stretching is in 3 space. (Note that the Box will not exactly track the location of the mouse
pointer.)
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To set the Box Tool by specifying coordinates:

1. Open the Transformation Editor dialog by -~ Transformation Editor (Box Tool) ]
clicking Transf. Edit... on the desktop. File Editor Function Help
) } Transform. Action: m] PRGN

2. Select Editor Function > Tools >Box...........{L..........: T

About Axis: X

1] +
Which Frame Scale Settings
Increment |1 nogono
Lirait 90.000000

44 Cartesian Coordinateg 4+

3. To place and size, enter the desired *+% of Box Teol in Frame 0 #++
coordinates for the Origin corner and X v Z
the length in each of the directions, Origin |7 50006-01 76219001 2.96860.01
and press return. ----coceieeieiieaieeoons |- - -
Length | 2 5000e-+00 3.7558e+00 4.0411+00

. Orientation Vectors
4. To orient, enter the components of the

. . X X
orthogonal axis orientation vectors ---------- B | 1:0000+00 0.0000e+00 0.0000+00
¥ [ 0.0000e+00 1.0000e-+00 0.0000e-+00
Z | 0.0000e+00 0.00008+00 1.0000e-+00
Clase

You can also rotate, translate or stretch the Box Tool by selecting the desired Transform Action, setting the desired
axis, and then manipulating the slider bar. For these tool actions, the values in the “Scale Settings” section control
the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Box Tool since the numeric values
always update to reflect the current location, size, and orientation. If you are positioning the Box Tool interactively
with the mouse, the values will update when the mouse button is released.

ADVANCED USAGE

After a model has been loaded, the initial location of the Box Tool is centered about the “look-at” point — the geometric
center of all visible geometry - and is aligned with the model axis system. The coordinates of the Cylinder are
specified with respect to the default frame: frame 0. However, if you have created additional frames, you can
position the Box Tool relative to the origin of a different frame. This is accomplished by selecting the desired frame in
the “Which Frame” list in the Transformation Editor dialog.

You can easily reset the position and orientation of the Box tool to the default. See How To Reset Tools and
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO

Other tools: Cursor, Line, Plane, Cylinder, Sphere, Cone, Surface of Revolution. See the How To article on
Frames for additional information on how frames effect tools.

User Manual: Tools Menu Functions
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INTRODUCTION

EnSight provides a cylindrical specification tool called the “Cylinder” tool. When visible, the Cylinder tool appears as
a (typically white) cylinder icon with a line running down the central axis. The Cylinder tool is used to supply EnSight
with a cylindrical specification, for example to specify the location for a cylinder clip or cut.

BAsSIC OPERATION

In many cases, the Cylinder tool will automatically turn on when performing some function that requires it. You can
also turn the tool on and off manually by toggling Tools > Quadric > Cylinder. The Cylinder tool can be placed in two
ways: interactively through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing
coordinates into a dialog.

To move the Cylinder with the mouse:
1. Place the mouse pointer over the center of the tool.  ............................... .
2. Click (and hold) the left mouse button. .
3. Drag the Cylinder to the desired location.
4. Release the mouse button.

To stretch the Cylinder with the mouse:

1. Place the mouse pointer over either of the center line’s endpoints.
2. Click (and hold) the left mouse button.

3. Drag the endpoint to the desired location.

4. Release the mouse button.

To change the Cylinder radius with the mouse:
1. Place the mouse pointer over the center ring.  --------------------
2. Click and drag to the desired radius. :

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool
transformation)

Cylinder moving and stretching is restricted to the plane perpendicular to your line of sight. If you need to move the
Cylinder in another plane, rotate the model such that the desired translation plane is perpendicular to your new line of
sight. (Note that the Cylinder will not exactly track the location of the mouse pointer.)
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To set the Cylinder by specifying coordinates:

1. Open the Transformation Editor dialog by
clicking Transf. Edit... on the desktop.

-+ Transformation Editor {Cylinder Tool)

File Edil‘nr Function Help
Transform Action: o
2. Select Editor Function > Tools > Cylinder. ........|l..........: | == EE

Abeout Axis: X v El All
- 0.0 +
Which Frame Scale Settings

Insrement |y 090000

Limit 2.000000

ek Cartesian Coordinates *t
it af Cylinder Tool in Frame 0 t#6

X ¥ Z
3. Enter the desired coordinates for the ) _Eﬂg -8.7850e-+00 0.0000g+00 9.9953¢-03
Orngln.(loc?tlon_ of the center point), 1A% [T oo00er00 000000100 0.0000e100
the Axis (direction vector), and the N rad
Radius and press return. «------cococooeoeeenon || ACHES [1.0142e101
Claze

You can also translate the Cylinder by setting the desired axis of translation in the Axis pop-up and manipulating the
slider bar. In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Cylinder since the numeric values
always update to reflect the current location. If you are positioning the Cylinder interactively with the mouse, the
values will update when the mouse button is released.

ADVANCED USAGE

After a model has been loaded, the initial location of the Cylinder center is set to the “look-at” point — the geometric
center of all visible geometry and aligned with the X axis. The coordinates of the Cylinder are specified with respect
to the default frame: frame 0. However, if you have created additional frames, you can position the Cylinder relative
to the origin of a different frame. This is accomplished by selecting the desired frame in the “Which Frame” list in the
Transformation Editor dialog.

You can easily reset the position and orientation of the Cylinder tool to the default. See How To Reset Tools and
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO

Other tools: Cursor, Line, Plane, Box, Sphere, Cone, Surface of Revolution. See the How To article on Frames
for additional information on how frames effect tools.

User Manual: Tools Menu Functions
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INTRODUCTION

EnSight provides a spherical specification tool called the “Sphere” tool. When visible, the Sphere tool appears as a
(typically white) sphere icon with a line running down the central axis. The Sphere tool is used to supply EnSight
with a spherical specification, for example to specify the location for a sphere clip or cut.

BAsSIC OPERATION

In many cases, the Sphere tool will automatically turn on when performing some function that requires it. You can
also turn the tool on and off manually by toggling Tools > Quadric > Sphere. The Sphere tool can be placed in two
ways: interactively through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing

coordinates into a dialog.

To move the Sphere with the mouse:
1. Place the mouse pointer over the center of the tool. ~ ........................ .
2. Click (and hold) the left mouse button.
3. Drag the Sphere to the desired location.
4. Release the mouse button.

To stretch the Sphere with the mouse:

2. Click (and hold) the left mouse button.
3. Drag the endpoint to the desired location.
4. Release the mouse button.

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool
transformation)

Sphere moving and stretching is restricted to the plane perpendicular to your line of sight. If you need to move the
Sphere in another plane, rotate the model such that the desired translation plane is perpendicular to your new line of
sight. (Note that the Sphere will not exactly track the location of the mouse pointer.)

To set the Sphere by specifying coordinates:

1. Open the Transformation Editor dialog by
clicking Transf. Edit... on the desktop.

-+ Transformation Editor (Sphere Tool) [=1E3]
File Editrr Function Help
Transform Action: P
2. Select Editor Function > Tools > Sphere.----------{f---------- ! S
About Axis: X
0.0
Which Frame Scale Settings
Increment |y 400000

Limit 2.000000

##4% Cartesian Coordinates
#+4% of Sphere Tool in Frame () ##+#

3. Enter the desired coordinates for the X ¥ z
Origin (location of the center point), 197ig [ g570e+01 0.0000e-+00 9.9953e-03
the Axis (direction vector), and/or the N axis

. : 1.0000600 || 0.00006+00 || 0.00008+00
Radius and press return, ------cooeoceoeanenannl = b b

Radius | 5 garges01
if you are going to create a developed surface from
a spherical clip, you need to be aware of how the Close

spherical axis orientation affects this operation. : .
(See How To Create a Developed Surface)
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You can also translate the Sphere by setting the desired axis of translation in the Axis pop-up and manipulating the
slider bar. In this case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Sphere since the numeric values
always update to reflect the current location. If you are positioning the Sphere interactively with the mouse, the
values will update when the mouse button is released.

ADVANCED USAGE

After a model has been loaded, the initial location of the Sphere center is set to the “look-at” point — the geometric
center of all visible geometry and aligned with the X axis. The coordinates of the Sphere are specified with respect to
the default frame: frame 0. However, if you have created additional frames, you can position the Sphere relative to
the origin of a different frame. This is accomplished by selecting the desired frame in the “Which Frame” list in the
Transformation Editor dialog.

You can easily reset the position and orientation of the Sphere tool to the default. See How To Reset Tools and
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO

Other tools: Cursor, Line, Plane, Box, Cylinder, Cone, Surface of Revolution. See the How To article on Frames
for additional information on how frames effect tools.

User Manual: Tools Menu Functions
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INTRODUCTION

EnSight provides a conical specification tool called the “Cone” tool. When visible, the Cone tool appears as a
(typically white) cone icon with a line running down the center axis. The Cone tool is used to supply EnSight with a
conical specification, for example to specify the location for a conical clip or cut.

BAsSIC OPERATION

In many cases, the Cone tool will automatically turn on when performing some function that requires it. You can also
turn the tool on and off manually by toggling Tools > Quadric > Cone. The Cone tool can be placed in two ways:
interactively through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing
coordinates into a dialog.

To move the Cone with the mouse:
1. Place the mouse pointer over the center of the tool.  .-............................ .. :
2. Click (and hold) the left mouse button.
3. Drag the Cone to the desired location.
4. Release the mouse button.

To stretch the Cone with the mouse:

1. Place the mouse pointer over either of the center line’s endpoints.-------
2. Click (and hold) the left mouse button. :
3. Drag the endpoint to the desired location.

4. Release the mouse button. NSNS
To change the Cone radius with the mouse:
1. Place the mouse pointer over the basering. .- - .ol
2. Click and drag to the desired radius.

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool
transformation)

Cone moving and stretching is restricted to the plane perpendicular to your line of sight. If you need to move the
Cone in another plane, rotate the model such that the desired translation plane is perpendicular to your new line of
sight. (Note that the Cone will not exactly track the location of the mouse pointer.)
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To set the Cone by specifying coordinates:

1. Open the Transformation Editor dialog by
clicking Transf. Edit... on the desktop.

=~ Transformation Editor {Cone Tool) =EA
File Editi”' Function Help
Transform. Action:

2. Select Editor Function > Tools > Cone.  ------jjl-----------! m == ﬂ 33

About Axis: X ¥ E All
- 0.0 +
Which Frame Scale Settings

Increment |y 090000

Limit 2.000000

4+t Cartesian Coordinates *+++
4t af Cone Tool in Frame (0 #h+

. . X i Z

3. Enter the desired coordinates for the O
Origin (|°cation of the cone tip), the L '»ng -5.7850e+00 0.0000e+00 9.9983e-03
Axis (direction vector), and the D || 2%5 [ 1.0000e+00 0.0000e-+00 0.0000¢-+00

conical half angle (in degrees) and

¢ ||| Angle | 2 g000e+01
pressreturn. --.-.ooooiiiiiiiiiiiiiiiiialll

Claze

You can also translate the Cone by setting the desired axis of translation and manipulating the slider bar. In this
case, the values in the “Scale Settings” section control the sensitivity and limit of the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Cone since the numeric values
always update to reflect the current location. If you are positioning the Cone interactively with the mouse, the values
will update when the mouse button is released.

The clip/cut from the cone tool will extend infinitely from the tip outwards. To limit the extent of the cone clip/cut, use
the plane tool and cut the cone clip/cut as desired.

ADVANCED USAGE

After a model has been loaded, the initial location of the Cone center is set to the “look-at” point — the geometric
center of all visible geometry and aligned with the X axis. The coordinates of the Cone are specified with respect to
the default frame: frame 0. However, if you have created additional frames, you can position the Cone relative to the
origin of a different frame. This is accomplished by selecting the desired frame in the “Which Frame” list in the
Transformation Editor dialog.

You can easily reset the position and orientation of the Cone tool to the default. See How To Reset Tools and
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO

Other tools: Cursor, Line, Plane, Box, Cylinder, Sphere, Surface of Revolution. See the How To article on
Frames for additional information on how frames effect tools.

User Manual: Tools Menu Functions
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" 20000 Revolution Tool

INTRODUCTION

EnSight provides a surface of revolution specification tool called the “Revolution” tool. When visible, the Revolution
tool appears as a (typically white) icon with a line running down the center axis. By default, the distance of five
planar points from the central axis defines the profile curve of the revolution surface (although you can add points up
to a maximum of ten). The Revolution tool is used to supply EnSight with a surface of revolution specification, for
example to specify the location for a revolution clip or cut.

BAsSIC OPERATION

In many cases, the Revolution tool will automatically turn on when performing some function that requires it. You can
also turn the tool on and off manually by toggling Tools > Quadric > Revolution. The Revolution tool can be placed in
two ways: interactively through direct manipulation of tool “hotpoints” with the mouse or precisely positioned by typing
coordinates into a dialog.

To move the Revolution tool with the mouse:

1. Place the mouse pointer over the center of the tool.  ------------ oot .
2. Click (and hold) the left mouse button. -
3. Drag the tool to the desired location. .

4. Release the mouse button.

To reorient the Revolution tool with the mouse:

1. Place the mouse pointer over either of the center line’s endpoints.----;

2. Click (and hold) the left mouse button. RRREEE >
3. Drag the endpoint to achieve the desired orientation. :

4. Release the mouse button.

(Undo/Redo button at the bottom of screen can be used to undo/redo the tool
transformation)

Revolution tool moving and stretching is restricted to the plane perpendicular to your line of sight. If you need to move
the Revolution tool in another plane, rotate the model such that the desired translation plane is perpendicular to your
new line of sight. (Note that the Revolution tool will not exactly track the location of the mouse pointer.)
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Use the Surface of
Revolution Tool

To set the Revolution tool by specifying coordinates:

: 1. Open the Transformations dialog by
clicking Transf. Edit... on the desktop.

2. Select Editor Function > Tools >
Revolution.

: The dialog displays the profile curve as a series
. of connected line segments with stars -
. positioned at the curve points. You can edit the .
. curve by clicking and dragging the points or by
: manually entering distance-radius pairs. You

© can also add or delete points. As you make

. changes, the tool in the graphics window

. updates interactively.

To edit points with the mouse:
. 1. Click on the point and drag to the desired

=+ Transformation Editor {Revolution Tool})
File

About Axis:

Editor Function Help
Transform Action s
== BB e
X ¥ El All
0.0 +

Which Frame

oo, frame O

Scale Settings
Increment 1000000

Limit 2 000000

ik Cartesian Coordinates e
#*+% of Revolution Tool in Frame 0 ¥

location. .- .-l

- To add points (up to a maximum of 10): "~~~ il

: 1. Click Add Point. ...............................

. 2. Move the mouse pointer into the curve : - -

. window and click the left mouse button in .- Distance. ......... Badius..... »_| Add Point
the location of the desired new point. -2.5355e-+01 1.0142e+01
Clicking Delete Point will remove the B -1.267Te+01 1.0142e+01 Delete Point
currently selected point. 0.0000e-+00 2.0283e+01

- . . -- B 2 5355e-+01 1.0142e+01

. To manually edit a point: ..

. 1. Click the point (to select it) in the curve : : X ¥ z

:  window orclick the desired polint In Orig | 1.6570e+01 0.0000e-+00 9.9983¢-03

. either the Distance or Radius lists. ------:

. 2. The distance and radius of the selected Vect | 1 0000e+00 0.0000e+00 0.0000e-+00

. point are shown in the text fields below A

¢ eachlist. -------oooi :

. 3. Edit the point’s distance and/or radius

value and press return.
P Close

: To edit the position or orientation:

. 1. Enter the desired coordinates for the
Origin (location of the axis center point)
or Axis (direction vector) and press
return.

You can also translate the Revolution tool by setting the desired axis of translation in the Axis option menu and
manipulating the slider bar. In this case, the values in the “Scale Settings” section control the sensitivity and limit of

the slider action.

Note that you can also use this dialog to view (rather than set) the position of the Revolution tool since the numeric
values always update to reflect the current location. If you are positioning the Revolution tool interactively with the
mouse, the values will update when the mouse button is released.

B 2000 @® HowTo Index
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ADVANCED USAGE

After a model has been loaded, the initial location of the Revolution tool center is set to the “look-at” point — the
geometric center of all visible geometry and aligned with the X axis. The coordinates of the Revolution tool are
specified with respect to the default frame: frame 0. However, if you have created additional frames, you can position
the Revolution tool relative to the origin of a different frame. This is accomplished by selecting the desired frame in
the “Which Frame” list in the Transformations dialog.

You can easily reset the position and orientation of the Revolution tool to the default. See How To Reset Tools and
Viewports for more information.

Positioning a 3D tool with a 2D device (the mouse) can be difficult. Multiple viewports are sometimes helpful in
positioning tools since you can see the tool simultaneously from multiple vantage points.

SEE ALSO

Other tools: Cursor, Line, Plane, Box, Cylinder, Sphere, Cone. See the How To article on Frames for additional
information on how frames effect tools.
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INTRODUCTION

Much of the strength of EnSight derives from it's flexible and powerful part creation mechanism. Since virtually every
task you perform in EnSight will involve some form of part manipulation, it is vital to understand these concepts.

In EnSight, a part is a named collection of elements (or cells) and associated nodes. The nodes may have zero or
more variables (such as pressure or stress) currently defined at the node positions. All components of a part share
the same set of attributes (such as color or line width).

Parts are either built during the loading process (based on your computational mesh and associated surfaces) or
created during an EnSight session. Parts created during loading are called model parts. Model parts can also be
created during an EnSight session by performing a copy on other model parts.

All other parts are created during an EnSight session and are called created or derived parts. Created parts are built
using one or more other parts as the parent parts. The created parts are said to depend on the parent parts. If one or
more of the parent parts change, all parts depending on those parent parts are automatically recalculated and
redisplayed to reflect the change. As an example, consider the following case. A clipping plane is created through
some 3D computational domain and a contour is created on the clipping plane. The contour’s parent is the clipping
plane, and the clipping plane’s parent is the 3D domain. If the 3D domain is changed (e.g. the time step changes),
the clipping plane will first be recalculated, followed by the contour. In this way, part coherence is maintained.

This article is divided into the following sections:

The Parts List

Creating Parts

Part Types

Part Operations

Part Attributes

Where Parts Are Created and Maintained
Hints and Tips

The Parts List

Both model parts as well as all derived parts are displayed as items in the Parts List.

Parent part of currently Select Part(s) To Operate On

selected part ------------ »P | 1-{M/Cl} Computational m
2-(C/C1) Contourpart || .. partdescription
F—{I/C1} Isosurface part
Part numbers........ SRt »1-{TVC1) Particle trace part
[T+ 5-(2/C1) Clip_plane

6-{VIC1) Vector Arroew e Currently selected part
T-{D/C1} Developed surface
A A

Part type symbol S . Case number (important when multiple
datasets have been loaded)
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Iltems in the Parts List are selected using standard Motif methods:

To ... Do this ... Details ...

Select an item Select (or single-click)  Place the mouse pointer over the item and click the left mouse
button. The item is highlighted to reflect the “selected” state.

Extend a contiguous Select-drag Place the mouse pointer over the first item. Click and hold the left

selection mouse button as you drag over the remaining items to be
selected. Only contiguous items may be selected in this fashion.

Extend a (possibly long) Shift-click Select the first item. Place the mouse pointer over the last item in

contiguous selection the list to be selected. Press the shift key and click the left mouse

button. This action will extend a selection to include all those
items sequentially listed between the first selection and this one.

Extend a non-contiguous  Control-click Place the mouse pointer over the item. Press the control key and

selection click the left mouse button. This action will extend a selection by
adding the new item, but not those in-between any previously
selected items.

De-select an item Control-click Place the mouse pointer over the selected item. Press the control
key and click the left mouse button. This action will de-select the
item.

Open the Quick Double-click Place the mouse pointer over the item and click the left mouse

Interaction Area for a part button twice in rapid succession.

Creating Parts

The mechanism for creating derived parts is largely the same regardless of part type:

1. In the Parts List, select the part(s) to use as parents.

2. Click the desired feature icon. This will open the corresponding creation section for the part type in the Quick
Interaction area.

3. If necessary, select a variable to use from the Variables List (e.g. for contours or isosurfaces).

4. Set the desired creation attributes in the Quick Interaction area. IMPORTANT: if you change a text field, you must
press return to have the change take effect!

5. Click the Create button in the Quick Interaction area.

The example below shows Isosurface part creation:

2. Click the isosurface

T ----- 4. Select an appropriate isovalue.
creationicon. ..... - :

File Edit GQuery rew Tools Case Help |:

e |- G

Select Part{s) To Operate On Select a Variable Value | | nooge+o0
1-{M/C1) Computational mesh N_temperature
! Imberactive 3
Coordinates
: Hin Haw {norement
ir\eat\e Apply New Variable Help...
Shaded [|Hidden Line ' Cursori Line _|Plane Axiz _|Bounds Fast Display  Legend... Infa...
1. Select the parent part(s). .- i.--- 3. Select the variable to use.

. 5. Click “Create”.
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Part Types
The following table provides information on the available part types in EnSight:
Part Type Symbol | Feature Icon Description

Clip 2 A surface or line resulting from a clip of other parts using the Line,
Plane, Cylinder, Sphere, Cone, or Surface of Revolution tool.

Contour C Lines of constant value on 2D elements.

Developed D A planar surface derived by unrolling a surface of revolution (e.g.

Surface unrolling a clip created with the Cylinder tool).

Elevated Surface E A part created by scaling a 2D part (in the direction of the local
surface normal) based on the value of a variable.

Isosurface | A surface of constant value through 3D elements.

Model M An original part (i.e.loaded from a disk file) or created through some
operation (e.g. copy or extract) on a model part.

Particle Trace T A part consisting of the paths taken by one or more massless
particles as integrated through a vector (typically velocity) field.

Profile P Plot of a variable along a line (the 2D counterpart to an elevated
surface).

Vector Arrow \% A part consisting of a set of arrows showing direction and
magnitude of a vector variable.

Subset S A part created by node and/or element label range(s) from model
part(s).

Tensor Glyph G A part consisting of tensor glyphs showing direction and relative
magnitude of the eigenvectors of a tensor variable.

Material Part A A part created according to the intersection of or domains of
material values.
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Part Type Symbol | Feature Icon Description
Vortex Core X A part consisting of line segments down the center of flow vortices.
..-l-"'---'--'-'I
Shock Surface/ K A part consisting of the surface or volume elements where shock is
Region higher than a threshold.
Separation/ L A part consisting of line segments on a surface where flow
Attachment Line separation and attachment is occurring.

Part Operations

EnSight provides several powerful part operators. These operations are accessible from the Edit > Part submenu.

Copy

Group

Delete

Extract

Merge

The copy operation creates a dependent copy of another part. The part is created on the client and
is not known to the server. The new part has its own set of attributes (except for representation), but
shares geometric and variable data with the original.

One of the best reasons to create a copy is to show multiple variables on one part at the same time
in a side-by-side configuration. The copies can be moved independently since each new copy is

automatically assigned a new frame.

See How To Copy a Part for more information.

This operation will collapse the selected parts into a new “umbrella” part. Grouping is most often
used to combine a series of parts into a single part for ease in handling. The part is created on the
client and is not known to the server. The operation is reversible through the Ungroup command.

See How To Group Parts for more information.

The delete operation completely removes not only the currently selected parts, but also any parts
derived from the selected parts.

See How To Delete a Part for more information.

The extract operation is closely tied to part representations. Extract creates a new dependent part
using only the geometry of the current representation of the part. For example, if the current
representation of a part consisting of 3D elements is Border, the result of extraction will be a part
consisting of all unshared 2D elements (the surface).

Extract is most often used to reduce the amount of information for a part (e.g. for faster display or for
geometry output) or to create a surface shell part — perhaps for subsequent cutting — of a 3D
computational domain.

See How To Extract Part Representations for more information.

Merge creates one new dependent part from one or more selected parts. The original parts are
unchanged. If only a single part is selected for the operation, merge will create a “true” copy of the
part (as opposed to the “shallow” copy that the Copy operation creates).

Merging is most often used to combine a series of parts into a single part for ease in handling (such

as attribute setting).

See How To Merge Parts for more information.

Note: The cut operation of previous versions of EnSight is now accessed by selecting the Domain for the clipping
operation. See the various How To clipping sections for more information.
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Part Attributes

All parts have numerous attributes that control behavior and display. Although many attributes can be controlled
either through the Quick Interaction area or the Part Mode icons, complete access is provided by the various Feature
Detail Editor dialogs. Part attributes and the Feature Detail editors are covered in detail in How To Set Attributes.

Where Parts Are Created and Maintained

Part creation occurs on either the EnSight client or the server. Since the data that is available on the client and server
are different, it is useful to understand where parts are created and where the data is stored. For example, you can
only perform a query operation for parts that are stored on the server. The following table provides this information
for each part type:

Part Type Where Created Data on Server? Data on Client?

Clip server yes depending on representation
Contour client no yes

Developed Surface server yes depending on representation
Discrete Particle N/A yes depending on representation
Elevated Surface server yes depending on representation
Isosurface server yes depending on representation
Model N/A yes depending on representation
Particle Trace server no yes

Profile client no yes

Vector Arrow client no yes

Subset server yes depending on representation
Tensor Glyph client no yes

Vortex Core server yes depending on representation
Shock Surface/Region server yes depending on representation
Separation/Attachment Line server yes depending on representation
Material server yes depending on representation

In the last column, “depending on representation” means the current visual representation for the part. For
example, if the part’s visual representation is “Not Loaded”, then no data is currently present on the client.

Hints and Tips

With some datasets that contain many parts, it sometimes becomes difficult to maintain the connection between a
part as displayed in the Graphics Window and the corresponding item in the Parts List. To see which part(s) are
currently selected in the Parts List, select View > Show Selected Parts... This will open a new graphics window (titled
Part(s) Selected Viewport) that will display only those parts that are currently selected in the Parts List.

You can rapidly cycle through items in the Parts List using the up/down arrow keys on your keyboard. Select any item
in the list and then press the up arrow (to move to previous entries) or down arrow (to move to subsequent entries).
This is particularly helpful when used in conjunction with the Part(s) Selected Viewport window (as described above)
to quickly locate a part of interest.

You can select parts in the Parts List by picking the part in the Graphics Window. In Part Mode, select Pick Part from
the Pick pull-down. In the Graphics Window, place the mouse pointer over any portion of the desired part and press
the ‘p’ key. If you hold down the control key at the same time, the part is added to the list of currently selected parts.

Selected parts can be written to disk and loaded in a future session. Select File > Save > Geometric Entities ... You
have the option of saving either in EnSight format, VRML format, STL format, or other user-defined formats. See How
To Save Geometric Entities for more information.

SEE ALSO

User Manual: Features, Part Operations
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INTRODUCTION

A contour is a line of constant value on a two-dimensional (though not necessarily planar) surface. The region on one
side of the line is larger than the isovalue; the region on the other side is less than the isovalue. EnSight creates
contour lines in groups where the isovalues either correspond to the levels in the palette defined for the contour
variable, or a user specified range and distribution. The main level contour lines can also be labeled with the
corresponding palette value.

BAsSIC OPERATION

CREEEETTER T 2, Click the Contours icon.

File Edit ?uery View Tools Case Help |
- i
Selct Prt(s) Teo Operate On Select a Variahle ¢ To Palette Display Offset 00000100
1-{M/C1) Computational mesh temperature
Range Min Levelz Visibl
' Range Max [ g000e+00 Sublevels | o Visible
Distribution Linear Label Attributes...
Create “‘ Apply New Variable Help...
, Shaded _|Hidden Line . Cursar i,.ine Plane Axis _|Bounds Fast Display  Legend... Info...
.- 1. Select the parent part. : .--. 3. Select the variable to use.

SRR 4. Click Create.

The Contour Quick Interaction area lets you set the number of contour levels (and sublevels) as well as attach labels
to the contour lines. Contour lines can be synced to the palette levels or can be chosen manually.

If you want the levels of the variable palette to be used for contours:

In the parts list, double-click the contour part you wish to edit.

Select a Variahl
elecla vanane Syne To Palette

sure Visible toggles
are set as desired. ---

See How To Edit Color Maps for how to set the color
palette levels.

1. Select the Variable.-.‘ temperature 4
2. Toggle on Sync To Cnates Bange MR g aeate-t9 TS H Visible
Palefte. -------.......-q-ooooooooo oo | Rangs Mavw [ sesec e . Sublevelg | Visible
3. Select the nun_‘ber Prisbribntion Ladmmay Lahel Attributes...
of sublevels desired : ;

if any). And make .

( y) Create Apply New Variable : Help...

=r Contour Label Settings

Visible| Spacing | r11ge+00
s . Mix...|B G B
4. Set the Visibility, Spacing, Color, and = = - 1.'.30
Format Of the contour Iabels- ______________________________ - Format Exponenﬁal Dectmal Places 1

Note that only the main contour levels (not the

Closze
sublevels) are labeled.
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If you want contour levels to be independent of Variable palette levels:
In the parts list, double-click the contour part you wish to edit.

Select a Variahl
Blecta variane Synec To Paletts

1. Select the Variable.u\ temperature y|

2. Toggle off Sync To || coordinabes ;Range M:‘ 0.0000e-+00 ' Lmls> 5 Visible

Palette' ----------------------------------- : ) -_-_-_-.‘- -Ra'ffge Max 1 .(000e+00 E Sublevels 0 Visihle

3. Specify the Min L Distribution Linear . Label Attributes...

and Max Range. ----- B L = - : : i
Logarithmic C

4. Specify the number Create Apply Ne,‘ Quadratic : Help... |

of Levels and ; : 5

sublevels. . - oo V

5. Specify the Distribution method for the Range........... S -w Contour Label Settings (Ol[x]

6. Set the Visibility, Spacing, Color, and Format of the Spacing | | 5118e+00

contour labels. ......... ...l »

Mix...| B 100 G100 B|1.00

Format Exponential Decimal Places | 4

Cloze

ADVANCED USAGE

When Sync To Palette is specified, the levels of the variable palette are used as the contour levels. You must edit the
palette using the Feature Detail Editor for Variables to modify the number of levels, distribution, etc. See How To
Edit Color Maps for guidance.

OTHER NOTES

Unlike most part creation operators, contours are created from the client’s representation of the part — not the
server’s. If the parent part of the contour consists of one-dimensional elements or has no client-side visual
representation at all, the resulting contour will be empty. This would be the case if the parent part was currently
displayed as feature angle, border representation, or not loaded. The 3D border, 2D full representation is typically
used for contour part parents. See How to Change Visual Representation for more information.

SEE ALSO

Introduction to Part Creation, How To Edit Color Maps.

User Manual: Contour Create/Update
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INTRODUCTION

An isosurface is a surface of constant value in a three-dimensional field. It is the 3D counterpart to the contour loop:
the region on one side of the isosurface has values greater than the isovalue; the region on the other side has values
less than the isovalue. In EnSight, an isosurface can be generated from a scalar variable, a component or magnitude
of a vector variable, or a component of the model coordinates.

An isosurface of a scalar or vector variable is typically a complex surface reflecting the distribution of the underlying
variable. Isosurfaces of coordinates, however, are typically regular geometric shapes such as planes, cylinders,
cones or spheres.

BAsSIC OPERATION

2. Click the Isosurface
creation icon. -----

File Edit Query Vieil;f Tools Case Help |

= ki
E =
Select Part(s) To Operate On Select a Variable Value | | pogge+on
1-{M/C1) Computational mesh N_temperature
! {nberactive 3
Coordinates
: Hin Haw {neremend
Create Apply New Variable Help...
, Shaded _|Hidden Line . Cursor .‘.Line Plane Axiz _|Bounds Fast Display  Legend... Info...
....1. Select the parent part. : -. 3. Select the variable to use.

D 5. Click Create.

ADVANCED USAGE

Interactive Isosurfaces

You can have EnSight automatically generate and display isosurfaces as you adjust a slider with the mouse.

Select a Variahle Value | | 1o00e+00
velocity 1 Inferactive” Manual
Coordinates : <
__________________________________ Min | g oo00e+00 Max | 5 §192e+01 Increment | 2 109g¢.+00
Create Apply New Variable Help...

... 1. Set the Interactive mode to Manual. - 2. Adjust the slider to the desired location.

You can also set the Interactive mode to Auto and EnSight will automatically sweep from Range Min to Max with step
size equal to Increment.
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Isosurface Animation

A range of isosurfaces can be automatically generated and viewed in a flipbook. Flipbooks provide on-screen
animation of various dynamic events and (in the default setting) permit graphic manipulation (e.g. rotation or zoom)
while the animation runs.

1. Open the Feature Detail Editor for isosurfaces (Edit > Part Detail Editors > Isosurfaces ...).

File Edit

2. Select the isosurface part. - (I/C1) Isosurface part

ey,

~ ]

B

Desc I [sosurface part

Creation Attributes

YVariahle velocity = |

3. In the Creation Attributes section, set the Animation X | 0.0000 Y |0_0000 Z | 0.0000
Delta to an appropriate value and hit return. For each
page (frame) of the flipbook, this value will be added | |T¥pe Iscsurface |
to the current value to yield the new isovalue. Value IW

4. Click the FIIPDOOK ICOM. -« -« -n e e e e oo

File Edit Query View Tools Case

Select Part(s) To Operate On Load 'T‘ype Create Data | Load As Objects i |
P | 1-{M/C1} Computational mesh AN .

2—{I/C1} Isosurface part Number of Flipbook Pages to Create e,
Recard Interactive Isa/Clip < Start < Stop
Page o
fun Tvpe | Step | ﬂl & 00 I £ g 0 09 Brodify Bun.. I
7 Regen. Loacd I Fagord... I Prelote.. I Help... I
All Pages
5. Set the Load Type to ! : 6. Set the number of pages

Create Data. -----------: to an appropriate value.

D 7. Click Load.

8. When loading is complete, the flipbook will begin to be displayed. The Run Type controls whether
playback is automatic or controlled via the page step buttons.
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EnSight can also automatically calculate a range of isosurfaces during keyframe animation.

ADVANCED USAGE

Isovolume Creation

An isovolume is a volume whose constituents (e.g. nodes and elements) are constrained to a constant interval range
in a scalar field. In EnSight, you can constrain the isovolume to ranges less than an interval minimum, greater than an
interval maximum, or between the interval minimum and maximum.

1. Open the Feature Detail Editor for isosurfaces
(either: Edit > Part Detail Editors > Isosurfaces ...,
or double click the Isosurface Feature Icon).

2. Select the isosurface part. ---------------o-oooiaoooes E 2 1IE - (I/CD) Icosurface part K
7

|~ J.-
Desc Y

I Isosurface part

Creation Attributes

Variahle velocity = |

. . . X v Z
3. In the Creation Attributes section, set Type to | 0.0000 | 0.0000 | 0.0000
Isovolume. «----crrrorereress e I‘ype Isovolume i | Constraint Band _l|
Min | 1.0000e+00 Max | 2.0000e-+00

4. Set the Constraint to Band to constrain the
isovolume within an appropriate Min and Max :
range of the scalar variable. - ... .. ..

OTHER NOTES

Effective display of more than two nested isosurfaces is difficult. Set transparency on the outermost isosurface(s) to
reveal the inner surfaces. To avoid confusion, don't try to display isosurfaces of more than one variable
simultaneously, or multiple isosurfaces of the same variable colored by different variables.

SEE ALSO

How-To Create a Flipbook Animation, How-To Create a Keyframe Animation

User Manual: Isosurface Create/Update
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INTRODUCTION

A particle trace represents the path a massless particle would take if released in a flow field. From an initial seed point
(the emitter), a path is formed by integrating through the velocity field over time. The path is therefore everywhere
parallel to the flow. Traces calculated in a steady-state flow field are called streamlines. For transient flow, the path is
known as a pathline.

EnSight provides a great deal of control over emitter definition and trace appearance:

» Emitters can be defined using one of the built-in tools (Cursor, Line, or Plane) or by clicking on any
surface in the Graphics Window. The nodes of an arbitrary part can be used as an emitter, or the
emitter time and locations can be read from a file (see EnSight Particle Emitter File Format in the
Chapter 11 of the User Manual).

» The streamline path can be generated in the positive, negative, or positive and negative time directions.
* Traces can be restricted to lie on any surface to search for flow topology and separation features.

* For transient cases, an emitter can have a delta time that controls the periodic release of additional
particles into the dynamic flow.

» Emitters can be interactive: as you move the emitter with the mouse, the associated traces
automatically recalculate and redisplay.

* Trace paths can be displayed as lines, ribbons, or as square tubes, where ribbon or tube twist follows
the local flow rotation around the path.

« Particle traces can be easily animated to provide intuitive comprehension of the flow field. Complete
control over all aspects of the animating tracers is provided, including length, speed, and release
interval for multiple pulses.

BAsIiC OPERATION
To trace particles through a steady-state flow field:

2. Click the Particle Traces icon..- --

File Edit Query View zool}s, '(_l—ase Help |
- - i
O - B3 BN :
Select Part(s) To Operate On Belect a Variable Type Stream Show As... Animate Animate...
1-{M/C1}) external flow field w
ZACD ' i-x hypersenic bod . Emit | cyrear Emit... Pick Surface Interactive Emitter
. . From ‘

Surface Variabde [ iian,0n
Restrict ¢vfsot RS

Tool Location...

Create Help
- 1. Select the flow field ; “--- 3. Select the vector variable to
mesh part(s) to trace : use.
through. : .
4. Select the desired emitter. ----.........
5. If the emitter is a tool (Cursor, Line, Plane), position the
tool at the desired emitter location. You can also click
the Tool Location button to precisely position the tool.
6. Click Create.” The particie traces will be If the chosen emitter is Part, then enter the part number
created from the desired emitter. Their in the Part ID field and press return.

maximum time duration is controlled via
the Total Time Limit found under Emit...
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Create Particle Traces

The following are the available Emit From options. Note that traces will only be generated for those emitter points
that actually lie within an element of the selected flow field part(s).

Cursor

A single trace will be emitted from the Cursor tool.

Line

Multiple traces will be emitted from evenly spaced points along the Line tool.
Enter the desired number of traces in the # Points field and press return.

Plane

Multiple traces will be emitted from evenly spaced points in a grid pattern over the
Plane tool. Enter the desired number of traces in the X and Y direction (with
respect to the Plane tool’s axis) in the # Points X/Y fields and press return. The
total number of traces will be the product of X and .

Part

One trace will be emitted from the number of nodes of the part you specify. This
number of nodes will be randomly selected. Enter the number (from the Main
Parts list) of the part you wish to use as an emitter, and the number of nodes.

File

Traces will be emitted from the locations, and at the times, specified in an EnSight
Particle Emitter file. See EnSight Particle Emitter File Format in Chapter 11 of the
User Manual.

The complete set of particle trace attributes can be edited in the Feature Detail Editor for Traces. However, some
emitter attributes can be changed from the Particle Traces Quick Interaction area by clicking the Emit... button:

+: forwards in time (positive

velocity direction) from the N --. Set the total amount of time a trace

emission point(s)

: backwards in time (negative
velocity direction) from the
emission point(s) towards the
entering flow boundary ;3% _| Emit At Current Time

Total Time Limit 1.0000e+02

)

will last (it may terminate for other
reasons as well).

.- Solution time at which to begin
pathline trace (pathlines only).

+/-: both forwards and backwards

Toggle on to have start time be the
current time, otherwise specify the

start time.

Emission Time Start

Emizsion Time Delta

Clase I

Display Traces as Ribbons or Square Tubes

Particle paths can be displayed as lines, ribbons, or square tubes, where ribbon or tube twist follows the local flow
rotation. To enable ribbon or square tube display:

1. Double-click the desired particle trace part in the Main

- Delta emission time for pathlines. If
not zero, a new set of traces will be
emitted at S, S+D, S+2D, efc. into the
changing flow field (where S is the
Start time and D is the delta value).
Used to create streaklines or smoke
traces. Animated streaklines are one
of the most powerful methods for
visualizing transient flow.

0.0000e+00

0.0000e+00

Parts list (to open the Quick Interaction area for the trace

part).

2. Click Show As... to open the Trace Show As Attributes

dialog.

Show .
3. Set Show As to Ribbon or Square Tubes. As Ribbon O |
. . . Width _
4. If desired, change the default ribbon or square tube width I 1.5318e-01

and press return.

5. Click Close.

Animate Particles

Clase I

Any type of particle trace can be animated. See How To Animate Particle Traces for more information.
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Pick a Surface to Trace a Particle

Rather than emit from a tool or a part, you can also interactively pick points on a surface in the Graphics Window to
define emitter locations. To do this:

1. Execute steps 1-3 as described above.
2. Click the Pick Surface toggle.
3. Click Create.

4. Move the mouse into the Graphics Window and click the left mouse button when the cursor is over the
desired location. The clicked point must be found within some element of the selected flow field mesh
part to result in a trace.

5. You can click to create as many point emitters as you like. When done, move the mouse out of the
Graphics Window.

6. Toggle off the Pick Surface button.

Note that you can also specify a rake (line) or net (plane) emitter by picking on a surface. Just set the emitter to Line
or Plane prior to clicking Create. Then follow in the instructions in the pop-up window.

Interactive Particle Tracing

If a particle trace was created from one of the tool emitters (Cursor, Line, or Plane) and the trace is not a pathline
trace, the emitter can be made interactive. When interactive, the tool that created the particle trace part can be
moved with the mouse. As the tool is moved, new particle traces are automatically recalculated and redisplayed. To
trace interactively:

1. Either create a particle trace part as described above (based on a tool) or double-click an existing particle
trace part to open the Quick Interaction area for that part.

2. Toggle on Interactive Emitter. If the tool that originally defined the emitter is not visible, it will be turned on
by this operation.

3. Move the mouse into the Graphics Window and manipulate the tool as desired. See the article on the
applicable tool for information on tool manipulation (Cursor, Line, or Plane).

4. When done, toggle off Interactive Emitter.

‘ 2000 ® HowTo Index User Manual Page 3 of 6




How To ... Create Particle Traces
n 20000

Trace Surface-Restricted Particles

EnSight can trace particles such that they are constrained to lie on a (not necessarily planar) 2D surface — even if the
velocity is zero at the surface. The trace is calculated by projecting a short distance off the surface into the 3D flow
field and using the velocity value found there. Both the projection distance (variable offset) and a display offset are

user definable.

Surface-restricted trace emitters are defined by mouse action in the Graphics Window. When you click and drag over
the desired surface, the emitter is defined by projecting the mouse path onto the surface. To trace surface-restricted
particle traces:

1. Select Edit > Part Feature Detail Editors > Particle
Traces... to open the Feature Detail Editor
(Traces) dialog.

2. Select the desired surface part(s) in the Main
Parts list. This should be the surface you wish to

trace on. Variable'None

Creation Attributes

3. Set the desired vector variable to use for tracing.-: | * | 1.0000 = Y 10000 = Z1.0000

. . . Foger Slvessnbine

4. Select the desired emitter type (Cursor, Line, or - ¥ i
Plane). Note that the applicable tool will not o A Ldme 3;:;:{;;?:‘* 154 e

actually be used in this operation. ------------oooooo b

Emitter Information .

ired setti irecti Emittors it [Tine 1|
5. Set other desired settings (e.g. trace direction or Firom

time limit). # Points [g <@----------- 1

6. Toggle on the Surface Restricted button. Note Interactive  Add Emit| Delete Emit
that all subsequent tracing will be assumed to be Emitter

surface restricted until this is toggled off. | |Direction  + Total Time [ ] oooner 02
: Limit
7. If desired, adjust the Variable and Display 5 Emit At Current Time
Offsets. (You can also change the Display Offset : et e
for a previously created trace without having to | |y Start 0.0000e-+00 Deltq L2:2000<+00
recalculate it.) ----------o-iiaiiaiiiiii
o P Surface Restrict el Burface

8. If the Emit From is set to Line or Plane, enter the : »Variable §.5500-02 Display | o o000e+00
desired number of points (Line) or X and Y points Offset Offset
(Plane). [ Time Step Determination

9. Click the Create button at the bottom of the - Massed Particle
dialog (not shown here). :

10. Move the mouse pointer into the Graphics Window and:
for a Cursor emitter: click the left mouse button on the desired location.

for a Line emitter: click and hold the left mouse button on one endpoint of the desired line. Drag
to the other endpoint (a white line will provide feedback).

for a Plane emitter: click and hold the left mouse button on one corner of the desired region. Drag
to the opposite corner (a white rectangle will provide feedback).

11. You can continue to specify emitters of the selected type as long as the mouse pointer remains in
the Graphics Window. When the pointer exits the window, the trace part will be created.

12. When done, toggle off Surface Restricted.
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ADVANCED USAGE

Trace Pathlines

EnSight provides complete control over transient particle tracing. Both the start time and the stop time can be
specified. In addition, you can specify a delta value for an emitter that will cause additional particles to be emitted into
the flow at regular intervals. This type of pathline is also called a streakline or smoke trace.

You create a pathline trace by setting the Type to Path (rather than Stream) prior to clicking Create. By default, the
pathlines will start at the first time step of your simulation and terminate at the last step (unless stopped earlier). You

can change these defaults with the Emission Detail Attributes dialog as described above (click Emit... to open).

Edit Emitter Attributes

Although the Particle Trace Quick Interaction area provides most tracing controls, the Feature Detail Editor for Traces
provides complete control over all creation attributes. To use the editor:

1. Select Edit > Part Feature Detail Editors > Particle Traces... to open the Feature Detail Editor (Traces)

dialog.

2. Select the desired particle trace part in the part list at the top of the dialog.

Set the desired flow field
variable

Set the fraction of each
component of the vector
variable to use in the trace
calculation.

Trace type
Line or ribbon display

List of the emitters belonging
to the selected trace part

Set interactive emitter - - ---------
Set emitter direction, total time. . . ..

Set to emit at current time, or
set emission time.

Set emission delta

Toggle on Surface Restricted

Creation Attributes

X ¥ Z
1 1.0000 1.0000 1.0000
ng‘&‘h‘eamline
Show A Ribbon Ribbon | 01
........ - Width 1.5418e-01
Emitter Information
Emitters Emit | oyrsor -

From

ursor at 0.500000

-

Delete EmitT®---:

- Interactive Add Emit
Emitter

Total Time | { 4p00e+02
Limit

1 Emit At Current Time

Pl | g
Emission T4 0000e+00 Time | 4 o0008+00
Delta

Time Start
""" Surface Restrict  _| Pick Surface <@ -----------
“f;*};f";jif’v 508 52‘;;?;? £ 3000+ 54

tracing

-

Time Step Determination

Masszed Particle

Set ribbon width

Emission tool for currently
selected emitter

Add Emit: add a new emitter to
the selected part based on the
current attributes.

Delete Emit: delete the
selected emitter.

Toggle on surface picking for
emitter definition

26000
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Massed Particle Traces
Ensight also provides massed particle traces via the Feature Detail Editor for Traces.

1. Select Edit > Part Feature Detail Editors > Particle
Traces... to open the Feature Detail Editor
(Traces) dialog.

2. Select the desired the particle trace part in the
part list at the top of the dialog.

3. Click the Massed Particle turn-down to reveal the
massed particle parameters. --------------ooooooo--- > El Massed Particle

4. Modify the massed particle parameters according Massed Particles Y :

to your dataset. For instance, to compute only . | Force Terms Drag | Gravity._| Pressure

the drag force term in the momentum balance : | Particle Diameter [{ goo0e.02 |

equation, toggle off the Gravity force term. ......
: Particle Density || 0000e+03

5. Toggle on Massed Particles. --------------........ o .
Initial Velocity

The selected particle trace part will update to a massed Use Fluid
particle trace(s) taking into consideration the drag force X [ 000002100 ¥ | 0.0000e+00  Z | 00000400

term parameters only.
Gravity Vectar

X 0.0000e+00 ¥ |.9.8100e+00 Z | 0.0000e+00
Fluid Density

For the theory used in massed particle traces, see the
User Manual: Particle Trace Create/Update

None v Or | | 0000e+00

Fluid Dynamic Viscosity

None v| Or || 962005

Preammry Gradisnt

B weloeily ¥
Drag Coefficient Function
Default ¥

OTHER NOTES

Particle trace calculation can be expensive for large or transient datasets and/or a large number of particles. Be
careful when you initiate a trace operation — there is currently no way to abort it. If you are calculating pathlines, you
should specify as many particles as possible at one time. Much of the pathline execution time is in reading the
transient data from disk and this operation has to be performed regardless of how many traces were specified.

The EnSight particle trace algorithm integrates the vector flow field over time using a 4 order Runge-Kutta method
with a time varying integration step. Several of the integration parameters can be changed by the user. See Particle
Trace Create/Update in the User Manual for more information.

If you have trace data for other types of particles (e.g. for multi-phase flow simulations) you can use the discrete/
measured data facility to load the particle path positions and animate them over time.

SEE ALSO

How To Animate Particle Traces

User Manual: Particle Trace Create/Update
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How To ... Create Clips

INTRODUCTION

EnSight provides a powerful set of clipping operators. See the following How To articles for more information:

Create Line Clips Clip lines are linear clips through 2D or 3D models with samples taken at evenly spaced
intervals (using the Line Tool). Values along a clip line can be visualized using profiles or
queried and sent to a plotter.

Create Plane Clips A clipping plane is a planar slice through a 3D mesh using the Plane Tool. EnSight’s clipping
operation can take arbitrary cuts through either structured or unstructured meshes. The clip
can be infinite in extent (at least to the bounds of the parts it is created from) or restricted to
the bounds of the Plane tool. The nodes of the resulting clipping plane can be based on the
topology and resolution of the underlying mesh or sampled on a regular grid.

You can also create a clip that contains all the elements that intersect the plane value via the
crinkly domain specification. These clips help view the integrity of the mesh at these values.

Create Box Clips A Box clip is a 3D volumetric hexahedral-shaped clip or cut. This clip uses the box tool (which
can be manipulated anywhere in space), and the result can be the surface intersection of the
box tool walls and the model, the volume portion of the model inside the tool, the volume
portion of the model outside the tool, or the crinkly surface elements of the intersection. Be
aware that due to the algorithm used, this clip can (and most often does) have chamfered
edges, the size of which depends on the coarseness of the model elements.

Create Quadric Clips | In addition to standard clipping planes, EnSight also provides clipping against quadric shapes.
These clips use the corresponding quadric tool (Cylinder, Sphere, Cone, Surface of
Revolution) to specify the location of the clip.

You can also create a clip that contains all the elements that intersect the quadric value via the
crinkly domain specification. These clips help view the integrity of the mesh at these values.

Create IJK Clips An IJK clip is a 1D or 2D slice through a structured mesh. The resulting clip is a 1D line or 2D
surface where one dimension (e.g. 1) is held fixed while the other one or two dimensions (e.g.
J and K) vary. The minimum and maximum range of the free dimensions can be set by the
user, as well as the step size. IJK clips can be interactively animated throughout the range of
the fixed dimension by manipulating a slider.

Although planar clips can still be created through structured meshes, it is often preferable to
create IJK clips since they are faster to calculate and use less memory. In addition, IJK clips
are often more intuitive for the user (who typically built the mesh).

Create XYZ Clips An XYZ clip is a 1D or 2D slice through a 2D or 3D mesh (structured or unstructured). The
resulting clip is a 1D or 2D mesh slice where one of the dimensions (e.g. X) is held constant
(or fixed) while the other two dimensions (e.g. Y and Z) vary in reference to the local frame of
the mesh. XYZ clips can be interactively animated throughout the range of the fixed
dimension by manipulating a slider. The minimum, maximum, and step size of the range of the
fixed dimension can be set by the user.

Although plane clips can still be created through meshes, it is often preferable to create XYZ
clips since they are constrained to the local frame of the meshed part.

You can also create a clip that contains all the elements that intersect the mesh slice value via

the crinkly domain specification. These clips help view the integrity of the mesh at these
values.

Create RTZ Clips An RTZ clip is a 1D or 2D slice through 2D or 3D meshes (structured or unstructured). The
resulting clip is a 1D or 2D mesh slice where one of the dimensions (e.g. R, radial
component”) is held constant (or fixed) while the other one or two dimensions (e.g. T, "theta
component” and Z, “z axis component”) vary in reference to the local frame of the mesh. RTZ
clips can be interactively animated throughout the range of the fixed dimension by
manipulating a slider. The minimum, maximum, and step size of the range of the interactive
fixed dimension can be set by the user.

Revolution Tool Clips | A Revolution Tool clip can be made using the surface of revolution tool. It can be the surface
created by the intersection of the surface of revolution tool and the model, the elements
intersected by the surface of revolution tool (crinkly), or the volume of the inside and/or the
outside domain swept by the revolution tool. This clip does not have interactive manipulation
capability, with a slider or by dragging the tool with the mouse. However, the tool can be
manipulated and the clip updated.

Revolve 1D Part Clips | A Revolution of 1D Part clip can be made using a 1D part and a user specified axis. It can be
the surface created by the intersection of the 1D part about the axis and the model, the
elements intersected by the 1D part about the axis(crinkly), or the volume of the inside and/or
the outside domain swept by the 1D part about the axis. This clip does not have interactive
manipulation capability, with a slider or by dragging the tool with the mouse. However, if the
1D part is capable of being moved, you can move it and the revolution clip will update.

Create General A general quadric clip AX2+BY2+CZ2+DXY+EYZ+FXZ+GX+HY+IZ=J can be created. This is
Quadric Clips only available from the Clip Feature Detail Editor.
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INTRODUCTION

In addition to standard clipping planes, EnSight also provides one dimensional clipping. Clip lines are linear clips
through 2D or 3D models with samples taken at evenly spaced intervals. Values along a clip line can be visualized
using profiles or queried and sent to a plotter.

BAsSIC OPERATION

2. Click the Clip icon. .- - --.

File Edit Query View Tools QSe Help |

SCf - Bl B8 K5

Select Part{s) Ta Operate On Use Tool Line Domain Intersect Interactive
1-{M/C1) Computational mesh A Tool

# of Points oni Line [ o, g

Create | Apply Tool Change Tool Location... Help...

‘.. 1. Select the parent part. S 3. Select Line from the Use Tool pull-down.

4. Enter the desired number of :
samples on the line. ----- - -ooonmeiiiiiil

5. Position the Line tool as
desired (see How To Use the
Line Tool).

U 6. Click Create.

ADVANCED USAGE

Like the other clipping tools in EnSight, clip lines can be interactive: as you drag the Line tool with the mouse, the clip
line is automatically recalculated and redisplayed. If a query has been created from the clip line, the plotted curve will
automatically redisplay as well. To perform interactive line clips:

1. Double-click the desired clip line part
in the parts list.

Use Toal Line Domain  Intersect Interactive
Toal
2. Toggle on Interactive Tool in the # af Points on Line | o :
Quick Interaction area. ... ... ... . il
3. Move the mouse into the Graphics Create Apply Tool Change Tool Lacation... Help...

Window. Click on one of the Line
tool hotpoints (either endpoint or
center cross) and drag the tool to the
desired location.
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Create Line Clips

OTHER NOTES

It is sometimes useful to display just the nodes of a line clip. Using the Feature Detail Editor, you can change the
display such that only nodes (not lines or elements) are displayed. The nodes can be shown as dots, crosses, or
spheres. If displayed as crosses or spheres, the size (radius) can be constant or scaled by the value of a variable.

See How to Set Attributes for more information.

SEE ALSO

Introduction to Part Creation
How To Use the Line Tool
How to Create Profile Plots
How to Query/Plot.

Other clips:

How to Create Clip Planes
How to Create Quadric Clips
How to Create Box Clips
How to Create IJK Clips
How to Create XYZ Clips
How to Create RTZ Clips.

User Manual: Clip Create/Update
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INTRODUCTION

A clipping plane is a planar slice through a 3D mesh. EnSight’s clipping operation can take arbitrary cuts through
either structured or unstructured meshes. The clip can be infinite in extent (at least to the bounds of the parts it is
created from) or restricted to the bounds of the Plane tool. The nodes of the resulting clipping plane can be based on
the topology and resolution of the underlying mesh or sampled on a regular grid.

Besides creating the intersection of a plane through a domain, which is the normal mode for clipping, a clipping plane
can also be used to create parts which are what would result from a cut of its parent domain into “front” (inside) and or
“back” (outside) parts. These parts contain valid elements of the same order as the original domain parts.

Like other clip tools, clipping planes can be interactively manipulated with the mouse providing a powerful volume
visualization capability. Clipping planes can also be automatically animated to display results throughout a region of
space or over time.

BAsSIC OPERATION

2. Click the Clip icon.--------: RREEE

File Edit Query View Tools *se

= i
E =
Select Part(s) To Operate On Use Toal v Plane Domain Intersect Interactive
1-(M/C1) Computational mesh Towol
Plane Type Mesh Plane Extents Infinite
Grid Pre o B | g ¥l
Create Apply Tool Change Tool Location... Help...
~... 1. Select the parent part. : 4. Position the Plane tool as desired (see

How To Use the Plane Tool).

S 5. Click Create.

ADVANCED USAGE

Interactive Clipping Planes

Like the other clipping tools in EnSight, intersection clip planes can be interactive: as you drag the Plane tool with the
mouse, the clipping plane is automatically recalculated and redisplayed. To perform interactive plane clips:

1. D?Uble-CIICk th_e desired Uszse Toal Plane Domain Intersect Interactive
clip plane part in the parts ' Taol

list.
Plane Type Mesh Plane Extents Infinite

Cipial Fiw o B & Y| a

2. Toggle on Interactive Tool
in the Quick Interaction :
=T T R R PP PP

Create Apply Tool Change Tool Location... Help...

3. Move the mouse into the Graphics Window. Click on one of the Plane tool
hotpoints (centerpoint or axis labels) and drag the tool to the desired location.
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Grid Clips and Finite Clips

By default, clipping planes are calculated based on the resolution and topology of the underlying mesh (parent
part(s)). Clipping planes can also be calculated using a regular sampling of the mesh. Such a clip is called a grid clip
and is typically used for clipping unstructured meshes where element volumes vary widely. Creating vector arrows
on a grid clip typically yields a more useful visualization than on a standard mesh clip.

By default, clipping planes extend to the bounds of the parent part. A clipping plane can also be restricted to the
bounds of the Plane tool.

To change an existing clipping plane to a grid clip or to have finite extent:

1. Double-click the desired clipping plane part in the parts list.

Usze Toaol Plane Demain Intersect Interactive
Toal

Plane Type Mesh Plane Extents Finite
2. To change to a grid clip, Gixdk Pis o Grid [ 1Y [ ¥
select Grid from the Plane R é - :
Type pull-down. ..............L.........

Create Apply Tool Change : | Taol Lacation... Help...
3. To change to a finite-extent :

Clipping Plane Animation

Although you can interactively sweep a clipping plane through a volume, it is sometimes desirable to have EnSight
automatically calculate a series of clipping planes for you. These can then be replayed (as fast as your graphics
hardware will permit) using EnSight’s Flipbook Animation facility. The flipbook can animate a series of clipping planes
using a starting and ending position for the Plane tool. You can also use the Keyframe Animation facility to animate
clipping planes.

For a description of calculating a series of clipping planes with the Flipbook, see How To Create a Flipbook

Animation. For more information on keyframing, see How to Create a Keyframe Animation.

Cutting with Planes

A plane can be used to create parts which are the result of a cut of its parent domain into “front” (inside) and or “back”
(outside) parts. These parts contain valid elements of the same order as the original domain parts. Cutting can be
used to slice away portions of a model that are not needed or to create animation effects such as “opening” closed
regions to view the interior.

1. Select the desired parent parts in the parts list.

2. Click the Clip feature icon.

Use T::n::l4 Plane Domain Intersect Interactive
K = Taol
3. Select the Plane Tool. -------------- g Crinkly
Plane Type Mesh Plane Extents In 1;,.ide
4. Set the Domain to Inside, Gadd Fleom & |50 ¥ | g 4 Qutside
Outside, or In/Out (both ) ;1.!0ut
inside and outside). ... ... ‘ =
5. Hit the Create button. ..., P Create Apply Tool Change Toal Lecation... Help...
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Crinkly Plane Clips

You can also check the integrity of your mesh by clipping with a crinkly intersection. Specifying a Crinkly Domain
results in a part composed of all the mesh elements that intersect the plane tool..

Use Toaol Plane Domain Intersect Interactive
= Teool
Crinkly
Plane Type Mesh Plane Extents Il‘.‘[nside
Crih Por o % 4 ¥l Outside
1. Change the Domain to ./ InfOut
o1 41,1 (|T AN |- ccoosaaneoo0aac0000a00000aa000003a0a0508 ‘
Create Apply Tool Change Tool Location... Help...
»

OTHER NOTES

Use clipping planes to create planar clips through arbitrary meshes. If you have a structured mesh (such as those in
PLOT3D format), you may wish to use IJK clips instead. An IJK clip displays a “plane” of constant |, J, or K. An
interactive IJK clip will sweep through the range of (for example) | displaying the JK plane at each | value. See How
to Create IJK Clips for more information.

SEE ALSO

Introduction to Part Creation
How To Use the Plane Tool
How To Create a Flipbook Animation.

Other clips:

How To Create Clip Lines
How To Create IJK Clips
How To Create Quadric Clips
How To Create XYZ Clips
How To Create RTZ Clips
How To Create Box Clips.

User Manual: Clip Create/Update
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INTRODUCTION

A Box clip is a 3D volumetric hexahedral-shaped clip or cut. This clip uses the box tool (which can be manipulated
anywhere in space), and the result can be the surface intersection of the box tool walls and the model, the volume
portion of the model inside the tool, the volume portion of the model outside the tool, or the crinkly surface elements
of the intersection.

Be aware that due to the algorithm used, this clip can (and most often does) have
chamfered edges, the size of which depends on the coarseness of the model
elements.

BASIC OPERATION

1. Select the parent part . --2. Click the Clip Icon 3. Select Box Tool ---.

File Edit Query View Tools . ga'se
; — =
Select Part(s) To Operate On . Use Tool
1-(M/C1) Computational mesh
Create Apply Tool Change ool Locabion.., Help...
4. Position the Box Tool as desired. ... 5. Click Create

SEE ALSO

Introduction to Part Creation
How To Use Box Tool

Other clips:

How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create IJK Clips
How to Create XYZ Clips
How to Create RTZ Clips.

User Manual: Clip Create/Update
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How To ... Create Quadric Clips

h 20000

INTRODUCTION

In addition to standard clipping planes, EnSight also provides clipping against quadric shapes. These clips use the
corresponding quadric tool Cylinder, Sphere, Cone, Surface of Revolution) to specify the location of the clip.

As with clip planes, these tools can also be used to perform cut operations, creating parts which are the “inside” or
“outside” of the parent domain.

As with intersection clip planes, quadric clips can be changed interactively by manipulating the corresponding tool
with the mouse.

BAsIC OPERATION
2. Click the Clip icon. ------.

File Edit e View Tools Case
File E Query Vi I K
f xvz

oD ] - =

Select Part{s) Ta Operate On Use Tool Line Domain  Intersect Interactive
1-(M/C1} Computational mesh Tool

Plane
# of Poi Box
Cylinder

Sphere
Co_neA

Revolution Tool
Crea: — '

' Mool Change Tool Location... Help...
A Revolwve 1D Part

. 1. Select the parent part. R REELEETTREY 3. Select the desired quadric tool from the
. Use Tool pulldown.

4. Position the tool as desired (see the How
to for the applicable tool).

U 5. Click Create.

ADVANCED USAGE

Like the other clipping tools in EnSight, intersection quadric clips (except those created with the revolution tool) can
be interactive: as you drag the applicable tool with the mouse, the clip is automatically recalculated and redisplayed.
To perform interactive quadric clips:

1. Double-click the desired quadric Use Tool lind D Y Pre—— Interactive
clip part in the parts list. se Toe Cylinder omaln [ HTereet Tool

2. Toggle on Interactive Tool in the .
Quick Interaction area. ---------csoiiii i

3. Move the mouse into the Graphics
Window. Click on one of the tool
hotpoints (see the How to for the
applicable tool) and drag the tool
to the desired location.

Create Apply Tool Change Teool Location... Help...
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Create Quadric Clips

Cutting with Quadric Tools

A quadric tool can be used to create parts which are the result of a cut of its parent domain into “inside” and or
“outside” parts. These parts contain valid elements of the same order as the original domain parts.

1. Select the desired parent
parts in the parts list.

2. Click the Clip feature icon. | Use Tool

3. Select the desired Quadric
Tool. -~ ]

4. Set the Domain to Inside,
Outside, or In/Out (both
inside and outside).

5. Hit the Create button.

Crinkly Quadric Clips

LIK
XYZ
RTZ :
. Domain  Intersect Interactive
Eins = Taal
Plane Crinkly
Box Inside
Cylinder SIS
In{Out
Sphere u
(9IS c0000000000d boooaoaoaoooooaad

Bevolution Tool | Change
Revalve 1D Part

Tool Location... Help...

You can check the integrity of your mesh by clipping with a crinkly intersection. Specifying a Crinkly Domain results in
a part composed of all the elements of the mesh that intersect the quadric tool..

Usze Tool

4. Change the Domain to
Crinkly.

5. Click the Apply Tool
Change button.

SEE ALSO

Introduction to Part Creation

Cylinder

Domain  Intersect

Interactive
Toal

(grinkly

Apply Tool Change

How To Use the {Cylinder, Sphere, Cone, Surface of Revolution} Tool.

Other clips:

How to Create Clip Planes
How to Create Clip Lines
How to Create IJK Clips
How to Create XYZ Clips
How to Create RTZ Clips
How to Create Box Clips.

User Manual: Clip Create/Update
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INTRODUCTION

An IJK clip is a 1D or 2D slice through a structured mesh. The resulting clip is a 1D line or 2D surface where one
dimension (e.g. 1) is held fixed while the other one or two dimensions (e.g. J and K) vary. The minimum and
maximum range of the free dimensions can be set by the user, as well as the step size. IJK clips can be animated
throughout the range of the fixed dimension by manipulating a slider.

Although planar clips can still be created through structured meshes, it is often preferable to create 1JK clips since
they are faster to calculate and use less memory. In addition, IJK clips are often more intuitive for the user (who
typically built the mesh).

BAsSIC OPERATION

File Edit Query View Tools Case

(2= B

Select Part(s} To Operate On
1-(M/C1) zane 1 (IN), Mins/Max

. | Use Toal

Hin 3 Imoremant 3
Mesh Slice I Value 1 Limit J K Extents...
Create ~ Ap]ély 'Tt:ml O:hange ‘ Fool Locabion.., Help...

1. Select the parent part.--- o
: i**. ' 6. If you desire to modify values for the Min,
: Max, and Step for the two free

3. Select IJK from the Use Tool pulldown.......... | & : dimensions, click this and the dialog
Lo below will openup. ...

2. Click the Clip icon. .- ----.'

4. Select the desired fixed dimension from the . 7. Click Create.

Mesh Slice pulldown. — ----------emommmeoannns!

5. Enter the value for the fixed dimension in :
the Value text field and press return. ---------------.:

=™ Limit Extents of Current Slice By IE

J Min Max 5
% tep 1 Show Parent

K Min 1 Max ag  Step 1 IJK Extents...

Close

Note that you can change the fixed dimension of an IJK clip at any time (with the Mesh Slice pulldown). If you change
one of the numeric values, remember to press return for the change to take effect.

‘ 2000 ® HowTo Index User Manual Page 1 of 3




How To ...
B 20000

Create JK Clips

ADVANCED USAGE

Interactive IJK Clipping

You can interactively sweep through the range of the fixed dimension by adjusting a slider with the mouse.

1. Double-click the desired IJK clip part
in the parts list.

2. Change Interactive to Manual, to
enable sweeping.

3. Adjust the slider with the mouse. ------

Changing IJK Step Refinement

Use Taaol LK C Domain Intersect | Interactive Manual A

- 1 >

Increment 1

Limit J,K Extents...

Apply Tool Change Fanipd Lasiambieeii.., Help...

You can modify block-structured model parts to any level of IJK step refinement with proper updating of all dependent

parts and variables.

1. Select Edit > Part Feature Detail
Editors > Model Parts ... to open the
Feature Detail Editor (Model) dialog.

2. Select the structured part (or parts). - - -

3. In the Creation Attributes area, enter
values into the From, To, and Step
fields based on their Min and Max
limits to update the refinement of the
respective |, J, and/or K mesh
component directions (remember to
press Return).

Clipping Plane Animation

el From T Step Min Max
| I T T
J | 1 | 76 | 1| 1 | 76
K | 1 | a8 | 1| 1 | 38

File Edit View
EE
22 —
] I =
| &
T
=] | -~
Y

Dese | zone | {IN}, Mins/Maxs=(1:1/38,J:1/76,

Creation Attributes
Usging Node Ranges:

Although you can interactively sweep an IJK clip through a mesh, it is sometimes desirable to have EnSight
automatically calculate a series of IJK clips for you. These can then be replayed (as fast as your graphics hardware
will permit) using EnSight’s Flipbook Animation facility. See How To Create a Flipbook Animation for more

information.

B 2000@® HowTo index

User Manual Page 2 of 3




How To ... Create IJK Clips
B 20000

SEE ALSO

Introduction to Part Creation
How To Create a Flipbook Animation.

Other clips:

How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create XYZ Clips
How to Create RTZ Clips
How to Create Box Clips.

User Manual: Clip Create/Update
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INTRODUCTION

An XYZ clip is a 1D or 2D slice through 2D or 3D meshes (structured or unstructured). The resulting clip is a 1D or
2D mesh slice where one of the dimensions (e.g. X) is held constant (or fixed) while the other one or two dimensions
(e.g. Y and Z) vary in reference to the local frame of the mesh. XYZ clips can be interactively animated throughout
the range of the fixed dimension by manipulating a slider. The minimum, maximum, and step size of the range of the
interactive fixed dimension can be set by the user.

BAsSIC OPERATION

File Edit Query View Tools Case

eCf -

Select Part{s} Ta Operate On . | Use Toal XYZ
1-(M/C1) Computational mesh . A

Bin | g s600e 09 Mav | g stte 09 Foorement | 4 sei6e.60]

Mesh Slice | %“& | Value! [ 0000e+00

A

Cr\eal‘e‘ Apply Tool Change Franind Lavabion... Help...

1. Select the parent part.

2. Click the Clip icon..------- T 6. Click Create.

3. Select XYZ from the Use Tool pulldown...... i

4. Select the desired fixed dimension from the
Mesh Slice pulldown. -« ccoivmiiill

5. Enter the value for the fixed dimension in :
the Value text field and press return. .--...............

Note that you can change the fixed dimension of an XYZ clip at any time (with the Mesh Slice pulldown). If you
change the numeric value, remember to press return for the change to take effect.
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ADVANCED USAGE

Interactive XYZ Clipping

You can interactively sweep through the range of the fixed dimension by adjusting a slider with the mouse.

1. Double-click the desired XYZ clip

part in the main parts IISt I Use Tool XYZ Domain Intersect Interactive AManual
2. Change Intera.cuve to Manual to o | Min |2 0000e+00 Max | 3 000e+00 A morement 2.5000e-01
enable sweeping. ............ ... ...l R 4 :

Mesh Slice X 1] Valtie [100000+00

3. If desired, enter values for the Min, T :
Maxs and Increment to override the L : A5 “Create Apply Tool Change P Lasation... Help...
defaults (remember to press return).:**~ g

4. Adjust the slider with the mouse.

Crinkly XYZ Clipping

You can check the integrity of your mesh by clipping with a crinkly intersection. Specifying a crinkly domain results in
a part composed of all the elements that intersect the mesh slice value.

. . Use Tool XYZ Domain  Intersect Interactive Manual
1. Change the Domain to Crinkly --------.. 1.0 o
T P Crinkly
Min |3 0000e+00 Max [g googe -7 Increment [ 5 5000¢.01
{hrtnldde
Mesh Slice | X 1 |Valus g ogoge-0p 10/t
Create Apply Tool Change Fool Localoen.. Help...

Clipping Plane Animation

Although you can interactively sweep an XYZ clip through a mesh, it is sometimes desirable to have EnSight
automatically calculate a series of XYZ clips for you. These can then be replayed (as fast as your graphics hardware
will permit) using EnSight’s Flipbook Animation facility. See How To Create a Flipbook Animation for more
information.

SEE ALSO

Introduction to Part Creation
How To Create a Flipbook Animation

Other clips:

How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create IJK Clips
How to Create RTZ Clips
How to Create Box Clips.

User Manual: Clip Create/Update
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INTRODUCTION

An RTZ clip is a 1D or 2D slice through 2D or 3D meshes (structured or unstructured). The resulting clip is a 1D or
2D mesh slice where one of the dimensions (e.g. R,”radial component”) is held constant (or fixed) while the other one
or two dimensions (e.g. T, "theta component” and Z, “z axis component”) vary in reference to the local frame of the
mesh. RTZ clips can be interactively animated throughout the range of the fixed dimension by manipulating a slider.
The minimum, maximum, and step size of the range of the interactive fixed dimension can be set by the user.

BAsSIC OPERATION

File Edit Query View Tools Case

oD | -

Select Part{s} Ta Operate On %

. | Use Tonol RTZ
1-(M/C1) Computational mesh [ A

Bin |6 sootests Mav | g stite 09 Fooroiant | ¢ saote.0

Slice R 1 (&alue [1.0000¢+00

Axis Y ) le-r-n--o-e
Cr\eat\e‘ | J P:;pplyi'f‘ool ?Ihange ool Locabion.., Help...
1. Select the parent part. .
2. Click the Clip icon..-------: A e 7. Click Create.
3. Select RTZ from the Use Tool pulldown. .. .. '
4. Select the Axis that describes the '

cylindrical length.

5. Select the desired fixed dimension of the
slice(R,T,orZ). --- - vovvveiiii

6. Enter the value for the slice (the value of :
R, T,orZ),and pressreturn. ...........................

Note that you can change the fixed dimension of an RTZ clip at any time (with the Slice pulldown). If you change the
numeric value, remember to press return for the change to take effect.

ADVANCED USAGE

Interactive RTZ Clipping

You can interactively sweep through the range of the fixed dimension by adjusting a slider with the mouse.

1. Double-click the desired RTZ clip

part in the main parts IISt Use Taoal RTZ Domain Intersect Interactive Manual
2. Change Interactive to Manual p

Change Inte a.Ct e to Manual to © | MR [ 0000e+00 Max | 2 0000e+00 A Inerement [} a000e.01

enable sweeping. ...................ol0 4 :

Slice 'R 1 | Value [1400oe+00
3. If desired, enter values for the Min, Hxis x

Max, and Increment to override the . - -él:eate Apply Tool Change ’Ef\w}. famaton...

L Help...
defaults (remember to press return)..-*~

4. Adjust the slider with the MOUSE. «---- -« << - <ooeomoo
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Crinkly RTZ Clipping

You can check the integrity of your mesh by clipping with a crinkly intersection. Specifying a crinkly domain results in
a part composed of all the elements that intersect the mesh slice value. Crinkly clipping cannot be done interactively.

: . Intersect
1. Change the Domain to Cl'lnkly el Use Tool RTZ Domain  Crinkly Interactive Off
Clrrdvicde

Bim | g goon

3 [ CR
wiut
Slice R 1 |Value |1 gpgoe+00
Axis X
Create Apply Tool Change Faal Lavaiion... Help...

Clipping Plane Animation

Although you can interactively sweep an RTZ clip through a mesh, it is sometimes desirable to have EnSight
automatically calculate a series of RTZ clips for you. These can then be replayed (as fast as your graphics hardware
will permit) using EnSight’s Flipbook Animation facility. See How To Create a Flipbook Animation for more
information.

OTHER NOTES

Inside, Outside, and In/Out cutting are disabled for this clipping type because it has no meaning for T. And if you
desire this effect for Z or R, you can use a plane clip or cylindrical clip instead.

SEE ALSO

Introduction to Part Creation
How To Create a Flipbook Animation

Other clips:

How to Create Clip Lines
How to Create Clip Planes
How to Create Quadric Clips
How to Create IJK Clips
How to Create XYZ Clips
How to Create Box Clips.

User Manual: Clip Create/Update
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INTRODUCTION

A Revolution Tool clip can be made using the surface of revolution tool. It can be the surface created by the
intersection of the surface of revolution tool and the model, the elements intersected by the surface of revolution tool
(crinkly), or the volume of the inside and/or the outside domain swept by the revolution tool. This clip does not have
interactive manipulation capability, with a slider or by dragging the tool with the mouse. However, the tool can be
manipulated and the clip updated.

BAsSIC OPERATION

M- Ensight (=[]
File Edit Query View Toolz Case Help |
5 3 “ = = .
(JE B Z $ 23 EN = [
Select Part(s) To Operate On .| Use Tool Revolution Toal Domain Intersect
1-(M/C1) Cogputaﬁonal mesh Crinkly
a0 Inside
Outside
Ini{Out
0 L I I
Create - Apply Teol Change Tool Location... Help...

1. Place the Surface of Revolution Tool at the . | : 6 Click Create.

desired location. See How To Use the
Surface of Revolution Tool.

: -2. Select the parent part. ; Note that you can manipulate the Surfacé
3. Click the Clip iCON. -« reneeeneeeeeee it of Revolution tool and update your clip by:

and clicking Apply Tool Change.----------:
4. Select Revolution Tool from the Use Tool Co
pulldown. -----oeoeiii D You can also change the domain, and the

5. Select the desired Domain. ---------<coccooeoeenooo ! clip will change.

ADVANCED USAGE

SEE ALSO

Introduction to Part Creation

Other clips:

How to Create Clip Lines

How to Create Clip Planes

How to Create Quadric Clips

How to Create XYZ Clips

How to Create RTZ Clips

How to Create Box Clips

How to Create IJK Clips

How to Create Revolution of 1D Part Clips.

User Manual: Clip Create/Update
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h 26000 1D Part Clips

INTRODUCTION

A Revolution of 1D Part clip can be made using a 1D part and a user specified axis. It can be the surface created by
the intersection of the 1D part about the axis and the model, the elements intersected by the 1D part about the
axis(crinkly), or the volume of the inside and/or the outside domain swept by the 1D part about the axis. This clip
does not have interactive manipulation capability, with a slider or by dragging the tool with the mouse. However, if the
1D part is capable of being moved, you can move it and the revolution clip will update.

BAsSIC OPERATION

NI Ensight =)

File Edit Query View Tools Case
i
T
Select Part(s} To Operate On | Use Tool Revolve 1D Part Domain Intersect
1-{M/C1) Computational mesh :
: : Revolve Part Crinkly
A 2-2c1) Clip _line relve e 2 ... .’( -
. X ¥ C g Inside
Ori — . q
18 [ 0.0000¢+00 0.0000c100 || g 2utside
Axis o A : Ini{Out
1.0000e+00 0.0000e+00 & . | bovrosTor
Create Apply Todl Cha'nge Fool Locabion.., Help...
~.. —

1. Select the parent part. 6. Click Create.

2. Click the Clip Icon. -+

3. Select Revolve 1D Part from the Use Tool

DUIOWR, -~ eemeemem e Note that you can manipulate the 1D part

: L or the origin and axis and the clip will
4. Enterthe 1D parttouse. ------ - -ocoiiiiot s update.
5. Set the desired origin and axis of the '

. D You can also change the domain, and the
revolution. ... ... . ...l :

: clip will change.
6. Select the desired Domain. ................... ... ...

ADVANCED USAGE

SEE ALSO

Introduction to Part Creation

Other clips:

How to Create Clip Lines

How to Create Clip Planes

How to Create Quadric Clips

How to Create XYZ Clips

How to Create RTZ Clips

How to Create Box Clips

How to Create IJK Clips

How to Create Revolution Tool Clips.

User Manual: Clip Create/Update
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B 20000 Quadric Clips

INTRODUCTION

Double Clicking on the Clip Create/Update Icon brings up the Feature Detail Editor (Clips), the Creation attributes
section of which offers access to one type of clip creation which is not available in the Quick Interaction area. It is
possible to create a 3D Quadric clip using the General Quadric option by directly specifying the coefficients of a
general quadric equation.

These coefficient values represent the general equation of a Quadric surface. They can be changed by modifying the:
coefficient values. No tool exists corresponding to this equation. :

AX2+BY2+CZ2+DXY+EYZ+FXZ+GX+HY+Z=J

BASIC OPERATION

=+ Feature Detall Editor (Clips) [I

1. Get to the Feature Detail Editor for clips. File Edit View He

The easiest way to do this is to double click

the Clip Feature Icon. @ —
2. Select the parent part(s) in the Parts list. =

3 - {2/C1} Clip_plane
- {2/C1) Clip_guadric

Dese| clip_quadric

Creation Attributes
3. Choose the General Quadric Tool.

.............. [— »
4. Choose the desired Domain (Intersect, Tool | General Quadric

Crinkly, Inside, Outside, or In/Out) --------.... _| | Demain Intersect
Clip Parameters

5. Edit the coefficients. ...................... . A2 o+ VA2 4 FAZ 4
.| | 1.0000e+00 1.00008+00 1.00008+00

3. Click the Create button. ~ XY + YZ + XKZ +
1.00002+00 2.0000e+00 0.0000e+00

X + ¥ o+ Z

0.00008+00 0.0000+00 0.0000+00
= | 1.0000e+01

Note: The Animation Delta is not available for

. ) Animation Delt:
general quadric clips. e

% ¥ &
{ eHntbing o 4} eI e R e {430 i}
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Quadric Clips

SEE ALSO

Introduction to Part Creation

Other clips:

How to Create Clip Lines

How to Create Clip Planes

How to Create Quadric Clips

How to Create XYZ Clips

How to Create RTZ Clips

How to Create Box Clips

How to Create IJK Clips

How to Create Revolution Tool Clips.

User Manual: Clip Create/Update
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INTRODUCTION

Vector arrows display the direction and magnitude of a vector at discrete locations in a model. Although vector
magnitude can be visualized with other methods (e.g. color), important directional information is provided by the
arrows.

Vector arrows have numerous attributes including length scale, tip style and size, projection, origin location, and
display filters based on vector magnitude.

BASIC OPERATION

REEETE 2. Click the Vector Arrows icon.

File Edit Query View Tools Case v Help || |

oD || - Bl B8 S

Select Part(s) To Operate On Select a Variahle Scale Factor | j noone+00 Cet Default Arrow Tips...
1-(M/C1) Computational mesh A
SurfaceMormal Type Rectilinear 3 Location Vertices
h . Density [ | g :---------------------------------:
Filter None Low | 0 0000e+00 High | 0000e+00
Create Apply New Variable Help...
-..-1. Select the parent. : - 3. Select the vector variable to use.

part. ' :

4. Click Get Default to load a suitable Scale Factor..----:

SRR 5. Click “Create”.
Arrow Tips

To change the arrow tip shape, click the Arrow Tips button to open the Vector Arrow Tip Settings dialog:

Tip Shape Choices:

None No tip (default).

Normal Single wedge. Good for 2D
problems. Plane of the
wedge is based on the
relative magnitudes of the
components.

Triangles  Two intersecting triangles.
Good for 2D/3D problems.

Vv

----1. Select the desired tip shape from the
Shape pulldown (see description at right).
Co Tipped End of the shaft colored in a
2. Select a color (for Tipped shape only).  -------- : different color. Good where
: other shapes yield too much
visual clutter.

\

3. From the Size pulldown, select whether tip
scaling is Fixed (and enter an appropriate
value in the text field) or Proportional to the
local vector magnitude. ----------oooaiaioia
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Other Vector Arrow Attributes

Other vector arrow attributes control the type of arrow, the location of the arrow origin, and arrow filtering options

based on vector magnitude:

1. Double-click the desired vector arrow part in the parts list.

Choices are:

Rectilinear

Rect. Fixed

Curved

Select a Variahle

2. Select the desired type from the Type pulldown.

Standard vector arrows: shaft points in local vector direction with
length equal to vector magnitude scaled by Scale Factor Value.

Same as Rectilinear except that length is set by Scale Factor value
independent of vector magnitude.

Arrow shaft is the path of a particle trace in the local flow field. Scale
Factor becomes “Time” and controls the duration (stopping criteria)
for each trace. WARNING! This can take a great deal of time for
large numbers of vector arrows and/or long Time values!

Scale Factor | 1 anooe+00 Get Default|  Arrow Tips...
""" -
SurfaceNormal Type Rectilinear Location Vertices R BEEEEEEEEED
Density | { o) ------
_____________________________________ Filteg, None Low [ g opoveron | High |1 poooeroo
Create Apply New Variable Help...

--- 3. Select the desired filter type from the Filter

5. Select the desired arrow origin from the

pulldown. Location pulldown. -------------o-oooaiaoon
Choices are: Choices are:
None No filtering — all vector arrows appear. Node Arrows originate from each node of the parent
art(s).
Low Display only those arrows with magnitude part(s)
above the value in the Low text field. Vertices Arrows originate only from those nodes that
) ) ) are also vertices of the parent part(s).
Band Display only those arrows with magnitude
below Low and above High (opposite of Low/ Element Center Arrows originate from the geometric center
High). of all elements of the parent part(s).
High Display only those arrows with magnitude
below the value in the High text field.
Low/High Display only those arrows with magnitude

between Low and High (opposite of Band).

4. Select the desired density (0.0t0 1.0). ...........:
A density of the arrows will vary from no arrows (0.0) to
arrows at every location (1.0). At intermediate densities
the arrows are placed randomly.
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ADVANCED USAGE

Although not accessible from the Vector Arrows Quick Interaction area, you can also change the projection of vector
arrows and the display offset.

1. Open the Feature Detail Editor for Vector
Arrows (Edit > Part Detail Editors... > Vector -~ Feature Detail Editor {Vector Arrows)

Arrows). File Edit View Help

2. Select the desired vector arrow part. ------ .

3. Select the desired projection type from the
Projection pulldown. ...l

The projection choices are modified by the settings in :
the Projection components X,Y,Z numeric fields. :
These values represent a scaling factor for the
component. Zero means that the component should :
not be considered (and therefore confine the arrows
to the plane perpendicular to that axis). One is the
default setting; values less than 1 diminish the
contribution of the component while values greater Creation Attributes
than 1 exaggerate the contribution. :

Desc | vector Arrow part

Variahble velacity

Choices for Projection are: Scale Factor | 5 gpi9e.01 Get Default
All Display arrows based on the vector direction re . .
as modified by the Projection Component Type Rectilinear Lacation Vertices
values. ¢ || | Filter Thresholds |  None
Normal Display arrows based on the “All” vector but in Low | o 0000e+00 High | § go00e+00
the direction of the surface normal at the arrow :
origin. : Display | ) 0000e+00 Density | 4 g9
: Offsef T
Tangential Dis_play arrows be}sed on the “All” vector but - Projection All .
projected tangential to the surface atthe arrow “-f"f -~ >
origin. This is good for locating flow Projection components:
components perpendicular to the main flow X100 ¥ [1.00 Z 100

direction (such as vortices).

Component  Display both the Normal and the Tangential
arrows.

4. Set the desired display offset. - - - ..o
The display offset is used to displace the vector arrows a

short distance away from the surface on which they are

defined (typically for hardcopy or animation purposes). This

is typically necessary when a tangential projection is used

and the arrows are coincident with the parent part’s surface.

Note that a negative offset may be appropriate (depending on

orientation).

OTHER NOTES

Vector arrows can be animated by animating the parent part (e.g. a clip plane) over space or time using flipbook or
keyframe animation. See How To Create a Flipbook Animation or How to Create a Keyframe Animation for
more information.

If vector arrows are created on a clip through an unstructured mesh, the resulting arrows can be difficult to visualize if
the resolution of the underlying mesh varies substantially or is highly irregular. One solution is to create the vector
arrows on a grid clip rather than the default mesh clip. See How to Create Clip Planes for more information.
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How To ... Create Vector Arrows
20000

Unlike most part creation operators, vector arrows are created from the client’s representation of the part — not the
server’s. For example, if you have a clip plane that is displayed using a feature-angle or border representation, only
those elements comprising the reduced display will yield vector arrows — even though all elements of the clip plane
reside on the server. See How to Change Visual Representation for more information.

Vector arrows with a tangential projection can sometimes by occluded by the surface on which the arrows are
defined. To solve this problem, use the Display Offset field to add a small displacement to move the arrows away
from the surface. This is most useful for presentation (e.g. hardcopy or animation) output.

SEE ALSO

Introduction to Part Creation.

User Manual: Vector Arrow Create/Update
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How To ...
B 20000

Create Elevated Surfaces

INTRODUCTION

An Elevated Surface is a 2D surface scaled (in the direction of the local surface normal of the parent part) based on

the value of a variable. Elevated surfaces resemble topog
differences in the value of a variable.

BASIC OPERATION

raphic maps and are useful for accentuating relative

.--- 2. Click the elevated surface creation icon.

File Edit Query View Tools Case

H
B BB

Eelpll
NECTC e enl=] = s

Scale Factor | 1.0000e+00

vl
Get DefaultI

velocity : -+ - Ofgset [ 0.0000¢+00

Surface [T Sidewalls
Apply New Variable I Help... I

Select Part(s} Ta Operate On Select a Variable
1-{M/C1) Computational mesh AN
: =
¥ Create I:

.1, Select the parent part.

3. Select the variable to use.

4. Select an appropriate scale factor
(or click the Get Default button).

5. If desired, enter an Offset value and press return.

The Offset allows you to “shift” the elevated surface
away from the parent, but does not affect the shape.

- 6. If desired, toggle Surface or Sidewalls off.

SEE ALSO

User Manual: Elevated Surface Create/Update

The Surface is the actual elevated surface. You can
also have Sidewalls which stretch from the border of
the parent to the border of the Surface to enclose the
created part.

7. Click “Create”.

B 2000 @® HowTo Index

User Manual Page 1 of 1




How To ... Create Profile Plots
n 20000

INTRODUCTION

A profile plot is the 2D counterpart to an elevated surface: a projection away from a 1D part based on the value of a
variable. Profile plots can be created on any 1D part: clip lines, contours, particle traces, or model parts consisting
of 1D elements.

BASIC OPERATION

----- 2. Click the profile creation icon.

Eile: Edit Query View Tools Case Help |I
- g

NEL EE
]
Select Part(s) To Operate On Select a Variable Scale Factor I 1 0000+00 Clet DefaultI
1-{M/C1) Computational mesh temperature grmmtTo »
» Felocity _____ HeeRn [0.00006+00 _
0.0000e+00
4 ] e
‘ Show Orientation Tooll Update Oﬁental'ionl
Create | ! Apply New Variable |. ! Help... |

1. Select the parent part. ... . : :-- 4. Select an appropriate Scale Factor (or click

: Get Default).
3. Select the variable to use.:

5. If desired, enter an Offset value and press return. ------

The Offset allows you to “shift” the profile away from the
parent, but does not effect the shape.

6. If desired, adjust the orientation of the Plane tool.----- 5

The Plane Tool is used to specify the orientation and
direction of the profile plot. See below for more
information.

... 7. Click “Create”.

For each node of the parent part, the corresponding node on the profile curve is determined by adding the value of
the Offset to the selected variable and then multiplying the sum by the Scale Factor. The projectors of the profile are
the lines that connect the nodes of the parent part to the nodes of the profile curve. The Plane tool is used to specify
the orientation and direction of the projectors. The projectors are created parallel to the Plane tool projecting away
from the center of the Plane tool (at least where the value of the selected variable plus the Offset is positive).

Although the parent part of a profile plot must be 1D, the nodes that make up the part do not have to be linear. For
curved parents, the projectors of the resulting profile plot are still parallel, but they do not all lie in the same plane.

SEE ALSO

User Manual: Profile Create/Update
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How To ... Create Developed
N 20000 (Unrolled) Surfaces

INTRODUCTION

EnSight provides several sophisticated tools for extracting computational surfaces from meshes. For clipped
surfaces with a defined axis of rotation (such as those created with the quadric clipping tools), the surface can
“developed” or unrolled onto a plane. All variables defined on the clip are properly interpolated onto to the developed
surface.

A clip can be developed based on curvilinear (radius, z), (theta, z), or (meridian, theta) coordinate projections. The
“seam” of the clip can be specified interactively.

BAsIC OPERATION
To create a developed surface:

1. First, create the desired quadric clip (cylinder, sphere, or cone).

:--- 3. Click the Developed e 4. Select the desired projection type (see
Surface icon. : below for details on the types).

File Edit *guery View Toaols Case . Help |I
- g

NEE=D

Select Part(s} Ta Operate On
P | 1-{M/C1} Computational mesh AN

£l

Projection (the&,z) _l|

2-{2/C1}) Clip_cylinder Scale Factars(uy) u I 1.0000e+00 Y 100008 +00 < -
Shew Cutting Seam | Align with Parent Origin/Axis |
- A o "
Ll | . - =

£ Create I . Help... I

. 2. Select the parent part for the
developed surface (i.e. the part
you created in step 1).

5. If applicable for the projection type (and desired)
enter u,v scaling factors and press return). -------..-.

6. To display and change the cutting seam, click the
Show Cutting Seam button, and adjust the slider.

e 7. Click Create.

A part is developed by specifying one of three curvilinear mappings called developed projections. The projections are
based on the curvilinear coordinates r (radius), z, 6 (theta), and m (meridian or longitude). These coordinates are
defined relative to the local origin and axis of the tool that created the parent part (e.g. the Cylinder tool). The
projections are (r,z), (6, z), and (m, 6). The u, v scale factors (only for (6, z) or (m, ) projections) provide scaling for
the coordinates in the listed order. For example, if the projection is (8, z) then u scales 6 and v scales z.

SEE ALSO

How To Create Quadric Clips

User Manual: Developed Surface Create/Update
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How To ... Create Subset Parts
" 20000

INTRODUCTION

A Subset Part can be created by specifying node and/or element label ranges of a model part. Subset Parts can only
be created from model parts that have node and/or element labels. The Subset Part feature can be used to isolate
specified nodal and element regions of interest in large data sets.

BASIC OPERATION

1. First, click the Subset Parts creation icon. ------ 3. Select Elements (or Nodes) to Show.

2. Now, for each parent model part,
enter the part number of the
desired parent part in the Add field
and press return. .

Eilie Edit Query View Tools Case
*lect Part{s} To Operate On
1-{M/C1) Computational mesh

Show Elements _l|(Ex.1,3,100—250)

100-200 < -« < -« e e meemeeaeennn -J\ .............

L]

1-(C1} Computational mesh

Fi

#dd Part | 1 Delete PartI
7 Create | Update | Help... |

A

4. Enter the element (or node) label range(s) in
the Show List text field (ranges are separated
by commas). - ------eiii i

SO 5. Click Create

SEE ALSO

User Manual: Subset Parts Create/Update
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How To ... Create Tensor Glyphs
N 260000

INTRODUCTION

Tensor glyphs display the direction of the eigenvectors for a tensor variable. Controls exist to show just the
compressive or tensile eigenvectors, and to selectively show the minor, middle, or major vectors.

Tensor glyphs have numerous attributes including length scale, tips, color, and line width which can be used to
indicate compression or tension.

BASIC OPERATION

2. Click the Tensor Glyph icon (by default this icon is
on the second row - if you don’t see it, click the
down arrow for the icon bar). ----.

--- 3. Select the tensor
variable to use.

File Edit gueryv View Tools Case Help |I .

INNEE =3

Select Part(s) To Operate On Select a Tensor Variable Scale Factor I 1.0000e4+00
2-(M/C1) left sgquare B uniaxial_tensor . . .
3-(M/C1) right square shear_tensor : Display Which

' devia_tensor i [T Compression [ Tension
‘ ro : Major [~ Middle [ Minor

plane_tensor

spherical_tensor Display Aﬂ-ribut\es...l
i Create I . Apply New Variable I Help... I

1. Select the parent : '
parts. -t Lol 4. Select which 5. Click Create.

eigenvectors to display.

Display Attributes

The glyph’s attributes to indicate tension or compression can be modified in several ways. Click the Display
Attributes button to open the Tensor Display Attributes dialog:

1. Select the desired tip shape from the Tip Shape pulldown..--.

7’l"il; ;Si\.;pe Normal i | Tip Size I 1.0000e-01
Tip Shape Choices:  Jcotorn Part
None No tlp (default) 3 o »Compression Color prix... RI 100 G I 000 B I 0.00
— Tension Color Mix...|B 000 G000 |B[100
. Line Widthby =~ Part |< ————————————————
/ Normal Single wedge. Good for 2D problems. 1
Plane of the wedge is based on the : Compression Line Width | 1 Pixel | -
relative magnitudes of the components. Tension Line Width 2 Pixels i |
Triangles  Two intersecting triangles. Good for 2D/ Close|

3D problems. ‘ .
.-. 2. The glyph can either be colored by

the part color, or show a specified
color for compressions and tension. :

3. The glyph can either be shown with the line width attribute of the glyphi,
or show a different line width for tension and compression. --------.-..:
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How To ... Create Tensor Glyphs
m 20000

OTHER NOTES

Tensor glyphs can be animated by animating the parent part (e.g. a clip plane) over space or time using flipbook or
keyframe animation. See How To Create Flipbook Animation or How to Create a Keyframe Animation for more
information.

Unlike most part creation operators, tensor glyphs are created from the client’s representation of the part - not the
server’s. For example, if you have a clip plane that is displayed using a feature angle or border representation, only
those elements comprising the reduced display will yield tensor glyphs - even though all elements of the clip plane
reside on the server. See How to Change Visual Representation for more information.

SEE ALSO

Introduction to Part Creation.

User Manual: Tensor Glyph Parts Create/Update
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How To ... Display Displacements
n 20000

INTRODUCTION

In structural mechanics simulations, a common output variable is a set of vectors representing the movement or
displacement of geometry. Each displacement vector specifies a translation of a node from its original position (an
offset). EnSight can display and animate these displacements to help visualize the relative motion of geometry.

In many cases, the magnitude of the actual displacements is extremely small relative to the size of the model.
EnSight provides a displacement factor to scale the vectors and exaggerate the displacement.

BAsSIC OPERATION

2. Click the displacement
creationicon. ---------ooooiil

File Edit Query View Tools Case Eelp* | Current Time — Step(20,000000} Sinulation(Z,3500e-01)
e - — &
N 5
¥
Select Part(s} Ta Operate On Displace By, Variable
5-(M/C1) front body H
B-{M/C1) rear body ! Displacement Factor 1 0000e+00
Apply New Variable : Help...
- 1. Select the parent parts. : --- 3. Select the variable to use. :-- 5. If desired, enter a value for the
5 Displacement Factor and press
:--- 4. Select Variable from the return.

Displace By pulldown.

Note that your changes in the Quick Interaction area are immediate. Specifying a displacement does not create a
new part, it merely sets the displacement attributes for the selected parts.
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How To ... Display Displacements
" 20000

ADVANCED USAGE

Vibrational analysis typically produces eigenvectors. EnSight can animate these vectors as mode shapes to
visualize selected vibration modes (each represented by a different displacement vector). The EnSight Flipbook is
used to build and load the animation. Once loaded, the animation can be replayed while still providing viewing
control. To create a mode shape flipbook:

1. Be sure displacements are active
and the Displacement Factor is set

to a suitable value (as described . . .
above). 2. Click the Flipbookicon..---------..

File Edit Query View Tools Case Help |ICurrent Ti tepl20, 000000;1 Simulationdz,3500e-01)

_ ] & i i [7) ()
Select Part(s) To Operate On Load Type Mode Shapes i Load As Objects i |
5-(M/C1) front body LN e
6—({M/C1} rear body : Number of Flipbook Pages to Create | 1) <« ---------ooooooonoooooo.
. Page Thone
B Tepe | Sl | j'| & 9000 I{s,z}{sz}{wg-s-{si} Sodify Hun.. |
|| Regen.” Load I Favord.. I Thebate... I Help... I
All Pages
v} .
3. Select Mode Shapes from : : 4. Enter the desired number of
the Load Type pulldown. - - : : Flipbook pages to create. ---------:
B EEEEEEE: 5. Click “Load”.

SRR 6. Once loading is complete, change
the Run Type to Auto.

The first page of the animation shows the full displacement (as it is shown in the Graphics Window without the
Flipbook) while the last page shows full displacement in the opposite direction. Intermediate pages show
displacements as driven by the cosine function.

Note that you can create copies or extracts of parts and simultaneously display them with different mode shape
variables or to show the initial static state along with the mode shape animation.

SEE ALSO

See How To Create a Flipbook Animation for more information on Flipbooks.

User Manual: Displacements On Parts, Flipbook Animation
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How To ... Display Discrete or

B 200060 Experimental Data

INTRODUCTION

In addition to meshed data consisting of nodes and elements, EnSight also supports discrete or measured data. A
measured dataset consists of a series of arbitrary points in space with no connectivity. Measured data can have
associated variable data and can vary over time. Examples of measured data include fuel sprays, multi-phase flows,
and experimental data.

Measured data cannot be loaded by itself — you must also specify a regular geometric mesh.

BAsIC OPERATION
Measured data is read into EnSight via the same dialog used to read meshed data:

1. Select File > Data (Reader)... to open the File Selection dialog for data file selection.

-w File Selection [x]
Filter

2. Find the directory containing the fusrilocalfbinfensight?3other datam3s#]
data (see How To Read Data for Directories Files
more information on using File 1z local/binfenzightT3/ather data/nds!. README .n3=
Selection). 1srlocal/binfensightTHother dataimds/.. n3dsflow . gea

n3dsflow . mres

3. If desired, select and specify a n3sflow.res
(meshed) geometry file and the R || R R LR >
corresponding result file. : particle.mgec000

particle.mgea00]
4. Select the measured result file in

the Files list. ---------ooonen
Casze {Add Replace,Delete)
¥ File Information*
5. If desired, specify an initial time Format N38§
step (the last step is the default). .------.. Specify Starting Time Step
§5§z;;x§;€,- Pilow Are | Blp-Podiand P IBM SGLIUN
6. If you are reading a meshed B ‘i}enmehy(Requimd), Results{Required},
dataset (as directed in step 3), -7 || EnSight Measured(*.mres Optional}
select the file format. --------------.... ’ (Set) Geometry| | n3sflow.geo

{Set) Result n3sflow . res

7. Click (Set) Measured to specify n3sflows.mres

the selected measured result file. .---
Sty Borandasy

Path tusrlocalbinfensightTdother_datamds

8. Click Okay to begin the reading )
PrOCESS. «-----ecomrmmmmramaamanaaenaass Selection

fusrflocalbin/ensight?3/other_data/m3sin3sflows.mres

ERERE r Okay Apply Filter Cancel Help
9. The Data Part Loader dialog
corresponding to the selected data file
format (as set in step 6) will open. You do not have to perform any further action to load the
measured data. However, if you are also loading meshed data, continue with the usual part loading
process. For details, see the How To article for the chosen file format.
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How To ... Display Discrete or
B 20000 Experimental Data

Measured data is represented as a single part. In the Main Parts list you should see a part named “Measured/
Particle” after loading.

Measured data is represented as a set of unconnected nodes. You can use EnSight’s ability to display nodes in
various ways to accentuate measured data visualization. To change node display:

1. Select the desired measured data part in the Main
Parts list.

2. Click Part in the Mode Selection area to enter Part
Mode.

3. Click the Node Representation icon to open the Part
Node Representation dialog. --------------oemneeee

4. Select the desired node display type (Dot, Cross, or
Sphere). See below for details on each type.  ------

Type\Sphere 1 | Scale IS.OllTe—OI

5. If applicable, set desired values for Scale, Detail, :
Size By, and Variable. Detail I 1 Size By Constant =

* Dot: nodes are displayed as points. Variahis  Mone I |

» Cross: nodes are displayed as crosses and can be fixed
size (size set by the Scale value) or sized based on a Cl""“l
Variable (and scaled by the Scale value).

» Sphere: nodes are displayed as spheres and can be
fixed size (size set by the Scale value) or sized based on
a Variable (and scaled by the Scale value). Sphere detail
controlled by Detail value.

OTHER NOTES

The file formats for measured data and the measured results file are detailed in EnSight5 Measured/Particle File
Format.

Transient measured data can be animated using either the flipbook or keyframe animation capability.

You can load multiple measured datasets simultaneously by using EnSight’s cases capability.

SEE ALSO

User Manual: EnSight5 Measured/Particle File Format
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How To ... Change Time Steps

h 20000

INTRODUCTION

From it’s inception, EnSight has been used extensively to postprocess time-varying or transient data. In many cases,
dynamic phenomena can only be understood through interactive exploration. The Solution Time Quick Interaction
area provides the interface for working with transient data and provides comprehensive control over time handling.

BAsSIC OPERATION

EnSight provides two ways to work with transient data. By default, time is presented as a series of discrete steps
running from zero to the total number of steps minus one. However, you can also present time based on the actual
simulation time values found in your results data. The presentation mode is controlled by the Time As pulldown
menu. In the dialog below, Time As is set to Step and time is presented as discrete steps running from 0 to 159 (160
total steps). The simulation time (as reported in the top line of the dialog) runs from 1.0 to 160.0.

The current time range is displayed in the Beg and End fields with the current time step shown in the Cur field. You
can modify the time range displayed in the slider by editing the Beg and/or End fields (remember to press return).
You can change the current time step by editing the Cur field (press return), manipulating the slider, or clicking the
left/right slider arrows. Clicking Reset Time Range will reset Beg and End to the full range.

Time scaling and stepping (as manipulated through the slider bar and Beg, Cur, and End fields) can either be
Discrete or Continuous. If scaling is Discrete, only your actual time steps as written in the results data can be
visualized. In addition, the Beg, Cur, and End fields can only be set to integer values (if Time As is set to Step and
Scale Type is Discrete) or actual simulation times represented in your results data (if Time As is set to Sim. Time). If
scaling is Continuous, you can display results between your actual output time steps (all variable values are linearly
interpolated between the two surrounding time steps). Note that if your mesh is changing over time (either set of
elements or element connectivity) you cannot display results continuously.

When you manipulate the slider or change the Cur field, EnSight will perform all tasks necessary to correctly display
the new time step in the Graphics Window. Depending on the size of the dataset and the number of additional parts
you have created, this may take a significant amount of time. If you wish to create an on-screen animation of your
results, use the Flipbook facility (click Animate Over Time to quickly jump to the Flipbook Quick Interaction area).

To use the Solution Time Quick Interaction area:

1. Click the Solution Time icon in the Feature
lconbar. -------oooiiiia >

2. Make changes as desired.
The slider bar lets you step through time. Grab the slider and dial to

the desired time or click the left/right slider arrows to increment (the
increment can be set by changing the Step Arrow Increment field). - - -

The Beg and End fields control the available RREEEE TR
time range (and also the range of the slider . .
action). The Cur field sets the current time fplution 'Tim% Steps(0-159) Simulation(1.0000e+00-1.6000e+02)

- --

step. Enter new values and press return to
updateB‘i 0 Cur[ g End [ |rg
Set Scale Type to Discrete or Continuous - . Step Arrow
(see above for details). - - - - -« v vuueeennnnan. Scale Typg, Discrete Time As |~ Step x Increment ! A
Click to reset the Beg/End fields back to the ;® __ Reset Time Range #OfGyelesly v T
default (full time range). .- - .- ool e - :
. Animate... . Ti t Details... : Help...
Click to open the Flipbook Animation Quick :> e : meser Jetals . e
Interactionarea. ---------ooooooooooll 0
Set the number of time cycles in Set Time As to Step or Sim. Set the step increment size forthei
the time range. For example, . Time (see above for details).---- -+ slider arrows. Must be an integer .
setting it to 2 changes End to 318. if Scale Type is Discrete..------.:
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How To ... Change Time Steps

n 260000

ADVANCED USAGE

EnSight allows geometry and variables to behave in a transient manner on different timelines, i.e., a variable called

Temperature can be defined att= 0., 3., and 6. while a variable called Pressure can be defined att=0., 2., and 5.5.
The Timeset Details button will bring up the Timeset Details dialog which allows the user to view the various timelines
as well as specify how the variables will behave when they are not defined.

The EnSight case file defines the timesets (name and associated time values) and associates a timeset with each of
the variables and geometry.

By default the Solution Time dialog will show a composite of all of the timesteps that exist across all of the timesets.
This can, however be changed to show just the time values associated with a particular timeset.

In the Timeset Details dialog shown below, multiple timesets exists. Three timesets (from the Which Timeset(s) list)
are selected and are thus shown in detail. The graphics for each timeset shows (a) the minimum and maximum
overall time value, (b) white tick marks immediately under the timeline indicate the total (composite) time values
available from the solution time dialog, (c) green tick marks indicating the time values defined for the timeset, (d) the
current time value (indicated with the long green line) associated with the timeset.

To modify all the timelines to The timeset can either be
behave the same way, select shown having a time range
which range is to be modified,  over the total number of time By default the Solution

The current solution time (as then select how they will be values or can be shown
set in the Solution Time dialog. - . 4 . ) , Time dialog shows the
.+ displayed.- - - according to the timeset’s LT
' composite timeline.
Select the timelinetobe . range..---- This button will modify

viewed..- - the Solution Time

: ' dialog’s Beg and End
values to those of the
selected timeset.- - -

**+4 Current Simulation Time = 8.0000e-+00 #++*
Which Timeset(s) "

Mogify All Selected Timeset(s ton Ti
1/C1)-Mod]_Geom v e i;‘,;‘;:::;“[{:‘:; B e TR
{ 2/C1)-Mod]_Gieom Range Between Steps
3/C1)-Varl
(NC-Vard U%‘:';:: ,i;’f’ “*Pick One**

- Shows the time value being
used at the current time.

Show Scale As Full Time Range <r———r———,,,,,,,,,:A.'»__.v"'
" Defined For

Timeset (C1)Moxdl_Geom

5.0000e+00
All Medel Geometry

0000, 5 The timeset is used by the
Left Of Between Steps Right Of .

Stop Do, | Nearest S Dutny Lt Stop Doga, _Noarest variables (or geometry)

fr Motet Cartaies shown in this list: - ;

Left OF N Between Steps Right Of
tep Def, Undefined ‘Step Defn. | Interpolate Ste Do, Nearest
Defined For
Model Variables
Nsea?
Nvee?

Timeset (C1}Var?

8.0000e+00

0.0000e+00
Left Of

Betwoon Stops | 1o olate Right Of |\ ¢

Stop Defn,  [Nearest Step Defn. Step Defn.
Close| k& Update Selected Timeset(s)

When the current time (from the When the current time (from the When the current time (from the
Solution Time dialog and indicated Solution Time dialog and indicated Solution Time dialog and indicated in
in the upper left corner of this in the upper left corner of this the upper left corner of this dialog) is
dialog) is set to a value less than dialog) is set to a value that does set to a value greater than what is
what is available for this timeline, not exist for this timeline, available for this timeline, use the
use the Nearest value or make the Interpolate between defined time Nearest value or make the variable
variable Undefined. values, use the Left, Right, or Undefined.

Nearest value, or make the
variable Undefined.

SEE ALSO
How To Load Transient Data, How To Animate Transient Data

User Manual: Solution Time
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How To ... Extract Vortex Cores
W 20000

INTRODUCTION

Vortex cores are centers of swirling flow where the velocity is parallel to the vorticity. For a more complete description
refer to the User Manual section below.

BASIC OPERATION

1. Select the parent part. S 2. Select the Vortex Core icon on the second row of icons.

: Click here if you do not see this icon..--.---..

E E EnSight E

File Edit Query View Tools Case Eelpl

D=

Select Part(s) Ta Operate On Define Vartex Variahles...l Thweshodd Filter <« I Select Threshold Yariable
1-(M/C1) flow field = 7K Trenaity
2-(M/C1) surface Method Eigen Analysis =i |’§"§xm5§w24& alne P, Hnergy
‘ ]| 2
‘ Hin ﬂ| catstests Al M9 [ seateien | Al
¥ . Create | Apply New Variakle | Help... I

= T= - A

3. Bring up the Vortex Core
Variable Settings dialog by
clicking here. ... ... ...

: 1 - 4. Define either (Density and
Select a variable and then select .
the appropriate SET button below. . Momentum) or Velocity, as well
ST - as the Ratio of Specific Heats.

Energy
Momentum

o e The variables can be set by
Time | either typing them into the
| fields, or selecting them from

|5 ; - - L
NOTE: Nat all fields are,m’niuimd. You must the list above and CIICKIng the
specify ({(Density and Momentum}, ar Set button..
Veloeity), and Ratio of Specific Heats. .

Density V'S |

Momentum I Momentum

| 5. Click Okay to finish the
Ratio of Specific Heats |1 40005400 variable setup. --.

{Can be a constant)

Velocity

6. Click Create. ...
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How To ... Extract Vortex Cores
W 20000

ADVANCED USAGE

The resulting vortex core lines can be filtered by the vortex core strength or by any other active variable.

E E EnSight E

File Edit Query View Tools Case Eelpl

Select Part(s) Ta Operate On Define Vortex Variables.. I Threshold Filter < i I‘ e Select Threshold Variable
P | 1-{M/C1} flow field I _vortcore_streng M- ---.
; 2-(M/C1) surface Method | Eigen Analysis 1 |'Threshold Value M tum :
1-(X/C1) Vortex Cores g e [ 7.75080-01 A : J‘,
Min ﬂ| 7.7506e-01 _| . Max ¥|[22777er02 | k|
7 Create I ' Apply New Variable I - . Help... I

1 = T= : ' i
1. Select the variable to filterby. .-l

2. Set the Threshold filter to remove the portion of
the vortex core that is larger or less than the
specified threshold value.

3. Enter a threshold value - - _.
-or- :
3. Slide the slider to a new threshold value. -------:

OTHER NOTES

Extract Vortex Cores does not work with more than one case.

SEE ALSO

User Manual: Vortex Core Create/Update
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How To ... Extract Separation and
h 20000 Attachment Lines

INTRODUCTION

Separation and attachment lines are created on any 2D surface and show interfaces where flow abruptly leaves
(separates) or returns (attaches) to the surface. For a more complete description refer to the User Manual section
below.

BASIC OPERATION

---1. Select the 2D parent part.

. 2. Click the Separation/Attachment part (Note: This icon is on the second row of icons. Click
icon. -------------oooooooooooooooooooooooooooo0 - here if you do not see this icon.) ------------ -
File Edit Query View Tools Case : Help |
- -
L T
nEEmsEaesE: 3@ 0o2ZzZ%0% 0 N
Select Part(s) To Operate On Define Sep/Attach Variables...| Thweshold Fiiler « Salaet Thessbold YVariabls
1-{M/C1} external flow field .- BHOEEUY
2-(M/C1} ami-x hypersonic hod | Method Phase Plane Threshadd Yalue | 6 apine.60 walwoily

3-(2/C1) Clip_plane
1-(ViC1) Vector Arrow part

s 9| [ seoness Maw w5 soanesnn s

Create Apply New Variable Help...

3. Bring up the dialog
defining the necessary : .
variables by clicking here. ------: 5 P 4. Define either Density and
Momentum or velocity, as
; | well as the Ratio of Specific

Select a variable and then select L’ i Heats.
| the appropriate SET button below. .

| The variables can be set by
; nergy

| [Momantum ) either typing them into the
| [Coordinates fields or be selecting them
Time from the list above and

= ; clicking the Set button. ...

5. Click Okay to finish the
variable setup. ----.

NOTE: Not all fields are m’x’;uir\ed. You must
] specify ({Density and Momentum), or

Velocity), and Ratio of Specific Heats.

6. Click Create ... Density I z £I
. SE

SE

SE

This will create two parts - || Momentum [ Momentur SET|
one each for the separation | _ . .

and attachment lines. You | ﬁ:ztxlmobffﬁ:':sf;:rﬂf " [1a000er00 [se]
can modify the visual | Velocity [ sET|
attributes of these parts
separately, but when you
change any creation ; ;
attribute, both parts willbe =~ T rTrrrrrr e
modified.
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How To ... Extract Separation and
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ADVANCED USAGE

The resulting separation/attachment parts can be filtered by the fx_sep_att_strength variable or by any other active
variable.

File Edit Query View Toaols Case Help
&
Select Part(s) To Operate On Define Sep/Attach Variables...| Threshold Filter < i |~ Seleet Threshold Variable
1-{M/C1} external flow field s -
2{M/C1} ami-x hypersonic bod Method Phase Plane Threshold Value | | 1516.02 | velocity

9-(L/C1) Separation Line

10-(LAC1) Attachment Line

«
Mi“é 1.545de-02 il Max¥|[y 0000e-01 &

Create Apply Néw Variable | Help...

1. Select the variable to filterby. - ... ... ———————————————————

2. Set the Threshold filter to remove the portion of the
separation/attachment line that is larger or smaller than . Lo
the specified threshold value. - ... il he

3.Enter a threshold value ...................._..__..._.......
-or- :
3. Slide the slider to a new threshold value. -----------------:

OTHER NOTES

The separation and attachment parts are linked together with regard to their creation attributes, i.e. when one is
modified the other is also. Further, when one is deleted the other is also deleted.

Separation and Attachment feature extraction only works with one case.

The separation and attachment line parts should generally not interfere visually with the 2D parent parts they lie on
(as long as the preference for graphics hardware offset is on - see View Preferences), but they may interfere if
printed. In either case you can apply a display offset manually to avoid the interference in the Feature Detail Editor
for the part. The display offset will be in the direction of the parent surface normal.

SEE ALSO

User Manual: Separation/Attachment Lines Create/Update
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How To ... Extract Shock Surfaces
W 20000

INTRODUCTION

Shock surfaces and regions help visualize shock waves in 3D (trans/super-sonic) flow. For a more complete
description, refer to the User Manual section below.

BASIC OPERATION

--1. Select the parent part.

2. Click the Shock Surface/Region icon.. (Note: This icon is on the second row of icons.
' .-------...1 Click here if you do not see this icon) .-----............

File Edit Query View Toals 'gase Eelpl

DNEm=ED

E Select Part(s) To Operate On i Define Shock Variables...| {hpeshoid Pillay <
----- 1-¢M/C1) fieldl —"—I = o ‘ _I
2_(M/C1) boundaryl " | Method | Surface i | Thaeshold Valee [ apope.ay

5-(M/C1) GROUP: j-slice

Haloot Threshold Yariable

Tronwity
Hanargy

FPrensityLoghhon
Select Creation Variakle PRI

B—(V/C1) Vector Arrow part . :
\ | | Density : ﬁl ﬂ
o | Energy : Min ¥ [aeateaz | 4l 0 M i‘” 1000000 L
P
il

Create | : Apply New Variable Help... |
=0 = A :

: 3. Bring up the dialog defining .
the necessary variables by ............
clicking here.

: 4. Define either Density
Select a variable and then select or (Temperatu re and
| the appmpmte SET button below. | Pressure), (Energy or
; : | Pressure), (Momentum or
DensitylogHorm Velocity), and Ratio of

| |Bensitutiorn | Specific Heats. ----..
{ |DensityNornStag .

Den=ityStag
|=

| NOTE: Not all fields are required. You must

specify (Density or (Temperature and Pr\essur\e}),
{Energy or Pressure), (Momentum or Veloelty),
and Ratio of Specific Heats.

Density I De_nsﬂ'y

The variables can be set
| | by either typing them into
Energy (Tofal) Per -~ [Enerey the fields, or se_lecting
Enthalpy | them from the list and

| clicking the Set button. ...

Mach I

Momentum
5. Click Okay to finish the
variable setup. -----

{ Pressure I Pres

Ratio of Specific Heats
| {Can be a constant) I 1.1000e+00
i X X Gas Canstant
6. Choose Reglon or : : {Can be a scalar field) I 1.00000+00
Surface. ------------ooo-l

Temperature

7. Click Create. ............... Velocty
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ADVANCED USAGE

The resulting shock can be filtered by any of the threshold variables

File Edit Query View Tonls Case

LLEL-EI=1
Select Part(s) To Operate On Define Shock Variables...l Threshold Filter ﬁ ------- Select Threshald Variahle
P [ 1-WCD fielar 5  eTT—
2-(M/C1) boundaryl Method Surface | Threshold Value |4 ggp0e-02 : SHK_'Threshold
5-(M/C1) GROUP: j-sli A : &
¢ ) Imsioe Select Creation Variable 4 .---------------. . Momentum 4
6-(V/C1) Vector Arrow part ~ & < = : =
5-(K/C1) Feature Extraction -
Min 1| 1.0000¢ 12 _| M“ Y!l 1. 0000el00 k|
¥l Create | Apply New Vana.ble | : Help... I

| -

1. Select the variable to filter by. ... ...........

2. Set the Threshold filter to remove the portion of the shock
surface or region that is greater or less than the specified . I
threshold value. -« ---oemomrmm ARITRILEY R

3. Enter a threshold value -~~~ -« - mmmmmmmiiiiiiie b
-or- : :
3. Slide the slider to a new threshold value .----....................i.......!

4. The shock is usually defined in a very narrow band, so the

slider min/max values may need to be adjusted by either

entering new values in the min/max fields, or clicking on the : .
up/down buttons to change by an order of magnitude. ........... ... .. .. .. ... ...

OTHER NOTES

See Other Notes in the Shock Surface/Region Create/Update section of the User Manual for options on how to pre-
filter flow field regions, and/or post-filter shock regions via a specified mach number. Also to apply the transient
correction term for moving shocks when using the shock Region method.

Shock Surface feature extraction does not work with multiple cases.

SEE ALSO

User Manual: Shock Surface/Region Create/Update
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n 260000

INTRODUCTION

A Material Part can be created as either a domain or an interface.

A material Domain is a solid region (or regions) composed of one or more specified materials. Parts with 2D
elements yield 2D material elements, and parts with 3D elements yield 3D material elements.

A material Interface is a boundary region (or regions) between adjacent materials composed of at least two or more
specified materials. Parts with 2D elements yield 1D material elements, and parts with 3D elements yield 2D material
elements.

The Material Part feature can be used to isolate specified elemental regions of interest in data sets with material
fractions.

BAsIC OPERATION
For Material Domain:

1. Click the Material Parts creation iconf_-_-r

File Edit Guery View Taools Cage "’ . Help |
- L
NE RN S ,
Select Part(s) To Operate On Select 1 or more materials  Type Dgmain
=\ o =, 2 1 1 )
1-(M/C1) nedmesh2d matl_01 Subdivide Level 1
. hnatl_02 .

matl_04 !

null_material

Cr\eat\eA Appl):r New Material{s} Help...

.. 2. Select the parent model part(s). :
3. Set Type to Domain. - ---------------- S
4. Select 1 or more materials. --------- PR ¥
5. Click Create. .-« -«----oocoeuaennl

For Material Interface:

1. Click the Material Parts creation Icon..

File Edit Query View Tools Case-- - Help
- i
Select Part{s) To Operate On Select 2 or more materials  Type Interface
(MACT sh2 ! T N
1-{M/C1) ucdm_h <l matl_01 Subdivie Level 1
# 2.(5/C1) Material interface :

" matl_03
matl_0d

null_material

Create " : Apply New Material(s) Help...

:.2. Select the parent model part(s). :
3. Set Type to Interface. ................ A
4. Select 2 or more materials.---------- Feaas :

5. Click Create. -« ---c-cooeeeeaeaea.l
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ADVANCED USAGE

Increased Element Resolution

You can increase the element resolution of the Material Part by increasing the Subdivide option from Level 1 to either
Level 2 0rLevel 3.« - - nmmmme

File Edit Query View Tools Case

“ - = - =

Select Part(s) To Operate On Select 2 or more materials  Type Interface
(MI/C1) sh2 h T i :
1-(M/C1) ucdm_h ol matl_01 Subdivide Level 1 -
2.(A/C1) Material interface
matl_03
matl_04

null_material

Create Apply New Material{s} Help...

Each 3D (or 2D) part element is first decomposed into tetrahedrons (or triangles) before it is processed. Level 1
simply processes each of these decomposed elements. Level 2 subdivides each of these decomposed elements into
3 sub-tetrahedrons (or sub-triangles). Level 2 subdivides each of these decomposed elements into 6 sub-
tetrahedrons (or sub-triangles). Each subdivided element is then processed.

SEE ALSO

User Manual:
Section 7.18, Material Parts Create/Update
In Section 11.1, EnSight Gold Casefile Format, see EnSight Gold Material Files Format
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INTRODUCTION

When a results dataset is read into EnSight, associated variables are noted and listed in the Main Variables List.
However, a variable will remain deactivated (not loaded into memory) until some operation requires it or it is explicitly
activated (read into memory).

If an active variable is no longer required, you can deactivate it and free the associated memory.

BASIC OPERATION

Variable Activation

In most instances, variables are automatically activated as required. For example, if you create a contour using a
deactivated variable, EnSight will automatically activate the variable prior to creating the contour.

You can also activate variables explicitly using the Feature Detail Editor for Variables.

1. Open the Feature Detail Editor for Variables.

You can either double-click the desired variablein -
the Main Variables List or double-click the Color icon :

in the Feature lcon Bar. ---- -~ -« -oooemie

Edit View

File

Available Variable Type Result
2. Select the variable(s) you wish to activate. --- - temPEtu‘"e “” Caa‘" 2
e C1TY Lo kYR Yeot.or
3. Click the Activate button. .-....................._. E?Drdmates t#d Gun Wector
4| Time t#} Gwn Scalar
OR 4
I~
2. Click the Activate All button to activate all Activate| Activate All|! Deactivate| Extended CFD
variables inthe list. .- A : Variables...
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Variable Deactivation

Variables are never deactivated automatically. To deactivate a variable:

1. Open the Feature Detail Editor for Variables.

You can either double-click the desired variable in o
the Main Variables List or double-click the Color icon :

in the Feature lconBar.-------------ooooeen

Available Variakle Type Result

tenpersture { ) Gvn Scalar A

velocity Veotor
Coordinates (%) Gun Vector
2. Select the variable(s) you wish to deactivate. .--- || Tine %) Gun Scalar
Fi
|~
Activate| Activate All| Deactivate| Extended CFD
A Variables...
3. Click the Deactivate button. ... ... .0

Note that variable deactivation can result in the modification or deletion of parts. If this is the case, you will be
asked to confirm the deactivation. A part could be modified if it used the deactivated variable for coloring. A part
could be deleted if it was based on the deactivated variable (such as a contour or an isosurface).

SEE ALSO

How To Edit Color Palettes, How To Create New Variables

User Manual: Variable Selection and Activation
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INTRODUCTION

EnSight provides a powerful capability to derive new variables from existing variables and parts. For example, in a
fluids dynamics problem, if you have momentum, density, and stagnation energy you can calculate temperature,
Mach number, pressure, or velocity. In addition to the built-in functions, you can also compose your own functions
using the equation editor in conjunction with previously defined variables.

This article is divided into the following sections:

Introduction

Variable Creation
Examples of Expressions
Built-in Function Reference
Extended CFD Variables

BASIC OPERATION

Introduction

EnSight provides five distinct types of variables:

Constant A constant variable is a single value. Constants do not vary across a part
although a constant can vary over time. Examples include Analysis_Time,
Temperature[123] (the value of temperature at node 123), Stress{3}[321]
(the value of stress at node 321 at time step 3), or the value of a function
that produces a constant (e.g. Area).

Scalar A scalar variable is a set of values: one for each node or element of the
applicable part(s). Examples include Pressure, Velocity[Z] (the Z component
of velocity), Stress{3} (the value of stress at time step 3), or the value of a
function that produces a scalar (e.g. Flow)

Vector A vector variable is a set of values: three (the X,Y,Z components) for each
node or element of the applicable part(s). Examples include Velocity,
Velocity{3} (the value of velocity at time step 3), Coordinates (a given
variable equal to the XYZ coordinate at a node), or the value of a function
that produces a vector (e.g. Vorticity).

Tensor A tensor variable is a set of values: six (if symmetric) or nine (if asymmetric),
for each node or element of the applicable part(s). Tensor variables can be
represented by Tensor Glyphs directly, and within the variable calculator
eigenvalues, eigenvectors, determinant, VonMises or Tresca, etc. can be
computed.

Complex A complex variable, which within Ensight can be either scalar or vector,
includes the real and imaginary portions of the values. The variable
calculator allows the user to compute things like modulus, argument,
transient response, etc.

Variables are either given (read from the dataset or automatically provided by EnSight) or computed (derived from
existing variables during an EnSight session). The variable type and whether it is given (shown as “Gvn”) or
computed (shown as “Cmp”) are shown in the Variables list in the Feature Detail Editor for Variables. If you have any
element-based variables in a model, the variable names in the Main Variables list will be preceded by “(E)” for
element-based or “(N)” for node-based.

Every non-constant variable (both given as well as computed) has an associated color palette that defines the
mapping from variable values to color. These palettes can be edited to change the mapping (see How To Edit Color
Maps for details). The value of a constant variable can be displayed as a text string in the Graphics Window (see
How To Create Text Annotation for details).

For time-dependent data, calculated variables will automatically recalculate when the current time step is changed.
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Create New Variables

Variable Creation

Derived variables are easily created using the Feature Detail Editor Variable Calculator. To create new variables:

1. Double-click the Variable Calculator icon in
the Feature Icon bar to open the Feature Detail
Editor (Calculator).

3. Select the desired function from the General
list or the Math list.

When you select a function, the Variable Name fieldé
(at the top of the section) is loaded with the name of:
the function. This will be the name of the variable as:
seen in the Main Variables list. You can change this:
name by entering a new value (and pressing return);

A description of the function parameters appears in
the feedback section, as well as instructions for :
properly composing the required parameters.------ .

The expression is built in the Working Expression : :
section. As you insert parameters, they are '
automatically added to the expression and the
instructions for the next parameter will appear.
Parameters can be inserted as follows:

Parts: by selecting the desired part(s) in the Main :
Parts list (and clicking Okay) or by entering the part
number directly in the Working Expression area.
Note that the place holder “plist” appears in the
expression denoting the list of currently selected
parts.

Variables: by clicking on the desired variable in thei---

Active Variables list.

Constants/other: by typing the desired constant or

other text directly into the Working Expression or by

clicking the desired item in the Calculator keypad: - - - -,

4. Follow the instructions to build the desired
expression and then click Evaluate.

Featurre Detail Editor (Calculator)

Edit View

E temnperature
E velocity

| |Coordinates
|| Tine

B

Availakle Variable

Type

Rezult

{3 Gun
1 Gen
(=) Gun
(%) Gun

Scalar
Vector
Vector
Scalar

Activate| Activate All|

Deactivate| Extended CFD

Variables...

Variakle Name I Flow

Woaorking
Expression

Flonsr

Clear I

N

Evaluate

General

Math

Active Varial:-;les

Entropyipart |- |ABS
FlowRate(pa
FluidShear}
FluidShearl

Faorce{part, p ri

— |ASIN

CcO

A
ACOS J

ATAN

CROSE |

Coordinates 1B

] -
Feedback

N -

BN | |
Okay :

Flow{any 1D ar 2D part{s}, velacity}

Select any 1D or 2D part{s) and select Okay

ar enter a part numhber

and select Okay.

I~

B 2000@® HowTo index

User Manual

Page 2 of 6




How To ... Create New Variables

W 20000
Examples of Expressions

The following examples demonstrate usage of the variable calculator. In each case, first enter a name in the Variable
Name field and click in the Working Expression area to activate it. The examples assume that Analysis_Time (a given
constant variable if the dataset is transient), pressure, density, and velocity are all given variables.

Expression Description and How to Build

-13.5/3.5 A simple constant.
To build, either type the text on the keyboard or click in the Calculator keypad.

Analysis Time/60.0 A constant variable. Assuming the solution time was given in seconds, this expression will
provide a variable giving the time in minutes.

To build, select Analysis_Time from the Active Variable list and either type or click /60.0

velocity*density Momemtum — a vector variable.

To build, select velocity from the Active Variable list, click or type *, and select density
from the Active Variable list.

SQRT (pressure [73] *2.5) Square root of (pressure at node 73 * 2.5 + the X component of velocity at node 73)

+ velocity[X] [73] To build, select SQRT from the Math function list, select pressure from the Active Variable

list, click or type [73] *2.5)+, select velocity from the Active Variable list, and click or
type [X] [73].

pressure{19} Scalar variable equal to pressure at time 19. This variable will not change if the current
time step is changed.

To build, select pressure from the Active Variable list and click or type {19}.

MAX (plist, pressure) Constant variable equal to the maximum value for pressure over all nodes of all parts in
plist.
To build, select MAX from the General function list and follow the instructions in the Feedback
area.

(pressure/max_pres) "2 Scalar variable equal to squared normalized pressure.

To build, first calculate the MAX constant variable as described in the preceding example
(here named max_pres). Click or type (, select pressure from the Active Variable list, click
ortype /, select max_pres from the Active Variable list, and click or type ) *2.

Since EnSight can compute only one variable at a time, one must break down involved equations into multiple
smaller ones, using temporary or intermediate variables.

Calculator limitations include the following:

1. The variable name cannot be used in the expression. The following is invalid:

temperature = temperature + 100
Instead use:
temperature2 = temperature + 100

2. The result of a function cannot be used in an expression.
(pressure / MAX (plist,pressure) )"2

Instead use two steps. Define p_max as:
MAX (plist, pressure)
then define norm_press_sqr as:
(pressure / p_max)"2
3. Created parts (or changing geometry model parts) cannot be used with a time calculation (using { }).

4. Calculations occur only on server-based parts. Client-based parts are ignored, and variable values may be
undefined.

Built-in Function Reference

Although all built-in functions are listed here, consult the User Manual for the complete definition of a function.
EnSight provides the following built-in general variable calculation functions:

Function Abbreviation (if Description
any)
Area Surface area
Case Map CaseMap Map values of a variable from one case onto the nodes of another case.
Coefficient Coeff Coefficient
Complex Cmplx Create complex variable from variables representing the real and
imaginary portions.
Complex Argument CmplxArg Argument of complex variable
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Function Abbreviation (if Description
any)
Complex Conjugate CmplxConj Conjugate of complex variable
Complex Imaginary Cmplxlmag Imaginary portion of complex variable
Complex Modulus CmplxModu Modulus of complex variable
Complex Real CmplxReal Real portion of complex variable
Complex Transient Response CmplxTransResp |Complex transient response
Curl Curl of a vector
Density Density
Distance Between 2 Nodes Dist2Nodes Distance between two nodes
Divergence Div Divergence
Dynamic Pressure PresDynam
Element to Node ElemToNode Make node-based variable from element-based variable (via average)
Energy, Total EnergyT Total Energy
Enthalpy
Entropy
Flow Integrated flow through 1D/2D part
Flow Rate FlowRate
Fluid Shear Stress FluidShear Fluid shear stress
Fluid Shear Stress Max FluidShearMax Max of fluid shear stress
Force Force Vector
Force, on 1D part Force1D Force Vector on 1D part
Gradient Grad 3D gradient of a variable
Gradient Approximation GradApprox Linear, closed-form gradient approximation
Gradient Tensor GradTensor 3D tensor gradient
Gradient Tensor Approximation |GradTensorApprox |Linear, closed-form tensor gradient approximation

Helicity Density

HelicityDensity

Helicity Relative

HelicityRelative

Helicity Relative Filtered

HelicityRelFilter

Iblanking Values

IblankingValues

Scalar that is the iblanking flag per node

Kinetic Energy

KinEn

Kinetic energy

Length Summed length of all 1D elements
Line Integral IntegralLine Integral over 1D elements

Log of Normalized Density DensityLogNorm

Log of Normalized Pressure PresLogNorm

Log of Normalized Temperature |TemperLogNorm

Mach Number

Mach number

Make Scalar at Elements

MakeScalElem

Scalar created, by placing a constant value at each element

Make Scalar at Nodes

MakeScalNode

Scalar created, by placing a constant value at each node

Make Vector MakeVect Build a vector variable from scalars

Massed Particle MassedParticle Massed particle scalar

Mass Flux Average MassFluxAvg

Maximum Max Find spatial max of variable over part(s) at current time

Minimum Min Find spatial min of variable over part(s) at current time

Moment Moment component of a force component based on the current position
of the Cursor Tool. This is a constant.

Moment Vector MomentVector Moment component of a force component at each node of selected
parts. This is a field of vectors.

Momentum Momentum

Node To Element NodeToElem Make an element-based variable from node-based (via average)

Normal Surface normal vector

Normal Constraints NormC NC

Normalized Density DensityNorm

Normalized Enthalpy EnthalpyNorm

Normalized Pressure PresNorm

Normalized Stagnation Density | DensityNormStag

Normalized Stagnation Enthalpy |EnthalpyNormStag
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Function Abbreviation (if Description

any)

Normalized Stagnation Pressure |PresNormStag

Normalized Stagnation Temp. TemperNormStag

Normalized Temperature TemperNorm

Normalized Vector NormalizeVector Vector field expressed as unit vectors.

Offset Field OffsetField Offset distance field (from boundary)

Offset Variable OffsetVar Variable Value offset from boundary of part into the field (placed on

boundary)

Pitot Pressure PresPito

Pitot Pressure Ratio PresPitoRatio

Pressure Pres Pressure

Pressure Coefficient PresCoef

Rectangular To Cylindrical Vector|RectToCyl Calculate vector in cylindrical coordinates

Shock Plot3d ShockPlot3d

Sonic Speed SonicSpeed

Spatial Mean SpaMean Mean of a variable over a part

Speed Magnitude of velocity

Stagnation Density DensityStag

Stagnation Enthalpy EnthalpyStag

Stagnation Pressure PresStag

Stagnation Pressure Coefficient |PresStagCoef

Stagnation Temperature TemperStag

Stream Function Stream Stream

Surface Integral

IntegralSurface

Integral over 2D elements

Swirl Swirl

Temperature Temperature

Temporal Mean TempMean Mean of a variable over time
Tensor Component TensorComponent |Component of a tensor variable

Tensor Determinant

TensorDeterminant

Determinant of a tensor variable

Tensor Eigenvalue

TensorEigenvalue

Eigenvalue of a tensor

Tensor Eigenvector

TensorEigenvector

Eigenvector of a tensor

Tensor Make

TensorMake

Make tensor from variables representing components

Tensor Tresca

TensorTresca

Tresca failure theory of a tensor

Tensor Von Mises

TensorVonMises

Von Mises failure theory of a tensor

Total Pressure PressT Total pressure

Velocity Velo Momentum/density
Volume Vol Volume of 3D elements
Volume Integral IntegralVolume Integral over 3D elements
Vorticity Vort Vorticity

Function Abbreviation
Absolute Value ABS
Arccosine ACOS
Arcsine ASIN
Arctangent ATAN
Arctangent (y / x) ATAN2
Cosine CcOos
Cross Product CROSS
Dot Product DOT
Exponent EXP

The following standard math functions are also available:

Function Abbreviation
Greater Than GT
Less Than LT
Log Natural LOG
Log Base 10 LOG10
Root Mean Squared RMS
Round RND
Sine SIN
Square Root SQRT
Tangent TAN

For information on the arguments (and equations), see General Functions or Math Functions in the User Manual.
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Extended CFD Variables

Rather than having to individually create the various common CFD variables, EnSight can automatically make them
available for use if the appropriate basis variables and constants have been provided. This can be accomplished
after loading the model with the Extended CFD Variable Settings Dialog:

1. From either the Variable or the Calculator
Feature Detail Editor, click the Extended
CFD Variables... button.

2. Select the variable name in the list and then
click the appropriate SET button.

For example, select Q1 in the list and then click the
SET button to right of the Density field.

3. After all variables and constants have been
specified, click Show Extended CFD
Variables.

4. Click Okay.

The common CFD variables will now be listed in
the main variables list. Note that they will NOT
actually be computed until activated.

If you have a “standard” PLOT3D Q file, the above
process can be accomplished automatically by
starting EnSight with the “-c£d” option on the
command line.

.- 3 | Show Extended CFD Variables

SEE ALSO

How to Edit Color Maps

User Manual: Variable Creation

Available Variable Type Result
tenperature (%3 Gun Scalar [l
velocity (=3 Gun Vector
Coordinates (=) Gwn Vector
Time (=) Gwn Scalar
7
= ]~
Activate| Activate All| Deactivate| Extended CFD
~yr Variables...

= rondeq G Varabie Serings ]

Select a variable and then select
the appropriate SET button below.

ot Lim
Coordinates
Time

o — |

~l -
Density 1.0000€+00 seT||
{Can be a constant) I . hd
Tatal Energy Per SET
Unit Valume I _I
Ratio of Specific Heats SET
{Can be a canstant) I 1.4000e-+00 _I
Momentum I SET
—— OR —
Velocity I SET

Freestream Mach # | 1.0000e-+00
| 1.0000e+00

1.0000e+00

I 1.0000e+00

Gas Constant
Freestream Density

Freestream Speed
of Sound

Okay

Cancel I

B 2000@® HowTo index
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How To ... Extract Boundary
B 20000 Layer Variables

INTRODUCTION

EnSight can compute the following boundary layer parameters:

boundary layer thickness named: (bl_thickness)

displacement thickness (bl_displ_thickness)
momentum thickness (bl_momen_thickness)
shape parameter (bl_shape_parameter)
skin friction coefficient (bl_skin_friction)

You must have a 2D surface in a 3D field and specify the 2D surface as the parent part(s).

For a complete description of these variables, refer to the User Manual section below.

BASIC OPERATION

--1. Select the 2D parent part(s).

2. Click the Boundary Layer variable icon.:-- (Note: This icon is on the second row of icons.
. Click here if you do not see this icon).---------.-..

File Edit Query View Tools Case

nEE=ED

Select Part(s) To Operate On W(zundary Layer Dependent Variables...l
1-(M/C1) fluid

2-(M/C1) surface g:t:an;nwelj;;l::g Outside

Convergence Criteria I

' Create/Update |

3.Bring up the dialog .- ...........0
defining the necessary

variables by clicking here. | ..o 4. Define either (Density

and Momentum) or

elect a variahle and then select VeIOCity-
he appropriate SET button below.
Density | The variables can be
Energzy . .
epeperay | set by either typing
Coordinates them into the fields, or
Time | selecting them from the
= | listand clicking on the
NOTE: All fields are required, except yon may Set button. ----- :
specify either ((Density and Momentum}, : :
ar Velocity). .
Density i - -------- -------------------:
. Dynamic Viscosity I LE300005 5. Click Okay to finish
6. Choose the method that {Can be a constanty the variable setup. ---.

will be used to determine Momenfum [Momentum
the velocity outside the : Velaeity |

boundary layer. -----------.... [Lowteo0 |
reestream Density 1.0000e-+00

reestream Velocity I 3.0000e-01
This will create the five new :

variables, which can be used for Gancel|

further operations - such as part
coloring.

7. Click Create/Update.........

‘ ? “.. How To Index User Manual Page 1 of 2




How To ... Extract Boundary
W 26000 Layer Variables

OTHER NOTES

Boundary Layer variables do not work with multiple cases.

SEE ALSO

User Manual: Boundary Layer Variables Create/Update
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How To ... Edit Color Palettes

h 20000

INTRODUCTION

All scalar and vector variables have an associated color palette that defines the mapping from variable values to
colors. These palettes can be easily edited to customize the mapping. Color palettes can also be saved to disk and
restored during a subsequent session.

BAsSIC OPERATION

Color Palettes have five basic components:

Levels A palette can have up to 21 Levels at which the variable value is specified. Note that the number
of Levels also controls the number of contour loops created for contour parts that depend on the
variable.

Scale The palette scale controls how variable values are assigned to Levels between the minimum and
maximum. Choices are linear (the default), quadratic (x?), or logarithmic (/log).

Type The palette type controls how color is interpolated across part elements and from Level to Level:
Continuous: Color is linearly interpolated across elements.

Banded: Geometry is colored in discrete bands of uniform color where the band boundaries
are permitted to cross element faces (as controlled by the nodal variable values).

Constant. Each element is colored by the color of the first node of the element.

Limit Fringes Limit Fringes controls how color is set for nodes outside the range of variable values specified by
the palette:

No: Nodes above the range are colored by the maximum color; those below by the minimum
color.

By Model Color: Nodes outside the range are colored by the underlying part color.
By Invisible: Elements whose nodes are outside the range are not displayed at all.
Display Controls how coloring is set when the variable value for nodes / elements are undefined:
Undefined
By Part Color: Color the element by the part color.

By Invisible: Do not display the element.

The default color palette created for each variable has five Levels (with the minimum and maximum set to the range
of the variable at the time step selected when the variable was activated), a linear scale, and is of type Continuous.
The color ramp is a standard spectrum with the five Levels set to (from min to max) blue, cyan, green, yellow, and
red.

EnSight can display multiple color legends in the Graphics Window:

Shaded _|Hidden Line Cuarsor _|Line _|Plane Axis Fast Display ’Legend... Infa...
1. Click the Legend... button on the desktop. .- ----.-......:
[ %= Legend visibility 1]

. . . . Select Below To Change Legend Visibility.

2. Select the desired variable(s) in the list. ------------------ . ——— ge Leg v
L[4} temperature Show Components
{ ) velocity

For vector variables, you can select magnitude (or click Show () Coordinates

Components to be able to select the components as well). ) Time | Ao

To remove a legend:
Repeat1.and 2. above prrrrommoapmnie s st otte ey s il

N *#*Naote: To edit legend values and type, select
or . Edit->Variables Editor in the main menubar.

You can remove all legends by clicking the All Off ; S rk e en s Tt of the e it o
button. .- . il Clase

Color legends have a number of display attributes including size, position, and how/where the variable labels are
formatted. See How To Create Color Legends for details.
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How To ... Edit Color Palettes
" 20000

The Feature Detail Editor for Variables provides access to all aspects of variables. The following shows the
components of the dialog in Advanced Interface mode:

1. Double-click the Color icon in the Feature Icon
bar to open the Feature Detail Editor for
Variables. -----------r-oomiii >

Use the File menu to save and

restore palettes. --------------. . Edit View

Available variable list. A * Result

indicates that the variable is = = .

currently active. Selected . yur Il L L alar . {71} Variable type (constant,
variable is highlighted. - -~~~ . velocity ¢ ) GuriN) Vector <€ | scalar, vector).

Coordinates (= Gen Vector
Time t= Gyn Scalar

- Whether given (Gvn) or
= | computed (Cmp).

Buttons to activate and ;
deactivate selected variables. - . fpmActivate| Activate All| Deactivate| Extended CFD
Variahbles...

Histogram of the distribution of
the selected variable. Provides
control for: :

Minimum Palette Value Slider. < Select component of vector
K | variables

Histogram Scale Adjustment -,
=- Maximum Palette Value

Slider

Overall min/max for the

Max=4.5192e+01
selected variable. - - - - - - - - -2 y> hax e

Crewr Those Slep ;?,ﬁ;,;| i §:mi| %
»

- Palette type (Continuous,

Calculate overall min/max from . Banded, Constant)
Be(gj; tto Ilin(: time s)teps (and 4.8192e+01 ey T3 Continuous i I Palette scale (Linear
update histogram) ........... PRIStRE S . ear,
. . Quaderatic, Logarithmic)
Scale Linear =
Limit -k Limit Fringes toggle
Color palette — click on a label b 4l 1 No _‘T . )
to set the current Edit Level - - - 3.61 1 Fringes i-Display Undefined Regions

Display AI | (By Part Color or Invisible)
Undefined By Part Color 3

# af Levels 5

Number of Levels in the
1 -palette

Edit Level [~ -1-1}&- Current Edit Level

_| Interpalate To Level | 1 | Automatic Level
. -1 1{3-interpolation toggle

i - Variable value assigned to
| current Edit Level

.RGB color assigned to
current Edit Level

Flip Colors
Swap the colors from

top to bottom - ----------- -

Legend Display At‘l‘ributes...ll

‘ 2000 ® HowTo Index User Manual Page 2 of 5




How To ... Edit Color Palettes
" 20000

Changing Color Palettes - Basic Operation:

Variables (or double-click the desired variable in the Main Variables list).  ---------------

By default, the changes you make to a color palette have an immediate effect. For large models, the

response rate for interactive editing (e.g. changing the minimum by moving the Minimum Palette

Value slider in the histogram) can be too slow. To disable this behavior, select Edit > Immediate Modification (in
the Feature Detail Editor) to toggle this setting off. To apply your changes, click the Apply Changes button at the
bottom of the dialog. g ;

1. Double-click the Color icon in the Feature Icon bar to open the Feature Detail Editor for @

File Edit View

| |
=
|

Available Variabkle Type

temperature (%3 Gun(M) Scals
¢ GeniM} Vector
Coordinates (=3 Gun Vector

2. Select the desired ---

variable. Click.-_____ fTine, fxd Gun - Sealar
Activate if it has not ;
been activated. {~ "’
| Activate| Activate All| Deactivate| Extended CFD
Variahles..
3. Select Simple
Interface ----------- N
] Simple Interface I Advanced Interface I |
To change the minimum  § § & sagnitade © % ¥ w2
or maximum: 1| H
4. Grab the Minimum | ‘I m To change the number of
(or Maximum) Palette 1 | nin-0.0000e+00 - -Max=1.8192e+01 | | |

Value slider (the levels:

white vertical bars)- - -
and adjust to the
desired location.

6. Enter new number of
i levels(2to 21) --

Min | 4 g000e+00 v

3.6144e4+01 A% 181920401 | To change the colors

| associated with the

or:

5. Enter new Minimum

(or Maximum). ------ Predefined Palettes values:

EnSightDefaultPalette L -7. Select a new palette
lava_waves -- | and click Restore ---
saturn_pastelyellow to_purple -
grayscale_handed

carnation_red _white P
1.2048e-+H)1 srayscale - | To undo changes from a

hot_metal palette:

reverse_rainhow .-~

8. Select the palette and

* Restore | click Undo Restore ---
Flip Caolors I UndoRestom:k . I

Legend Display Al‘h'ibutes...l
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How To ..
N 20006

Edit Color Palettes

ADVANCED USAGE

1. Double-click the Color icon in the Feature Icon bar to open the Feature Detail Editor for

Variables (or double-click the desired variable in the Main Variables list).  -----------.-.. @

By default, the changes you make to a color palette have an immediate effect. For large models,
the response rate for interactive editing (e.g. changing the minimum by moving the Minimum
Palette Value slider in the histogram) can be too slow. To disable this behavior, select Edit >

Immediate Modification (in the Feature Detail Editor)

to toggle this setting off. To apply your changes, click
the Apply Changes button at the bottom of the dialog.

2. Select Advanced Interface - - - - - _________.

There are several ways to edit a color map.

3. Select the desired variable. Click Activate if |t
has not been activated. .............. ... .. ..

To change the minimum or maximum (and have the
intermediate Levels adjust accordingly):

4. Grab the Minimum (or Maximum) Palette Value
slider (the white vertical bars) and adjust to the
desired location. ............. ... ...

To change the number of Levels:

4. Enter the desired value (between 2 and 21) in
the # of Levels field and press return. -------

Note that this will also change the number of contour,
loops for any current contour parts that depend on the! |

selected variable.

To edit individual Levels: X
4. Select the desired Level: either click on the |
Level label, ---------------"-"--"--~-~--~-~-~-~--

OR enter the Level number into the Edit Level b
field and press return. --------------------

5. If you wish to automatically interpolate the
variable values at preceding (lower) Levels,
toggle on Interpolate to Level and enter the
desired Level to interpolateto. .____________

6. To change the variable value associated with

the Level, enter the new value in the Value field

andpressreturn. - - - - - - ____________

7. To change the color associated with the Level,
enter the new color in the RGB fields OR click

Mix... to open a Color Selector. -------------

File Edit

Available Variable Type Result

velocity \\ { ) GuniMY} Vector
. ||Coordinates (%) Gwn Vector
S| Time A (%) Gun Scalar

tempeTsture (%3 GuniM) Scalar

I~

Activate| Activate Alll Deactivate| Extended CFD||
Variables..

AN
\

Simple Interface I Advanced Interface I

O Hagnitade R QY G2

B,

Min=0.0000e+00 Max=4.8192e-+01
Ll ey Timne Sten ;?sﬁ;,g| i Hmil

Continuouns I

Linear = I

Nao _II

By Part Color i |

Value | Ofnoooemo

1R|0.00 G000 [B[100

B 2000 @® HowTo Index
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How To ... Edit Color Palettes
20000

OTHER NOTES

When a variable is first activated, the minimum/maximum settings for the associated palette are set to the minimum/
maximum values of the variable. Although this is the standard way of initializing color maps, it can result in under
utilization of the palette since typically only one node has the minimum or maximum value. You can override this
default behavior by using the option “-range10” when you start EnSight. This will shrink the palette towards the
median value by 10% off the top and the bottom. In previous releases of EnSight this was the default behavior.

SEE ALSO

How To Create Color Legends, How To Create New Variables, How To Create Contours

User Manual: Variable Summary & Palette and Palette File Formats
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How To ... Get Point, Node, Element,
B 26006 and Part Information

INTRODUCTION

EnSight provides many methods for extracting exact quantitative data from your results. Specific information about
nodes, elements, parts, or arbitrary points can be displayed.

BAsSIC OPERATION

Show Point Information
To show information about an arbitrary point:

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit >
Solution Time Editor...).

2. If you have multiple Cases, select the desired case using Case > casename.
3. Position the Cursor Tool to the desired location.

4. Select the desired part(s) in the Main Parts List. The query will only be successful if the Cursor Tool
is found within an element of a selected part.

5. Select Query > Show Information > Cursor.

The query results will be printed to the Status History area (just above the Quick Interaction area). The
following shows sample output from a point query:

Point (6.19810e-01,2.77589e-01,2.41451e-01)(In Frame 0) Query Information.
Found in structured part # 2.

Found in element # 168379.

Closest node # 1782 (within the element)

Value for Variable density is 9.96230e-01.

Values for Variable momentum are:
x=3.03989e-01,y=-1.42727e-02,z=8.51241e-02,mag=3.16005e-01.

Show Node Information

To show information about a specific node, you must have either given or automatically assigned node labels for your
data. You must also know the number of the node of interest. If you do not know the number, you can display node
labels for the part or, if you know an element that contains the node, you can display element information for the
element (as described in the next section). To show node information:

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit >
Solution Time Editor...).

2. If you have multiple Cases, select the desired case using Case > casename.

3. Select the desired part(s) in the Main Parts List. The query will only be successful if the specified
node is found in a selected part.

4. Select the variable(s) you wish to query in the Main Variables List (only node-based variables will be
queried).

5. Select Query > Show Information > Node. The Query Prompt dialog opens. Enter the ID number of
the desired node in the text field and click Okay.

The query results will be printed to the Status History area (just above the Quick Interaction area). The
following shows sample output from a node query:

Node 123 Query Information.

Coordinates (In Frame 0) are: (-2.00000e+00,0.00000e+00,1.19320e+00)
Found in unstructured part # 1.

Values for Variable velocity are:
x=5.82290e-01,y=3.70160e-02,z=-1.82780e-03,mag=5.83468e-01.
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How To ... Get Point, Node, Element,
B 26006 and Part Information

Show Element Information

To show information about a specific element, you must have either given or automatically assigned element labels
for your data. You must also know the number of the element of interest. If you do not know the number, you can
display element labels for the part. To show element information:

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit >
Solution Time Editor...).

2. If you have multiple Cases, select the desired case using Case > casename.

3. Select the desired part(s) in the Main Parts List. The query will only be successful if the specified
element is found in a selected part.

4. Select the variable(s) you wish to query in the Main Variables List (only element-based variables will
be queried).

5. Select Query > Show Information > Element. The Query Prompt dialog opens. Enter the ID number
of the desired element in the text field and click Okay.

The query results will be printed to the Status History area (just above the Quick Interaction area). The
following shows sample output from an element query:

Element 321 Query Information.

Found in unstructured part # 2.

Type of element is 6 Noded triangle

Number of nodes is 6

Node IDs are: 1050 910 1054 1052 1053 1055
Neighboring Element Information is:

Element neighbor 318 is of type 6 Noded triangle
Element neighbor 322 is of type 6 Noded triangle

Show Part Information
To show information about a part:

1. If your data is transient, set the desired time using the Solution Time Quick Interaction area (Edit >
Solution Time Editor...).

2. Select the desired part in the Main Parts List.

3. Select Query > Show Information > Part.

The query results will be printed to the Status History area (just above the Quick Interaction area). The
following shows sample output from a part query:

Part 2 Query Information.*

Unstructured part.*

Number of nodes 2380*

Minimum coordinate(In Frame 0) is (0.00000e+00,0.00000e+00,0.00000e+00)*
Maximum coordinate(In Frame 0) is (3.80000e+01,1.20000e+01,0.00000e+00)*
Element Information is: *

Element type: 6 Noded triangle, count = 1128.*

SEE ALSO

How To Query/Plot, How To Probe Interactively.

User Manual: Show Information
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How To ... Probe Interactively

n 260000

INTRODUCTION

EnSight provides an interactive query capability that displays variable data in the Graphics Window as you move the
mouse pointer over geometry, as you move the cursor tool within the model, or at specified node, element, ijk or xyz
locations. The probe can display the value directly under the mouse pointer (by interpolating the nodal values of the

applicable element) or search for and display the value at the node closest to the mouse pointer.

BAsIC OPERATION

To probe interactively:

1. Click the Probe Icon (or select
Query > Interactive Probe...). -----

2. Select the desired variable to
display.

3. Set the Query pulldown to
desired operation.

Surface Pick: Interpolate to any picked
position on the surface of the model.

Cursor: Interpolate to location of cursor
tool within the model.

Selsct Part(s) To Operate On
1-(M/C1) Computational mesh

Surface Pick
Cursor
Node

K

Element
XYZ

None

Selectv.ariable(s) Query
{*) temperature # Items 1
() velocity Displayed

{ ) Coordinates A

mtes...

P |Show Components

Clear Selection Display Results Table... Help...

™ G

Node: At a specific node number. --5. Enter a value controlling the number of
UK: At ific 1K locati simultaneous probe markers displayed. Once
- Ataspecilic ocation. this number has been reached, the oldest
Element: At a specific element number. marker is replaced by each new marker.
XYZ: At a specific XYZ location 6. If the selected variable is a vector variable,
' ’ you can specify which component (or the
magnitude) of the variable is displayed.
------- 7. In addition to having the results displayed on
the model in the graphics window, you can
open a table that displays the results
4. If Query is set to Surface Pick, 8. When done, change the Query to None to
you can select: disable interactive probing.
a) whether the probe will snap
to closest node or
b) use exact location. \J
Select Variable(s) ue: urface Pic earc] xae ontinuous
And whether the information will tomperature Q#_Ke:.srf lp : SDispll:\) gog;t Node gi.;khwse e
be sampled: e e Displayed = A
c) when you click the “p” 5
keyboard key or Show Components
d) continuously as you move Clear Selection Display Results Table... Help...
the mouse.
If Query is set to Node, Element, @ - ---rrrmromrrmrrm s
IJK, or XYZ, enter ID or values
needed followed by Enter.
If Query is set to Cursor, move
the cursor tool to desired
location and press the “p”
keyboard key (while the mouse
is in the graphics window).
‘ ? .... How To Index User Manual Page 1 of 2
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Interactively

Probe Display Attributes

Probes are displayed as a marker (sphere) and the query text label. The appearance of the marker and label can be

changed:

1. Click the Display ..

Attributes... button in the
Probe Quick Interaction
area.

E .'nteracﬁve Probe Query Display
| 7 Display ID :

Toggle visibility for the query e
textlabel. ... [ Visible I'fs.lways On Top

iz G B ;
Set the color of the label. —------- I 1.00 I 1.00 I 1.00 MLI

Marker |

Toggle visibility for the probe & - ;0. Size IW_ |
marker. --------eiiiiiiiiiaioonn - :

. Bl100 |¢[100 B[100 | mix..||

Set the color of the marker. ----" "7 :

OTHER NOTES

Toggle visibility for the id label.
(Node id, element id, etc.)

Toggle whether query text
labels are “always on top”
(never hidden by geometry) or
occluded by geometry that is
closer.

Set the radius of all probe
markers.

Note that interactive query actions do not generate corresponding command language!

When in query mode with the Action set to Request, other picking options that use the ‘p’ key are disabled (such as

the picks in Part Mode: Part, Cursor, Line, Plane, and LookAt Point).

The Quick Interaction area contains all the attributes that can be set for Probe Interactively. There is no Probe

Feature Detail Editor.

SEE ALSO

How To Query/Plot

User Manual: Interactive Probe Query
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How To ... Query/Plot

h 20000

INTRODUCTION

EnSight can perform a number of different kinds of queries over time or space. The result is a Query Entity that can
be plotted using EnSight’s built-in Plotting facility or that can be printed as a table or written to a disk file.

BAsSIC OPERATION

One first must create query items, which can be any of the following types:

At Line Tool Over Distance. At Node Over Time

At 1D Part Over Distance. At Element Over Time
At IJK Over Time

At Cursor Over Time
At Minimum Over Time
At Maximum Over Time

By Operating on Existing Queries

Read From An External File

As one of these is selected, the Quick Interaction Area changes to reflect the information needed (such as variable to
use) for the selected type. One can control whether the query entity will be a curve or a scatter plot by the choice for
Variable 1 and 2.

Query entities can be printed to the Status History Area, saved to a file, deleted, or plotted.

Sample Query Creation and Plot (At Maximum Over time)

2. Click the Query/Plot icon (or select
Query > Over Time/Distance...). ----------- ...

File Edit Query View Tools Case Help Current Time - Step(12,000000 Simulstion{(l,4100e-01)
- -— 5 q i
ey - Bl E9 LL :
Select Part{s) To Operate On @ Query Items Sample | placce Select & Query Style ¥
13-(M/C1) guardrail supports u A
14-(M/C1) guardrail supports -> = '
15-(M/C1) guardrail ; 0
16-(M/C1} GROUP: car
P
1
o| Show...| Save...| Delete...
t

Masker Vislbiliey o {vwats : Tiedate Help...

1. Select the part to query.

3. Select the Sample type for the

o 8L 7
4. Select the variable for
8 © | @] Query Items Sample | atMaximum Over Time L
Variable: 1. ................: “ A
e Variable: 1 plastic ¥ 2 None{optional}) ¥
Leave Variable: 2 as None 5 Samples [ 5
and it will default to Time, P Beg/End Time...| Sample By Value
because of sample type. 1
a| Show... Save... Delete...
. t
5. Click Create ---------. Marker Visibility ... Create Uipednte Help...
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h 20000

Query/Plot

6. Click Plot

7. Select the Query Item to

plot. oo
. Ap
8. Click New Plotter. -----------/ QLR LLLLELEELELEEE TR
‘:‘ Show, Save Delete

Note: If any previous plotter has
the correct type, it will show up
in the list and can be selected

instead of creating a new one, if desired.

Platters Of Query’s Type

Rescale plotter when
curve assigned

New !loﬂ\er Delete... Help

The plot will be displayed in the graphics window and will be listed in the Plotters Of Query’s Type list.
For more information on plotting, see the Plotting section towards the end of this How To.

Managing Query Entities

The Quick Interaction area provides various controls for managing existing Query Entities:

List of current Query Entities. :
Selected items are operated !
on by the following actions. .:

Query Items v
Time vs. Maximum pla |-

)
=
W

3

@
=
1)
@
-
i
T
—
-
o
=4
o
=
o
Lo

Plot the selected Query

Entity as described above. --»

Show...| Save...

+C0 = |Mrad D

4 Marke ‘ ibili A
Append the text of the A YK
selected Query Entity to the .~

Status History window. ------ L e

Save the selected Query Entity to a disk file, either as :
xy data or in a formatted report-like manner. ---------- L

XA Save Query Entity To [E3]
Format Formatted
File nar XY Data

File Select...

Okay Cancel

Note that previously created and saved query entities are
restored through the use of the Read From An External
File query Sample option.

Delete the selected Query Entity.

=» Waming [x]

% Do you really want to delete this guery entity?

Okay Cancel

Delete...

Sample | 5t Line Taol Over Distance ¥

Variable: 1 [ ctic ¥| 2| None{optional) i

Tool Loe...

Distance Samples 21

Arc Length

Help...

(o][]

=m EnSight Message Window

Time ws, Maximum plastic

VYalue

L0000 +00
L0000 +00
L 35830e-01
+31500e-01
LE0520e-01
LB8620e-01
,98560e-01
L81520e-01

Time{Sim,}
LO0000e+00
L17500e-02
LE3E000e-02
L52500e-02
L 700002 -02
LA7E00e-02
L0E000e-02
L 225800e-02

[l WA R =S SR )
[ R EN [ a )

Close Save Text To File Clear Text

L Update the selected query when any of
its attributes or have been modified.

Ceeees For various queries, marker visibility, as
well as size and color can be controlled
here as well.

=" Query Display Attributes [%]
R oo G100 Bli00

Size | | po00e+00

Cloze
L Il

B 2000 @® HowTo Index
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Over Distance Queries

EnSight can perform queries at uniform points along the line tool or at nodes along a 1D part. One-dimensional parts
include model parts consisting of bar elements, 1D (Line) Clips, and particle traces.

At Line Tool Over Distance.
After selecting the part to query

and clicking the Query/Plot icon | ?;;f:_e;iximum e i :'S‘a\‘::r'::’b;:t:“m Too) Jver Divienes . 0

i BIDistance v=. plastic for] N 3 plastic y None{optional) y
1. Select Sample as “At Line ; Disitance Are Length Samples | ) Tool Loc...
Tool Over Distance” ----------} PR EEPPTETPPPIPPPPPPPE = AE Yy
2. Select the variable to ‘l: Show...| Save...| Delete... . :
query over the distance in Y - Marker Visibility - © Create Update Help...

“Variable: 17. -~ oo

Leave “Variable: 2” as None unless you want a scatter
query of two different variables along the line tool.

3. Optionally, select the Distance option desired,
number of points along the line, and modify the tool : _
location if needed. ......... ... ...

4. ClCK Create ... .o

At 1D Part Over Distance.

Select Part(s) To Operate On
13-(M/C1) guardrail supports
13-(M/C1) guardrail supports -»

Q| Query Items Sample | At 1D Part Over Distance v
= g
e
. r : i
15-(M/C1} guardrail ¥ ‘Distance  Arc Length: Multiple ' 5 ooumulation
: : >
P
1
o
t

[Distance vs. plastic for] ' YVariable: 1

plastic v 2 None{optional} ¥

P |16-(M/C1} GROUP: car ‘ Segments B?’_ -
Query Origin...~g “o 52"

Show...| Save... Delet\e...i D
Marker Visibility - : Create U.pdat\e Help...

3. Select the variable to query in “Variable: 1”
4. Optionally modify Distance, origin and multiple segment attributes............. B

B, CIICK CI@ALE. -« - - e e e et oot

For the two over distance query types, the variable is plotted against the selected “Distance” metric. The node with
the lowest node ID number is queried first. Since the nodes for 1D part over distance are not necessarily evenly
spaced, the reported distance is one of the following:

Distance In Setting Reported Distance
Arc Length The distance along the part from the first node to each subsequent node (i.e. the
sum of the 1D element lengths)
X Arc Length The X coordinate value of each node accumulated from the start
Y Arc Length The Y coordinate value of each node accumulated from the start
Z Arc Length The Z coordinate value of each node accumulated from the start
From Origin The distance from the origin
X From Origin The X distance from the origin
Y From Origin The Y distance from the origin
Z From Origin The Z distance from the origin

If the 1D part contains more than one set of contiguous 1D elements (such as a particle trace from a Line emitter), the
resulting query will contain one plot entity for each set.
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Over Time Queries

For transient dataset, EnSight can query the variable values over a range of time at a particular node, element (or
specific IJK coordinate for structured data) or an arbitrary point. You can also search the minimum or maximum of a
variable over all nodes over a time range.

At Node Over Time

After selecting the part to query Queory Ttoms Samble | At Nods Over Timne =

L . Q
and clicking the Query/Plot icon | l\! tablos 1 = = -
e ’,' v a g _e> displacement ¥ None{optional}) ¥
r . X
¥

1. Select Sample as “At Node

Samples [ o Node ID [ 149 -
Over Time” ---------vommmmemeeea b 2 : A S
. Beg/End Time...| Sample By \;lue

2. Select the variable to query Show...| Save...| Delste..|:

over time in “Variable: 1”.----. Marker Visibility ... Create . Update " Help...

Leave “Variable: 2” as None
unless you want a scatter query of two different variables over time.

3. Enter the Node ID. -« -.oo o o oo

4. Optionally, change the number of Samples (defaults to number of time
steps), and whether to sample by Value of FFT. ... -................... ... ...

B CHCK CrEAtE .- e oo e e e e

At Element Over Time
After selecting the part to query

L. . Q| Query Items Sample | 4t Element Over Time ¥
and clicking the Query/Plot icon | u b : s :
€ | 3Pt ‘- clem_plastic ¥ None{optional}) ¥
1. Select Sample as “At ; . :Samples | 9y ‘Element ID | a5 -l
ime” B -
Element Over Time” ----------igt oo * Beg/End Time...| Sdmple By ‘vralue
1 : -
2. Select the variable to query p Show...| Save..| Delete...|: : :
over time in “Variable: 1”.- - -: Marker Visibility - Create A © Update * |Help...

Leave “Variable: 2” as None
unless you want a scatter query of two different variables over time.

3.Enterthe Element ID.. ..« ..ouomom o L

4. Optionally, change the number of Samples (defaults to number of time
steps), and whether to sample by Value of FFT. ----------------oooooooonn e

B, ClICK CF@ALE -« -« ce e e e et

At IJK Over Time
After selecting the part to query

el ' Q| Query Items Sample | &t [TK Over Time T

and clicking the Query/Ploticon | u .

@ '.",_\{a_l?‘_’]f’!eg node_scalar | 2 None{optional) ¥
13 r .
;I_). Sel:_f:t S,::\mple as “AtUK | & ’ iSamples [ 39 I[ 1 I3 K[ 3 .
A I pl : |Beg/End Time...| Sample By Yalue :

2. Select the variable to o| Show..| Save..| Delete...|: .

t

o : .4 . . o
query in “Variable: 1”. -...... Marker Visibility = Create A : Update : Help...

Leave “Variable: 2" as None : :
unless you want a scatter query of two different variables over time. e R

3. EnterIJKforthepoint.--------------------------------------------------------i-..i...............f

4. Optionally, change the number of Samples (defaults to number of time
steps), and whether to sample by Value of FFT.- .- -coovveniiiainl

B, ClICK CF@ALE -« -« -« e e et et
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At Cursor Over Time
After selecting the part to query

and clicking the Query/Plot icon | Q ,sﬁc (PC § 'S::I::M‘:tlcumr _Owr T \ I

e oo | plastic ¥ None{optional}) ¥
1. Select Sample as “At ; Samples | 5 » Point/Cursor Location... SSULLLLLLLLL
Cursor Over Time” ~-----------| P ------------------- : Beg/End Time... ‘Sqmple By ;alue :
2. Select the variable to query ‘1, Show...| Save...| Delete... .
over time in “Variable: 1”.----- Y - Marker Visibility ... A Create Update Help...

Leave “Variable: 2” as None
unless you want a scatter query of two different variables over time.

3. Place the cursor where desired in the model, either through
picking, or other transformation methods. (Can get to the : : .
Transformation Editor through the Point/Cursor Location ... button.) - - .. Ceeend R EETEREPEPREPEPR

4. Optionally, change the number of Samples (defaults to number of :
time steps), and whether to sample by Value of FFT.........................:

5. Click Create

At Minimum Over Time

After §elgct|ng the part to QUErY g Query Items e =
and clicking the Query/Plot icon " | variable [l Y] 2 [Nome(optional) -
1. Select Sample as “At 5 | i Samples [ 4 3
[ - L L el o . -
Minimum Over Time P . Beg/End Time...| Sample By'\?alue
1 . .-
2. Select the variable to query | o| Show...[ Save...| Delete...|

over time in “Variable: 1”.----. Barker Visiility o : Cr\eat\eA : Update Help...

Leave “Variable: 2” as None
unless you want a scatter query of two different variables over time.

3. Optionally, change the number of Samples (defaults to number of
time steps), and whether to sample by Value of FFT.-------------oooeiannnit

B. ClICK CI@ALE -« - - e e e e ettt

At Maximum Over Time
After selecting the part to query

L. . Q| Query Items Sample | 4 ¢ Mayimum Over Time ¥
and clicking the Query/Plot icon | B 2P s
© B s e» plastic ¥ None{optional) ¥
1. Select Sample as “At 5 Samples [ 31
H H b . . .
Maximum Over Time”----------1; Pl . Beg/End Time...| Sample By 'Value
1 a s oo
2. Select the variable to query p Show...||Save...| |Delete...|
over time in “Variable: 1”..... Siarker Vislbility oo 5 Create A . Update Help...

Leave “Variable: 2” as None SO L
unless you want a scatter query of two different variables over time. : :

3. Optionally, change the number of Samples (defaults to number of
time steps), and whether to sample by Value of FFT..------- oot

B. CliCk CrEAte .- oo
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Scatter Query Example

Everything is done like a
regular query except you
select another variable in the
Variable: 2 field, instead of
leaving it as None. .......

Query ltems Sample | &t Node Over Time ¥
lisplacement vs. plasti Variable: 1

plastic v 2 displacement ¥
Samples | g Node ID | 5y

Beg/End Time...| Sawpde By Value

Show...| Save..| Delete...

+C0 = |Mrad D

Marker Visibility - Create Update . Help...

Operations on Existing Queries
You can perform a scaling of an existing query, or a scaling and algebraic addition of two queries.

By Operating on Existing Queries
1. Select Sample as “By T ..

- . . R ‘
Operating On Existing @ Query Items Sample | py Operating On Existing Queries ¥
Queries” -----cceeieiiaaaaal Ul I Time vs. Maximum pla Scal " - -
: ime s, Miniu P F::t\:r 5.0000e-01 cﬁ:‘iﬁ’ ;1me vs. Maximum plasi ¥
2. Select the Query Item and | ¥ FEEGEARL | | Added With ‘ P
set the Scale Factor if you 11) g::tl:r 5.00009.% 1* ‘%;g*: Time vs. Minimum plast ¥
want to scale a SIngle query - o| Show.. Save..| Delete... Tt :'_:'4 - i
- t 5
or - Select both Query Items Masker Vislbiliey o Create o Update Help...
and set both Scale Factors if 7 } :
you want to scale and add ;
algebraically. ... ... .l

3.Click Create ...........oooooi i

Queries From External Sources
You can import previously created and saved (or externally generated) EnSight queries or Dytran time history (.ths)
files.
Read From An External File

1. Select Sample as “Read  .----------------omeiiiei i ees R

From An External File”. ----- @ Query Items Sample | pead From An External File Y

A Ul | Time vs. Maximum pla
2. Click the “Load XY Data : Time vs. Minimum pla Load XY Data From File...
From File ...” button to open || |°-800000"plastic + 0.500
the File Selection dialog, and |p

H 1
selef:t any preVIOl:'SIy saved o| Show... Save...| Delete.. :
EnSight XY data file or a t :
Kasker Visibiliey o ! Create iipdate Help...

Dytran .thsfile. -...............| ... 000 U T
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Plotting

Once Queries exist, they can be easily plotted in a new plotter in EnSight, or if an existing plotter of the correct type
exists, they can be added to the existing plotter.

1. Select the Query Item to be

Query Items Platters Of Query’s Type
pIOtted ---------------------- . 10.000000*displacermen Time vs. Maximum displa Rescale plotter when
XVEL& RIGID MR2 curve assigned

XACC@ RIGID MR2

Time vs. displacement

2. Click the New Plotter
button if a new plotter is
desired. ..o

o= e

. . . Sh | | S ...| Delete... N Platte Delete... Hel
In this case we did not choose: ek il | ik [ it = =

to plot the node query at Node "| """~~~
100 on the Maximum plot.
Instead we created a new plotter. - ------ - ooiiiiis

3. Select the next Query Item to be plotted. -------

Query Items . . Plotters Of Query’s Type

4. Select the existing plotter :
on which to add this query placement : :u"laximum displacement A Rescale plotf\er when
D MR2 : curve assigned
plot. ... D ME2 : A
. lacement for Nod’ll]l) N

In this case, the node query at :
Node 120 is added to the plot :
for Node 100 (which we just
created in step 2. above) - thus: .
the plotter will now have two & ... o
curves on it.

lacement for Node 120

+8 -1 |4ra2 D

Show...| Save...| Delete... New Plotter Delete... Help

Note: the toggle indicated controls whether the plot is automatically rescaled

OTHER NOTES

See XY Plot Data Format in the User Manual for a description of the plot file format.

SEE ALSO

How To Probe Interactively
How To Change Plot Attributes

User Manual: Query/Plot
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INTRODUCTION

EnSight provides a full-featured X-Y plotting system fully integrated with the query and transient data handling
capabilities. Query entities (see How To Query/Plot) are assigned to plotters. Plotters display one or more curves
where each curve is based on the data from a single query entity. If the query entity is changed, the corresponding
curve will automatically update. Plotter attributes (controlling aspects of appearance such as color of curves and
titles, axis labeling, gradation and tick marks, and border/background color) can be edited in Plot Mode.

This article is divided into the following sections:

Anatomy of a Plotter
Create Plotters

Select Plotters and Curves
Move and Resize Plotters
Set Plotter Visibility

Set Title, Background, Legend, Border, Position Attributes

Set Axis Attributes
Set Curve Attributes
Delete Plotters

Anatomy of a Plotter

Plotters are composed of the following fundamental components:

Plot Title

Y Axis Value Labels - - - - BEEEEEEg

Y Axis Gradation- - - - - (R o

Y Axis Subgradation- - - - - JEEEEEE

Y Axis Title----- - §

Plot border (red indicates
that it is currently selected) -

Plot Scale Handle (grab to
scale all except Plot Title
and Legend) ------

Legend
Legend Position Handle

i r l
f HH ni.uﬁﬂﬁ

ﬁl'H ik i i L'
VY “

1!

Curves

-- X Axis Value Labels

X Axis Title

B 2000 @® HowTo Index
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Create Plotters

Plotters are automatically created when you assign a query entity to a new plotter (see How To Query/Plot for
details).

Select Plotters and Curves

When you create a new plotter, it automatically becomes the currently selected plotter (as shown by the border drawn
in the default highlight color). Any action to change plotter attributes always operates on the currently selected
plotter(s) (or the plotter defaults if none are selected). To select plotters:

1. Click Plot in the Mode Selection area to enter Plot mode.
2. Move the mouse pointer into the Graphics Window and click the left mouse button anywhere within

the desired plotter. You can add to an existing selection by holding down the Control key as you click
in additional plotters.

Since plotters may contain multiple curves, it is necessary to select individual curves within a plotter for subsequent
action. If no curves are selected, changes to curve attributes reset the defaults for subsequently created curves. To
select curves within a plotter:

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Move the mouse pointer into the graphics window and click the left mouse button on the desired

curve. You can add to an existing selection by holding down the Control key as you click on
additional curves.

Move and Resize Plotters

Plotters can be easily moved and resized. You can either reposition a plotter with the mouse in the Graphics Window,
or precisely by entering exact values. To move or resize a plotter interactively:

1. Click Plot in the Mode Selection area to enter Plot mode.
2. Select the desired plotter (as described above).

3. To move a plotter, move the mouse pointer into the Graphics Window and into the selected plotter.
Click and hold the left mouse button and drag the plotter to the desired location.

4. To resize a plotter, move the mouse pointer into the Graphics Window and place the it over one corner

or side of the selected plotter. Click and hold the left mouse button and drag the corner or side to the
desired location.

A plotter can also be positioned precisely. See below for details.

Set Plotter Visibility

Selected plotters can be made invisible:

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired plotter(s).

3. Click the Plotter Visibility Toggle to toggle display of the 7y
selected plotters on or off (when not in Plot Mode). ----------- >

Plotters that are currently invisible are displayed dimmed while in Plot mode.
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Set Title, Background, Legend, Border, Position Attributes

Overall attributes of plotters are controlled through the Plotter Specific Attributes dialog:

1. Click Plot in the Mode Selection area to enter Plot mode.
2. Select the desired plotter(s).

3. Click the Graph Attributes icon. .- ...

The Plotter Specific Attributes dialog contains five sections: Title, Background, Legend, Border, and Position. Click
the button at the top to display the corresponding section.

The Title section controls the main title at the top of the plotter (remember to press return after changing a text field):

-4 Plotter Specific Attributes{Title) |@E
Title| Background| Legend| Border| Position
Settitle text Tlﬂil Pressure/Velocity over Time | Insert

Symbol...

Set the size of the title text- - - -+~ -----aaeeatn Size

______ S 5 55.000
Set the text color (either enter new values in R el B Mi
the RGB fields or click the Mix... button to - | 100 1.00 1.00 S

open the Color Selector dialog) - --------------¢

If you desire special symbols, click Insert : T ; I
Symbol, pick the symbol(s), close, then hit R R
return in the title field.

The Background section controls the type and color of the plotter background:

TitleI Backglnundl Legendl Bor\derl Posit‘ionl

Set background type to either None or Solid. .

A solid background is opaque. - -~ -« -« aceiaiaaanns Typg Solid |

If the background type is Solid, set the color R»I oo0 © I oon B I 000 Mix'"l
(either enter new values in the RGB fieldsor ~ :"" "~ I

click the Mix... button to open the Color : Clase . Helmp...
Selector dialog). - - - -+ -+ - saaie e —I . —PI

The Legend section controls the plotter legend text. The actual text in the legend is specific to the individual curves
displayed in the plotter. See Set Curve Attributes below.

Toggle legend visibility -------------cocaaoaes Titlel Backgmundl Legendl Borderl Posiﬁonlg

Settextsize- - #IT Visible Text Size [g5 009

Set origin (with respect to lower left corner . Origin K,I 0.500 ¥ I 0.800
of plotter) - -----vvve e

_ _ Elroo Glroo Blroo MlxI
Set text color (either enter new values in the . | >
RGB fields or click the Mix... button to open ' Cl .
the Color Selector dialog) - - - - -----............ ﬂl
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Change Plot Attributes

The Border section controls the visibility and color of the plotter border:

Toggle border visibility - ------ o e

Set border color (either enter new values in
the RGB fields or click the Mix... button to

open the Color Selector dialog) - ---------.---- .

"I‘itlel Backgmundl Legendl Bor\derl Posiﬁonl
| Visible

Elioo Glieo B0 MlxI
Closel

The Position section controls the size and position of the plotter:

Set the origin of the plotter (with respect to
the lower left corner of the Graphics

WiINdOW). - - -« - e

Set the plotter width/height (0-1 normalized
to the width and height of the Graphics :
Window)

Titlel Backgmundl Leg-endl Bnr\derl Posiﬁonl
OriginX |o.100 ¥ |o0.100

Width | g q90p  Height | 0.200

Clase I

B 2000@® HowTo index
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Set Axis Attributes

Axis attributes of plotters are controlled through the Axis Specific Attributes dialog:

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired plotter(s).

3. Click the Axis Attributes icon.

The Axis Specific Attributes dialog contains three sections: General, X-Axis, and Y-Axis. Click the button at the top to

display the corresponding section.

The General section controls axis width, color, and scaling as well as Gradation and Subgradation marks.

Set line width of axes «--------r-mrrrmemrea

Setcolorof axes - ------- - i

Set auto scaling - when on, the Min/Max values and the
number of gradations (attributes for the X-Axis and Y-Axis) will
be used as suggested values to arrive at pleasing numbers for
the axis labels.

Set line width, style, and color for major gradations (gradations ...

are enabled on a per-axis basis in the X-Axis and Y-Axis

SECHONS) - e

Set line width, style, and color for subgradations
(subgradations are enabled on a per-axis basis in the X-Axis

and Y-AXis Sections) . - ...

Both Axes
Line Width 1 Pixel |
B0 Glroo Blioo | Mix..
- ¥ [ Auto Axis Scaling

[ s Specitc Atwibutes Gerera) |

Generall K—Axisl Y—Axisl

— Gradation/Grid

Line Width 1 Pixel i |Lirue Style  Solid |

R|1.00 Gr|1.00 B|1.00 Mix...

— Sub-Gradation/Sub-Grid

Line Width 1 Pixel i |Line Style Datted |

R|1.00 G|1.00 B'|1.00 Mix...I

Closel Help...I

B 2000@® HowTo index
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The X-Axis section controls the title, value labels, and gradation marks for the X axis. (The Y-Axis section is similar
and is not presented here).

Toggle visibility of the X axis line - - -----------mmommnannn

Set the X origin location of the plot (with respect to the left . Generall X—Axisl Y—Axisl
edge of the plotter) - --------vommmi

Visikle
Set the width of the plot (with respect to the width of the : ‘s Size
PIOHET) - - e e e ee e em e e e e oo e e eee ey Do : Size | 0.750

Set the title of the X axis - - ---------=--mrmmmmmmmmaaaans Title

Set the size of the title of the X axis - ---------------------

Set the color of the title of the X axis. - - - - -« vveeeonnn. .S.iial 55.000
Set the type of axis label: None (show no value labels), All Blioo Sl100 EBl1.00 M
(show value labels at each gradation), or Beg/End (show >I : I : I : LI

only the first and last value labels) - - ------------aaannnnnn Value Lakels

Set the size of the X axis value labels

Linear o |

Set the min/max range of the variable displayed on the X

axis (Note: will be used as exact values only if the Auto Axis - - 4} - 11 ) 0.00008-+00 A% | 1.0000e+00
Scaling toggle under the General Section is off:)- - - - - - - - - Swap Min/Max f
Set the display format of the value labels (or click Format... Format
to select common formats fromalist) - - - - - - - - - - - - - - - - R >I Fog, M
1R G B i
Set the color of the X axis value labels - - - -~~~ -~~~ - - - - - >I 1.00 I 1.00 I 1.00 Ml“'"l

Set the type of gradation: None (no gradation marker), Grid Gradation/Sub-Grad
(a vertical line), or Tick (a mark on the axis at the value label ]

el T a
POSItIONS) - - = - === == - - oo {|Grad Type Tick s | ¥ 255

Set the approximate number of gradations (also dependson ¢ '11/1' aof I
the min/maxrange) - - - - _______________. SubG Type None‘ - | 2 i
|

Set the type of subgradation: None (no subgradation 4
marker), Grid (a vertical line), or Tick (marks on the axis M
between the value label positions) ---------- - __ eSS

Set the number of subgradations between each value label - - - - - - - - - - - - - - - -

By swapping the min and max can swap the positive
direction. - == - - - - - - - 4
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Set Curve Attributes

Curve attributes are controlled through the Curve Specific Attributes dialog:

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired curve(s) by clicking on them in the
Graphics Window (control-click to select multiple curves).

If no curves are selected, any changes are applied to the curve
defaults which will effect any curves created in the future.

3. Click the Curve Attributes iCON. «- -« --cemmmmnoeeeeol

== Curve Specific Attributes [o][x]
Set the description text for the curve (this will appear as the Desc
legend) - SEEE Pressure
Scale X B

If desired, you can apply scale factors to your x and/or y data-------------- >ca ® Y | 1.000000
Set the line Width -« - - - - -« e ee e Scale Y By | 1 npgong
Setthelinestyle .................................................. ‘¢ Line Width 1 Pixel
Setthe line type: -----------mmrmiiiiie e L T e Style  Daotted

None (only curve markers are drawn), : .

Connect Dots (data points are connected by straight lines), *-- o Line Type  Connect Dots

Smooth (a piece wise spline is fit to the data points using the Smooth Sub-points p

number of points specified in the Smooth Sub-points field)

Setthemarkertype---------------------------------------------:_”'. MarkerType

Secal
Set the size of the MArkers - - - -« -« -« oeeeeeeeeeeeeieeeeeeeeeeeeee o ©A | L0000oD
Normalize x and/or y values, if desired. =~ =" === =-rsrsmrsoseoiees - MNormalize Values .4 ¥
Set the color of the CUIVE: - - = - - - v e e e e ol Blioo %looo Plooo Mix...
Clase Help...

Delete Plotters

Existing plotters can be deleted:

1. Click Plot in the Mode Selection area to enter Plot mode.

2. Select the desired plotter(s). Note that deleting a plotter

has no effect on any query
entities that were attached
to the plotter

3. Click the Delete icon.

Select All

You can select all curves or all plotters.

=+ Plot Selection Options

Select All Curves |

Select All Plotters

Closze
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SEE ALSO

How To Query/Plot

User Manual: Plot Mode
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INTRODUCTION

Results datasets often consist of multiple files. EnSight provides a mechanism to quickly ascertain basic information
about dataset files.

BAsIC OPERATION

To display dataset information:
1. Select Query > Dataset...

Aszzociated Files

Filename Size Date
The Associated Files section displays all & || o, tt1e,erid o517 Fri Mar 10 0S:23:
dataset files giving the size in bytes and | | | eyerarsyypmm Fri Mar 10 Q5:2
last modification date. 1] shuttle,=oln 4536028

I~

E File Specific Information
The File Specific Information section o100
displays information about the file 1

currently selected in the Associated Files " Et'l— theltigelvglue_st“
. . . . E={alv E.s=0ln en=1ry
list. The |nformat|on presented varies shuttle.saln 5 5 enerey
based on the file type and format.

I

General Geometric

Coordinate System Type: Rectangular
The General Geometric section displays
the 3D extent of all geometry as wellas Moclel Em;;‘ﬁs’ Max
the number of nodes and elements. H —4,9717e-01 3,1069e+00
3 -1,2679=—01 1,2720e+00

]
Element Detail
The Element Detail section shows the Element Type Humber of
type and number of all unique element
types in the dataset. Original cells 215612
|
Closel
SEE ALSO

User Manual: Query Dataset
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INTRODUCTION

In EnSight, parts can be colored either by a constant color or based on the value of a variable. Coloring geometry by
variables is one of the simplest and most effective means of visualizing the distribution of a variable.

You can also set a “default” color — all parts subsequently created will automatically be colored by the default color
(described in the Other Notes section below).

This article covers changing the color of a part. See How To Edit Color Maps for information on changing the
mapping from variable values to color.

BAsIC OPERATION
To change a part’s color:

RREEE 2, Click the Color icon.

Eilei Edit Query View Tools Case

®lC] -]

Select Part(s} Ta Operate On Vectar :
Color By Constant Color i Magnitude i |
P | 1-(M/C1} Computational mesh |- Component
2—(2/C1) Clip_plane Mix...I R I io0  © I io0 B I 1.00 e
N Coordinates .
! Time .
7 ; | Apply New Variable | Help... |
..1. Select the desired part(s) in 5 :-- 4. If coloring by a variable, select Variable from
the Main Parts List. ! the Color By pulldown. (You can also click

Apply New Variable to do the same thing.)

3. If coloring by a variable,
select the variable in the Main
Variables List. -------------ooonnnaaol

—OR-

4. If coloring by a constant, either enter the
desired RGB values in the appropriate fields
(remember to press return) or click the Mix...
button to open the Color Selector dialog
(remember to click Apply in the dialog prior to
closing to have your changes applied). -----------:

OTHER NOTES

You can set a default variable that will be used to color all subsequently created parts. To do this, be sure no parts
are selected in the Main Parts list. (To de-select a part, hold down the control key as you click on the selected item.)
Select the desired default variable in the Main Variables list. Click the Color icon to open the Color Quick Interaction
area and click the Update Variable button. Any part created subsequently will automatically be colored by the default
variable.

If you are coloring by a vector variable, you can choose whether to color by the magnitude (default) or one of the
components. Click Magnitude in the Quick Interaction area to select the desired component.

SEE ALSO
How To Edit Color Maps.

User Manual: Color
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INTRODUCTION

The copy operation creates a dependent shallow copy of another part. The new part has its own set of attributes
(except for representation), but shares geometric and variable data with the original. One of the best reasons to
create a copy is to show multiple variables on one part at the same time in a side-by-side configuration. The copy
can be moved independently since new copies are automatically assigned a new frame.

BASIC OPERATION

To create a copy of a part or parts:

1. Select the desired part(s) in the Parts List. A separate copy will be created for each selected part.

2. Select Edit > Part > Copy.

The new copies will be added to the end of the Parts List with “—~ COPY” appended to the part description.

ADVANCED USAGE

The most common reason for needing a copy of a part is to display multiple variables on the same geometry
simultaneously. When you create a copy, a new Frame is also created and the copy is assigned to it (when you
create multiple copies at the same time, a new frame is created for each new copy). Using Frame Mode, frames can
be manipulated (e.g. translated or rotated) independently. See How To Create and Manipulate Frames for more
information.

OTHER NOTES

The dependence of the copy on the original has some important consequences:
1. If you change the visual representation of the original, the representation of the copy will change as well.

2. If you perform a Cut operation on the original, the copy will also be cut. If the operation was Cut & Split, the copy
will only refer to (depend on) the “front” or “inside” portion of the resulting cut part.

3. You cannot delete the original until the copy has also been deleted.
4. Since the part copy only exists on the client, you cannot save a part copy to disk.

If you want to create a dependent, non-shallow copy of a part, you can perform a merge operation on a single part.
This type of copy does now have the same consequences: the resulting “copy” is basically independent except that it
cannot exist without its parent.

SEE ALSO

User Manual: Part Operations
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INTRODUCTION

In many types of analysis, multiple parts are used to distinguish between various components or material types. To
the extent allowed by the particular data format, EnSight maintains this distinction by assigning these entities to
separate model parts. In many cases however, this distinction is no longer useful for postprocessing. When
manipulating parts, you often need to apply the same set of attributes to all of them. If the number of parts to be
treated identically is large, this process can become unwieldy. EnSight provides a group operator to combine multiple
parts of the same type and case into a single part. The selected parts for the group are automatically removed from
the user interface, leaving only the newly formed group part. The operation can be reversed by performing the
Ungroup command.

BAsSIC OPERATION

1. Select the desired part(s) in the Parts List.
2. Select Edit > Part > Group

3. Enter a new part name in the pop-up dialog.

The selected parts for the group are removed from the part list, and a new Group part is added to the end of the Parts
List.

OTHER NOTES

The operation can be reversed by selecting Edit > Part > Ungroup

Grouped parts cannot contain other grouped parts.

SEE ALSO

User Manual: “Part Operations”

‘ 2000 ® HowTo Index User Manual Page 1 of 1




How To ... Merge Parts

h 20000

INTRODUCTION

In many types of analysis, multiple parts are used to distinguish between various components or material types. To
the extent allowed by the particular data format, EnSight maintains this distinction by assigning these entities to
separate model parts. In many cases however, this distinction is no longer useful for postprocessing. When
manipulating parts, you often need to apply the same set of attributes to all of them. If the number of parts to be
treated identically is large, this process can become unwieldy. EnSight provides a merge operator to combine
multiple parts into a single part.

The merge operation creates one new part from one or more selected parent parts. The original parts are
unchanged. If only a single part is selected for the operation, merge will create a “true” copy of the part (as opposed
to the shallow copy that the Copy operation creates), with the only dependence being that the parent must exist.

If you delete any of the original parts after the merge, these components will be deleted from the merged part as well.

BAsSIC OPERATION

1. Select the desired part(s) in the Parts List.

2. Select Edit > Part > Merge

The new merged part is added to the end of the Parts List with the description “Merge of parts #,#,#” where # are the
part numbers of the originally selected parts.

OTHER NOTES

Unlike Copy, merge creates true, server-based parts. Unlike Extract, merge creates parts based on the full, server-
based representation of the part.

If you merge a structured (1JK) part, the resulting part will be unstructured.

SEE ALSO

How To Group Parts.

User Manual: “Part Operations”
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INTRODUCTION

The extract operation is closely tied to part representations. Extract creates a single new part using only the
geometry of the current representation of the selected part(s). For example, if the current representation of a part
consisting of 3D elements is Border, the result of extraction will be a part consisting of all unshared 2D elements (the
surface).

Extract is most often used to reduce the amount of information for a part (e.g. for faster display or for geometry
output) or to create a surface shell part — perhaps for subsequent cutting — of a 3D computational domain.

BAsSIC OPERATION

1. Select the desired part(s) in the Parts List.

2. Select Edit > Part > Extract

The new part is added to the end of the Parts List with the description “Extract of parts #,#,#” where # are the part
numbers of the originally selected parts.

SEE ALSO

See How To Change Visual Representation.

User Manual: “Part Operations”
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INTRODUCTION

It is sometimes desirable to cut parts to, for example, reveal the interior of a solid or remove unwanted or unneeded
portions of a model. EnSight can cut any server-based part and either keep both “sides” or discard one. Any of the
3D tools (Plane, Quadric, or Box) can be used as the cutting surface.

The cut operation produces dependent copies of the parent part. The part(s) resulting from a cut are completely valid
parts consisting of standard elements types. These parts can be used for any operation — including further cuts.

BAsSIC OPERATION

To cut a part:

1. Select the part(s) in the Main Parts list.

2. Click the Clip Feature icon.

:U_s_e_"[_‘:_; Plane Domain Intersect Inl‘%l::]ﬁw
3. Select the desired cutting tool (Plane, : Crinkly
Box, Cylinder, Sphere, Cone, Surface of |:PlaneType Mesh i | Flane Extents | In pnside
Revolution or Revolve 1D Part). - ----...... | WP i g ¥ g Outside
In/Out
4. Position the desired cutting tool in the A
desired location. Create Apply Tool Change Tool Location... Help...

5. Select which “sides” to keep. -----------omommo
Inside: Keeps inside of quadrics or box and “front” of plane.

Outside: Keeps outside of quadrics or box and “back” of plane.
In/Out: Keeps both sides

Crinkly: Keeps all elements that intersect the plane.

For the Plane tool, the inside is the positive Z side of the tool. For the quadric tools, the inside and outside are
intuitive. In the Main Parts list, the original part remains and cannot be deleted without also deleting the cut parts (but
can easily be made invisible if desired). If In/Out was used, two new parts are added to the end of the Main Parts list
with the same name as the original part with “+” added to the name of the Inside part and “-” appended to the name
of the Outside part. If Inside or Outside was used, one new part is created with “+” added to the beginning of the

name.

OTHER NOTES

A part copy cannot be cut. However, if the parent of the copy is cut, the copy will be cut as well (since part copies
share geometry with the parent).

The cut operation maintains the order of the elements, e.g. 3D elements yield 3D elements and 3D quadric elements
yield 3D quadric elements.

The cut algorithm breaks elements intersecting the cutting surface into tetrahedrons. Since there is no transition
zone created between these tetrahedrons and their non-cut neighbors, non-shared element faces are possible.
These non-shared faces can result in undesired lines and/or elements during border and/or feature angle
representations.

If you cut a structured (IJK) part the resulting parts will be unstructured.

Cuts with the Box are not true cuts, but simply a division of all elements that fall completely within the box or not.

SEE ALSO

User Manual: Part Operations
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INTRODUCTION

The delete operation removes selected parts and any parts dependent on them. All information associated with the
parts on both the client and server is removed. Deletion cannot be undone.

BAsSIC OPERATION

1. Select the desired part(s) in the Parts List.

2. Select Edit > Part > Delete
(or click the Delete icon of Part Mode, or click the Delete key on
your keyboard while the mouse is in the graphics window).

3. Confirm the deletion.

OTHER NOTES

In some cases, variables that depend on a deleted part may have to be updated. For example, if you have a variable
such as Area calculated on a set of parts and one of the parts is deleted, the Area variable will automatically be
recalculated.

If you delete a grouped part, all parts in the group will be deleted.

SEE ALSO

User Manual: “Part Operations”
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How To ... Change Visual
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INTRODUCTION

The ability to change part representations is a powerful management tool in EnSight. Not only can you select the
visual representation that best meets your needs, you can also manage memory more effectively. Part
representations exist on the client, the full part is maintained by the server. Using simpler representations both
reduces your client memory consumption as well as improving graphics display speed.

EnSight provides five representation modes for parts:
Full  Every face and edge of every element is displayed.

Border Only unshared faces (for 3D parts) or unshared edges (for 2D parts) are
displayed.

3D Border, 2D Full  Display 3D parts in Border representation; display 2D parts in Full
representation. This is the default representation for all parts.

Feature Angle  Only those edges joining faces in the Border representation for which the
angle between the faces is less than some threshold are displayed.
Feature Angle typically extracts the topological features of interest in a
model.

Bounding Box Only a wireframe box representing the XYZ extents is displayed.

Non Visual No visual representation exists on the client. It is often useful to use Non
Visual as the representation for 3D computational domain parts —
provided you also have some sort of shell part to display the outer
surface.

BAsSIC OPERATION

1. Select the desired part(s) in the Parts List. P
2. Select Part in the Mode Selection area to enter . ‘ '
Partmode. ------------ooii K .
| -+ Part Element Settings [l [x]
3. Click the Element Representation icon to open Aa
the Part Element Settings dialog. «---------------------- 18 Visual Rep. | 3D border, 2D full _ |
.-
4, Select the desired visual representation. : T | PO Angle | 450
Options are: t
9D border, 2D full o Reduce Polygons 2
Border P less mors
- 1 1
Eeai'ure Angle L | le] ygons j ole] ygons
Bounding Box t Close
Full 7 . .
NonVisual B
[+ ]
T
t

5. If desired, you can apply polygon reduction.

Polygon reduction is designed to speed up visualization
processing by thinning out the number of polygons that are
rendered. There is naturally a trade off in image quality and
speed. Note that the original model is not modified, just its
rendered image.
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OTHER NOTES

Note that some derived parts (such as contours or vector arrows) are based on the client’s representation of the
parent part. If the parent’s representation changes, the derived parts will change as well.

You cannot change the representation of a copied part. A copy always exhibits the current representation of the
original part.

A part’s representation can be made “permanent” by creating a new part based on the current representation. See
How to Extract Part Representations for more information.

SEE ALSO

User Manual: Element Representation

‘ ? .... How To Index User Manual Page 2 of 2




How To ... Set Attributes

h 20000

INTRODUCTION

Part attributes control the appearance and behavior of parts. Much of the power of EnSight derives from the broad
range of attributes available and the ease with which they can be changed. Attributes are grouped into three classes:

Creation Creation attributes are unique for each (non-model) part type (e.g. the isovalue of an isosurface). Most (if
not all) of the creation attributes for a part are accessible in the Quick Interaction area after double-
clicking the part in the Main Parts List, or by the main menu structure Edit->Part Feature Detail Editors-
>Model Parts.

General Visibility

Susceptibility to auxiliary clipping

Reference Frame

Response to change in time (active or frozen)
Symmetry options

Viewport visibility

Coloration (by variable or constant color)

Hidden surface toggle
Hidden line toggle

Shading type (flat, Gouraud, smooth)
Transparency
Lighting (diffuse, shininess, highlight intensity)

Node, Element, Node, line, element visibility toggles

and Line Node type (dot, cross, sphere)

Node scale (constant or variable)
Node detail (for spheres)

Node and element label toggle

Element-line width
Element-line style (solid, dotted, or dot-dash)

Element representation on client (full, border, 3D border/2D full, feature angle, bounding box, not loaded)
Element shrink factor
Polygon reduction factor

Displacement Displacement variable
Displacement scaling factor

IJK Axis Display | IJK Axis visibility
IJK Axis scale value

Most (if not all) of the Creation attributes for non-model parts can be edited in the Quick Interaction area by double-
clicking on the part in the Main Parts list. Most display attributes (such as color and visibility) can be controlled via the
icons in Part mode. If required, the Feature Detail Editor can be opened for complete access to all attributes. See
How To Use the Feature Detail Editors for more information.

Since Creation attributes are specific to each (non-model) part type, they are not covered here. Look in the How To
article for the specific part type for details on those particular Creation attributes.

This article is divided into the following sections:

Part Mode Attribute Icons

General Attributes

Node, Element, and Line Attributes
Displacement Attributes
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BAsIC OPERATION

Part Mode Attribute Icons

The Part mode icons can be used to quickly set attributes for parts. To use these controls:
1. Select the desired part(s) in the Main Parts list.
2. Click Part in the Mode Selection area.

3. Click to set the desired attribute:

Part Visibility

Visibility Per Viewport

Shaded Surface
Hidden Line

Line Width Shading Type
Opacity / Transparency Element Labeling
Element Visual Representation

Node Labeling

Visual Symmetry Auxiliary Clipping

Node Representation

Fast Display Representation
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Set Attributes

General Attributes

The General Attributes section in the Feature Detail Editor duplicates many of the controls available in Part mode. To
set attributes using the General Attributes section:

1. Select Edit > Part Feature Detail Editors > part type.

2. In the parts list at the top of the Feature Detail Editor dialog, select the desired part(s).

By default, any changes you make to attributes will take effect immediately. If you wish to “batch” a series of
changes, select Edit > Immediate Modification (be sure to use the Edit menu in the Feature Detail Editor dialog) to
toggle this setting off. When toggled off, a button at the bottom of the dialog becomes active: Apply Changes.
Click it when you are ready to apply a set of changes.

3. Set the desired attribute(s):

Toggle whether the client’s portion
of the part changes if the current :~
time step changes --------------!
Set color by constant or color by
variable

General Attributes

- Visible T\v_’is:il::ulv:: In . Fast
Viewport(s) Display Rep.
P~ Aux. Clip Ref. [,
Frame A
- Active :
Color B last
| etor Y> plastic L
BB 100 Glioo Blroo Mix.

Set the part color if constant

Toggle part hidden surface
Toggle part hidden line ---------.

Set part transparency as “true” l
or with a fill pattern

Set part shading parameters: .

« Diff: diffuse shading — the
amount of light that a surface
reflects. 0is none and 1 is full.

* Shin: Degree of shininess — 0 is
dull and 100 is very shiny.

* H Int: Degree of highlight
intensity — 0 is none and 1 is full.

SEE ALSO

Set Global Viewing Parameters

LN

Visual Symmetry -
Show Original Instance

Type

None

Surface

Shaded Shading Gouraud

Hidden Line

agueness Fill :
| Opaquenesg[109 00 |Fillo
= Lighting
Diff | 910 | Shin| gg0 = HiInt g9

Set part detail representation
(according to Global
ViewingDetailMode):

* Box: part is represented as
bounding box.

* Elements: part is represented
according to Element
Representation

* Points: part is represented as
a point cloud

Set part reference frame

Set part graphical symmetry

Set shading type:

* Flat: color and shading are
constant across elements

* Gouraud: color and shading
vary linearly across elements

* Smooth: color and shading
calculated based on surface
normal interpolated across

elements to simulate a
smooth surface.

B 2000 @® HowTo Index
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Node, Element, and Line Attributes

Node, element, and line attributes control how a part’'s nodes and elements are displayed. Nodes can be displayed
as dots, crosses, or spheres. If displayed as crosses or spheres, the radius can be set by the value of a variable at
that node. To set attributes using the Node, Element, and Line Attributes section:

1. Select Edit > Part Feature Detail Editors > part type.

2. In the parts list at the top of the Feature Detail Editor dialog, select the desired part(s).

By default, any changes you make to attributes will take effect immediately. If you wish to “batch” a series of
changes, select Edit > Immediate Modification (be sure to use the Edit menu in the Feature Detail Editor dialog) to
toggle this setting off. When toggled off, a button at the bottom of the dialog becomes active: Apply Changes.
Click it when you are ready to apply a set of changes.

3. Set the desired attribute(s):

Mode, Element, and Line Attributes
Set visibility of nodes, lines, General Visibility
elements . ---.oooiiiiiiiiiiil » | Nade Line Element
Lakel Visibility
Set node/element label visibility. - - - | Nade Element e .. Set node representation
* Dot: nodes are displayed as
Node Representation ; points.
< ................
Type Dot Beale g tovieny « Cross: nodes are displayed as
) crosses and can be fixed size
Dabadd | 5 Silme By Comsband (size set by the Scale value) or
sized based on a variable (and
Yariainie priastic scaled by the Scale value).
* Sphere: nodes are displayed as
Line Representation spheres and can be fixed size
Set Line width and Style (Solid, Width . (size set by the Scale value) or
Dotted, or Dot-dashed) - - ------.... ... e » 1 Style Solid sized based on a variable (and
scaled by the Scale value).
Element Reprezentation Sphere detail controlled by Detail
Set element representation . value.
(described below) ... o KL Visual Rep; 3D border, 2D full
| Bhrink Factor [ 46 | Sugle | 350
Set element shrink factor (shrink ~ : Reduce Polygons 2 €t A ..1]..Set polygon reduction. Same
elements toward the centroid). - ---: : model, but simpler representation.
less more Trade-off of visual fidelity and
Set angle for Feature Angle polygons peolygons rendering speed.

representation - --.---........

EnSight provides six representation modes for parts (see also How To Change Visual Representation):

Full  Every face and edge of every element is displayed.
Border  Only unshared faces (for 3D parts) or unshared edges (for 2D parts) are displayed.

3D Border, 2D Full  Display 3D parts in Border representation; display 2D parts in Full representation.
This is the default representation for all parts.

Feature Angle  Only those edges joining faces in the Border representation for which the angle
between the faces is less than some threshold are displayed. Feature Angle typically
extracts the topological features of interest in a model.

Non Visual  No visual representation exists on the client. Itis often useful to use Non Visual as the
representation for 3D computational domain parts — provided you also have some sort
of shell part to display the outer surface.

Bounding Box  Displays a bounding box surrounding (and in place of) the nodes and elements.
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Displacement Attributes

In structural mechanics simulations, a common output variable is a set of vectors representing the movement or
displacement of geometry. Each displacement vector specifies a translation of a node from its original position (an
offset). EnSight can display and animate these displacements to help visualize the relative motion of geometry. To set
Displacement attributes (see also How To Display Displacements):

Set Displace By to either None

(no displacement) or the vector . .
variable to use for displacement. _ _ __ Displacement Attributes

Set nodal displacement factor to Factor I 1.0000e+00
reduce or exaggerate a A

displacement

IJK Axis Display Attributes

Model Parts and clips (because they can be structured parts) will have these attributes available. These attributes will
only be applicable to structured parts.

Toggle IJK Axis Visible to display an IJK axis for
the part. - -« o o . LIK Axis Display Attributes

| BN

IJK Axis Visible Scale a 9982&“}0

The scale factor for the IJK Axis triad can be
modified in this field. .. - .. ... il

SEE ALSO

Introduction to Part Creation

User Manual: Part Attributes
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INTRODUCTION

It is often useful to be able to identify specific nodes or elements within your model. EnSight can display node and
element labels in the Graphics Window. If your data provides explicit node or element labels, EnSight will use those
values. Otherwise, default values are used (starting from one). Only model parts can have labels.

Displaying labels on parts with thousands of nodes or elements can obscure both the geometry as well as the labels
of interest. EnSight provides a filtering mechanism to display only selected ranges of labels.

BAsSIC OPERATION

Displaying Node Labels

To display node labels:

1. Select the desired part(s) in the Main Parts list.
2. Select Part mode in the Mode Selection area.

3. Click the Node Label Toggle to display node labels for the
selected part(s). ~---cccciriiiiiiii i

Displaying Element Labels

To display element labels:

1. Select the desired part(s) in the Main Parts list.
2. Select Part mode in the Mode Selection area.

3. Click the Element Label Toggle to display element labels for the
selected part(s). ------cccciiiiiiiiiiiiie

Note that the Node and Element Label toggles also have counterpart toggles in View Mode. The buttons in View
Mode act as global toggles that enable or disable any per-part node or element labels.
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Coloring and Filtering Labels

You can color node and element labels separately to distinguish them from each other and from other objects. You
can also reduce the number of labels shown by displaying only certain ranges. Both of these tasks are accomplished
in the Node/Element Labeling Attributes dialog.

1. From the Main Menu: Select View >
Label Visibility > Labeling Attributes.

To set filters for node labels, select the
desired filter and enter the appropriate
values in the Low and/or High fields. .........

Low | 1 High | 1 g00000 ,

Set the node label color. +++++--++- | 'Red [756~ Grewn 1o | Bine [Top | M. |||

To set filters for element labels, select the

desired filter and enter the appropriate REEE | >
values in the Low and/or High fields. --------: Thresholds —IN"“" -
' Low | 1 High | 4300000

SO | SOTRUUUTSEoooorY NevessTUUURURoN !
Set the element label color. ~~~~-----== == ﬁ‘_"ll 1.op  Green | 1.onp ~ Blue I 1.00 Mix...I
Closel Helpl g

The label filters operate as follows:

None Display all labels.

Low Remove all labels < the Low value
Band Remove all labels >= Low and <= High
High Remove all labels > the High value

Low/High Remove all labels < the Low value as well as those > the High value.

OTHER NOTES

Note that created parts do not have node or element labels.

Another useful technique for reducing label clutter is to use the front and back Z clipping planes to display only a thin
slice of interest. See How To Set Z Clipping for more information.

SEE ALSO

User Manual: Label Visibility
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Set Transparency

INTRODUCTION

EnSight can display parts as transparent using two different methods:

True (alpha)

Fill Pattern

True transparency uses the hardware alpha planes. Although the resulting
visual effect is superior to fill patterns, true transparency is much slower to
draw (especially for large models) since all geometry must be sorted from back
to front prior to each redraw.

Fill pattern or screen-door transparency uses polygon fill patterns to control
where polygons are drawn (typically a fine grid specifying on and off). EnSight
provides three patterns that yield varying degrees of pseudo-transparency.

Transparency is not available on all platforms.

Note: Hidden line overlays cannot be displayed while using transparency

BASIC OPERATION

1. Select the desired part(s) in the Parts List.

2. Select Part in the Mode Selection area to enter
Part mode. ------

3. Click the Transparency Attributes icon to open

the Part Transparency Modification dialog. -------==

For true transparency:

4. Either adjust the slider to the desired
setting or enter a value and press
return............

The Graphics Window will dynamically

Transparent

t the sli i justed.
update as the slider is adjusted | Fill Pattern | Fillo 4 I

For Fill Pattern transparency:

Clnsel

4. Select the desired pattern from the :
Fill Pattern pulldown. ------ - oo

Fill pattern O is solid.

SEE ALSO

User Manual: Part Transparency
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INTRODUCTION

Manipulating parts is one of the fundamental operations in EnSight. Before you operate on parts, they must be
selected in the Main Parts list. Parts can either be selected through standard mouse interaction with the items in the
Main Parts list or selected by picking parts in the Graphics window.

BAsSIC OPERATION

Selecting Parts using the Main Parts List

Items in the Parts List are selected using standard Motif methods:

To ... Do this ... Details ...

Select an item Select (or single-click)  Place the mouse pointer over the item and click the left mouse
button. The item is highlighted to reflect the “selected” state.

Extend a contiguous Select-drag Place the mouse pointer over the first item. Click and hold the left

selection mouse button as you drag over the remaining items to be
selected. Only contiguous items may be selected in this fashion.

Extend a (possibly long) Shift-click Select the first item. Place the mouse pointer over the last item in

contiguous selection the list to be selected. Press the shift key and click the left mouse

button. This action will extend a selection to include all those
items sequentially listed between the first selection and this one.

Extend a non-contiguous  Control-click Place the mouse pointer over the item. Press the control key and

selection click the left mouse button. This action will extend a selection by
adding the new item, but not those in-between any previously
selected items.

De-select an item Control-click Place the mouse pointer over the selected item. Press the control
key and click the left mouse button. This action will de-select the
item.

Open the Quick Double-click Place the mouse pointer over the item and click the left mouse

Interaction Area for a part button twice in rapid succession.

Selecting Parts by Picking

Parts can also be selected by “picking” them in the Graphics window. To select parts by picking:

1. Click Part in the Mode Selection area to enter Part Mode. ‘
-

2. From the Pick pulldown icon, select Pick Part..-----------.-...... -
(Note that this is the default, and this setting will be retained  :-- s 2ick Part
until explicitly changed.) Pick Plane(3 Pts.) Tool Location
Pick Plane(2 Pts.) Tool Location

3. Position the mouse pointer over the desired part in the Pick Plane Tool Origin

Graphics Window and press the ‘p’ key (see below .
regarding how parts are identified). Pick Plane Tool Normal
Pick Line Tool Location

Pick Cursor Tool Location
Pick Center Of Transform
Pick Look/At Point

Note that the picked part is now selected in the Main Parts list.

Parts are identified for picking as follows. If the part (as represented on the client) consists of surface (2D) elements,
a pick will occur if the mouse cursor is over any portion of the surface — even if the part is drawn in line mode and the
mouse was over the middle of the element (and not over one of the visible lines). If the part is drawn as 1D elements
(e.g. the part is in feature angle representation), the mouse must be over one of the visible lines of the part.

By default, when you press the ‘p’ key any previously selected parts are de-selected. Holding down the Control key
as you hit ‘p’ modifies this behavior: if the picked part is not currently selected, it will be added to the existing selection
(so you can select multiple parts by picking), otherwise the picked part is de-selected.
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OTHER NOTES

Selecting View > Show Selected Parts will open a small graphics window that will only display the parts currently
selected in the Main Parts list. This can be helpful when trying to select multiple parts from a large list.

SEE ALSO

User Manual: “Part Selection and Identification”
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INTRODUCTION

In many instances, a modeler can take advantage of symmetry present in a problem to reduce the computational
complexity of a subsequent analysis. EnSight can impart visual realism to such models by mirroring parts around any
or all axes of the part’s reference frame or performing rotational symmetry about any of the axes. Although the
mirrored or rotated portions appear identical to the source part (except for the reflection or rotation), they are only
visual (client-based) and cannot be used for calculation. For example, you cannot start a particle trace in one half
and expect the trace to cross the plane of symmetry into the other half (although you can make the particle trace part
symmetric as well).

EnSight also provides “true” or “computational” symmetry operations (mirror, rotational, translational) as an attribute
of the part’s reference frame. With computational symmetry, you can trace particles across a periodic boundary.

Both types of symmetry (visual or computational) are based on the part’s reference frame. Although you can use
simple visual or computational symmetry without having to manipulate the frame, more advanced usage of symmetry
could require a working knowledge of frames. See How To Create and Manipulate Frames for more information.

BAsSIC OPERATION

Visual Symmetry

Visual symmetry is an attribute of parts. You can enable display of a mirrored copy of a part into one or more of the
seven octants (opposite of +,+,+) of the part’s reference frame. You can also enable display of a number of rotational
instances about the x,y, or z axes of the part’s reference frame. To display visual symmetry:

Visual Mirror Symmetry:

4 Part Visual Symmetryi@@

Show Original Instance

. . . i Type  Mirror
3. Click the Visual Symmetry icon---------------ooooomn s R

1. Select the desired part(s) in the Main Parts list.

2. Click Part in the Mode Selection area to enter Part mode.

4. Select Mirror from the Type pulldown menu. .............................: Mirror X Mirror XY

5. Select the desired octant(s) fromthe menu. - ------- .ol p | Mirror ¥ Mirror X2

Mirror Z Mirror YZ

Mirror XYZ

Visual Rotational Symmetry: S(- Part Visual Symme“ﬁl@

C1
1. Select the desired part(s) in the Show Original Instance —
Main Parts list. ' :

type [Eotationat ]
2. Click Part in the Mode Selection R |

area to enter Part mode.

e
Angle
3. Click the Visual Symmetry icon gle | 45.00

Instances 1

4. Select Rotational from the Type
pulldown menu. ---------ooooolllld

5. Select rotational axis, instance

angle, and number of instances. ---------:
Cloze

Recall that symmetry is performed with respect to the reference frame of the part. The frame’s axes define the
partitioning of space into the octants that attached parts are mirrored into, or the rotational axis. If the symmetry
operation did not produce the desired effect, it is probably due to the fact that the part's frame is not aligned with the
plane of symmetry, or the rotational symmetry axis, as designed for the model. The solution is to create a new frame,
assign the part(s) to the new frame, and position the frame such that two of its axes lie in the plane of symmetry, or
one of its axes align with the rotational axis. There operations are discussed in How To Create and Manipulate
Frames.
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Computational Symmetry

Computational symmetry can be used for unstructured and structured model parts with periodic boundary conditions.
(Note, it does not work for created parts.) Computational symmetry can handle rotational, translational, and mirror
symmetry. Unlike visual symmetry, computational symmetry actually produces the symmetric geometry and variables
on the server - allowing for more than just visual symmetry.

You enable computational symmetry by selecting the frame, specifying the type (Mirror, Translational, Rotational),
and setting type specific attributes (such as the rotation angle and the number of instances to create). Each part
assigned to the frame will be updated on the server to reflect the specified symmetry.

Note that each new instance of a part created through computational symmetry creates a new part on the server.

To use computational symmetry, you will need to enable Frame Mode if it isn’t already enabled. (Edit > Preferences...
General User Interface - Frame Mode Allowed). Then:

1. Click Frame in the Mode Selection area to enter Frame mode.

2. If the default frame (frame 0) is not correctly positioned for the desired
symmetry operation, create a new frame, position the frame in the
proper location and orientation, and assign the part(s) to the new frame.
(See How To Create and Manipulate Frames for details.)

3. Select the desired frame.

4. Click the Computational Symmetry Attributes Icon.

The remaining steps depend on the type of symmetry desired.

Mirror Symmetry is similar to graphical symmetry as
described above. :

5. Select Mirror from the Type pulldown. --------- 1. >

Type Mirror — I
6. Select the desired octant(s) from the Mirror In. - - . '
¢ 3 Mirror In
pulldown. - ----omvmm = |

Clnsel Updatpl Helpl

7. Click Update. «—~-----------wmmomo oo

Rotational Symmetry creates instances by rotating,
around the selected axis of the frame, the specified
number of degrees. The selected frame’s axis must
be aligned with the desired symmetry axis.

=+ Frame Computational Symmetry Attributes

5. Select Rotational from the Type pulldown.--------- TYP"L Rotational
6. Select the frame rotational axis. ------------------- > Avis F
7. Set the desired rotation angle (in degrees) in Angle [3 00006101
the Angle field. -~~~ -oomoe el » | 20E
8. Set the desired number of instances inthe ... || Instances|
Instances field (number 1 is the original, set ! Use Periodic File
Instances to 2 to yield one copy).------------: A
9. If a periodic match file is available, toggle Use File Nams |
Periodic File and enter the file name. ........_. .. o Select File
Periodic match files are discussed below.
Closze v Update Help

10. Click Update. ------ - oo T -~
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Translational Symmetry creates instances in the
direction of the specified translation vector. The
translation vector is first rotated by the frame’s
rotation, but is independent of the frame’s origin
location.

5. Select Translational from the Type pulldown:.--- - Type™ Translational i

6. E_nter the desired translation vector in the XYZ x 0.00008+00 b I 000008+ 00 Z I 0.0000e+00
fields and press return. ------- oo =

7. Set the desired number of instances in the
Instances field (number 1 is the original, set
Instances to 2 to yield one copy). -------------

8. If a periodic match file is available, toggle Use Select File...I
Periodic File and enter the file name. .--------:

Clnsel K Update

Periodic match files are discussed below.

9. Click Update. -------------=---=nmmeeeeeee

Periodic Matching for Computational Symmetry

When a model is created with periodic boundary conditions, there is typically a built-in correspondence or “match”
between certain nodes and elements. For example:

The elements defined by nodes 1,2,3 and nodes 1,6,7 should 5
match when rotated about an axis passing through node 1

(perpendicular to the screen). When another instance is

created, node 2 matches with 6 and node 3 matches with 7.

When instances are added to a part, it is desirable to eliminate these duplicate nodes. Without a match file, EnSight
will attempt to find and remove them using a hashing scheme. This method works quite well, but may not find all
duplicates. (Remaining duplicates are usually noticed when the part is in feature angle representation since EnSight
treats elements with duplicate nodes as separate — even if they are coincident.)

Note that if you have a periodic match file you do not need to specify the rotation axis and angle in the Frame
Computational Symmetry Attributes dialog — the value is provided in the file.

A user-supplied matching file can be used to quickly find and remove all duplicates. The match file is a simple ASCII
text file. The file for the example above would be (the text in italics is not part of the file):

rotate_z specifies rotational symmetry and the applicable axis
52.34 the angle of rotation (in degrees)

3 the number of node pairs to follow

11 first node pair

26 second node pair ...

37

See Periodic Match File for more information on periodic match files.

SEE ALSO

How To Create and Manipulate Frames
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INTRODUCTION

Transient data can be animated through EnSight’s flipbook capability. During the flipbook load process, all parts
(both model and created) are automatically rebuilt (if necessary) using the data from each time step in sequence. At
each step, a graphical “page” is created and stored in memory. When the flipbook is active, the pages are displayed
in order as rapidly as the hardware allows (although you can slow it down). You can also step through pages
manually.

The graphical pages can be one of two types: object or image. An object flipbook saves each page as 3D geometry
so you can continue to manipulate the model (e.g. rotate or zoom) during playback. However, for very large models
and/or long sequences, the memory requirements can be substantial. In this case, you can create image flipbooks
that save only the image pixels for each page. Although the size of each page is now fixed, you cannot change the
viewing parameters without reloading the flipbook.

This article covers using the flipbook capability for transient data (and assumes that you have successfully loaded
your transient data). See How To Create a Flipbook Animation for more details on flipbooks. EnSight's keyframe
animation capability also works with transient data and provides a flexible mechanism for synchronizing your
available time steps with the output animation frames. See How To Create a Keyframe Animation for more
information.

BAsSIC OPERATION

Prior to loading the flipbook, you should create all parts of interest (e.g. clips, contours, isosurfaces, etc.). These parts
will automatically be recalculated for each time step. To load a transient flipbook:

1. Click the Flipbook Animation icon
in the Featurelcon Bar. ----------------mmmommmeiei e

2. Be sure the Load Type is 3. Select the desired page type

set to Transient. ---: (Object or Image). --------
: Y .~
4. If desired, reset the current Load Type Transient 1 I Load As Objects |
beginning and ending time.
(Clicking this button will replace | :-- > Adjust Beg/End Time...| Increment Time By [
the Flipbook Quick Interaction area |: . . A
: Record Interactive Iso/Cl o :
with the Solution Time Quick : FroRe Thisrachive e ;—;:i{“v Start..ﬁmitop :

Interaction area. When you are 5& " Sters = &l :
. s T S o Alendify B
done, do step 1 again). ... : g e | _'II 6409 || 0apdtentd Bledify Ban.. |
. . . [T Regen. Ln'.:.*au:iA I Fugwrd, . I Tralate.., I Help... I
5. If desired, you can specify a time All Pages 7 .

increment for the load.

For example, using 0.5 would create
pages representing time steps 0, 0.5, 1,
1.5, 2, 2.5, etc. The in-between steps
are calculated by linear interpolation.

B. ClICK LOA, <<= -=eeemeeeneaeaaeaae e
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The Load Flipbook Status dialog will open and show the progress of the load. You can cancel the load by clicking the
Cancel button and retain all the pages loaded to that point. Once the load is complete, you can run the flipbook:

Load Type  Transient | Load As Objects |
Adjust Beg/End Time...| Increment Time By | 1

Recard Interactive Iso/Cli Brapt O Sie
1. Set the Run Type to Auto. ---------f-------mmmeeeees .pr ¢
Fage Thume

\
, I R Auto A i
The flipbook will begin to run. un Type u_-ll E |o0080 | b.a0dpeebs Modify Run... |

I—Arlale%‘:;as Load I Record... I Delete... I Help... I

You can also step through the pages
manually:

1. Set the Run Type to Step.

2. Click the up/down buttons to
change pages. You can also enter
values in the Page or Time fields
(and press return) to jump to a
SPECIfIC PAGE. .. oo

3. When done, set the Run Type to
Off.

You can control flipbook playback range, speed, and cycle behavior:

1. Click the Modify Run... button to open the Auto Run
Settings dialog.

Current Page: Min | g 000000

Max| 10.000000 |

2. To change the range of displayed pages, enter new

values in the Show From Page and/or Show To Page Show From Page

fields (and press return). ------cocoieiiiie 4|':'-':":'0':":'0
3. To change the display speed, enter a new value in the : .

Display Speed field (and press return).  ----------........0 ﬁ Display Speed IW
A speed of 1.00 represents “full” hardware speed with no
delays; a value of 0.5 is half of full speed. ;- gl Cyele

4. To cycle the page display, click Cycle.

Cycle will replay the pages in reverse order when the last
page is reached.

5. Click Cl0SE WHen dONe. -« -« -« xnrmmemmameae e

Delete
Any type of flipbook can be deleted:

1. Click Delete... in the Flipbook Quick Interaction Editor.
2. Confirm the deletion.

All memory associated with the flipbook is freed.
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ADVANCED USAGE

If you have created transient particle traces (pathlines) and set up a particle trace animation, you can also load a
flipbook and show the particle trace animation synchronized with the flipbook. The trace animation will automatically
play through the time range of the flipbook and stay in sync with the flipbook pages. See How To Create Particle
Traces and How To Animate Particle Traces for more information.

On some Silicon Graphics machines, it is possible to output a flipbook animation in MPEG format. If available, two
new options are listed in the Save Flipbook Pages to dialog: MPEG 320x240 and MPEG 640x480. Note that these
formats cannot be restored into EnSight.

OTHER NOTES

Since both object and image flipbooks build pages from the current set of parts based on their current attributes, if
you make a change (such as color a part by a different variable or create a new part), you must reload the flipbook.
There are exceptions. With an object flipbook, you can make a part invisible while the flipbook is running.

SEE ALSO

How To Load Transient Data

User Manual: Flipbook Animation, Solution Time
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INTRODUCTION

Various types of data can be animated through EnSight’s flipbook capability. During the flipbook load process,
selected parts are automatically rebuilt based on some criteria (such as a delta for a clipping plane). For each step, a
graphical “page” is created and stored in memory. When the flipbook is active, the pages are displayed in order as
rapidly as the hardware allows (although you can slow it down). You can also step through pages manually.

The graphical pages can be one of two types: object or image. An object flipbook saves each page as 3D geometry
s0 you can continue to manipulate the model (e.g. rotate or zoom) during playback. However, for very large models
and/or long sequences, the memory requirements can be substantial. In this case, you can create image flipbooks
that save only the image pixels for each page. Although the size of each page is now fixed, you cannot change the
viewing parameters without reloading the flipbook.

There are four distinct types of flipbooks:

Transient Pages are constructed by stepping from the current beginning to ending
time range and rebuilding all time-dependent parts based on each time
step in sequence.

Mode Shapes Pages are constructed by applying a cosine-driven scaling factor to a
displacement variable.

Create Data Pages are constructed by applying a delta to either a clip part or an
isosurface.

Linear Load Pages are constructed by applying linear interpolation ranging from zero

to the maximum (displacement) vector field value.

This article covers only the “Create Data” type of flipbook. See How To Animate Transient Data for details on
transient flipbooks. See How To Display Displacements for details on mode shape flipbooks.

For more sophisticated animations, use EnSight's keyframe animation capability.

BASIC OPERATION

For each page of the flipbook, a delta value will be applied to all active clip parts and isosurfaces. For clips, the delta
represents a translation vector; for isosurfaces it is an increment to the isovalue. There are two ways to specify these
delta values: either through interactive manipulation or via the applicable Feature Detail Editor for the part. The
former method is discussed below, the latter in the Other Notes section at the end.
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Prior to loading the flipbook, you should create all parts that you wish to animate (clips and/or isosurfaces) and
manipulate the part so that it is in the desired location for the start of the flipbook. To load the flipbook:

1. Click the Flipbook Animation icon
inthe FeaturelconBar. ---------------ormmiii e

2. Be sure the Load Type is 3. Select the desired page type
set to Create Data. --. (Object or Image). - - - - -

Load Type Create Data Load As Ohbjects [

4. Set the desired number of Number of Flipbook Pages to Create |
PAgeS. - T T L R T >

The delta value will be added to the

appropriate entities for each page. o Page Theas :
| B Tepe Step | G| e 1 0 s Bodify Bun..
5. Click Start to begin recording 5
interactive part manipulations...: Regen. Load Feowrd,. fielete.. | | Help..
All Pages 7y :

6a. For clipping plane parts, reopen the Quick Interaction area for the part
(double-click on the part in the Main Parts list).

6b. Toggle on Interactive Tool, move the mouse into the Graphics Window and

interactively position the tool to the desired location for the end of the
flipbook.

6a. For isosurface parts, reopen the Quick Interaction area for the part (double-
click on the part in the Main Parts list).

6b. Change the Interactive Pulldown to Manual and adjust the slider until the
isovalue is as desired for the end of the flipbook.

7. Return to the Flipbook Quick Interaction area (i.e. perform step 1 again).
8. Click Stop to end recording interactive Iso/Clip. - --------------- oo

9. ClCK LOA.
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The Load Flipbook Status dialog will open and show the progress of the load. You can cancel the load by clicking the
Cancel button and retain all the pages loaded to that point. Once the load is complete, you can run the flipbook:

Load Type Create Data

Load Az Objects _l|

Number of Fliphook Pages to Create I i

Record Interactive Isa/Clip < Siart > Soop
1. Set the Run Type to Auto.  -----f-------evomeennes Pags Frane

\
Fun Type Auto .II éll{;,s}{;s}{; I{;,s}{;s}{se-;-{;s} Modify Run... I
You can also step through the 'Ad
pages manually: [T Regen. Load I Recard... I Delete... I Help... I
All Pages

1. Set the Run Type to Step.

2. Click the up/down buttons to change
pages. You can also enter values in
the Page field (and press return) to :
jump to a specificpage. ...l

3. When done, set the Run Type to Off.

You can control flipbook playback range, speed, and cycle behavior:

1. Click the Modify Run... button to open the Auto Run
Settings dialog.

M
2. To change the range of displayed pages, enter new A%| 10.000000

values in the Show From Page and/or Show To Page

Show From Page
fields (and press return). -------oooooeeee e g/l':'":"m':":"]

3. To change the display speed, enter a new value in the e ..
Display Speed field (and press return).  -------ooooooooooon 0 a) Display Speed I‘\IT

A speed of 1.00 represents “full” hardware speed with no =

delays; a value of 0.5 is half of full speed. ;g Cyele

Current Page: Min | g 000000

4. To cycle the page display, click Cycle.

Cycle will replay the pages in reverse order when the last
page is reached.

5. Click Cl0SE When dONe. -« -« -« xnemmammaae e
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Record...

Flipbook images can be recorded to a number of different formats. Available recording file formats:

Apple PICT Flipbook files saved as sequence of Apple PICT files.

JPEG Flipbook files saved as sequence of JPEG files.

TIFF Flipbook files saved as sequence of TIFF files.

PCL Flipbook files saved as sequence of Page Control Language files.
PostScript Flipbook files saved as sequence of PostScript files.

Silicon Graphics RGB Flipbook files saved as sequence of SGI RGB files.

TARGA Flipbook files saved as sequence of TARGA files.
CEI RGB with depth Flipbook files saved as sequence of RGB files with depth.
EnVideo Flipbook files are saved to EnVideo file.
MPEG Flipbook files are saved to an MPEG file.
AVI Flipbook files are saved to an AVI file.
Delete

Any type of flipbook can be deleted:

1. Click Delete... in the Flipbook Quick Interaction Editor.
2. Confirm the deletion.

All memory associated with the flipbook is freed.

OTHER NOTES

Rather than specify the part delta values through interactive part manipulation as described above, you can set the
values explicitly using the Feature Detail Editor for the part. For clip parts:

1. Select Edit > Part Feature Detail Editors > Clips... to open Feature Detail Editor (Clips).
2, Select the desired part in the parts list of the Feature Detail Editor (Clips).
3. In the Animation Delta section, enter the desired values in the X, Y, and Z fields and press return.

For isosurfaces:

1. Select Edit > Part Feature Detail Editors > Isosurfaces... to open Feature Detail Editor (Isosurfaces).
2. Select the desired part in the parts list of the Feature Detail Editor (Isosurfaces).
3. In the Animation Delta field, enter the desired isovalue delta value and press return.

When a flipbook is subsequently loaded, active clips and/or isosurfaces will update based on these animation delta
values.

Since both object and image flipbooks build pages from the current set of parts based on their current attributes, if
you make a change (such as color a part by a different variable or create a new part), you must reload the flipbook.
There are exceptions. With an object flipbook, you can make a part invisible while the flipbook is running.

SEE ALSO

User Manual: “Flipbook Animation” on page 80

‘ 2000 ® HowTo Index User Manual Page 4 of 4




How To ... Create a Keyframe

" 20000 Animation

INTRODUCTION

EnSight’s ability to handle large, transient datasets has led to its use in the production of many video animations of
engineering and scientific data. EnSight uses a keyframe animation system. A keyframe is a set of viewing
parameters that specify a particular view of the scene in the Graphics Window. The view may be notable because of
what is visible, or because the view represents the transition point from one scene to another. Once a set of
keyframes has been selected, EnSight can automatically generate frames to interpolate the viewing parameters
between keyframes for a smooth animation.

The changes to viewing parameters between keyframes are not limited to simple rotations, translations, or zoom
operations. You can also use EnSight's frames capability to move parts independently, e.g. to animate an exploded
view of a complex assembly. You can also animate the global look-from and look-at points for “fly-by” style
animations.

While refining your animation, you can display it directly in the Graphics Window. When complete, you can specify
the output resolution (e.g. for NTSC or PAL video) and set the recording device (e.g. to a disk file).

Although the production of adequate animation is easy, good animation takes experience. A sequence that looks
good on your high resolution workstation screen may look less than acceptable when transferred to VHS videotape.
An object rotating in ten degree increments may be an appropriate speed for your workstation graphics. At thirty
frames per second, however, the rotation will complete in just over a second — too fast for normal viewing. See the
Other Notes section for some additional hints and tips.

BAsSIC OPERATION

All keyframe animation functions are controlled through the Keyframe Quick Interaction area. You can define the
transformations between keyframes, or you can create standard animations

To define you own keyframes:
1. Click the Keyframe Animation icon in the Feature Icon bar. ............_, » |

2. Set all viewing parameters to the desired location for keyframe 1.

3. Click Create
Keyframe to save the Keyframing

first keyframe. ----- o
. Create Keyframe Quick Animations... Delete Keyframe...
Note that the Keyframing

toggle is automatically Run Animation I\ oo Adtrfeaies..
switched on when you .
begin saving keyframes.

Save... Restore... Recard... Help...

4. Change the viewing parameters to
the desired location for keyframe 2.

5. Click Create Keyframe to save

keyframe 2. important Notes!

You can play your animation at any time to
check your results. The animation will play
the keyframe range specified in the Run

From/To fields in Run Attributes... ! If you toggle-off the Keyframing button, any keyframes
6. Click Run Animation to play the . currently defined will be deleted. If you wish to save a set of
animation. ..-.-............................... keyframes, click the Save... button.

You can abort a running animation by moving the mouse into
the animation display window and pressing the ‘a’ key.

7. Continue to change viewing
parameters and click Create
Keyframe until you have saved all
desired keyframes.
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Create a Keyframe
Animation

There are many ways to specify the desired transformations between keyframes. See the following articles for more

information:

How To Rotate, Zoom, Translate, Scale
How To Create and Manipulate Frames
How To Set LookFrom/LookAt

How To Define and Change Viewports

To Create Keyframes using Predefined Animations:
1. Click the Keyframe Animation icon in the Feature Icon bar. ............ .| -
2. Set all viewing parameters to the desired location for keyframe 1.

3. Click Quick Animations... to bring up
the Keyframe Quick Animations
Dialog.

In this dialog you will be able to create
keyframes which define transformations
which will (a) fly the viewer around your
model, (b) rotate your model, or (c) create
exploded views of your parts. Any one of
these, or a combination may be used.

4. Set the number of frames which will be

created

. Acceleration at the first and last
keyframes that will be created isonby ...
default. If you do not want to accelerate/
decelerate toggle these off. ~-~~--~--~-"~"""

. Toggle Fly Around on if you wish to move
the viewer (camera) in a circle. ---------
(a) You can choose Right (start the viewer
moving to the right) or Left.

(b) Specify the number of revolutions.

s

. Toggle Rotate Objects if you wish to rotate
the scene.

You can rotate positively or negatively about
all three axis. For each axis you set the
number of revolutions.

. Toggle Explode View if you want your
parts to be translated in reference to an
origin.
You can specify the origin or set the origin to
the transformation center.

Direction sets the explode direction and can

Sawve...

=+ Keyframe Quick Animations

Tatal Frames

Select one or any combination of predefined animations.

o Explode View

Keyframing

Create Keyframe Quick Animations... |---

Run Animatian oo Abdribabes.

Restore... Record...

(o]

Accelerate at first keyframe

----------------- Accelerate at last keyframe

Fly Around

Starting direction Right Revolutions | § gy

Ratate Objects

Positively about x-axis with revelutions of | | og
Positively about y-axis with revalutions of | ; 5o
Positively about z-axis with revelutions of |, 45

fAbout origin . X |y 9000e+01

Y 5.0000e+00 | Z | 0.0000e+00

Get Transform Center
X

Direction Distanee | | g000e-+01

Create Keyframes Close Help...

be one of: I

X,Y,Z -translate in the coordinate direction

XYZ - translate in the dominant coordinate direction
Radial - translate in the direction from the origin
specified through the part centroid

The part that is farthest from the origin
specified will be transformed Distance units

9. Click Create Keyframes to create the
keyframes which will transform according
to the selections made.
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The following sections provide details on the animation control dialogs opened from Run Attributes... in the
Keyframing Quick Interaction area.

Speed/Actions

The Speed/Actions tab allows you to set the number of sub-frames between each pair of consecutive keyframes as
well as specify run attributes such as acceleration and commands to execute:

1. Click Run Attributes... in the

Keyframing Quick Interaction area __eylame Bun Alnbules r
to bring up the Keyframe Run SpeedHAcﬁnnsl Viewing Window | BEun From/Ta| Transient
Attributes dialog. Use Interactive Iso/Clip

2. Click the Set Speed/Actions tab. ----* Animate Transparency Change

3. Select the desired keyframe to Spline the Translations and Look-From Paoints

edit: either enter the value or use For Keyﬁ'am-,e' 1
the up/down buttons, «-------rrraeereaqbe e

. | Sub-Frame 20 Ta The Next Keyframe
4. Enter the desired number of sub- :*"""""|p~ "t >

frames between the keyframe Hold & Acceleration --------------

selected in s.tep 1 and the next Commaneds To Execute At This Keyframe
(the defaultis 20). ----------------: : T

5. If desired, set the number of : ' v
frames to hold for the keyframe :
(defaultis 1). -----ooooooe D T

6. If desired, enter EnSight :
commands to execute whenthe : | . ... >
selected keyframe is reached. The |
command(s) will be executed :
before the frame is displayed. -----:

Update Commands

Close Help...

7. If you added or changed the
commands to be executed at a
keyframe, click Update : :
Commands. ---------oooooaaoa e 9. Continue by selecting a new keyframe to edit

and click Close when done.

8. If you want the transformation to accelerate out
(or into) the keyframe, toggle Acceleration on.

Use Interactive Iso/Clip

By turning this toggle on, any clip or isosurface interactively moved
during the keyframe will animate.

Animate Transparency Change

By turning this toggle on, transparency changes to parts during the
definition of the keyframes will be part of the animation.

The number of sub-frames controls the speed with which objects transform between keyframes. More sub-frames
yields slower motion.

You can insert any valid EnSight command to be executed at a keyframe. If your command sequence is more than a
few lines, it is best to save the sequence in a file and just enter the command play: filename. There is a special
case of executing a command at a keyframe. If you insert the command shell: filename, The file filename
(which is assumed to be a UNIX executable command) will be executed after each sub-frame and each surrounding
keyframe. In addition, if you are saving animation frames to disk files, the name of the image file just written is
passed to the executable as the first argument. This capability can be used to postprocess the image files, for
example to resize and re-sample an image or copy it to a different location. If this capability is used, the shell:
filename command must be the only command specified.
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Viewing Window

The Keyframe Viewing Window tab allows you to set the size and location of the animation display window:

1. Click Run Attributes... in the Keyframing |- Keyframe Run Attributes(® Normal ns) 1IE3
Quick Interaction area to bring up the Speedr’Acﬁnnsl \&ewing Wi Full Ta| Transient
Keyframe Run Attributes dialog. SRR EEEEEEEELEEEE - ;:AL NTSC

2. Click the Viewing Window tab. ... | FP® — PAL

B A ¥ User Defined
. o : o Bretachod Daplay
Bax 838 Ay

Fave Bailipde hmages

Close < - -; Help...

Normal Use the current Graphics Window L 4. Click Close

(initially 794 x 659)
Full  Use the full screen with no window
borders (typically 1280 x1024)

NTSC Use NTSC video resolution (640 x 480)
and position at the lower-left corner

PAL Use PAL video resolution (720 x 576)
and position at the lower-left corner

User Defined Use the Min/Max X and Y settings

Detached Display Use the detached display and set Min/
Max settings

The Min setting for User Defined specifies the position of
the lower-left corner of the animation window (as an offset
from the lower-left corner of your monitor screen). The Max
setting is the upper right corner of the animation window.
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Run From/To

The Run From/To tab allows you to specify the range of keyframes to play.

1. Click Run Attributes... in the Keyframing -» Keyframe Run Attributes{Run From/To)

Quick Interaction area to bring up the
Keyframe Run Attributes dialog.

2. Click the Run From/To tab.

3. If you wish to limit the animation
playback to certain keyframes set the
Run From and To fields. By default they
are set to cover all of the keyframes you
have created.

Close

Help...
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Transient

If you have transient data you can specify how it will be used during the keyframe animation.

1. Click Run Attributes... in the -+ Keyframe Run Attributes(Transient Data)

Keyframing Quick Interaction area to Speed#Acﬁonsl Viewing Window| Run From/To 'Transient
bring up the Keyframe Run Attributes .- -{-----------------ooooooc

Use Transient Data

dialog. v
. . e || Transient Timeline 1 : New | Delets
2. Click the Transient tab. .- R 4 :
3. Toggle Use Transient Dataon ifyou :| Start At Keyframe [ * End AtKeyframe [ ¢
want to use transient data during the : . .
: : 4+ Units Below Are Time Steps *++
animation. :

) Start Time  Use Begin {r AEEEg - E5)
Transient data does NOT have to be on

: < -
(and should not) to play back a flipbook ~:| End Time 1B DY :

animation during the keyframe animation. : Specify Time Increment | 5 soooo .o
. E 4
-..

4. Timelines allow you to use transient
¥ hen Arrbve A4 BlavtiEnd Thne | Loop

data during each defined timeline.

If the timelines do not cover all of the
keyframes you will have a portion of your
animation with no transient data.

By default a single timeline exists which : ; :
covers all of the defined keyframes. To Close : ; . Help...
create more timelines click New i ; .

5. For each timeline you can specify the begin and
ending time value (either step or simulation time - : : .
See Solution Time dialog). . ........... ... beeenanaans

6. Time will be interpolated such that the Start Time
occurs at the Start At Keyframe and the End Time
will occur at the End At Keyframe unless the Specify
Time Increment is toggled on. If the Specify Time
Increment is on each frame during the timeline is .
incremented by the time indicated. - ---- === --oo oo

If the Start Time or End Time is encountered before the
Start At or End At Keyframes the transient data will either
Loop (go back to the Start Time) or Swing (play in .
FEVEISE). - x v - rx s o r o rmm e

Record...

The Keyframe Animation Recorder dialog specifies the type of recording device:

1. Click Record... in the Keyframing Quick
Interaction area.

XA Keyframe Animation Recorder [l
2. Toggle on Record To File. ---- I+ Record Tao Filel St Fowmgd, | Current Format: Silicon Graphics RGE

3. Select the desired file format || #:ix Prefin :
and options.(see below). ...l ... . ... o L e

4. Provide the File prefix. ------|-...................:

Clasze Help...

5.Click Close. -------oeeeeeunn-. T
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Available recording file formats:

Apple PICT Animation files saved as sequence of Apple PICT files.

JPEG Animation files saved as sequence of JPEG files.

TIFF Animation files saved as sequence of TIFF files.

PCL Animation files saved as sequence of Page Control Language files.
PostScript Animation files saved as sequence of PostScript files.

Silicon Graphics RGB Animation files saved as sequence of SGI RGB files.

TARGA Animation files saved as sequence of TARGA files.

CEI RGB with Z Animation files saved to an RGB file. The depth (Z) values are also saved.
EnVideo Animation files are saved to EnVideo file.

MPEG Animation files are saved to an MPEG file.

AVI Animation files are saved to an AVI file.

Save and Restore
A set of keyframes and related information can be saved to disk and later restored. To save keyframes:

1. Click Save... in the Keyframing Quick Interaction area.

2. Enter the desired file name in the File Selection dialog and click Okay.

To restore previously saved keyframes:

1. Click Restore... in the Keyframing Quick Interaction area.

2. Enter the desired file name in the File Selection dialog and click Okay.

OTHER NOTES

As pointed out in the introduction to this article, high-quality animation takes time and experience. CEl has produced
a great deal of animation over the years and has learned a variety of lessons. In the hope that EnSight users can
avoid many of the pitfalls inherent in the process, many of these lessons and rules of thumb are presented here.

EnSight's keyframe animation methodology is borrowed from the animated film industry. In making animated films,
the master animator defines how the scene will look at certain points in time (the keyframes) and then hands the work
off to an “in-betweener”, with instructions on how many frames to add between each pair of keyframes. The in-
betweener then draws the missing frames. EnSight’s approach is similar with the user as the master animator and
EnSight as the in-betweener. Some of the strengths of this approach include:

1. When keyframing is on, EnSight is not only recording the viewing parameters when you click Create Keyframe, it
also records the actions taken to get from the last keyframe to the current one. This approach permits certain
operations to be performed without ambiguity (such as rotating by 180 degrees or more).

. Each Viewport can be animated independently.
. Flipbooks can be played during an animation.
. Animated particle traces can be played during an animation.

a b~ WODN

. Transient data is easily synchronized with the generated frames. When the animation is run, EnSight will
automatically step through time and recalculate all time-dependent entities.

6. Output can go directly to disk files for later recording, manipulation, or conversion to other formats (e.g. MPEG or
QuickTime).

7. Additional power and flexibility can be achieved since EnSight command language statements can be issued at
keyframes.
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The keyframe capability was designed to enable engineers and scientists to produce quality animation. As such, it
lacks most of the more elaborate controls available in commercial animation packages (which typically cost 2-3 times
more than EnSight). Some limitations:

1. Only transformation parameters (global, frame and camera transforms) are saved through the keyframing
process. Other parameters and part attributes are not interpolated between keyframes.

2. Light sources are fixed in EnSight — they cannot move during the animation.

3. The shading and lighting model used by EnSight is fairly simplistic.

Tips for Video Recording

Animation Holds

Whenever an animation is started or stopped use a “hold” to allow your viewers to establish the visual context of the
scene. A hold of 3 seconds at the beginning and 2 seconds at the end usually works well. For complex imagery,
longer holds may be required. Note that a hold can typically be performed at the recording level — it is not necessary
to have EnSight compute multiple frames for a hold.

Rate Control

The speed at which events occur during an animation is one of the most difficult aspects to master. Viewers become
confused and disoriented if motion is too fast; too slow and your viewer may lose interest. The frame rate for NTSC
(the video format used in North America) is 30 frames per second. Although there is a great deal of variation
(depending on graphics hardware speed and model size), your workstation will typically have a much slower frame
rate. Therefore, what appears to be good speed on your workstation may be much too fast when recorded to video
at 30 frames per second.

Trial and error is one method to determine proper rates. Although you may end up doing some “line test” video
recording to refine your rates, use the method described here to derive good starting values:

. Define all the keyframes.

. Set up the animation to play back at full screen.

. Set up the animation to play only from the first to the second keyframe.

1
2
3
4. Set the number of sub-frames between keyframes 1 and 2 to be 300.
5. Select View > Bounding Box > Static Box.

6

. Using a watch with a second hand, time how long it takes to play the animation. Call this time “T". We know that
it will take 10 seconds to play 300 frames on video. Compute the following:

factor = T/10.

For example, if you find T to be about 12 seconds, then factor is 1.2, which means that the rate you see on the screen
is 1.2 times slower than what you will see on video.

7. Iteratively adjust the number of sub-frames between keyframe 1 and 2 (running the animation after each
adjustment) until you like the rate you see on the screen.

8. Finally, adjust the number of sub-frames by the factor found in step 6. For example, if 150 sub-frames were
required for a good rate of speed, then change the number of sub-frames to 150*factor to see the same rate on
video.

9. Perform steps 3 through 8 for the next set of keyframes.
Transient Data

Animation is particular useful for presenting transient data. However, since both viewing parameters and time can
change simultaneously, the potential for confusing viewers is very high. In general, you should never change both
viewing parameters and time simultaneously. It is typically much better to use transformations in an opening scene to
present the model to the viewer. The transformations should end at a vantage point suitable for viewing the transient
phenomena. At that point, the time-dependent data can be displayed. If you must alter the scene during transient
display, do so with great care to avoid disorienting viewers.

Note that you can animate time-dependent information without transformations by merely creating two keyframes
without performing any transformations between them.
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In many instances, there will not be enough time steps in the simulation to produce an animation of adequate
duration. If the simulation does not involve changing geometries, EnSight can interpolate between time steps
(linearly) to yield additional frames. However, keep in mind that your simulated phenomena is almost certainly not
linear in nature. If you have EnSight generate more than a few interpolating frames between each actual time step,
the resulting discontinuity at keyframes (from the piece-wise linear interpolation) is quite visible in the resulting video.

Frame count

The total number of frames that EnSight will produce during the animation is the sum of all sub-frames plus the
number of keyframes. This is especially important to keep in mind when synchronizing transient data with animation
frames.

Animated Traces

If you display animating particle traces during keyframe animation, you may have noticed that the trace animation
always resets at the beginning of the keyframe animation. However, in most cases it is desirable to have the trace
animation fully in progress when the animation begins. This can be accomplished by creating an additional keyframe
at the beginning of the animation. Set the number of sub-frames between keyframes 1 and 2 to a value high enough
to yield the desired tracer saturation. When you run the animation, set the Run From field to 2 so that the animation
begins generating frames with keyframe 2. At that point, the tracer animation process will have executed once for
each sub-frame between keyframes 1 and 2.

Color

The color gamut (the range of colors a device is capable of displaying) of video (especially NTSC) is significantly less
than that of your workstation monitor. The result is that certain colors that look fine on your workstation cannot be
reproduced on video. Fully saturated colors (especially red and blue which “bleed” across the screen) are particularly
troublesome. However, it is quite easy to de-saturate your images prior to recording. There are actually three ways
to do this:

1. Modify all of the colors in use to de-saturate them. For example, if a color is pure red (1., 0., 0.), change it to be a
more pastel red (.85, .1, .1).

2. Modify the saturation factor in the Image Format Options. A factor of 0.85 is usually good.

3. Create your animation, then de-saturate the images using an image tool such as the one available from the San
Diego Supercomputing Center (it’s free). This will only work, of course, if you are saving animation images to disk
files.

Dark backgrounds work much better than light backgrounds. Black is often the best choice.
Lines

Moving single-width lines have a tendency to “crawl” on video. Use a minimum line width of 2.
Anti-aliasing

Without correction, computer-generated imagery exhibits aliasing artifacts that typically show up as jagged edges.
For our purposes it is sufficient to say that aliasing results from sampling at a resolution too low to capture the “signal”
represented by the underlying geometry. We can only sample our geometry at the available pixels. Since the
effective number of pixels in the NTSC video signal is only one quarter the number of your workstation screen, what
looks fine on your workstation may be less than acceptable on video. Although EnSight provides no direct anti-
aliasing support, there are ways to mitigate this problem.

1. If you are recording images from EnSight directly to a video recorder, use a scan converter (a piece of hardware)
to filter full screen images to NTSC resolution images.

2. If you are recording images to disk files, record them at full screen resolution and then use an image re-scaling
tool (such as izoom on SGI hardware) to down-sample the images to the desired video resolution. This down-
sampling averages several pixels to yield one output pixel, effectively preserving much of the resolution contained
in the original full screen image.

Annotation

The smallest annotation text that can be clearly read on video has a font size of 40. For title sequences, use a size of
about 65.
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If you display parts colored by variables, you should always include the applicable color legend so viewers
understand what the coloration represents. For color legends, it is often sufficient to display just one value at the top
(the maximum) and one at the bottom (the minimum) in addition to the name of the variable. In fact, sometimes just
using “High” and “Low” are sufficient if only the relative magnitudes of the variable are important.

Screen Space

The region of a video display that is “safe” for viewing is typically smaller than your animation display window. You
should plan your scenes such that objects of interest (especially annotation entities) do not come “too close” to the
edge. If you keep these objects within the range (in EnSight viewport coordinates) .06 to .94 for X (width) and .05 to
.95 for Y (height) you should be safe.

Introductory Sequence

Your animation should begin with some title slides explaining the problem domain to your viewers. Try not to put too
many words on any one slide and display each one for at least four seconds.

Next, before displaying your results, provide a sequence that introduces viewers to your model. This sequence
should be long enough and complete enough to orient the average target viewer to your problem. It is difficult to
overestimate the need for this sequence. Without it, viewers are often confused and disoriented for the entire
animation.

Credits

You should always include proper credits on any animation you produce. Even animations initially intended only for
internal consumption often end up shown to broader audiences.

Stretching an Animation

Ten minutes of video requires 18,000 frames. Only after you have created your first animation will you realize that this
can represent a logistical nightmare. In many cases, you can reduce the number of generated frames required using
each frame multiple times. If you record two video frames for each actual frame you have, in effect, slowed your
animation by half since there are only 15 new frames per second. Although 15 frames per second produces less
smooth motion than 30, it is still usually acceptable. Further reduction however, say to 10 unique frames per second,
produces noticeable jerkiness.

The Recording Process

There are three basic ways to go about recording your animation:

1. The cheapest method (and the one that typically yields the poorest results) is to simply record the animation
directly off the workstation. This can be done either by pointing a video camera at the screen or using the built-in
video out signal available on some workstations.

Although this may be suitable for some simple steady-state problems, the resulting video is usually of very poor
quality. Note also that the frame refresh rate is dependent on the complexity of your geometry (which can vary
throughout the animation) and the speed of your hardware.

2. EnSight can also write each generated frame to a disk file. Given the current state-of-the-art in hardware and
software for video production, this is the preferred method. The images can be further manipulated on disk (e.g.
color de-saturation or pixel averaging) prior to recording. If a problem occurred, missing or bad frames can be
regenerated. Tools also exist to convert sequences of image files to popular animation formats such as MPEG and
QuickTime.

3. EnSight can directly output popular animation formats, including MPEG, AVI and its own format - EnVideo.

SEE ALSO

User Manual: “Keyframe Animation” on page 86
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INTRODUCTION

EnSight’'s powerful particle tracing facility can trace massless particles (either steady-state or transient) through flow
fields. Animating the resulting traces often promotes intuitive comprehension of the characteristics of the underlying
flow field. Traces are animated by displaying one or more tracers on all traces of the trace part. A tracer moves
along the path of a trace with length proportional to the local velocity. EnSight provides complete control over all
aspects of the tracers including length, speed, and release interval for multiple pulses.

This article covers particle trace animation and assumes that you have already created one or more particle trace
parts. See How To Create Particle Traces for more information.

BASIC OPERATION

To enable particle trace animation and adjust the animation parameters:

1. Double-click the desired e e—— Smam ........... 0

H H Type Show As ( Animate Animate.. <-----
particle trace part in the e EEE—— T Lo - -
Main Parts list. 'l | Emit...| [ Pick  Restrict To| _I Interactive |

Surface Syrface... Emitter

2. Toggle on Animate in the

Tool Location... |
Quick Interaction area. - --|--- - -l B

Create | Help... |

3. Click Animate to open the Trace Animation Settings dialog. Make changes as desired (remember :
to press return for changes to text fields). ... -...... ...

Set the color of the tracers to either Trace
Color (i.e. the same color as the parent

trace part) or Constant (and set the desired
color using the Mix... button or the RGB
fields. ---ooveeee

Set the line width of the tracers. ----------- ; a

If transient traces (pathlines), set the Start

Time and/or Max Time.. - - - -+ ......ooooo.. . | ATALL LLITU 2. »| 2.3500e-01 M Max Time ;- 1:1 e B

Tracer Time [ no00er00 A Multiple Pulses

Set the tracers length factor (see below). - ----. ... (Length) - Fulse bnbarval 1 ¥R 0

Tracer Delta | | G000e+00
(Speed) 4| 000

Set the tracers speed factor (see below).. . .- ... & .. . T2E7T00 :

Set tracers head representation. Either Tracer Head Representation
None or Spheres. If Spheres, the radius
can be Constant (set by the Scale value) or

ITyFIE None o | | Foale I 4 e D {aeinil I 61
sized by a variable and scaled by the Scale Sime By | Conetant oI Ig,vm,ga;};ﬁ Biome |
value. Sphere detail set via Detail field. -------&4------ :

Click to load good default values to the

Closel
Tracer Time, Tracer Delta, and Pulse

Intervals fields. - --------coo o

Toggle on Multiple pulses and set the :
interval between pulses (see below). ..................
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Animate Particle Traces

Tracer Parameter Descriptions:

Tracer Time (Length)

The Tracer Time (Length) parameter acts as a scaling factor for all tracer lengths
(the higher the value the longer the tracer). Tracer length varies as the local
velocity changes along the trace. For example, the tracer will lengthen as the
leading edge of the tracer moves into a higher velocity region.

Tracer Delta (Speed)

The Tracer Delta (Speed) parameter acts as a scaling factor for the tracer speed
(the higher the value the faster the tracer). The speed of the leading and trailing
tracer edges varies as the local velocity changes along the trace.

Pulse Interval

The interval between successive tracer emissions when in multiple pulse mode
(the higher the value the longer the interval between pulses). Note that the
distance between tracers will increase when the local velocity increases.

ADVANCED USAGE

If you have time-dependent data and have calculated transient particle traces (pathlines), you can enable trace

animation, load a transient flipbook,

and view the animating pathlines simultaneously with the dynamic flipbook. See

How To Create Particle Traces and How To Animate Transient Data for more information.

OTHER NOTES

The parameters in the Trace Animation Settings dialog are not specific to the currently selected particle trace part —
the settings apply to all currently animating particle trace parts.

SEE ALSO

User Manual: Particle Trace Animation
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INTRODUCTION

Every currently active variable has an associated color legend that can be displayed in the Graphics Window. Color
legends provide essential information about images that use parts colored by variable values (color fringes).
Legends are particularly important if the image is to be viewed by others.

Legends are drawn as a vertical color bar with associated variable values. The size and position of the color legend
can be changed. This article discusses changing the appearance of color legends using Annotation mode. To edit
the color palette itself (change colors or change the mapping from variable values to colors) see How To Edit Color
Palettes.

BAsSIC OPERATION

To display a color legend:

1. On the desktop, click the
Legend... button. ---- - ---oooo

File Edit Query View Tools Case
i
(] & B :
Select Part(s) To Operate On Color By Constant Color o Vector o Magnitude
1-(M/C1} Computational mesh omponen
Mix...| B [1o0 | ©[100 | B[r00
N_velocity
Coordinates
Time
Apply New Variable Help...
Shaded _|Hidden Line Cursor [ Line _|Plane Axis _|Bounds Fast Display  Legend... Info...

2. Click the variable legend(s) you

wish to display (or not display).--------------- E E Legend Visibifity

The list contains Iegends for scalar ' Select Below To Change Legend Visibility.

variables and for magnitude of vector T () temperaturs - Bhow Components
i () velocity [

var!ables. The componen.ts of \{ector () Coordinates .

variables will become available in the () Time g All Off

list if Show Components is toggled on...... .. .. .. .. & . ... .. .. ... ‘

More than one legend can be selected
concurrently.

***Nuote: Ta edit legend values and type, select
Edit—>Variables Editor in the main menubar.

***Nuote: Ta edit legend position and style, select
Anno mode on the left of the graphics window,

Clasze

Note: () indicates legend not currently visible,
(*) indicates currently visible legend.
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Resize or Reposition Color Legends

In Annotation Mode, color legends can be grabbed and then scaled or moved:

1. Make a color legend visible as described above.

2. Click Annot in the Mode Selection area. Handles (currently selected)

Like other annotation entities, color legends must be selected prior to
performing an operation. A selected color legend has handles
surrounding the color bar colored in the highlight color (typically green).
Unselected color legends have white handles.

3. Select the desired color legend: move the mouse into the
Graphics Window and click the left mouse button anywhere
within the color bar.

4. To move the color legend, place the mouse pointer within the color bar, click
the left mouse button, and drag to the desired location.

5. To resize the color legend, place the mouse pointer over one of the four
corner handles, click the left mouse button, and drag to the desired size.

OTHER NOTES

Additional icons in Annotation Mode provide control over legend appearance.

Visibility

Visibility of Legends can be controlled in the Legend Visibility Dialog as explained above. Additionally, the visibility of
selected legends can be turned off with the visibility icon in Annotation mode:

1. Click Annot in the Mode Selection area.

2. Select the desired color legend (click the left mouse button
anywhere within the color bar).

3. Click the Visibility Toggle iCOn. ~-----ss-ccormmmeeaeann. uE O

Color of Text and Colorbar Outline

To specify the color of the text and colorbar outline of selected color legends:
1. Click Annot in the Mode Selection area.

2. Select the desired color legend (click the left mouse button
anywhere within the color bar).

3. Click the Coloricon, «-----r--orrmmrmierrrei e eeee > @

4. Specify the desired color with the Color Selector dialog
and click Apply.
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Location

Although you can interactively reposition a color legend with the mouse, you sometimes need to specify the size and
position precisely:

1. Click Annot in the Mode Selection area.

2. Select the desired color legend (click the left mouse
button anywhere within the color bar).

Ohbject

. . . . Locati
3. Click the Object Location icon. -« -« -«---sxs-mrmmmmomoooconn ocation.

= Annotation Item Location [o][x]

Positions are given as a
fraction(0.0-1.0) «f X and Y.

o3 X
4. Enter values for X & Y (lower left corner) and W|dth R 4 m 0.025

and height, and press return. ..................._.. || Width | g2 Height [, 150

Legend Type

To specify the type of selected color legends:
1. Click Annot in the Mode Selection area.

2. Select the desired color legend (click the left mouse button
anywhere within the color bar).

3. Click the Legend Type Pulldown icon and select either
Continuous (the default) or Discrete.  ------------ oottt

Title Position

To specify position of the title of selected color legends:
1. Click Annot in the Mode Selection area.

2. Select the desired color legend (click the left mouse button
anywhere within the color bar).

Title

3. Click the Legend Title Position Pulldown icon and select
either Above (the default), Below, or None.  -----------oooonoe

Text Position

To specify position of the variable value label text of selected color legends:

1. Click Annot in the Mode Selection area.

2. Select the desired color legend (click the left mouse button
anywhere within the color bar).

3. Click the Legend Label Position Pulldown icon and select
either Left (the default), Right, or None.  -------- - ciieioninne
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Text Size

To specify size of all text (title and labels) of selected color legends:

1. Click Annot in the Mode Selection area.

2. Select the desired color legend (click the left mouse button
anywhere within the color bar).

3. Click the Legend Text Size iCOM.

Legend Text Size I a0
4. Enter the desired text size and press return. .

Closel

Text Label Format

To specify the format of all variable value labels of selected color legends:

1. Click Annot in the Mode Selection area.
4 [alu]

2. Select the desired color legend (click the left mouse button
anywhere within the color bar).

3. Click the Legend Label Formaticon.-------------........ : Format Selection List
B Y
4. Either select a pre-defined format from the Format | 1.0000e+00 J
Selection List or enter a new format string in the Legend | Lo0000e+00
Text Format field. ----- -~ - 100

£

I Fo.2e

Legend Text Format

>| Go.2e
Closel

5. Press return in the Legend Text Format field.

Legend Orientation

A legend can be horizontal or vertical.
1. Click Annot in the Mode Selection Area.

2. Select the desired color legend in the graphics window.

3. Click the Legend Orientationicon. ... --........................... > unl

SEE ALSO
How To Edit Color Palettes

User Manual: Annot Mode
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INTRODUCTION

EnSight can display 2D lines with or without arrowheads. These annotations overlay the Graphics Window and are
not associated with any viewport.

BAsSIC OPERATION

1. Click Annot in the
Mode Selection Area.

2. Click New Line from the Mode Icon Bar to
create a new line in the Graphics Window.

SRR

Location in Graphics Window

The location or position of a line may be specified two ways. First, position may be specified
interactively by selecting the line in the Graphics Window (while in Annot Mode) and dragging it to the
desired location.

Second, precise coordinates for placement may be specified. While in Annot Mode, select the
desired line in the Graphics Window. Click Object Location
Attributes (shown at right) in the Mode Icon Bar to open the
Annotation Item Location dialog

Paositions are given as a
Type coordinates in the X, Y, X2, and Y2 fields and then press | fraction{0.0-1.0) of X and Y.
return to specify the location of the end points of the selected || X I 0.250 v I 0.250
line. : :

X2 |0.750 v2 |0.250

Closel

Orientation and Length

The orientation and length of a line may be adjusted interactively. Click on either end of the line (while in Annot
Mode) and drag to the desired location.

Visibility

Visibility of lines can be controlled. While in Annot Mode, select the desired line in the Graphics

Window (note that the color of the center control point will change to the selection color). Clicking Y77
the Visibility Toggle in the Mode Icon Bar will toggle visibility and determine whether that line is n ©

visible when viewing the Graphics Window in other Modes (View, VPort, Part, Plot, Frame). In
Annot Mode invisible lines are drawn in a subdued color.

Color

The color of a line can be specified. While in Annot Mode, select the desired line in the Graphics
Window (note that the color of the center control point will change to the selection color). Clicking ”
Color Attributes in the Mode Icon Bar will open the Color Selector dialog. LLL]
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Line Width
The width of a line can be specified. While in Annot Mode, select the desired line in the E
Graphics Window (note that the color of the line’s center control point will change to the

selection color). Click the Line Width Pulldown in the Mode Icon Bar and select the desired

line width. 1 Pixel
2 Pixels
3 Pixels
4 Pixels
Arrows

Arrows may be placed on lines. While in Annot Mode, select the desired line in the Graphics
Window (note that the color of the line’s center control point will change to the selection color).

Click the Line Arrowhead Pulldown in the Mode Icon Bar to select the desired arrowhead —
configuration. None
On First End
On Second End

On Both Ends

SEE ALSO

User Manual: Annot Mode
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" 20000

INTRODUCTION

EnSight has comprehensive features for text annotation. Not only can you display and position user-specified text,
you can also display text contained in the description lines of some data formats as well as dynamic text that changes
over time.

BASIC OPERATION

1. Click Annot in the Mode Selection Area. --------- -t »

2. Click New Text Attributes from the Mode Icon
Bar to open the Text Annotation Creation REEEE >
dialog.- - ---- - sns

3. Enter the desired text. ~--------c-oooooeees

4. Click New to create the text entity and T
display it in the Graphics Window.--------- |1.

“* Normal .y Superscript s Subscript

Special Coded Ttems

Insert
Special
Ttem

5. To change the script to super or sub, click : Symhbiols
the Superscript or Subscript buttons which : || |Censtant Variable

will insert <up> or <dn> into the string..-----: |{ |Date

| | Geometry Header
4 |Measured Header
The Special Coded Items are discussed below. | |variable Header
| |Part Value
Part Description

5] e

S — |

Text Visibility

Visibility of individual text strings can be controlled. In Annot Mode, select the desired text string in

the Graphics Window (note that the color of the control points will change to the selection color). Ry
Clicking the Visibility Toggle (shown at right) in the Mode Icon Bar will toggle visibility and LR &
determine whether that string is visible when viewing the Graphics Window in other Modes

(Scene, VPort, Part, Plot, Frame). When in Annot Mode, the text will not be completely invisible

but will be displayed in a subdued color.

Color

The color of a text string can be specified. In Annot Mode, select the desired text string in the

Graphics Window (note that the color of the control points will change to the selection color). ”
Clicking Color Attributes (shown at right) in the Mode Icon Bar will open the Color Selector dialog. T
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Location in Graphics Window

The location of a text string may be specified two ways. First, position may be specified interactively
by selecting the desired text string in the Graphics Window while in Annot Mode and dragging it to
the desired location.

Second, precise coordinates for placement may be specified. In Annot Mode, select the desired text ,:;‘:Jaff;r1

string in the Graphics Window (note that the color of the control points will change to the selection sss
color). Click Object Location Attributes (shown at right) to open the
Annotation Item Location dialog.

Positions are given as a
fraction{0.0-1.0) of X and Y.

Type coordinates in the X and Y fields and then press return to specify || x I 0.250 ¥ I 0.250
location of the selected text string Justification Point.
Relative To Viewport I 0

Specify the viewport that the text is to be positioned relative to. If 0, the
position is relative to the graphics window. Closel

Text Justification Point Location

The text Justification Point is shown just beneath each text string while in Annot Mode. It is
this point which is placed by the X & Y coordinates specified in the Annotation ltem Location
dialog. Itis also about this point that the text may be rotated. The point location (just beneath
the text string) may be specified to be left, center or right. In Annot Mode, select the desired
text string in the Graphics Window. Clicking the Text Justification Pulldown (shown at right)
allows you to choose the desired location.

Text Size

The size of text may be specified in two ways. First, the size may be adjusted interactively. In
Annot Mode, grab the Resize Point of the text string (beneath and to the right) and adjust text
to the desired size.

Second, size can be precisely specified. In Annot Mode, select the desired text string in the
Graphics Window. Click Text Size Attributes (shown at right) to open the Annotation Text
Size/Rotation dialog.

Typing the desired font size in the Size field and pressing return will resize

the text. Size
Important Note! The text size specified is relative to the size of the Rotation{Degrees)
Graphics Window. If you increase the size of the Graphics Window, all text |

will also rescale to maintain the same relative size. Closel

Text Rotation

The orientation of text about the text justification point may be specified in two ways. First, the
text may be rotated interactively. In Annot Mode, grab the Rotation Point of the text string
(cross shape above and to the right) and rotate the text to the desired orientation.

Second, orientation can be precisely specified. In Annot Mode, select the desired text string
in the Graphics Window. Click Text Rotation Attributes (shown at right) to open the
Annotation Text Size/Rotation dialog. Typing the desired rotation angle in the Rotation
(Degrees) field and pressing return will rotate the text.
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Special Coded Items

EnSight can automatically build text strings based on information from various sources. To use one of these special
strings, select the desired item from the Special String list, select any required options, and click Insert Special String.

A code will be inserted into the Text field. Click New to create the text entity and display it.

The following special strings are available. If multiple cases are loaded, any reference to parts or variables applies to

the currently selected case (select Case > casename to changes cases)

Symbols

Brings up a symbol dialog. Click on any symbol to insert it at the current character
insertion point of the string. The symbol will be inserted in to the string via a <sy>xxx,
where xxx is the ASCII number for the selected symbol.

Constant Variable

The value of a constant variable (such as Time or Length). Select the variable from the
Constant Variables list and select the desired numeric display format from the Number
Format list.

If the constant variable changes, the corresponding text will automatically update. This
is very useful for displaying the current solution time during a transient animation.

Date

Current date. Example: Wed Jan 1 12:34:56 1997

Geometry Header

The first or second text line of the geometry file of the current case. Select Line 1 or Line
2.

Measured Header

The first line of the measured (discrete) data file of the current case.

Variable Header

The first line (typically the description line) from a variable file. Select the desired
variable from the Variable(s) list.

Part Value

The “value” of a part. Currently only works for isosurface parts where the value is the
corresponding isovalue. Select the isosurface part in the Part(s) list and select the
desired numeric display format from the Number Format list.

Part Description

The description of the part as displayed in the Main Parts list. (Note that you can change
this text by editing the Desc field in the applicable Feature Detail Editor for the part.)

Version

The name and current version number. Example: EnSight Version 6.0.

SEE ALSO

User Manual: Annot Mode

‘ 2000 ® HowTo Index User Manual Page 3 of 3

Create Text Annotation
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INTRODUCTION

EnSight can display bit mapped graphics loaded from disk files. A bitmap can be any image, however, the most
common use is to include a logo or other signature graphic to identify the source of images or animations. Bitmaps
are drawn over all geometric objects in the Graphics Window (at least where the bitmap is opaque), but under all
other annotation entities.

Bitmaps are stored in X Pixmap format. See the Other Notes section for more information.

BASIC OPERATION

To load an XPM format bitmap:

A
1. Select Annot in the Mode Selection Area  -------- - ool > n
n
[+ ]
t

2. Click the Logo Import icon from the Mode Icon Bar to open the File
Selectiondialog. - ---- -~
: Logo
3. Select the desired XPM file and click Okay. LL L

Logo Visibility

Visibility of individual logos can be controlled. In Annot Mode, select the desired logo in the

Graphics Window (note that the color of the border will change to the selection color). Clicking the WA
Visibility Toggle (shown at right) in the Mode Icon Bar will toggle visibility and determine whether LR & ]
that logo is visible when viewing the Graphics Window in other Modes (View, VPort, Part, Plot,

Frame). When in Annot Mode, the logo will not be completely invisible but will be displayed in a

subdued color.

Location in Graphics Window

The location of a logo may be specified two ways. First, position may be specified interactively by
selecting the desired logo in the Graphics Window (while in Annot Mode) and dragging it to the
desired location.

Second, precise coordinates for placement may be specified. In Annot Mode, select the desired logo
in the Graphics Window (note that the color of the border will change to the selection color). Click
Object Location Attributes (shown at right) in the Mode Icon Bar to open the Annotation Item
Location dialog. 3

Enter coordinates in the X and Y fields and then press return to Pasitions are given as a
specify location of the selected logo. fraction{0.0-1.0} of X and Y.

X | 0.450 ¥ o

Closel
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Logo Size

The size of a logo cannot be adjusted interactively but it can be specified precisely. In Annot
Mode, click Logo Size Attributes (shown at right) in the Mode Icon Bar to open the Annotation
Logo Scaling dialog.

Typing the desired scaling factors into the X & Y fields and then
pressing return resizes the selected logo. Scale values are positive real numbers. |

X | 1.000000

1Y 1000000
- Clnsel

OTHER NOTES

The X Pixmap format is a widely used format for storing pixel maps for use in X Windows environments. For more
information on the format, visit http://koala.ilog.fr/lehors/xpm.html.

Please note that EnSight requires that the color values in the .xpm files be hex numbers. Color names cannot be
used. The program “xv” seems to convert them such that Ensight can read them if your application uses color names.

SEE ALSO

User Manual: Annot Mode

‘ 2000 ® HowTo Index User Manual Page 2 of 2




How To ... Customize lcon Bars
" 20000

INTRODUCTION

EnSight uses several sets of icons to group functionality. To suit personal preferences or simplify the interface, the
order of the icons within each set can be changed or icons can be removed altogether (typically eliminating access to
that portion of functionality).

The icon sets correspond to the seven major groupings of function within EnSight: Main Feature (the icons in the
Feature Icon bar) and the six Modes: View, Part, Annot, Plot, VPort, and Frame. By default, EnSight displays
informative text labels underneath each icon in the Mode icon bars. Once the icon functions have been learned,
these can be removed to save space in the icon bar.

BASIC OPERATION

To customize an icon bar:

1. Select Edit > Preferences..., select General User_Interface and click the Modify and Save Icon Layout...
button.

R > | Show Help Lakels For Mode Icons :
: Select the icon bar to change, ALl field=. except the "Menu ID" keywords. can be changed,

The text below is in a simple positional text editor, Just select and change the text,
==MOTE==1 You mnust restart EnSight to see changes to the order of the icons.

Which Icon Bar? Main Feature |‘ """"""""""""""""""""""""""""""

Menu ID Button Mame Vizible Order Description

FEAT_COLOR  "Color” OM 1 "Color Parts” o
FEAT_CHMTRS “Contours” O 2 "Contour”

FEAT_ISOSE “Isosurfaces” OM 2 "Isosurface”

FEAT_TRACE “"ParticlesnTraces” OM 4 "Particle Trace”

FEAT_CLIPS “Clips” OM 5 "Clip”

FEAT_ARROW “VectorsnArrows” OM & "Vector Arrow” ~
FEAT_TEMSOR ~TensorsnGlyshs” OM 18 “Tenzor Glysh”

FEAT_ELSRF “"Elevated“wSurfaces” OM 7 "Elevated Surface”

FEAT_PROFI  "Praofiles” OM 16 "Profile”

FEAT_DWSEF  “DevelopedinSurfaces" O 17 "Developed Surface” v
-] |
Closel Save Asg Default I Eelpl

3. To disable display of the icon help labels, toggle off the Show Help
Labels For Mode Icons button.

To edit, click the left mouse button at the desired location and change the text. Each entry in the list controls one icon
and has the following components:

Menu ID Internal ID. (Included for potential future usage — do not change).

Button Name The name of the icon. (Included for potential future usage — do not change)

Visible status Either ON or OFF.

Order Icon order within the bar.

Description Description printed in the Message Area when the left mouse button is clicked and held on the
icon.

Note that changes will not take effect until the next time you run EnSight. To save your changes, click the Save As
Default button and then click Close. To exit the dialog without saving your changes, just click Close.
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Customize lcon Bars

ADVANCED USAGE

The lists presented in the Icon Bar Preferences dialog are stored on disk as text files in the .ensight7/ directory
(which is located in your home directory). If you prefer, you can edit these files directly with any text editor and the
changes will take effect during your next EnSight session. The files are named as follows:

Main Feature
View

Part

Annot

Plot

VPort

Frame

SEE ALSO

User Manual: Icon Bars

ensight_ feat_panel.def
ensight_view_panel.def
ensight part panel.def
ensight_ annot_panel.def
ensight_plot_panel.def
ensight viewp panel.def

ensight_ frame_panel.def
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How To ... Customize Mouse

B 20000 Button Actions

INTRODUCTION

When the mouse pointer is in the Graphics Window, clicking and holding the left mouse button as you drag will
perform the current transformation (e.g. rotate or zoom) as selected in the Transformation Control area. To perform a
different transformation, you have to move the mouse to the Transformation Control area, select the new operation,
and move back to the Graphics Window. To avoid this, you can redefine how the left mouse works as well as map
additional transformation operations onto the middle and right mouse buttons.

This customization only effects the mouse usage while in the Graphics Window. The left button is still used for other
user-interface actions.

BAsSIC OPERATION

To change the behavior of mouse buttons in the Graphics Window:

1. Select Edit > Preferences..., then click on Mouse and -+ Preferences x|
Keyboard Preference Categories(Select One)
Data

General User Interface
Image Saving and Printing
Interactive Prabe Que:

Mouse and Keyboard )
bttt e ol it )

Parts
Performance

2. Set each mouse button pulldown (Left, Middle, Right) as woee Mouse and Keyboard Preferences o
desired (see below). ... ereeee

> Left Transf. Action
A |Middle | Translate
A ||Right Zoom

3. Set desired Zoom Style Picking iz accomplished using the 'p' key.

[ Zoom Sty e  Manual Drag

4. Click Save To Preference File to save your changes (if you i
want these changes to be the default for future sessions of | >2ve To Preference File

EnSight) and Close to exit the dialog. -------- ..ol

The new settings will take effect as soon as you hit the close
button. If you clicked Save To Preference Files, your changes are
also written to a file and automatically loaded during future EnSight
sessions.

Each mouse button can have one of the following associated behaviors:

Transf. Action When this mouse button is clicked and dragged, the operation performed will be the currently
selected function in the Transformation Control area.

Rotate When this mouse button is clicked and dragged, the operation performed will be rotate.
Translate When this mouse button is clicked and dragged, the operation performed will be translate.

Zoom When this mouse button is clicked and dragged, if Zoom Style is Manual Drag then a zoom
displacement will occur, and if Zoom Style is Automatic Slide then a zoom velocity will occur

Pick When this mouse button is clicked, the action will be “pick”. Picking is used to position various
EnSight tools as well as to select parts by clicking on them in the Graphics Window.

Nothing When this mouse button is clicked, no action will be performed.

Note that at least one of the mouse buttons must be set to Transf. Action!
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SEE ALSO

User Manual: Mouse and Keyboard Preferences
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INTRODUCTION

The default size and position of the EnSight user interface windows was chosen to try to minimize window overlap.
Since some users may have different criteria for window placement, EnSight provides a method for saving this
information.

BASIC OPERATION

You can move and resize windows using the standard window manager operations. Once you have positioned your
windows as desired:

1. Select Edit > Preferences..., select General User Interface and click Save Size and Position of Main
Windows.

The information is saved in your .ensight7/ directory (which is located in your home directory) in the file
ensight.winpos.default.

This and many other preference settings can be set and saved, see How To Set and Modify Preferences.

SEE ALSO

User Manual: Save Window Positions under the General User Interface of Prefs.
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INTRODUCTION

Advanced users of EnSight often find themselves performing repetitive tasks. EnSight’s macro facility lets you save a
sequence of commands and then assign a keyboard key or mouse button to those commands such that they are
executed when the key or button is pressed.

Pressing a key/button assigned to a macro causes the associated command file to be read and executed.
Depending on how it is set up, a macro can execute it’s file in one of three ways:

1. The command file is executed once for each key/button press. This mode is useful for one-time operations such
as cutting flipbook animation on/off or saving an image.

2. The command file repeatedly executes as long as the key/button is held down. This is useful for operations that
are continuous in nature, such as rotating around the Y axis by 5 degrees.

3. Multiple command files execute in a cycle for each keystroke or mouse button click.

Note: In the 7.0 release, EnSight uses a separate utility program (macromake) to create macros. In a subsequent
release, this facility will be integrated into the user interface.

BASIC OPERATION

The first step in creating macros is to save the various command sequences that perform the desired actions. See
How To Record and Play Command Files for more information. Be careful as you perform the operations that are
saved to the command files. Superfluous or errant commands will slow down macro operation or cause errors. You
may wish to view the resulting command files with a text editor and possibly make changes.

Once created, you should move the command files to your ~/ . ensight7/macros directory. Although not required,
it is useful to be able to distinguish these files from others — a common suffix such as “.mac” is often used.

Once the command files are ready, run the macro utility program, macromake. The executable is located in the
$CEI_HOME/bin directory so it should already be in your command search path.

1. From a UNIX shell window, run macromake:

o

% macromake

The utility will print requests for action to the UNIX shell window. It also opens a graphics window (titled “Macromake”)
that is used to capture keyboard and mouse event codes. The basic macro definition process is as follows:

2. Specify the keyboard/mouse action by moving the mouse pointer into the Macromake window and
pressing the desired keyboard key or mouse button. The Macromake window will close.

3. Respond to the questions in the UNIX shell window:

How many command files are Enter the number of command files that will execute (in turn) when the
tied to this key? macro is executed.

Enter command file 1 to be Enter the name of the first command file to execute. If the response to the
tied to this key: first question was greater than one, then enter each subsequent command

file name (in the desired order of execution) when prompted.

Is this a repeatable macro? Answer y for a repeatable macro (executes continuously as long as the key/
button is depressed) or n for single execution.

Do you wish to define Answer y to define another macro or n to quit.
another macro?

If EnSight is still running, you can click Reload Macros in the Command dialog (File > Command) to make your new
macros active. Otherwise, they will be available during your next session of EnSight.
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OTHER NOTES

The mapping from keys/buttons to command files is saved in the macro.define file. This file and associated macro
command files are saved in your ~/.ensight7/macros directory. Your local EnSight administrator can also define
a common set of macros that are located in the $SCEI_HOME/ensight76/site preferences/macros/
directory. These macros (if present) will be read first, followed by user-specific macros. User-specific key/button
assignments therefore take precedence over site macros.

SEE ALSO

How To Record and Play Command Files

User Manual: Keyboard Macro Maker (macromake)
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Enable User Defined
Input Devices

INTRODUCTION

EnSight offers user defined input devices that have been specifically designed for (but not limited to) typical input
devices used in VR environments (such as the Immersadesk). Implementation of these input devices requires
adherence to the instructions outlined in the respective reference files listed below.

BAsIC OPERATION
Manual Panel Interface:

1. Select Edit > Preferences..., and click User
Defined Input.

2. Toggle Macro Panel Interface -------------nnnnnn.

The Main Graphics window updates the Macro Panel as
defined in the file:

~/.ensight7/macros/hum.define

(If you have not created this file, an example is provided
in:

$CEI_HOME/ensight76/src/input/HUM/hum.define

on your EnSight Client host system.)
3. Toggle Part Panel Interface (if you desire a

part list in the graphics window). ------------------

4. Toggle User Defined Input.. - ----------..oooooonLt.

(Detailed steps to implement the User Defined Input
Device are outlined in the file:

$CEI_HOME/ensight76/src/input/README

on your EnSight Client host system.)

5. Set Zoom Using to the appropriate type of
input device you are using to record zoom
transformations, adjusting the Sensitivity as

needed (i.e., 0 < slower < 1 faster).

6. Set Rotate Using to the appropriate type of
input device you are using to record rotation
transformations, adjusting the Sensitivity as

needed (i.e., 0 < slower < 1 faster). ..-.............. :

SEE ALSO

User Manual: “User Defined Input Preferences”

= Preferences (%]
Preference Categories(Select One)
Parts
Performance
Platter

Query _ _ _ _ _ _ _ _ _
E ger Defined Input iy

——————————— —
Variables

View

#dadddt User Defined Input Preferences wbtttttid

- (=1 Macre Panel Interface

Seeeans »-_| Part Panel Interface

P | User Defined Input Device
Zoom Using Valuator
Sensitivity | 1 000000
Ruotate Using  Mixed Mode

Sensitivity | | nogoog

Save Ta Preference File

Clasze Help

B 2000 @® HowTo Index

User Manual Page 1 of 1




How To ... Setor Modify Preferences
B 26000

INTRODUCTION

Nearly every operation and function in EnSight is initially set to a default value. Preferences allow you to set these
initial values as well as set some default behaviors such as which time step to initially load for transient data, how the
mouse buttons are defined, etc. When EnSight starts, the preference settings are read from the $ENSIGHT_HOME/
site_preferences directory and then overlaid by the preference settings found in your .ensight7 directory.

BASIC OPERATION

1. Bring up the Preferences dialog by selecting Preferences ,=é EnSight
from the Edit pull-down menu. - ...

Ezarr ____________ x -_i

Sel Part Feature Detail Editors b
e

Flipbook Animation Editor...
Keyframe Animation Editor...
Solution Time Editor...
Transformation Editor...
Variables Editor...

N --- - » Preferences...

The following preference categories are available in the Preferences dialog (and will be explained below):

To Set Annotation Preferences:

To Set Color Palette Defaults:

To Set Command Line Preferences:

To Set Data Preferences:

To Set General User Interface Preferences:
To Set Image Saving and Printing Preferences:
To Set Interactive Probe Query Preferences:
To Set Mouse and Keyboard Preferences:
To Set Part Preferences:

To Set Performance Preferences:

To Set Plotter Preferences:

To Set Query Preferences:

To Set User Defined Input Preferences:

To Set Variable Preferences:

To Set View Preferences:

To Set Viewports Preferences:
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To Set Annotation Preferences:

1. Select Annotation from the Preference
Categories list. -------------------oooo oo .

2. Click the “Click Here To Start” button. This Preference Categories(Select One)

will bring up Annotation mode in EnSight and | E
deselect any annotations. ---------------------- 1 | Color Palettes
' |Command Line Parameters
3. Since Annotation mode normally shows you : | |pata
icons only for the selected annotations, click | general User Interface
on the “Allow Editing Defaults” button to get ! Image Saving and Printing
full access to all attributes. .. ————— | | Interactive Probe Query

- Aoy P
A Ml | | Mouse and Keybaard
perRuLTS I
' Parts

4. Set any attribute, for example line widths to 2 Performance
Pixels, text to left justification, etc. ]

5. You can also define any annotation (text, line, sk & e o Preferences b
and logo) and have it be part of your :
preferences. Legends can also be part of the

preferences, but these preferences are 1} * Click Here To Start
independent of the variable tied to the 2} Turn ON the button named
legend, i.e., the preference file keeps attributes | 'ALLOW EDITING DEFAULTS’
for the first, second, third, etc. visible legends. | in the Annot mode icons.

3} Modify any Annot mode icons
: now available. For example:Line Width.

6. Click Save to Preference File to save the
default annotation attributes. If you have
defined any annotations, a pop-up will ask you

. .
if you want to save this annotation as part of | 'y_Save To Preference File |

your default or if your intent is to save the B g :
default attributes only. ------------......... g CIOSEI H'EIPI
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Set or Modify Preferences

To Set Color Palette Defaults:

1. Select Color Palettes from the Preference

Categories list. .-

2. Choose to color by RGB or Textures. .- ----........ :

3. Toggle on if you want the color legend to
automatically appear when you color a part by a

variable. ... ..ol -

4. Toggle on if you want color legends to be
replaced when the current legend is no longer in
use (i.e., no parts are colored by the variable)

5. Toggle on if you wish the legend ranges tobe :------

updated when time is changed, thus based on

values of variable at the current time. ...........0 """

6. Set the default legend for per element
variables to be constant over the element or to
vary continuously over the element (averages

with neighbors).

7. Set the default legend editing interface to

simpleoradvanced ............. ...

8. If you have predefined color palettes, you can
set one of them to be the default by entering the
name or picking one from the list of defined

palettes. - --rocooe i '

9. To set default legend attributes, click here.
This will bring up the detail editor for color
legends with no legends selected. In the feature
detail editor, set the desired attributes such as
linear/logarithmic scale, and continuous or

banded type. ... :

10. Click here to save the preferences. --------------- g

-4 Preferences ||§||z|

Preference Categories{Select One)

Annatation

Command Line Parameters
Data

General User Interface
Image Saving and Printing
Interactive Probe Query

dErtEt Color Palette/Legend Preferencesg #tttdttd

Color By, RGB

' Display Legend When Part Is Colored

and a new variable is inuse. ----..oooooooooeeens I Auto Replace Legend When Part Is Colored

Rezet Legend Ranges When Time Is Changed

>_| Use Continuous Palette For Per Element Vars

Legend Editing Interface Advanced

B >

Palette LS

To zet legend defaultz(such as the Scale type):
1} y Click Here Ta Start

2} Modify any legend attributes in the
‘Feature Detail Editor now displayed.
! For example: Tvpe or Scale.

4 Save To Preference File

Close Help

B 2000 @® HowTo Index

User Manual Page 3 of 17




How To ...
W 26000

Set or Modify Preferences

To Set Command Line Preferences:

A number of command line parameters exist for
EnSight. These parameters can be set in your
preference file so you do not have to specify them on
the start line each time you use EnSight.

1. Select Command Line Parameters from the
Preference Categories list.

2, Select a command line argument.

An explanation of the selected argument will appear
in the dialog.

3. Click here to add the parameter.
It will be placed in the editarea. -........................

If you make a mistake and add an unwanted ;
parameter, simply highlight it in the feedback area and - - -
delete it. Lo

If additional information is required, a note will be

- Preferences

[EEd

» lommand Line Parameters

Preference Categories{Select One)

Annotation
Color Palettes

Data

General User Interface
Image Saving and Printing
Interactive Probe Query

Btk Bt Cﬂmmand Line preferences wertekkkrkk ke

Select From This List Ta See More
Information. Select Add To Insert
Into The Preference List.
«leonfig
-no_display_lis
- guad _sters
-multi_samplir
-na_rmulti_san
-num_samples
1=no_-start-scree:
-no_stencil_bui
P
-ports
-rangell
-readendhg
-rsh

Add Selected Item To
Current Args Below

Save To Preference File

Help

posted here to help you.

4. If you need to add additional information, add
any text needed into the editarea. ........ ... ... .. .. .:

5. Click here to save the preferences.

B 2000 @® HowTo Index
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Set or Modify Preferences

To Set Data Preferences:

1. Select Data from the Preference Categories
list.

2. If you want to specify a path to look for data,
specify it here.

3. You can specify the default binary file type
here.

4. When transient data is loaded into EnSight
you can choose to specify a beginning time
step. If you do not specify a beginning time step,
either the first or the last time step will be loaded
depending on this preference.

5. After successfully reading data into EnSight

you are presented (for most data formats) witha .. ..
part loader if this attribute is set to No Parts. If

set to any other attribute the parts specified will : .-
be loaded and displayed without intervention :
from the partloader. ----------coooiiii

Concerns periodic model updating while
EnSightis running - Please Contact CEl Support
regarding this option. .. .............................]

6. The readers shown with a * will show up in the
pull-down for data format in the EnSight data
reader dialog. You can take readers off of the
pull-down list if you toggle the * off (select the
reader in the list).

7. You can specify the default data type by

=" Preferences
Preference Categories{Select One)

Annotation
Calor Palettes
Command Line Parameters

General User Interface
Image Saving and Printing
Interactive Probe Query

***M*?tﬂf** Dﬂ.tﬁ pmferences dokkokhkrkkok

Default Data | &
Directory

Binary

Files Are  DigEndian(HP.IBM,SGI,SUN)

If Starting Time Step [ .t
is not specified load - _2 tep

When reading data Parts
automatically load (N b

Select Below To Togsle Reader Visikility.

*3 Case

{*> EnSight §

{*y ABAQUS

{*y ANSYS RESULTS

{*y ESTET

{*y FAST UNSTRUCTURED
{* FIDAF NEUTEAL

(") FLUENT UNIVERSAL
{*) Movie

{*y MPGS 4.1

Default R-ein.-:_i!e_r_ >

typing in the exact name of thereader. ..............-

8. Click here to save the preferences.

A Save To Preference File

Help

B 2000 @® HowTo Index
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To Set General User Interface Preferences:

Preference Categories{Select One)
Annaotation iy
| | Color Palettes

1. Select General User Interface from the | |Command Line Parameters
Preference Categories list. ~-~---------------- . .|| Data

2. Toggle to show tool tips (balloon help). ... .. Image Saving and Printing

Interactive Probe Query

3. Toggle to show an extra dialog with a long Mouse and Keyboard

partlist. - oo ]

| |Parts
4. Toggle to show Frame mode as an available ' | | Performance
mode. oo
5. Toggle to show View mode as an available e — Ceneral User Interface Profopencag bttt
mode. --------iiiiiii o 1
6. EnSight’s command language records part *. - | | Tool Tips
names or numbers according to this choice. ]
Recording by name is more portable for using |
the command language with a different dataset Frame Mode Allowed
since the part numbers do not need to match | 17 View Maode Allowed

up. However, recording by name produces " & oy ot Galection Tn o5

slightly larger command files. ! 3 Command Language By Numhber i |

7. Click Save Above Items To Preference File to > Save Above [tems To Preference File
save the GUI items to your preference file. .-~

- Modify and Save Icon Layout...

8. To Modify EnSight’s Icon Layout, click here..-- |

Save Size and Position of Main Windows
.—‘

9. To save as a preference the location and size ;
of EnSight’s windows, click here. -----------------

‘ 2000 ® HowTo Index User Manual Page 6 of 17
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To Set Image Saving and Printing Preferences:

Preference Categories(Select One)
| | Annotation A
Colar Palettes

Command Line Parameters
Data

1. Select Image Saving and Printing from the Ceneral User Interface

Preference Categories list. --------------------- - [mage Saving and Printing

Interactive Probe Query
Mouse and Keyboard
Parts

FPerformance

2. Click the “Click Here To Start” button. This
will bring up the Print/Save Image dialog. ---------

3. Modify the attributes you want for your 5 !, Click Here To Start

preference such as the image format. 2) Modify any printisave image attributes in

4. Click here to save the preferences. ............ | the dialog now displayed.

Save T Preference File I

ED

‘ ? .'.. How To Index User Manual Page 7 of 17
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W 20000

To Set Interactive Probe Query Preferences:

Preference Categories(Select One)
| | Annotation A
Colar Palettes

Command Line Parameters
Data

1 | General User Interface

Image Saving and Printing
Bl gpinteractive Probe Query |
| | Mouse and Keybuoard

Parts

FPerformance 7

1. Select Interactive Probe Query from the
Preference Categories list. ---. .

2. Click the “Click Here To Start” button. This

will bring up Interactive Probe quick ki Prole Query Preferences ik
interactionarea. ... .. .. ... .. ... .. ..

3. Modify the attributes you want for your 1) !, Click Here To Start
pl_'eference such as Report By, and # Items 2) In the probe query interaction area,
Displayed. that was just made availahble, adjust

. parameters for any of the guery types,
4. Click here to save the preferences. .. display attributes, items displayed,

ar ‘Report By value.

3)‘ Save Tao Preference File I

- ? ®O®®® HowTo Index User Manual Page 8 of 17
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n 20000

To Set Mouse and Keyboard Preferences:

This preference allows you to modify the behavior
of the mouse buttons used during EnSight
transformations. Each mouse button can be set up
to be one of Transf. Action (meaning that the
button is set to the action as shown in
transformation icons at the bottom of the EnSight
dialog - set to rotate by default), Rotate, Translate,
Zoom, or Pick. At least one button must be set to
Transf. Action. If no mouse button is set Pick, the

p” keyboard key will be used for this function.

1. Select Mouse and Keyboard from the B
Preference Categories list. --.-..............._. -

2. Modify the preference for each of the mouse
buttons. -

Picking iz accomplished using the 'p’ key.
Zoom Style| BAanual Drag

3. Click here to save the preferences.

Preference Categories{Select One}

Annotation &
Color Palettes

Commaned Line Parameters
Data

General User Interface

Image Saving and Printing
Interactive Probe Query

Parts

Performance

ettt Monse and Keyboard Preferences et

Transf. Action
Translate

Zoom

T Save To Preference File

B 2000@® HowTo index

User Manual Page 9 of 17




How To ...
n 20000

Set or Modify Preferences

To Set Part Preferences:

1. Select Parts from the Preferences Categories
list. ...l o

2. Click the “Click Here To Start” button. This
will bring up Part mode in EnSight and deselect

any parts (so you can edit defaults). ----------- .

3. Modify any part attribute such as line
thickness.

4. Click Save General Part Preferences To File

to save the default visual attributes for parts. e |

5. If you want to modify creation attributes for
created parts, specify which dialog you want to

USE. ~---ooenoeneeenooeooi

6. Set the parttype. ---------- -

7. Modify the attribute. For example, set
subcontours to 3 for contour parts.

8. Click Save Preferences For Part Type
Chosen To File to save the attributes for the

Rt ]

part type edited. - --------oooooioioioill

Preference Categories{Select One}

Annotation &
Color Palettes

Commaned Line Parameters
Data

General User Interface
Image Saving and Printing
Interactive Probe Query
Mouse and Keyboamd

Performance i

et Part Preferences ¥+

‘ #* Ta save generic attributes for all part types:

13 Click Here To Start

2} Modify any Part mode icons now
. gvailable. Faor example:Line Width.

S
3} Save General Part Preferences To Filel

**+ Ta gave attributes for specific part types:
- gQuick InteractHon Area I

Using

| 2) Start Editing | a

For Part Contours — I

3} Modify part attributes with the chosen

editor{Detail Editor or Quick Interaction
Area.

13 Save Preferences For Part

.y  Type Chosen To File

B 2000 @® HowTo Index
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To Set Performance Preferences:

Preference Categories{Select One)

Image Saving and Printing KX

| | Interactive Probe Query
1. Select Performance from the Preferences Mouse and Keyboard
Categories list. ................................. .. |Parts

Performance ‘
£

2. To cull duplicate lines in line drawing mode, Plotter
Query

set this toggle. ---------- -l .
| | User Defined Input
Variables

3. To set fast mode to static, toggle on. The
default is off meaning that the fast display
(i.e., bounding box) is only active during
transformations such that the image returns
back to full graphics display when the mouse
buttons are not depressed. In static mode the
fast representation is continuously displayed.. .

View

1. eeeeckerdk Derformance Preferences ¥Fereeeres

VJ Cull Lines

4. To sort the geometry during ~| Static Fast Display
transformations, thereby creating correct 1 Transparency Re-sart
transparent image at all times (but at a ] Detail Repr. Point Resolution(1-100) [
performance cost), set this toggle on. To D {1=Draw every point, 2=Draw half, ...}
delay the re-sort until the mouse is released, : o
’ Detail B . Model B luti
set this toggle off (better performance with (l'ig'limf_’fws.}’:}‘:‘;'fn el Reselufion |5'J A

Often acceptable enough Image) 77777777777777777 : A Sa‘re To pmfemnce P‘ile

wn

4. If using point display for fast display mode,
set the point resolution here. -.......... ... ..

5. If using sparse geometry display for fast
display mode, set the percent of the model to ‘ ‘
showhere. .- ...

(Only used if immediate mode is being used.)

6. Click here to save the preferences. -.........
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W 260000

To Set Plotter Preferences:

1. Select Plotter from the Preferences

Categories list. ... ... .. ...

2, Click the “Click Here To Start” button. This
will bring up Plotter mode in EnSight and

deselect any plots and curves. --------------------

3. Set any attribute, for example line width for
curves, tick marks for axis, etc.

4. Click here to save the preferences. .

Preference Categories{Select One)

Image Saving and Printing
Interactive Probe Query
Mouse and Keyboard

Parts

Performance

Query

User Defined Input
Variables

View

A

|

skt Platheyr Prefemeneeg ikt

now available. For example:

2} Modify any Plat mode attributes

Graph Attrs: width, height background...
Axis Attre: label format,line width...
Curve Attrs: type, width, style...

3}‘ Save To Preference File |

B 2000@® HowTo index
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Set or Modify Preferences

To Set Query Preferences:

1. Select Query from the Preferences
Categories list.

2. Click this toggle on so that once you create
a query it will be automatically plotted...-----......

3. If Auto Plot Queries is toggled on, then you
have the option to check this toggle. If on and
an existing plot uses the same variables, you
query will be added to this existing plot.
Otherwise an new plot will be created. .........:

4. Click the “Click Here To Start” button. This
will bring up the Query quick interaction area .
with all query items deselected. .................;

5. Set any attribute, for example Distance Type
and 30 Samples for the Line tool constraint.

6. Click here to save the preferences.

=+ Preferences

Preference Categories(Select One)

Interactive Probe Query
Mouse and Keyboard

Parts

Performance

PlEl'tEr _________
gluey |

E dkkobkokktokk Quew Preferences dkkobkokktokk

Auto Plot Queries

| el Por Beletag Plobiery

2) In the guery interaction area,
that was just made available, adjust
parameters for any of the gquery types,
constraints, ar visibility attributes.

Save To Preference File

Close Help

To set gquery defaults{such as the guery type):
| 1)y Click Here To Start

=1IES)
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To Set User Defined Input Preferences:

1. Select User Defined Input from the
Preferences Categories list. ----------............ ..

2. Turn this on to show the macro panel display .

3. Toggle to select the default to display a part
list in the graphics window. This is especially
helpful in full screen mode or a VR environment. .

4. Turn this on to activate the user defined input
device (ENSIGHT7_INPUT must be set to the
proper device). --------oooiieeioiiiieee oo

5. A Valuator can be used for zoom operations
(like a virtual joy stick), or Position which

simply means to delta movement in the Z L
direction will be used. ------------oooao

6. Sets the sensitivity for the zoom operation.

The values for zoom are scaled by this setting,

so values larger than 1.0 will make the inputs
larger while less than 1.0 will make them :
smaller. .- -ooroi

7. Mixed mode will use the input devices z
rotate directly but use x and y translation values
for xly rotations. Direct mode will use the
rotation angles from the input device directly

forallthreeaxis. ... ... ... .. .. ... ... ... Ll

8. Sensitivity will set a scaling factor for the
rotation values. ---------cooioiiiiiiii

9. Click here to save the preferences. ---------------

=» Preferences [x]
Preference Categories(Select One)

Interactive Probe Query
Mouse and Keyhoard
Parts

Performance

Platter

Que

B N e —

bkttt User Defined Input Preferences ettt
bbbtttk EnSight Gold Only bbbkttt

Macro Panel Interface

A Part Panel Interface

P | User Defined Input Device

Ratate UsinaMix-ed Mode

Sensitivity |} aonooo
v

Save To Preference File

i

Claose Help

B 2000 @® HowTo Index
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or Modify Preferences

To Set Variable Preferences:

1. Select Variables from the Preferences Y

Categories list.

2. Turn this on if you want to be notified
before a variable is activated.

3. Toggle to select visibility of functions in the
General Functions list of the New Variable
Calculatordialog. ....... ... . ... ... ... . ... ...

4. Save this notification request and function
visibilities to the preference file by clicking
here.

5. Brings up the dialog for setting extended
CFD settings.

Save these settings by clicking here.

=" Preferences
Preference Categories{Select One)

Performance
Platter

Query
User Defined Input

-"ariables )

N ) —

Rt b st f 2 Variable meemnces sekiketekekk

\ Notify Before Activating A Variable

Select Below To Toggle Visibility
Far a General Function.
{*1Area
{(*}CaseMap
»(*)Coeff
{(*ICmplx
(FICmplxArg
{*ICmplxConj
() CmplxImag
(FICmplxMMeodu
{*)CmplxReal
{(*ICmplxTransResp

p Save To General Variable Preferences File

p Modify Extended CFD Variabkle Settings...

-p> Save To Extended CFD FPreference File

Close Help
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To Set View Preferences:

-~ Preferences [l [x]
1. Select View from the Preferences Preference Categories(Select One)
Categories list. .......... ... . ... .. ... : Performance
' Platter
.|| | Query

L Defined I t

2. Turn on if you want the plane tool to be ser Detined p
. Variables

shown as a transparent plane, or off if you
want it shown in line drawing mode. .............. i 2 = = =E=m=nmimns =t N
3. There are two offsets employed in EnSight. .
This one, hardware offset, is perpendicular to it View Preferences iy
the monitor screen, and done in hardware if :
this toggle is on. This will allow, for example :. |y | Plane Tool Filled
contour lines to appear closer to the viewer

-

than their parent part so they are visibleno """ Use graphics hardware to offset line objects

matter what orientation the part is viewed from salid surfaces. (Ex. offset contours, vector
FFOML - e oo p arrows, ete, from their clip plane parent part.)

The second offset is the display offset. The display offset ;---f-™= === ===
can be set in the feature detail editor for line parts such as
contour lines, particle trace lines, vector arrows, and
separation/attachment lines. The display offset is the
distance in the direction of the element normal
(perpendicular to the surface).

FPleaze zet the main interface '"View' menu
items as you wonld prefer them to be for
defaults. Then select Save belonws:.

: Save To Preference File
4. Select the default viewing orientation. .......: A

5. Pull down “View” menu and set items
desired.

6. Click here to save the preferences. ............|...........:

Close Help
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To Set Viewports Preferences:

1. Select the Viewports Category. ................... .

2. Click the Click Here To Start button. ------------.

This will bring up the Viewports quick interaction
area with all viewport items selected.

3. Set any viewport attributes (for example,
background color to blended).

4. Click here to save the attributes set in 2. to
the preference file as defaults for future

SESSIONS. - - v o ceem oo

5. Click her to save the current viewport layout

to the preference file. ... .. lll -

=" Preferences

Preference Categories(Select One)

Performance
FPlotter

Query
User Defined Input
Variables

. Aerkkokek ok ok vimﬂﬂ Preferences sbkkekokkkeokk

1} 1 Click Here To Start

2) Modify any Vport mode attributes
now available. For example:
Background Calor: constant, blended...
Baorder Attrs: visibility, colaor...
ID/2D Grid Attrs: line width,color,gradations...

3} P Save Defaults To Preference File

.y~ Save Current Layout To Preference File

Close Help
SEE ALSO
User Manual: Edit Menu Functions
‘ ? .... How To Index User Manual Page 17 of 17




How To ... Setup for Parallel
n 20000 Computation

INTRODUCTION

Ensight supports shared-memory parallel computation via POSIX threads on a variety of platforms. As of this writing,
threads are supported on IRIX 6.5, HP-UX 11.0, OSF1 V4.0, AlX 4.3, Solaris 8 (server portion on Solaris 6 and 7
also), Linux 1.1, and Linux 2.4. Additional support may be added in the near future.

BASIC OPERATION

Configuration

Each executable of EnSight can be configured individually to control the number of threads used.
The following environment variables are used to specify the maximum number of threads that the
executable should use for computation.

ENSIGHT7_MAX_THREADS
The maximum number of threads to use for each EnSight server. Threads are used to
accelerate the computation of streamlines, clips, isosurfaces, and other compute-intensive
operations.

ENSIGHT7_MAX_CTHREADS
The maximum number of threads to use for each EnSight client. Threads in the client are
used to accelerate sorting of transparent surfaces.

ENSIGHT7_MAX_SOSTHREADS
The maximum number of threads to use for each EnSight server-of-servers. This variable is
introduced for planned future use, but at the time of this writing no operations in the server-of-
servers are accelerated with threads.

OTHER NOTES

The number of threads is limited to 2 (per client or server) with a Standard license, while the upper limit for a Gold
license is 128. When setting these parameters it is a good idea to take into account the number of processors on the
system. In general, you will not see benefit from setting the parameters higher than the number of total processors.
Because the server, server-of-servers and client operate in a pipelined fashion, it is not necessary to limit one in order
to apply more threads to another.

Compute intensive server operations that make use of shared memory parallel computations include isosurface,
clipping, and particle trace computations. Client threaded operations include transparency resort and display list
creation.
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B 26000 Rendering

INTRODUCTION

EnSight Gold now supports general parallel rendering for increased performance, increased display resolution, and
arbitrary screen orientations. The configuration file format and several examples are described in the User Manual.
Just click the link below to see this information.

SEE ALSO

User Manual: Parallel Rendering and Virtual Reality
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INTRODUCTION

Many operations in EnSight (such as loading data) require that you specify a file. EnSight uses a standard file
selection dialog that lets you quickly search through directories to find the desired file.

BAsSIC OPERATION

By default, the File Selection dialog opens with the directory from which the EnSight client was started as the current
directory. When opened subsequently, the directory that was last selected will be current.

The following shows the basic components of the File Selection dialog:

The Files list displays the list of files contained in the
current directory (possibly modified by the wildcard in
the Filter field). To make a file the current Selection,

click it. To accept a file and close the dialog,
The Filter displays the name of the current double-click it. ==~ === rrr

directory and controls the listing of files in
the Files list. You can use standard wildcard
characters (such as *) to restrict the list to
only those file names that match the

wildcard. See Wildcarding below for more File Seleotion :
information.

L. [Filter
The Directories list displays all directories tseratchfjohngaltbjn/server’data_rel/ami’*
in the current directory. Note that the . . . .
current directory is shown ending with “.” | Directories Files Y ;
and the parent of the current directory is J¥scratchfjohngalt/bin/zerver/data_rel/amir. - |README.ami |-

shown ending with “. .” (standard UNIX
nomenclature). To open a directory,
double-clickit. ... ... ...

tscratchfijohngalthjn/serveridata_relfamil.. ami.case
ami.gea
ami.res
ami.scl
ami.vet

£
]~ =

| Selection

fscratchfijohngaltfhjn/serveridata_relfami/

The Selection field contains the full path

Okay | | Apply Filter | Cangel
name of the file currently selected in the ‘ A P

Files list. This is the file that will be

chosen if Okay is clicked. Change the : . :
selection either by clicking a file in the Click to accept the current Click to apply the Filter Click to cancel the

Files list or editing the field directly. Selection and close the after a change (you can selection and close the
Pressing return will accept the dialog. also just press return after dialog.
Selection and close the dialog. making a filter change).
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Wildcarding

The EnSight File Selection Filter field accepts a standard set of regular expression characters that let you restrict the
display of files in the Files list to those that match the regular expression. This can be useful when trying to quickly
locate specific files in directories that contain large numbers of items. By default, the Filter field displays the current
directory with “*” appended. The “*” is a special character that matches a sequence of zero or more characters of
any type. For example, “* . geo” will match all files in the current directory that end with “. geo”. This form of regular
expression matching is essentially identical to that used by the UNIX shell programs (such as csh) to match file
names when issuing commands.

You enter a wildcard by clicking the left mouse button in the Filter field and entering the desired text. When done,
either press return or click the Apply Filter button. The Files list will then update to reflect the new filter.

The recognized regular expressions are:

Special Description Examples
Character
* Match any (zero or more) characters. *.geo
widget*.cmd
? Match any single character. gadget?.geo
[...] Match any single character in the enclosed list(s) or file[13579] .rgb
range(s). A listis a string of characters. A range is two file[1-9].rgb

characters separated by a minus-sign (-), and includes all
the characters in between in the ASCII collating sequence.

~ Matches your home directory. This is a special case: ~
entering ~ (and pressing return) will set the current directory | ~/*.geo
to your home directory and display all files in the Files list.

~user Matches the home directory of user. This is a special case: | ~joeuser
entering ~user (and pressing return) will set the current ~joeuser/*.cmd
directory to the home directory of user and display all files in
the Files list.
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Use The Feature
Detail Editor

INTRODUCTION

Although most attributes of EnSight parts can be edited

either through the appropriate Quick Interaction area or the

Part Mode icon bar, full control is provided by the Feature Detail Editors for the various part types. Full control over
variables (e.g. activation, color palette editing, and new variable calculation) is also provided through a Feature Detail

Editor.

BASIC OPERATION

You can open the Feature Detail Editor by either selecting the appropriate item from the Edit > Part Feature Detail
Editors menu or by double-clicking the appropriate part icon in the Feature Icon bar. All Feature Detail Editors (except

the two dealing with Variables — see below) contain the

File (these items are only available for the Variables Feature
Detail Editor — see below)

Edit
Select All: Select all parts listed in the dialog’s parts list
Copy: Make a copy of the selected part(s)
Delete: Delete the selected part(s)

Immediate Modification: If on, all changes in the dialog have
an immediate effect. If off, the Apply Changes button at the *-

bottom must be clicked to apply your changes (good for
batching several expensive changes).

View

Show Selected Part(s)...: Open the Selected Part(s)
window to display only the selected parts.

List of variable/part icons; click to change to the desired
Feature Detail Editor type. - - - - - -« ccveoeaii il

Parts list of the current Feature Detail Editor type; lists only
those parts of the current type. (For example, the contour

Feature Detail Editor is shown and only the current contour
parts are listed.)

Description of the currently selected part in the parts list. Click
to type, make changes, and press return. - ------------------

Creation Attributes section. This section (which is missing for___.

Model parts) is unique to the Feature Detail Editor type and
controls part-specific attributes (e.g. the isovalue of an

ISOSUMACE). + -+ - v wrr e

The remaining sections (General, Node/Element/Line, and

Displacement) control attributes common to all part types. See
How To Set Attributes for more information.----------------- :

Click to Close the Feature Detail Editor dialog. - - - - -~ ... .....

Click to Create a new part based on the attributes as currently

set and with parent part(s) as selected in the Main Parts list.. . . .

Click to change the parent part(s) of the selected part(s). The

new parent part(s) must be selected in the Main Parts list.- - -

same basic components:

File Edit
3 - {C/C1} Contour of temperature EY
l — {C/C1) Contour of velacity
F
|1 |~
.- jpt Desc I Contour of velocity o
Creation Attributes |
.- l General Attributes
Node, Element, and Line Attributes
: | Displacement Attributes
I .,
] ? -
Clnsel Cr\eai‘el Update Par\entl Fmaly CE%&%;;WI
A

Click to apply any changes you have made (only
active when Immediate Modification is toggled off .
in the Feature Detail Editor Edit Menu).- - - - ------:
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The Feature Detail Editor for variables is different from the part Feature Detail Editors:

1. To open the Feature Detail Editor for Variables either
select Edit > Variables Editor... or double-click the Color
icon in the Feature Icon bar.

File

=+ Feature Detail Editor {Vatiahles)
File Edit View

Save Selected Palette(s).... Write palettes for selected
variables to a disk file

Save All Palettes...: Write palettes for all variables to a disk
file

[

Restore Palette(s)...: Load palettes from a disk file
Edit
Select All: Select all parts listed in the dialog’s parts list

o

Immediate Modification: If on, all changes in the dialog have
an immediate effect. If off, the Apply Changes button at the
bottom must be clicked to apply your changes (good for -
batching several expensive changes).

View

Show Selected Part(s)...: Not available in Variables
Feature Detail Editor.

List of available variables. Click to select a variable.- - - - - -- -

Buttons to control variable activation/deactivation. See How .
To Activate Variables for more information.- - - - - -----------:

Variable Summary and Palette section (Simple Interface is
Shown). See How To Edit Color Palettes for more
information.

Available Variable Result

Type

=

welooity

{0 Gun{M) Vector
Coordinates (%) GuniH! Vector
Time (=3 GuniM} Scalar

Activate| Activate All

. '4

Deactivate| Extended CFD
Variahles...

#+# Palettes are using RGE made *#+*

Simple Interface Advanced Interface

Magnibuds 4 ¥ o
Min=6.5398e-01 Max=1.0786e+0(
# of Levels | ¢
Max |y 0786e+00

Min | g 52998.01
Predefined Palettes

EnSightDefaultPalette
Ps

hobz_rainkow
carnation_red white
grayscale
grayscale_hancded
grayscale_inverted
hot_metal

Restore Save...

Undao Restore

Flip Colars

Legend Display Attributes...

Frpapndy (:Etétfigﬁ?.‘ﬁ

- T' Close
1|

Lanl L
Click to apply any changes you have made (only
active when Immediate Modification is toggled off
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The Feature Detail Editor for variable Calculator is also different from the part Feature Detail Editors:

1. To open the Feature Detail Editor for variable Calculator click
the Calculator icon in the Feature Iconbar.. ... ... .. .. .. .. ...... »

Variable Calculator section. See Variable Creation in the

User Manual for more information. Feature Detail Editor (Caleuiator)

Available Variable Type Result

tenperature (%) Gun Scalar
velocity ) Gun Vector
4 |Coordinates (=) Gun Yector
Time (%3 Gun Scalar

k I~

Activate| Activate All| Deactivate| Extended CFD
Variables...

Variahle Name I

Warking
Expression

Clear I Evaluate I
General Math Active Variables

Arealpart) ﬁ ABS = temperature EY
ACOS J Coordinates
ASIN
ATAN
CO
CROSE

-

Feedback

IS
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SEE ALSO

Most of the creation attributes for parts can also be set in the Quick Interaction area for the part type. See the How To
article for the desired part type for more information.
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Feature Icon Bar

Elevated Interactive Flipbook Variable
Color Isosurface Clip Surface  Displacement Query Animation  Calculator
| Developed Material Shock Region/ Boundary
Elg @ l l Surface Parts Surface Layer
| |
I I g
Contour Particle Vector Subset Query/ Solution Keyframe “ =
Traces Arrows Parts Plot Time Animation | i l .
Profile Tensor Vortex Separation/
Plot Glyph Core Attachment
Line
Transformation Control Icons
ResetTools & .
Rotate Zoom Viewports Look Down Axes Tool Tip Help
Reset...| Transf. Edit... +X| +Y| +Z| -X| .¥| -Z| Store| Recall| |iissio Towol Tips
| | |
Translate ~ Rubber Transformation Store/Recall Undo last
Band Editor last View transformation
Zoom
Part Mode Vport Mode Frame Mode Annot Mode
Part Attributes Viewport Attributes Frame Attributes Annotation Attributes
Pick Layouts New ancae Text Creation
- 6 Visibility D__E View Part Assignment E Line Creation
Visibility in Viewport [*Fsd Visibility Axis Visibility Logo Import
Line Width Move Forward Color m 6 Object Visibility
Transparency Move Back Line Width Object Color
Element Visual Rep. Color Axis Object Location
Symmetry Border Comput. Symmetry Text Size
Shaded Location Coordinate System Text Justification

Hidden Line Special Settings Location Text Rotation

Shading Global Visibility Line Arrows

Part Bounds

Elem Label Visibility

Transform/Define % Line Width

Select All

Node Label Visibility Delete Select All Logo Size

Auxiliary Clipping é M| Delete Legend Type

View Mode

Title Position
Node Rep. Global View Attributes
Fast Display Rep. PIOt MOde j| Text Position
- Shaded Plotter Attributes
Select All _ _ Text Size
Hidden Line R ed| Visibility

[Claa| Delete

Text Label Format

Elem Label Visibility Plotter

Legend Orientation
Node Label Visibility Axis

Select All
Label Attributes Curve

Delete
Auxiliary Clipping Select All m

Allow Def. Editing

Axis Visibility Delete
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A B C D E

A

ABAQUS data
acrobat reader
activating variables
animation
flipbook
hints and tips
keyframe
mode shape
particle trace
recording to video
transient data
annotation
color legend
line
logo
preferences
text
ANSYS data
archive
restore
save
arrows, vector
attachment line
attributes
displacement
general
IJK Axis Display
node, element, line
part
automatic connection
on Unix systems
on Windows systems
auxiliary clipping
AVI
compression
output

background color

batch mode

bitmap overlay

border representation
boundary layer variables
box clip

box tool

Cc

calculator
camera
look-at
look-from
projection
case
adding
deleting

A B C D E

F

G

H

part, display by
reading
replacing
viewport visibility
CEI RGB with depth 4
CEl, Inc.
CFD variables
client/server overview
clip
animation
auxiliary clipping
box
general quadric
grid
IJK
line
plane
quadric
revolution of 1D part
revolution tool
RTZ
XYZ
Z clipping
collaboration
color
background
default
legend
part
selector
variable palette
command file
play
record
command line options
client
-ar
-batch
-bbox
_bg
-box_resolution
-C
-case
-cm
-collab_port
-ctx
-custom
-dconfig
-delay_refresh
-display_list
-double_buffer
-extcfd
-ff
_fg
-fn
-font
-gdbg
_g|
-glconfig
-glsw
-gold

S T U V W

-h, -help, -Z
-hc
-helvetica
-iconlblf
-inputdbg
-iwd
-localhostname
-maxoff
-multi_sampling
-nb
-ni
-no_display_list
-no_file_locking
-no_multi_sampling
-no_occlusion_test
no_prefs
-no_start_screen
-no_stencil_buff
-norm_per_poly
-norm_per_vert
-num_samples
-occluson_test
-ogl
-p
-ports
-range10
-readerdbg
-rsh
-SC
-scaleg
-scalev
-security
-silent
-single_buffer
-smallscreen
-sort_first
-sort_last
-S0s
-soshostname
-standard
-stderr
-stdout
-stencil_buff
-swd
-time
-timeout
-writerdbg
-X
client examples
preferences
server
-C
-ctries
-ether
-gdbg
-h, -help
-maxoff
-pipe
-ports
-readerdbg
-scaleg
-scalev
-security
-sock
-soshostname
-time
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A B C D E F G H

-writerdbg
server examples
S0s
-C
-ctries
-ether
-gdbg
-h, -help
-maxoff
-pipe
-ports
-readerdbg
-rsh
-scaleg
-scalev
-security
-sock
-soshostname
-time
-writerdbg
sos (server-of-servers) examples
computation
setup for parallel
computational symmetry
cone clip
cone tool
connection
automatic
automatic on Unix systems
automatic on Windows systems
collaboration
contacting CEI
context
restore
save
contour
copy (part)
created variables
creating parts
cursor tool
customize
icon bars
mouse buttons
window positions
cut (part)
cylinder clip
cylinder tool

D

data
discrete

ens_checker
experimental
measured
preferences
dataset
information
querying
reading

A B C D E F G H

J K L M N O

deactivating variables
default color
delete

frame

part

plotter

viewport
Desktop 1
developed surface
discrete data
displacements
display remotely
displaying stereo
distance query
documentation

acroabat reader

online use

printing

use of How To

E

editing features
detail editor

element
labels

query
representation
elevated surface
email address
ens_checker
EnSight 5 data
EnSight 6 data
EnSight Gold data
ensight7
start-up options
ENSIGHT7_MAX_CTHREADS
ENSIGHT7_MAX_SOSTHREADS
ENSIGHT7_MAX_THREADS
EnVideo output
ESTET data
experimental data
Extent Bounds
extract (part)

extracting
boundary layer variables
separation/attachment lines
shock surfaces/regions
vortex cores

F

fast display mode

FAST Unstructured data
fax number

feature angle representation
feature detail editor

Q R 8§ T U V W X Y Z

FIDAP data

file selection

flipbook
animation
transient data animation

Fluent data

frame
assigning parts to
attributes
creating
deleting
repositioning
selecting
transform reset

full representation

G

general quadric
clip

general user interface
preferences

geometry
file
save in EnSight Gold format
save in VRML format

grid clip

group (part)

H

hidden line overlay
hidden surface drawing

icon bar
customize
icons
reference
IJK
changing step refinement
clip
interactive plane sweep
image output
preferences
input devices
defining
interactive
clipping
line
plane
quadric
isosurfaces
particle traces
probe preferences
query
isosurface
animation
creation

isovolume
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A B C D E F G H

creation

J

JPEG output

K

keyboard macros
keyframe animation

L

labels
element
node
legend, color
lighting
static
lighting model
line
annotation
clip
line tool
logo annotation
look-at
look-from

macros
measured data
merge (part)
mode shapes
Model Axis
Model Extent Bounds
mouse
buttons, customizing
preferences
MOVIE.BYU data
MPEG
from keyframe animation
out from flipbook
output options
MPGS data
mterial part

N

N3S data

node
labels

query
not loaded representation

(o)

online documentation use
orthographic projection

output formats
AVI

EnVideo

J K L M N O

JPEG
MPEG
PCL
PICT
Postscript
SGI RGB
TARGA
TIFF
overview
client/server architecture
graphical user interface
parts concept

P

palette
editing
preferences
parallel computation
configuration
setup
parallel rendering
setup
part
attributes
box clip
clip plane
clips
color
contour
copy
creation
cut
delete
developed surface
displacements
element labels
elevated surface
extract
group
IJK clip
introduction
isosurface
isovolume
line clip
material
merge
node labels
particle trace
preferences
profile
quadric clips
query
revolution of 1D part clip
revolution tool clip
RTZ clip
save to disk file
selection
separation/attachment line

R 8§ T U VvV W X Y Z

shock surfaces/regions
subset
symmetry
computational
visual
tensor glyphs
transparency
vector arrows
vortex core
XYZ clip
Part Bounds Display
particle traces
animation
creating
interactive
pathlines
streaklines
surface restricted
parts concept
PCL output
performance
preferences
periodicity
perspective projection
phone numbers
pick
cursor tool
line tool
look-at point
part
Plane tool
plane tool
PICT output
plane clip
Plane tool
PLOT3D data
plotter
preferences
plotting
attributes
delete (plotter)
point
query
PostScript output
preferences
annotation
color palettes
command line
data
general user interface
icon bar
image saving/printing
interactive probe
macros
mouse and keyboard
part
performance
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A B C D E F

plotter

query

user defined input

variables

view

window positions
printing documentation
printing images
probe query
profile plot

Q

quadric clip

query
dataset
element
interactive
node
over distance
part
point
preferences

R

reading
ABAQUS data
ANSYS data
data (introduction)
ens_checker
EnSight 5 data
EnSight 6 data
EnSight Gold data
ESTET data
FAST Unstructured data
FIDAP data
Fluent data
MOVIE.BYU data
MPGS data
N3S data
new data without quitting
PLOT3D data
server of servers
transient data
user defined data reader
reference
icons
rendering
setup for parallel
representationl
reset
frame transform
transformations
restart
session (archive)
without quitting client
restore
context
session (archive)

A B C D E F

G

G

H

H

J K L M N

viewing parameters
result file
revolution of 1Dpart

clip
revolution tool

clip
RGB image output
rotate
RTZ

clip

S

save
command file
context
geometry
image
preferences
scenario
session (archive)
viewing parameters
scale

scenario
save

selecting
colors

files

parts
separation line
Server of Servers

using
setup for parallel computation
setup for parallel rendering
shaded surface drawing

shock
surface/region

Silicon Graphics RGB output
solution time
sphere clip
sphere tool
starting
automatically
options
static lighting
stereo display
subset parts
surface of revolution tool
surfaces, developed
symmetry

T

TARGA output
tensor glyph parts
text annotation

threads
environment variables

R 8§ T U

v W X Y Z

ENSIGHT7_MAX_CTHREADS
ENSIGHT7_MAX_SOSTHREAD
S
ENSIGHT7_MAX_THREADS
TIFF output
time
stepping through
tools
box
cone
cursor
cylinder
line
Plane
resetting
sphere
surface of revolution
traces
animation
creating
interactive
pathlines
streaklines
surface restricted
transformations
frames
resetting
rotate
scale
translate
zoom
transient data
animation
reading
setting current time
stepping through
translate
transparency

U

unrolling surfaces
user defined

data reader

input devices

input preferences
Using Server of Servers 1
Using Sever of Servers 1

\'

variable
activation
and cases
boundary layer
calculator
color palette
common CFD
deactivation
preferences
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A B C D E F G H | J K L

vector arrows
density
view
preferences
viewport
2D or 3D
attributes
camera projection
case visibility
color
creating
deleting
Part Bounds Display
part display
repositioning
resetting
saving viewing parameters
standard layouts
visual representation
vortex cores
VRML

w

window positions, customizing
working variable (default color)

X
XYz
clip
interactive plane sweep
Y4
Z clipping
zoom
rubberband
A B C D E F G H | J K L
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